PDA

View Full Version : Error message when replying to a thread..


RobbieZ
30 Aug 2008, 20:24
Im getting an error message when i reply to a thread..

Its ok in the default style but not in the new skin/style i have..



Code:
---------------
Code is only visible to licensed users, and only when logged into the forums.
---------------



*edit* also when i try and rep somebody

Is there something ive missed when installing this..

Can i update it by running a script check or something in adminCP

Lynne
30 Aug 2008, 20:31
See this thread about Security Tokens - Implementing CSRF Protection in modifications (http://www.vbulletin.org/forum/showthread.php?t=177013) Probably what happened is you upgraded your vbulletin, but didn't revert some of the templates which have the added security token added in.

RobbieZ
30 Aug 2008, 21:30
Thanks lynne.. your a doll.. :D

ive deleted the style and reinstalled the XML.. and see the errors again..

What would happen if i 'revert' it ?

Or should i just post this at the top of each template that shows the error:

<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />

would that solve my prob ??

Lynne
30 Aug 2008, 21:43
No, you can't just post that at the top of the template because it has to be in a form.

What I would do is if you know the templates causing the problem, go to Edit it and hit View History and then Compare. The changes between your template and the default vb one will be highlighted. Somewhere in there you will see the security token and you should copy/paste it into your template in the exact same place.

Opserty
30 Aug 2008, 21:54
If you have questions regarding a custom style you should in the style thread (or site/board) from which you downloaded it. The author (and/or other users) of the custom style will be the ones best placed to provide you with assistance.