PDA

View Full Version : Slow load times for showthread


EvilLS1
14 Nov 2003, 00:37
I don't know if its just me or what, but ever since vb.org has upgraded to VB3 showthread has been loading extremely slow for me with internet explorer 6, even with a high speed connection. Seems to load quicker in Mozilla (hate that browser though). Anyone else noticed this?

Josh Combs
14 Nov 2003, 01:52
I thought it was my roadrunner not beeping as fast.

Erwin
14 Nov 2003, 03:36
I don't know if its just me or what, but ever since vb.org has upgraded to VB3 showthread has been loading extremely slow for me with internet explorer 6, even with a high speed connection. Seems to load quicker in Mozilla (hate that browser though). Anyone else noticed this?
It's the Javascript associated with Quick Reply. Turning off WYSIWYG helps with it.

We did turn off post caching as well for security reasons - that may slow things down a bit too.

Zachery
14 Nov 2003, 04:09
It's the Javascript associated with Quick Reply. Turning off WYSIWYG helps with it.

We did turn off post caching as well for security reasons - that may slow things down a bit too.
im on broadband and i havent noticed any slowness >.>

drives fast
14 Nov 2003, 04:53
I mentioned this back when the first beta was up here and was told that it was just me (I knew better)

everyone running the 3.x version has a slow site

Zachery
14 Nov 2003, 05:09
I mentioned this back when the first beta was up here and was told that it was just me (I knew better)

everyone running the 3.x version has a slow site
yes, but showthread.php has been improved apon quite abit. the editor seems to load in under a second every time >.>

all my users at my site have commented on nothing but how much faster the forums seem to go now

Logician
14 Nov 2003, 11:57
I don't know if its just me or what, but ever since vb.org has upgraded to VB3 showthread has been loading extremely slow for me with internet explorer 6, even with a high speed connection. Seems to load quicker in Mozilla (hate that browser though). Anyone else noticed this?
Exactly same thing happens to me (though I didn't speak up before lol):
1- Since board upgraded to VB3 show thread is extremely slow for me in IE
2- Mozilla is fast
3- The problem is not my connection (tried with different connections and ISPs, including ADSL)
4- The problem is not WYSIWYG, because it is off for me since day one.

My wild guess is:

I think VB3 show thread templates (or their customization here in vb.org) must have a different HTML syntax than VB2 which IE does not like. I'm not sure what it is but it can be <table> structure somehow. For instance IE does not display table contents until it pulls all table info from the webserver (this means until it gets </table>, altough Mozilla displays partially while it is pulling it. So if VB3/vb.org table structure is configured in a way like this, IE may not be showing the whole page until it gets all posts and when you configured your settings to show 50 posts per thread, then you'll have a huge delay in page display times until all these 50 posts are pulled and served to your browser. Mozilla displays them one by one so there is no delay in it.

I'm not sure if this is the problem so it is just a guess. But I can confirm that I have the same problem and as a matter of fact it is quite disturbing because it affects thread readings really badly.

Xenon
14 Nov 2003, 15:12
Well it's not slow for me.
I've disabled wysiwyg and that surely helps.

but in conclusion Erwin and Logician made the correct points.

the JS for threaded mode/quickreply slow down the pages.
As we don't use the threaded mode Erwin and me will discuss about removing the whole JS part of it with the final vb3.

As for Logicians part: yes, the table-structure of vb3 has been changed strongly, so that could also be part of the problem.
i think we should wait for the new style, as i'm sure Kier doesn't use that much table tags anymore :)

EvilLS1
14 Nov 2003, 15:17
I've also had WYSIWYG turned off since the beginning.

Logician's guess sounds like a good one. That makes sence seeing that all posts are now within a single table, unlike VB2 where each post was in its own table. I like the old vb2 table structure much better because not only was it faster (in IE), but large images didn't stretch the whole page.. Only the post which contained them. Hopefully they'll change this in the final style.

Zachery
14 Nov 2003, 15:50
I've also had WYSIWYG turned off since the beginning.

Logician's guess sounds like a good one. That makes sence seeing that all posts are now within a single table, unlike VB2 where each post was in its own table. I like the old vb2 table structure much better because not only was it faster (in IE), but large images didn't stretch the whole page.. Only the post which contained them. Hopefully they'll change this in the final style.
eh, personally showthread.php is almost instant for me. and vb2 (dev boards) seems slower to me >.>