vBulletin Mods

The Official vBulletin Modifications Site
http://www.vbulletin.org/forum/showthread.php?t=248042

ubeaut 10 Apr 2011 21:43

Just wondering. The below lines appear at the bottom of our main forum page, the represent the entire 5 days Spam-O-Matic has been online on our updated forum.

15 Spammers Denied Registration
66 Spammy Posts Automatically Moderated

Two questions:
  1. Prior to Glowhost we used vbStopForumSpam with results of around 250 spammers per day rejected. Why does there seem to be such a big difference with only 15 rejected/denied registration in 5 days?
  2. The 66 Spammy Posts Automatically Moderated... Where on earth do they go when moderated? we can't find them anywhere and I have mods who are going stir crazy because they can't find then to delete.
My guess was they are being automatically reported then banned but we don't know who, what, where or when they were banned.

Maybe we're missing something. All I can say is I'm getting a bit of a laugh from it as it's messing with the brains of a couple of my moderators.

Cheers - Neil :D

PS Excellent mod, I love it. Saves a heap of time and gives me great enjoyment watching mods and admins chasing their tails trying to figure out where the moderated posts have gone.

camoit 10 Apr 2011 22:38

Look in your ACP on the first page. there you will see on the right side at the top. messages needing moderation. Just click that and you can see all of them.

ubeaut 10 Apr 2011 23:40

Thanks for the reply camoit.

Moderating them isn't a problem, we know where moderated threads/posts reside and how to moderate them been doing it for over 12 years. The problem is that the numbers mentioned of 66 don't show anywhere and have never appeared in Moderation that any of my moderators or administrators have seen. They seem to be phantoms, untouchables, unfindables. Gone without a hint they ever existed.

Cheers - Neil :)

ubeaut 11 Apr 2011 06:56

OK so no one seems to want to satisfactorily answer the two questions in my previous post. Let's try another.

This is part of a post I made at vBulletin.com (full post HERE) So far no response to that one either.

I currently have an instances where one new member (spammer from China) has been able to register his username twice within 1 minute. He then proceeded to do 3 spam posts and then went on to changed his email address in second registration.

First registration was deleted as spam and reported to Stop Forum Spam after he had posted.

The second registration was then banned by moderator.... However it did not show as banned in his profile, but did in Banned Users list, whilst the first registration does not show up in the Banned Users list at all.


Today this person appears to have registered again. Different username, same IP address different email address.

Still shouldn't have got through Spam-O-Matic his ip is 220.179.121.198 and can be found in a search at SFS. There must be a glitch somewhere to allow this to happen.

We do have Name Check disabled in Spam-O-Matic for obvious reasons, as we had in VBStopForumSpam prior. Still I would think it shouldn't let a banned IP through though.

Cheers - Neil

Phaedrus 11 Apr 2011 14:00

There's a timeout setting. If your site cannot contact the StopForumSpam site for a certain period you either allow registration or deny it. In this case it seems that this may have been the cause of your spammer getting through with a tagged IP. I can't be certain without reading the stats, but that is the most likely culprit.

dannefaerd 11 Apr 2011 21:34

Hey all.

We've been getting some new spammers registering - no worries, their IP/email/username doesn't appear in the database.

Now they're not posting threads/posts, but are adding user notes to their own profile with links to spam sites. (gambling, etc). These notes are getting moderated into a queue, but I cannot find an option to report them via the Spam-O-Matic links.

To date we're just banning or deleting the users which are doing this - but any help so we can assist in improving the database would be welcome.

Thanks!
Martin

ubeaut 11 Apr 2011 22:57

Quote:

Originally Posted by Phaedrus (Post 2183382)
There's a timeout setting. If your site cannot contact the StopForumSpam site for a certain period you either allow registration or deny it. In this case it seems that this may have been the cause of your spammer getting through with a tagged IP. I can't be certain without reading the stats, but that is the most likely culprit.

G'day Phaedrus - Thanks for the reply. Please don't get me wrong and I'm not trying to be rude, but that really does sound a bit suspect to me. :rolleyes: I'll admit it is possible if there's a timeout setting. But that's not very reassuring when one is relying on a fix that doesn't appear to work as it should.

But maybe this timeout setting is the reason why only 15 Spammers Denied Registration for an entire 5 day period when prior to that there were approx 250 per day, (that's1,250 for the same time period) or maybe the spammers have just stopped trying. Certainly haven't on my other forum where we are still running at around 250-300 per day being denied access using vbStopForumSpam and we have never had a problem with anyone ever getting back in with the same IP after banning them via SFS.

I fear there may be a serious problem or at least a better explanation than a timeout, especially with the dramatic drop on denied registrations.

Still looking for an answer to Question 2 above in the original post.

Cheers - Neil :D

DannyITR 11 Apr 2011 23:39

I have legit users that are being denied registration using a hotmail account. How come? How can I allow them to register?

GlowHost.com 13 Apr 2011 00:26

1) Because the orginal mod did not count correctly. This has been answered in this thread many times. SOM counts only the users who manage to get past vBulletin's built in registration form. The original mod checked the users before they tried to register on the built in vB form.

There is no reason to waste resources and connections to SFS by checking every bot that may not even get past the built-in vB validation.

2) They end up in the moderated posts as every other moderated thread would. If you are not seeing them then there is an unreported bug or you have another mod which is playing games, or your vB install is corrupt.

Phaedrus 13 Apr 2011 02:33

Quote:

Originally Posted by ubeaut (Post 2183605)
G'day Phaedrus - Thanks for the reply. Please don't get me wrong and I'm not trying to be rude, but that really does sound a bit suspect to me. :rolleyes: I'll admit it is possible if there's a timeout setting. But that's not very reassuring when one is relying on a fix that doesn't appear to work as it should.

But maybe this timeout setting is the reason why only 15 Spammers Denied Registration for an entire 5 day period when prior to that there were approx 250 per day, (that's1,250 for the same time period) or maybe the spammers have just stopped trying. Certainly haven't on my other forum where we are still running at around 250-300 per day being denied access using vbStopForumSpam and we have never had a problem with anyone ever getting back in with the same IP after banning them via SFS.

I fear there may be a serious problem or at least a better explanation than a timeout, especially with the dramatic drop on denied registrations.

Still looking for an answer to Question 2 above in the original post.

Cheers - Neil :D

You can change the setting to disallow registration.

ubeaut 13 Apr 2011 23:04

Quote:

Originally Posted by GlowHost.com (Post 2184018)
1) Because the orginal mod did not count correctly. This has been answered in this thread many times. SOM counts only the users who manage to get past vBulletin's built in registration form. The original mod checked the users before they tried to register on the built in vB form.

There is no reason to waste resources and connections to SFS by checking every bot that may not even get past the built-in vB validation.

2) They end up in the moderated posts as every other moderated thread would. If you are not seeing them then there is an unreported bug or you have another mod which is playing games, or your vB install is corrupt.

Thank you for that. Greatly appreciated and makes sense. However.....

I have banned all moderators and administrators from moderating threads/posts etc to make sure no one is sneaking in and approving, deleting anything from the Moderated thread/post section. Since that time there have been according to the notice on the forum home page 75 Spammy Posts Automatically Moderated (9 more than when I posted originally) but only 2 have gone into the Moderation section leaving 7 more mysteries that have never been seen by us and they join the rest that are lost somewhere.

I have been able to find the moderated posts in the GlowHost - Spam-O-Matic Log Viewer but haven't been able to moderate them as the bulk of them just don't show anywhere other than in that viewer and the links go to an empty Moderation box.

Also on the forum homepage the only stats from SOM are:

Spam-O-Matic StatisticsSpam-O-Matic Statistics

23 Spammers Denied Registration

75 Spammy Posts Automatically Moderated (to date we've only found around 12 of them

We were running v4.1.2 and have updated to v4.1.3 but nothing has changed. vB instalation is not corrupt.

Other mods installed and running are:
Skimlinks Plugin 2.0.7
Tab And Link Manager 4 4.2.0
vBulletin Blog 4.1.3
vBulletin CMS 4.1.3
vBSEO 3.5.2

Cheers - Neil :D

GlowHost.com 13 Apr 2011 23:27

Does anyone else have this problem?

I can't duplicate it on our boards. I don't run any of the mods you have nor blog or CMS.

Boofo 13 Apr 2011 23:29

I would venture to say that maybe vBSEO 3.5.2, or Skimlinks Plugin 2.0.7, are what might be causing some of it.

DannyITR 14 Apr 2011 00:54

Guys I get email every day now from people who can't register. I'll have to uninstall if I can't figure this out. Please help.

ubeaut 14 Apr 2011 06:07

Quote:

Guys I get email every day now from people who can't register. I'll have to uninstall if I can't figure this out. Please help.
The one thing I can maybe help with a little.

Taking name recognition off may help, as there are many many people with the same username around the world and just because one is reported, doesn't tar them all with the same brush. We have something like 20 odd Robbo's registered on one of our forums alone, all with variations of the name but you can bet they nearly all tried plain old Robbo to begin with.

Hope this is of some help.

Quote:

I would venture to say that maybe vBSEO 3.5.2, or Skimlinks Plugin 2.0.7, are what might be causing some of it.
Will disable everything for a few days and see what happens then slowly reintroduce them one at a time over a week or so and see what happens.

Cheers - Neil :D


All times are GMT. The time now is 04:16.

Powered by vBulletin® Version 3.6.12
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©2001 - , vbulletin.org. All rights reserved.