Register Members List Search Today's Posts Mark Forums Read

 
 
Mod Options
  #1  
Old 13 Mar 2001, 17:37
Overgrow's Avatar
Overgrow Overgrow is offline
 
Join Date: Nov 2001
Object: display the highest number of user sessions your board has ever had.

Disclaimer: for snyx.. I don't use 2.0 so I have no idea if anything has changed. This is for 1.x and I have NOT tested this. I wrote it at work and decided to post it since you needed it ASAP. It's something I will use as well, but I can't install and test until later tonight. There is a good chance this will work on 2.0 if it hasn't changed in this area.


1) Create table

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

2) Modify your index.php. Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and under it, ADD:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

3) Open your forumhome template and use the variable $numberoldhigh wherever you want to display your "record" number of sessions. Use $timeoldhigh to display the date of that record.

enjoy
__________________
Marijuana Growing Magazine - since vB 1.1
Comments
  #2  
Old 13 Mar 2001, 19:09
Guest
 
Anyone test this with 2.0 yet?
  #3  
Old 13 Mar 2001, 19:54
Guest
 
Anyone test this with 1.x yet?


heheh
  #4  
Old 13 Mar 2001, 20:21
Guest
 
Lightbulb

You might wanna include a timestamp to recall the date and time when the record was added
  #5  
Old 13 Mar 2001, 20:31
Guest
 
Uh oh.. a little piece of code is turning into an actual hack.



I changed the first post to now use a timestamp.
  #6  
Old 13 Mar 2001, 21:18
Guest
 
Well testing this with Beta 3 it doesn't have

if ($displayloggedin==1) {

it has

if ($displayloggedin) {


So I pasted below that and added to my template, but it prints Dec 31, 1969 16:00


Any ideas?
  #7  
Old 13 Mar 2001, 21:48
Guest
 
Wow it works! 2.0 even... hehe

OK the problem is that when you created the table, there is no value for "TIMESTAMP"

Soooo either you need to enter a value for timestamp manually, or delete the "high" mark and let it set itself again that way it writes a timestamp into the database.

That is assuming there are no errors in my code (haven't tested the timestamp part, just threw it in).
  #8  
Old 13 Mar 2001, 21:58
Guest
 
Originally posted by Overgrow
. . . . . Disclaimer: for snyx.. I don't use 2.0 so I have no idea if anything has changed . . . . .
LOL! Thankz man, just Kier saved me on that one!
  #9  
Old 08 Apr 2001, 05:11
theprof
Guest
 
May I please have the code for vB 1.x? It doesnt seem to be working on my board. No values are entered into the highsessions table. Instead, the total number of people are shown as the maximum number.
  #10  
Old 15 Apr 2001, 22:01
Spider Spider is offline
 
Join Date: Nov 2001
Arrow

Looks like a cool hack to me.
Unfortunatly, I have the same problem as theprof.

The date of record keeps standing on Dec 31, 1969 19:00 and the record of simultanious logged in users is the same as the number of users logged in at the moment.

Could you please tell us what to do so that we can enjoy this cool hack too?

[EDIT: Forgot to tell you that I'm using vbb 1.xx]

Greetings,
Spider
  #11  
Old 25 Apr 2001, 16:46
Overgrow's Avatar
Overgrow Overgrow is offline
 
Join Date: Nov 2001
It sounds like the query is never performing since there is no data in the table to select. Try this...

change:

if ($totalonline > $numberoldhigh) {

to

if ( ($totalonline > $numberoldhigh) or ($numberoldhigh < 1) ) {


Check your highsessions table and see if any data is being entered.
__________________
Marijuana Growing Magazine - since vB 1.1
  #12  
Old 03 May 2001, 17:33
Spider Spider is offline
 
Join Date: Nov 2001
Cool

Great! I finally got it to work.

I changed

if ($totalonline > $numberoldhigh) {

to

if ( ($totalonline > $numberoldhigh) or ($numberoldhigh < 1) ) {

But after that it still didn't work. Then I just went bold, went into the database and setted a
value of 0 in the "high" field. After I did that, it worked like a charm.

Thanks alot for helping me out.

Greetings,
Spider
  #13  
Old 20 May 2001, 03:31
theprof
Guest
 
Now it works ;)

Thanks!
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 14:00.

Layout Options | Width: Wide Color: