Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Forum Category Icons (Advanced) Details »»
Forum Category Icons (Advanced)
Mod Version: 2.0.0, by Dark_Wizard (Coder) Dark_Wizard is offline
Developer Last Online: Sep 2012 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (127 votes - 4.73 average) Installs: 966
Released: 10 Jun 2010 Last Update: 05 Aug 2011 Downloads: 7090
Not Supported DB Changes Uses Plugins Template Edits Auto-Template  

This is a hack that will add icons to your forum categories on the forum home page.

History: I was the originator of this hack back in the vBulletin 1.x days and continued this in vb 3.7.x. I have had numerous requests to port this to vb 4.x.x so here you are.

Please click install if you want support for this mod and to encourage me to continue adding features!

Enjoy!

You can find nice icons here, here and here.

Thanks to LatinoCheats for this link.

Changelogs:

1.2.0:
  • * Option to change icon location i.e. After Status Icon, Under Forum Title or Replace Status Icon.
    * Now contains a dropdown listing your icons in the folder so you just select and save.
    * Displays icon in forum manager when editing a forum that contains an icon.
    * Change icon width and height so you need to only upload one size icon.
    * Set icon position so you can center the icon when using smaller icons.
    * Dropdown of transparency settings for icons used to replace status icons when indicating "Old Posts".
    * Allows you to mark forum/subforum as read.
    * Now shows locked icons (lock icon added to download and this overlays the status icons when indicating a locked forum).

1.2.1:
  • * Now works for Mark Forum/SubForum as read!

1.2.2:
  • * Fixed: template bug.
    * Added: Now shows locked icons (lock icon added to download and this overlays the status icons when indicating a locked forum.)

1.2.3:
  • * Added: Automatic Template Edits!
    * Added: Only jpg, gif and png icons allowed. (extensions checked in forum edit).
    * Fixed: Mark Forum Read for specific forum/subforum.
    * Fixed: Now shows non-transparent status icon when "Show Locks" is enabled.

1.2.4:
  • * Fixed: Users Viewing. (This is working on a default vb style, others styles may have issues)
    * Fixed: Mark Read should now be fixed, working fine on my end.
    * Fixed: Icon not appearing when "Forum Description" disabled.

2.0.0
  • * Icon size can be set either globally or set per forum, setting is in vb options.
    * When selecting an icon in forum manager the selected icon now shows to the right of the dropdown so you can see what you are selecting.
    * If your upgrading from 1.2.4 and had to do manual template edits then you will need to revert the templates and redo the edits.

Upgrades: For those upgrading just make sure when you import the product you select "Allow Overwrite". You will also need to revert your templates (only for users of version 1.2.2 or earlier) and then follow the instructions as outlined in the install.html file.

Note: Before you ask, yes this works with all browsers. (Tested on FF, IE8, IE7, Chrome, Safari and Opera)

IMPORTANT! If you use the "Auto Template" feature of this mod and it doesn't work then you MUST do the manual template edits outlined in the install.html. This plugin was created using a default vbulletin style.

If you like this mod than please nominate for "MOTM".

Donations are gladly accepted!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	select_icon.jpg
Views:	1855
Size:	15.9 KB
ID:	118464Click image for larger version

Name:	forum_edit.jpg
Views:	2800
Size:	15.1 KB
ID:	118465Click image for larger version

Name:	after_status.png
Views:	5146
Size:	25.0 KB
ID:	118466Click image for larger version

Name:	title.png
Views:	5464
Size:	11.6 KB
ID:	118476Click image for larger version

Name:	status.png
Views:	5069
Size:	12.4 KB
ID:	118477Click image for larger version

Name:	status1.png
Views:	5975
Size:	13.2 KB
ID:	118478Click image for larger version

Name:	options.jpg
Views:	5982
Size:	104.5 KB
ID:	118966Click image for larger version

Name:	lock.png
Views:	4648
Size:	13.3 KB
ID:	118967

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Category Icons on Forum Home Dark_Wizard vBulletin 3.7 Add-ons 106 02 Oct 2011 11:14

  #46  
Old 15 Jun 2010, 23:07
Ken Sanders Ken Sanders is offline
 
Join Date: May 2010
Not working right

I installed this earlier today "before" the new update and am having some problems getting the icons to show next to the main icon. If I replace the icon, all seems well, but for some reason I cant get them to show next to the icon.
Do I need to update counters or optimize any tables before I see these?
Reply With Quote
  #47  
Old 15 Jun 2010, 23:12
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by Charlie98902 View Post
This was a nice mod and still is but with the mass template edits now I am not sure I want this.
What mass template edits? This is only 2 template edits and is very simple.
Reply With Quote
  #48  
Old 15 Jun 2010, 23:13
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by Ken Sanders View Post
I installed this earlier today "before" the new update and am having some problems getting the icons to show next to the main icon. If I replace the icon, all seems well, but for some reason I cant get them to show next to the icon.
Do I need to update counters or optimize any tables before I see these?
Nothing else needed. Did you check your template edits? Can you provide me a url to see why you are having an issue? Lastly, it could be something with the style you are using if it is very different template wise from the default style.
Reply With Quote
  #49  
Old 15 Jun 2010, 23:18
Ken Sanders Ken Sanders is offline
 
Join Date: May 2010
Originally Posted by Dark_Wizard View Post
Nothing else needed. Did you check your template edits? Can you provide me a url to see why you are having an issue? Lastly, it could be something with the style you are using if it is very different template wise from the default style.
Using default style.
Here is the URL http://3dcadjewelry.com/forum/forum.php
Only using it on the sub forums Cad design programs and milling machines to this point.
Reply With Quote
  #50  
Old 15 Jun 2010, 23:22
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by Ken Sanders View Post
Using default style.
Here is the URL http://3dcadjewelry.com/forum/forum.php
Only using it on the sub forums Cad design programs and milling machines to this point.
In the file you d/l from here does it have the template edit for forumhome_forumbit_level1_post as indicated here?
Reply With Quote
  #51  
Old 15 Jun 2010, 23:25
Ken Sanders Ken Sanders is offline
 
Join Date: May 2010
Originally Posted by Dark_Wizard View Post
In the file you d/l from here does it have the template edit for forumhome_forumbit_level1_post as indicated here?
Nope, only for formbit_level2 (at least that is what was in the instructions.txt
Will take a look at the link.
Reply With Quote
  #52  
Old 15 Jun 2010, 23:34
Ken Sanders Ken Sanders is offline
 
Join Date: May 2010
Still stuck on only replacing, but they do show up immediately now ...not sure where to go from here. I'll double check to make sure I inserted everything correctly.
Reply With Quote
  #53  
Old 16 Jun 2010, 00:25
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by Ken Sanders View Post
Still stuck on only replacing, but they do show up immediately now ...not sure where to go from here. I'll double check to make sure I inserted everything correctly.
Checked your site a few times now and it looks like you sorted it all out....
Reply With Quote
  #54  
Old 16 Jun 2010, 00:54
Ken Sanders Ken Sanders is offline
 
Join Date: May 2010
Thanks Dark_Wizard,
Love the mod, but I guess I am doing something wrong in order to get the icons to display next to the regular icons...Still don't know what I am doing wrong. Double checked all the template mods and all seems well.
Will use as is, and hopefully figure out what brain fart I am having to get this to work the way I want it to.
Reply With Quote
  #55  
Old 16 Jun 2010, 10:12
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by Ken Sanders View Post
Thanks Dark_Wizard,
Love the mod, but I guess I am doing something wrong in order to get the icons to display next to the regular icons...Still don't know what I am doing wrong. Double checked all the template mods and all seems well.
Will use as is, and hopefully figure out what brain fart I am having to get this to work the way I want it to.
Did you select "After Status Icon"?
Reply With Quote
  #56  
Old 17 Jun 2010, 01:32
texasteamplayer's Avatar
texasteamplayer texasteamplayer is offline
 
Join Date: Jan 2010
updated.

loading in 100px icons....but it still isn't allowing me to set them other than 48 px.
__________________
www.teamplayergaming.com
Reply With Quote
  #57  
Old 17 Jun 2010, 10:14
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by texasteamplayer View Post
updated.

loading in 100px icons....but it still isn't allowing me to set them other than 48 px.
Just checked your site, you need to redo the template edits from the install.txt.
Reply With Quote
  #58  
Old 17 Jun 2010, 10:25
KURTZ KURTZ is offline
 
Join Date: Nov 2006
Real name: Christian

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just installed and got this into the ACP under the forum manager ...

edit: if i select 'after status icon' option i got this (check the pic attached)
Attached Images
File Type: png Suite_1276770671422.png (21.4 KB, 93 views)

Last edited by KURTZ : 17 Jun 2010 at 10:32.
Reply With Quote
  #59  
Old 17 Jun 2010, 18:09
Dark_Wizard Dark_Wizard is offline
 
Join Date: Nov 2001
Real name: Bob
Originally Posted by KURTZ View Post
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

just installed and got this into the ACP under the forum manager ...

edit: if i select 'after status icon' option i got this (check the pic attached)
That error would only show up if you had no icons in the folder. As for the other issue this is the first anyone has had that issue. Can you provide me a url so I can check it out?
Reply With Quote
  #60  
Old 17 Jun 2010, 22:56
eddieor eddieor is offline
 
Join Date: Jan 2009
Best mod I've downloaded

great app, no problems and very easy to install.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 13:28.

Layout Options | Width: Wide Color: