Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Quick Edit! -Edit posts directly from within the thread itself Details »»
Quick Edit! -Edit posts directly from within the thread itself
Mod Version: 2.00, by EvilLS1 (Member) EvilLS1 is offline
Developer Last Online: Dec 2014 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.0.6 Rating: (1 vote - 5.00 average) Installs: 145
Released: 04 Jan 2004 Last Update: 25 Jan 2005 Downloads: 27
Not Supported  

This hack will allow your users to edit their posts without having to load the editpost page..

How it works: In the bottom right-hand corner of all your posts will be a small Quick Edit icon (users will only see it in posts which belong to them).. When you click it a text box will drop down below your post allowing you to edit it instantly in the thread itself.

This will save you a lot of time when fixing those spelling mistakes, typos, or broken links. It should also help save on bandwidth since your users will no longer need to load the editpost page.

Very easy to install.. 2 file edits, 2 template edits, and 1 template to add.

Known bug: Quick Edit will NOT work with Opera web browsers. Those who use Opera simply won't see the option to quick edit (icon will be invisible when viewed in that browser). It'll work fine in other browsers such as IE or firefox.

Support: Due to work my time is limited as of late so this hack is released AS IS with no support. However, several questions have already been answered in this thread.

Update (7-25-04): Fixed a minor bug with the QE window moving further to the left with each click in mozilla/firefox browsers. To update simply replace your showthread_quickedit template with the new one. Thanks to sv1cec for this bug fix.

Add Ons:
*Show the "delete post" option for those who have permission in the Quick Edit form (also adds edit reason). (by sv1cec)
*Show the "edit reason" field in the Quick Edit form. (Requested by Convergys)
*Alternate Quickedit icon image (by ryancooper)
*Another alternate Quickedit icon (by sv1cec)
*Another alternate Quickedit icon (by charlesk)
*Yet another alternate Quickedit icon (by iguanairs)
*Give users the option to disable quick edit in the usercp (by pco)



If you find this hack useful please click the install button.

Screenshot attached:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	screenshot.jpg
Views:	1790
Size:	43.1 KB
ID:	18540

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Quick Edit! -Edit posts directly from within the thread itself EvilLS1 vBulletin 2.x Full Releases 126 30 Jan 2004 07:01

  #226  
Old 13 Oct 2004, 04:08
kirupa kirupa is offline
 
Join Date: Dec 2002
Thanks for the reply Evil! Yeah - I do have that line removed, and I even retried by copying your original code into the showthread_quickreply and making the changes you mention. It is weird, for regardless of whether Subscribe is checked or not, the editer is subscribed to the thread after quick-editing a post :surprised:
Reply With Quote
  #227  
Old 13 Oct 2004, 04:55
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Kirupa,
I know this will sound crazy, but put this line of code back in the template where it was to begin with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Then just keep the code for the checkbox exactly like you have it. Just tested it on my board, it works fine that way.
__________________
V4MuscleBike.com
Reply With Quote
  #228  
Old 13 Oct 2004, 05:15
kirupa kirupa is offline
 
Join Date: Dec 2002
Thanks a lot Evil! That works perfectly :banana:
Reply With Quote
  #229  
Old 13 Oct 2004, 05:31
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Y/W. Sorry for the mix up.
__________________
V4MuscleBike.com
Reply With Quote
  #230  
Old 05 Nov 2004, 21:37
kirupa kirupa is offline
 
Join Date: Dec 2002
Hey evil!
Just wondering, is there a way to have the sig checkbox in QuickEdit check to see if the user's post has a signature? In other words, if a user's post has a signature, pressing QuickEdit would have the Sig box checked.

If you can't do that without straining valuable brain processing power, don't worry about it. It's just a minor request several members had.

Cheers!
Kirupa :devious:
Reply With Quote
  #231  
Old 05 Nov 2004, 21:55
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Try this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
V4MuscleBike.com
Reply With Quote
  #232  
Old 09 Nov 2004, 21:48
RsX's Avatar
RsX RsX is offline
 
Join Date: Sep 2004
there seems to be a problem with the editor now that u updated the template... When an admin tries to delete someone elses post it deletes the last post on the thread instead.. Could u maybe please post a complete template with these features if you can?

*Admin can edit all posts
*Delete button
*Reason for editing (not so important)

With the latest template?
Thanks alot in advance
Reply With Quote
  #233  
Old 11 Nov 2004, 23:48
theArchitect's Avatar
theArchitect theArchitect is offline
 
Join Date: Sep 2004
Originally Posted by RsX
there seems to be a problem with the editor now that u updated the template... When an admin tries to delete someone elses post it deletes the last post on the thread instead.. Could u maybe please post a complete template with these features if you can?

*Admin can edit all posts
*Delete button
*Reason for editing (not so important)

With the latest template?
Thanks alot in advance
I am having a slight problem. I have been using your quick edit feature for a month or so now and it has been working fine. But now when I use the quick edit feature instead of just updating the post it moves the post to the position of first post in the thread with no user details in the postbit.

If I then delete the post it deletes the whole thread.

I added the vB Journal & vB Stock system created by AN-Net. but surely this shouldn't effect this hack in this way.

HELP!!
Reply With Quote
  #234  
Old 12 Nov 2004, 00:07
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Are you using the instructions from the first post or have you added some other version posted within this thread? If you're using another version I'd suggest removing it and installing the original to see if that fixes it. Other than that the only thing I can tell you is that it has to be another hack conflicting with quick edit. You'd have to temporarily remove them to see which one is causing the problem. More specifically, any edits to functions_showthread.php, showthread.php, editpost.php, or changes to the postbit template.
__________________
V4MuscleBike.com
Reply With Quote
  #235  
Old 12 Nov 2004, 00:14
theArchitect's Avatar
theArchitect theArchitect is offline
 
Join Date: Sep 2004
Originally Posted by EvilLS1
Are you using the instructions from the first post or have you added some other version posted within this thread? If you're using another version I'd suggest removing it and installing the original to see if that fixes it. Other than that the only thing I can tell you is that it has to be another hack conflicting with quick edit. You'd have to temporarily remove them to see which one is causing the problem. More specifically, any edits to functions_showthread.php, showthread.php, editpost.php, or changes to the postbit template.
Thanks. I am just using the instructions from the first post. But you have supplied me with the info I needed, which was what files could be interfering with the hack.

Just out of interest. Is the problem likely to be because of a file change or could a DB change have caused this.

Sorry to be so vague, but I am stumbling around in the dark at the moment.
Reply With Quote
  #236  
Old 12 Nov 2004, 00:18
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Most likely just a file change.
__________________
V4MuscleBike.com
Reply With Quote
  #237  
Old 27 Nov 2004, 12:23
Revan's Avatar
Revan Revan is offline
 
Join Date: Jan 2004
Real name: Fillip
I am having the same problem, but I dont have the time to tamper with the files back and forth... So if anyone else with this problem could come up with the solution it would be most appreciated
Reply With Quote
  #238  
Old 28 Nov 2004, 23:42
charlesk charlesk is offline
 
Join Date: Nov 2004
Awesome hack, thank you.

As a newbie hacker, my feeble contribution is my rendition of a quick-edit button, which I think looks nice.

Charles
Attached Images
File Type: gif quickedit_icon.gif (2.1 KB, 195 views)
Reply With Quote
  #239  
Old 29 Nov 2004, 00:27
EvilLS1's Avatar
EvilLS1 EvilLS1 is offline
 
Join Date: Apr 2002
Thanks charlesk. Your icon looks good. Added a link to it in the first post.
__________________
V4MuscleBike.com
Reply With Quote
  #240  
Old 29 Nov 2004, 01:11
charlesk charlesk is offline
 
Join Date: Nov 2004
Thanks EvilLS1.

Two questions.. I want to add the delete post option but when I open your link it seems to be talking about two different things, an error fix and the delete option. Could you clarify for me what I need to do? Again, I'm a newbie.

Also.. any chance of a tweak to this hack so that the QEdit box appears for admins on everyone's posts? Or would that make the files too big by duplicating everything?

Thanks.

Charles
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 10:36.

Layout Options | Width: Wide Color: