Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 11 Jan 2017, 18:16
Disco_Dave's Avatar
Disco_Dave Disco_Dave is offline
 
Join Date: May 2011
*A little advice if possible*

Hi Everyone

Long time off vb.org, and my own forum tbh. I have a list add-ons that need updated. My question is should I update the forum first, which is on 4.2.2 or should i do the update all my add-ons first.

Our forum is coming to the end of the server it's on, so we are going to be moving to a more modern server (above my head tbh) Can vBulletin 4.2.3 move to a more modern server.

Here's a list of our server info at present:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I am not moving our site is another admin, but he's telling me that the new server is php 7.1 the mysql will be a higher version also. Is this achievable with vbulletin 4.2.3

Regards,
Dave
__________________
www.nirc.co.uk
Reply With Quote
  #2  
Old 11 Jan 2017, 18:36
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
You will need to upgrade to vB 4.2.5 Beta 1 to run PHP 7.x.

I really don't think it matters much whether you upgrade your add-on products before or after the vB upgrade.
__________________
Reply With Quote
  #3  
Old 11 Jan 2017, 18:37
Disco_Dave's Avatar
Disco_Dave Disco_Dave is offline
 
Join Date: May 2011
Thanks Mark, is this build available from the vb customer area?
__________________
www.nirc.co.uk
Reply With Quote
  #4  
Old 11 Jan 2017, 18:49
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Yes it is...I'm now running it on my local dev site, and am planning a live upgrade to this version tonight.
__________________
Reply With Quote
  #5  
Old 12 Jan 2017, 10:49
cellarius's Avatar
cellarius cellarius is online now
 
Join Date: Aug 2005
Real name: Sven
Originally Posted by Disco_Dave View Post
Hi Everyone

Long time off vb.org, and my own forum tbh. I have a list add-ons that need updated. My question is should I update the forum first, which is on 4.2.2 or should i do the update all my add-ons first.
That won't matter on an upgrade from 4.2.2 to 4.2.3. I doubt you'll even find newer addon versions. You should test if those addons work with PHP 7.1., which some may not.
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #6  
Old 12 Jan 2017, 15:40
Disco_Dave's Avatar
Disco_Dave Disco_Dave is offline
 
Join Date: May 2011
Getting this error when trying to upgrade to 4.2.5
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The forum upgraded to 4.2.3 from 4.2.2 ok. Getting that error also on 4.2.4 Waiting on the host getting back to me.
__________________
www.nirc.co.uk
Reply With Quote
  #7  
Old 12 Jan 2017, 19:08
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
That error indicates your php version is too old, 4.2.5 Beta 1 requires at least php 5.5.

From Beta 2 onwards that will increase to php 5.6.
__________________

Cable Forum
Lead Developer, vBulletin.Org & vBulletin.Com
Please do not PM me about custom work - I no longer undertake any.

Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #8  
Old 12 Jan 2017, 19:57
Disco_Dave's Avatar
Disco_Dave Disco_Dave is offline
 
Join Date: May 2011
Originally Posted by Paul M View Post
That error indicates your php version is too old, 4.2.5 Beta 1 requires at least php 5.5.

From Beta 2 onwards that will increase to php 5.6.
Thanks, I've spent most of today learning this. The only reason why I'm doing this, is are host has ran out. And so has the forum, but a few I mean a few members that still post and don't want it to die just yet. So a forum member that helps with the forum has offered to host the site on a cloud server at his work, but he's telling me that, it's running on php 7 and the mysql version is higher also.

I can no longer justify paying out anymore money on this forum.
__________________
www.nirc.co.uk
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 10:45.

Layout Options | Width: Wide Color: