Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Chrome Browser Notice (For Quick Reply Editor) - How to fix non-working space bar Details »
Chrome Browser Notice (For Quick Reply Editor) - How to fix non-working space bar
Mod Version: 1.0.0, by BirdOPrey5 (Moderator) BirdOPrey5 is offline
Developer Last Online: Mar 2017 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (2 votes - 5.00 average) Installs: 34
Released: 05 Nov 2016 Last Update: 05 Nov 2016 Downloads: 87
Supported Uses Plugins Auto-Template Re-usable Code  

If you are not already aware the latest version of Chrome browser (Version 54.0.2840.71, possibly others) has introduced a bug or incompatibility with the version of CKEditor used in VB 4.x.

If a user attempts to use the "Reply With Quote" feature on an existing post and begins to type their reply under the existing quote without hitting the Enter key first, the space bar will not work.

The issue is talked about on vBulletin.com here: http://www.vbulletin.com/forum/forum...rking-on-reply

While this is not a true fix, it does display a notice above the quick reply editor advising Chrome users that they can fix the problem simply by hitting the Enter key. (See Screenshot.)



The actual text displayed is held in a Global phrase called chrome_editor_message_bop5 so it is easily edited or translated as needed using Phrase Manager in the Admin CP.

There are no options, just install it and it will become active. Disable or remove the product to stop using it.

Notice will only be displayed in Chrome browser and when the enhanced WYSIWYG editor is enabled in the user's options. The Standard Editor and Basic Editor do not have this bug.

The function that attempts to determine the browser version was publicly available, location it can be found is a comment in the Functions plugin.

This mod will only install on VB 4.x versions and is only useful with VB 4.x versions 4.1.12 and above. May not work on heavily customized styles.

------------------------------------------------------

Please "Mark as Installed" if you use this.
Donations always appreciated.
Nominate MOTM if you LOVE it!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	chrome_browser_warn_ss.jpg
Views:	94
Size:	62.3 KB
ID:	155457  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Show Thread Enhancements [CKEditor] MARCO1 Advanced Editor - Quick Reply & Quick Edit With Full Editor Control MARCO1 vBulletin 4.x Add-ons 467 26 Jan 2017 21:33

Comments
  #2  
Old 05 Nov 2016, 12:19
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Reserved.
__________________
-Joe (@BirdOPrey5)
Qapla.com - Exclusive VB Mods! | Joe's Ultimate Off Topic | My Free VB "Mods"
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #3  
Old 06 Nov 2016, 14:11
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Well, I guess this was a waste of my time.

Google has already pushed out an update with Chrome that fixes the issue. The new version on Win 10 64 bit is 54.0.2840.87.

If you have already installed it maybe give it a week or so for everyone to update and then remove it. No need for it.


Edit - Not true.
__________________
-Joe (@BirdOPrey5)
Qapla.com - Exclusive VB Mods! | Joe's Ultimate Off Topic | My Free VB "Mods"
Note - I do not read my PMs often, do not expect quick replies.

Last edited by BirdOPrey5; 07 Nov 2016 at 10:56. Reason: fixed
Reply With Quote
  #4  
Old 06 Nov 2016, 17:14
andryus andryus is offline
 
Join Date: Jan 2006
I am getting the same issue with the latest chrome update ( 54.0.2840.87 m )
Reply With Quote
  #5  
Old 06 Nov 2016, 20:09
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
Originally Posted by andryus View Post
I am getting the same issue with the latest chrome update ( 54.0.2840.87 m )
As am I and my users.
Reply With Quote
  #6  
Old 06 Nov 2016, 20:24
BadgerDog BadgerDog is offline
 
Join Date: Oct 2006
Real name: Doug
Originally Posted by BirdOPrey5 View Post
Well, I guess this was a waste of my time.

Google has already pushed out an update with Chrome that fixes the issue. The new version on Win 10 64 bit is 54.0.2840.87.

If you have already installed it maybe give it a week or so for everyone to update and then remove it. No need for it.
I've found your code and contributions are never a waste of time ..

Thanks for doing this ..

Regards,
Doug
Reply With Quote
  #7  
Old 07 Nov 2016, 01:57
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Originally Posted by andryus View Post
I am getting the same issue with the latest chrome update ( 54.0.2840.87 m )
Originally Posted by Kane@airrifle View Post
As am I and my users.
Have you restarted your browsers and perhaps cleared your cache? I know I cleared my cache for a different reason but it definitely works for be after restarting the browser.
__________________
-Joe (@BirdOPrey5)
Qapla.com - Exclusive VB Mods! | Joe's Ultimate Off Topic | My Free VB "Mods"
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #8  
Old 07 Nov 2016, 02:56
andryus andryus is offline
 
Join Date: Jan 2006
Originally Posted by BirdOPrey5 View Post
Have you restarted your browsers and perhaps cleared your cache? I know I cleared my cache for a different reason but it definitely works for be after restarting the browser.
Sure, already tested, still with the same issue with the latest chrome update, tested on different computers with clean chrome.
Reply With Quote
  #9  
Old 07 Nov 2016, 10:55
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
So weird... seems like it is still broke for me. I thought changing styles would have reloaded the CSS but I had to clear my cache and once I did the problem was back.

There is no working fix yet from Chrome, sorry for the confusion.
__________________
-Joe (@BirdOPrey5)
Qapla.com - Exclusive VB Mods! | Joe's Ultimate Off Topic | My Free VB "Mods"
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #10  
Old 09 Nov 2016, 13:29
DeMonViTo DeMonViTo is offline
 
Join Date: Jun 2005
Hello thanks for the mod!
I have the same problem even when I reply to private messages, you could place the warning them also?
__________________
asd
Reply With Quote
  #11  
Old 09 Nov 2016, 18:54
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
I'll need to take a closer look. A quick glace suggests it possible but more difficult. Will get back to you here.

Please "Mark as Installed" if you're using it.
__________________
-Joe (@BirdOPrey5)
Qapla.com - Exclusive VB Mods! | Joe's Ultimate Off Topic | My Free VB "Mods"
Note - I do not read my PMs often, do not expect quick replies.
Reply With Quote
  #12  
Old 10 Nov 2016, 07:26
Kane@airrifle's Avatar
Kane@airrifle Kane@airrifle is offline
 
Join Date: Jun 2011
Real name: Kane
This mod is still relevant.

The issue remains in Chrome 54.0.2840.99 m
Reply With Quote
  #13  
Old 15 Nov 2016, 15:46
sticky sticky is offline
 
Join Date: Sep 2003
Such a joke Vbulletin can't fix this.
Reply With Quote
  #14  
Old 15 Nov 2016, 15:52
In Omnibus's Avatar
In Omnibus In Omnibus is offline
 
Join Date: Apr 2010
Real name: Kris
Originally Posted by sticky View Post
Such a joke Vbulletin can't fix this.
Why are you blaming vBulletin for a problem with the Google Chrome web browser and the CKEditor, neither of which are developed by vBulletin?
Reply With Quote
  #15  
Old 16 Nov 2016, 19:47
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul M
Originally Posted by sticky View Post
Such a joke Vbulletin can't fix this.
The only "joke" is people who make clueless comments about things they dont seem to understand. This is a bug/issue in Chrome, so I suggest you go and moan at them.
__________________

Cable Forum
Please do not PM me about custom work - I no longer undertake any.
Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 18:03.

Layout Options | Width: Wide Color: