Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Track Guest Visits Details »»
Track Guest Visits
Mod Version: 3.8.003, by Paul M (Dr Pepper Addict) Paul M is offline
Developer Last Online: Dec 2014 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (46 votes - 4.76 average) Installs: 618
Released: 09 Jan 2009 Last Update: 19 Sep 2010 Downloads: 2753
Supported Uses Plugins Auto-Template Additional Files Translations  

vBulletin 3.8 Version
Please remember to click Mark as Installed if you use this modification.
Support questions from members who have not marked this as installed will be considered low priority.

This tracks the number of guests that have visited a forum each day. This isn't possible in stock vbulletin as no record is kept of guest visits, they are a 'realtime' display only. This will add (another) section to the "What's Going On" area.

Options / Features ;

* The ability to turn it on/off.
* The ability to turn just the display on/off.
* The ability to allow (or prevent) certain usergroups viewing the display.
* The ability to run the display code on all pages (not just forumhome).
* The ability to switch between 'Today' and Rolling 24 Hours display (default).
* The list of guests can be set to be always collapsed on initial view.
* The script that the Guest is running is logged (e.g. showthread, usercp etc).
* The request variables in use are logged (e.g. threadid, userid etc).
* The guest table can be cleaned of old records to help control it's size.
* Controls for the displays automatic template update.
* The datastore read (for spider detection) will read from the File/APC/Memcache/Xcache datastore [if used].
* Guest Views data collection - tracking each guests viewing of the forum index page, forums and threads.
* Guest Views data collection can be separately disabled.
* Multiple guest visits to the same page are logged separately.
* Clicking on a Guest type in the main display will list all recent visits by guests of that type.
* Clicking on the option in the guest listing will show that guests viewing data (if enabled).
* Usergroup permissions are done with the standard vbulleten usergroup permissions system.
* The option to keep a record of [and display] the most ever guests can be enabled.

Four new usergroup permissions are provided in the usergroup manager.

* Can View the Guests Visited Display - Members can view the guests visited display on Forumhome.
* Can View Guest IP Addresses - Members can see the ip addresses of visiting guests.
* Can View Guest Visits List - Members can view the list of guest visits page.
* Can View Guest Tracking Data - Members can view the individual guest visit tracking page.

* All (non usergroup) modification settings are in vBulletin Options > Guest Tracking.

To install (or upgrade);
  • Unzip the XML files.
  • Upload the bitfields file to your ../includes/xml folder.
  • If upgrading from a previous version, delete the old bitfield xml file from your ../includes/xml folder.
  • Import the product into vBulletin using the ACP Product Manager.
  • Set your required permissions in the usergroup manager.
Note that by default no usergroup permissions are given, you must set them.


You can get an improved Spiders Definition file from this post.

Note: For Spider detection to work you must set Enable Spider Display to 'Yes' in vBulletin Options > Who's Online Options.

Template Hook

Please note that this modification uses the following template hook in the FORUMHOME template ;

forumhome_wgo_pos2

This must be present in any customised template/style you are using, otherwise this modification will not display.



History:

v3.8.001 : Initial vb 3.8 release.
v3.8.002 : Fix install code SQL error.
v3.8.003 : Fix bug in attachment viewing links.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Track Guest Visits Paul M vBulletin 3.7 Add-ons 276 12 Jan 2014 17:47
Track Guest Visits Paul M vBulletin 3.6 Add-ons 889 09 Dec 2008 22:17

  #46  
Old 09 Feb 2009, 22:10
harlita harlita is offline
 
Join Date: Dec 2006
Originally Posted by japancars View Post
I installed the mod and made the permissens in the usergroups manager...
But i cant see anythin on the index page... what have i done wrong?
I use vb 3.8.1

So the section doesn't even show up? It doesn't stand out, it looks very neat and natural, right below the list of folks online right now as you can see here: http://i166.photobucket.com/albums/u...li/visitor.jpg
Very neat and tidy.

Once it shows up for you, there is a noted delay after initial installation before you'll see any data showing up for the Visitors / Spiders / Bots, but that's of course due to the fact it's a new install, so there's no data to display yet.

Is the box not showing up at all, though? I'm running 3.8.0 as well, but not 3.8.1 - though I can't imagine a non-major release would adversely affect the code PaulM gave us to the point it doesn't even display.. :S
Reply With Quote
  #47  
Old 13 Feb 2009, 00:48
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Hi Paul,

I have installed it to the tee (Even removed your old hack on th 3.6.8) but I am getting no box.

I am still pretty new to this, so, would you (or anyone else) mind explaining what is meant by what you say here, Please? Where & how would I check for it, what is it exactly that I am looking for? And how do I overcome it Please? I am running 3.8.1.

Originally Posted by Paul M View Post
You prob have a customised forumhome template, missing the vb template hooks.
I know that you are very busy - But I would appreciate some help.
Reply With Quote
  #48  
Old 13 Feb 2009, 08:51
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul Marsden
Compare your template to the vb default, you will see the missing template hook(s) that you must add.
__________________

Cable Forum
Lead Developer, vBulletin.Org & vBulletin.Com
Please do not PM me about custom work - I no longer undertake any.

Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #49  
Old 13 Feb 2009, 17:21
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Thanks for your reply, Paul. I will check it later.
Reply With Quote
  #50  
Old 14 Feb 2009, 21:56
rizelim's Avatar
rizelim rizelim is offline
 
Join Date: Nov 2006

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Where to it will combine. thanks!
__________________
Temizel Lift Community
Reply With Quote
  #51  
Old 21 Feb 2009, 16:42
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Originally Posted by Welshy2008 View Post
Hi Paul,

I have installed it to the tee (Even removed your old hack on th 3.6.8) but I am getting no box.

I am still pretty new to this, so, would you (or anyone else) mind explaining what is meant by what you say here, Please? Where & how would I check for it, what is it exactly that I am looking for? And how do I overcome it Please? I am running 3.8.1.



I know that you are very busy - But I would appreciate some help.
Originally Posted by Paul M View Post
Compare your template to the vb default, you will see the missing template hook(s) that you must add.
Originally Posted by Welshy2008 View Post
Thanks for your reply, Paul. I will check it later.


Hi Paul,

It is now showing for me Mate. I have searched my "FORUMHOME" and the 'forumhome_wgo_pos2' is there as follows...


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any Ideas, Please?
Reply With Quote
  #52  
Old 21 Feb 2009, 16:54
Welshy2008's Avatar
Welshy2008 Welshy2008 is offline
 
Join Date: Jul 2008
Cancel the above post, Paul. I un-installed and re-installed them and it works great.

Thank You.
Reply With Quote
  #53  
Old 22 Feb 2009, 01:45
Tophon Tophon is offline
 
Join Date: Jan 2009
Thanks Paul, great add-on!

Installed
Reply With Quote
  #54  
Old 07 Mar 2009, 16:17
Dave-M Dave-M is offline
 
Join Date: Sep 2007
Hi Paul,

Thanks for this, I have been using the older version for 3.7 plus the "Members who have visited" add on.

I've updated to 3.8.1 from 3.7.4 and now neither of the add ons will display.

Having read through this thread, I've made sure that I have the latest version of my template and it does indeed contain the required hook (see piccy below). The add ons seem to have installed correctly and are enabled, but I cant see them on the forumhome page.

I've reinstalled them, but still no luck.

Would you have any idea why this may not be working please? If you need any more details, please say.

Thanks

Dave

Edit: Fixed, changed to a different template, reinstalled the add on and then changed the template back and it's ok now...weird!
Attached Images
File Type: png installed-ok.png (4.9 KB, 70 views)
File Type: jpg settings1.jpg (114.4 KB, 78 views)
File Type: jpg templates-comparison.jpg (74.7 KB, 77 views)

Last edited by Dave-M : 07 Mar 2009 at 16:46.
Reply With Quote
  #55  
Old 20 Mar 2009, 00:02
reverse1312 reverse1312 is offline
 
Join Date: Jan 2006
Real name: Martin
Originally Posted by Dave-M View Post
changed to a different template, reinstalled the add on and then changed the template back and it's ok now...weird!
Hello Dave,

I have the same problem

Wonder what you mean with "changed to a different template" and "changed the template back"

Could you just explain a bit more please ?

Thanks
EDIT : After having once more uploaded the "bitfield xml file" - you must erase the existent one, everyting is running fine again :-)

Last edited by reverse1312 : 20 Mar 2009 at 04:36. Reason: correcting
Reply With Quote
  #56  
Old 28 Mar 2009, 02:11
Phobos49 Phobos49 is offline
 
Join Date: Jan 2009
Great!!! Thanks!

I have a problem:
After editing the phrase [trg_visitors] the whole plugin stops working!
I would like to change "Visitors" into "Heutige Gäste". How can I do this without crashin' the PlugIn?
The problem seems to be the blank between the 2 words!

Last edited by Phobos49 : 28 Mar 2009 at 02:24.
Reply With Quote
  #57  
Old 28 Mar 2009, 14:29
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul Marsden
I have changed it to that on my test forum and it seems to be working fine, what do you mean by "crashing" ?
__________________

Cable Forum
Lead Developer, vBulletin.Org & vBulletin.Com
Please do not PM me about custom work - I no longer undertake any.

Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #58  
Old 29 Mar 2009, 02:22
Phobos49 Phobos49 is offline
 
Join Date: Jan 2009
Originally Posted by Paul M View Post
I have changed it to that on my test forum and it seems to be working fine, what do you mean by "crashing" ?
"crashing" means that if you click on the number of guests, the displayed guest tracking page has no entrys.
I think I figured out the problem: the blank between the two words "Heutige Gäste" appears as "%20" in the link to misc.php

But don't worry about the problem! I now use the single word "Gäste" instead of "Heutige Gäste" and everything works fine.

Last edited by Phobos49 : 29 Mar 2009 at 02:53.
Reply With Quote
  #59  
Old 29 Mar 2009, 12:00
Paul M's Avatar
Paul M Paul M is offline
 
Join Date: Sep 2004
Real name: Paul Marsden
It works fine for me, with the space
__________________

Cable Forum
Lead Developer, vBulletin.Org & vBulletin.Com
Please do not PM me about custom work - I no longer undertake any.

Note: I will not answer support questions via e-mail or PM - please use the relevant thread or forum.
Reply With Quote
  #60  
Old 15 Apr 2009, 09:48
Rakehel's Avatar
Rakehel Rakehel is offline
 
Join Date: Dec 2005
Real name: Michael
Question

This is the 4th(?) version of this mod that I've used and it has always worked well and been a favorite. For some reason this version isn't functioning properly. The appropriate display with a Guest count/link shows on the main board but the individual spiders are no longer listed. I can click the link for the generated guest count and review all of the pertinent information, as before.

I'm running vB v3.8.1 w/PL1. I began the Track Guests upgrade after moving to a new server about two weeks ago. We've been using a dedicated I.P. longer than that without issues in displaying individual spiders.

-I've uninstalled the old version, removed the bitfield.
-Uploaded the new bitfield.
-Imported the product.
-Set permissions.
-Verified the hook location in defult and customized styles.
-Made certain the mod was activated in vB ACP options and Plug-In mgr.
-Double-checked spider detection in WOL. (ACP options)
-Uninstalled product and removed bitfield from server a few times over 2-3 days. (Reinstalled with vB default style activated too.)
-Verified chmodding.
-Verfied content and re-uploaded vbulletin_spider.xml list.
-Repaired SQL tables.

What am I missing here? The most recent reinstall has been in place for over 12 hours, spiders are visiting but not displayed individually and the total count keeps growing. Do I need to wait longer? Run the query to clear the WOL cache?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 00:26.

Layout Options | Width: Wide Color: