Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Cyb - Advanced 'New Posts' (AJAX) Details »»
Cyb - Advanced 'New Posts' (AJAX)
Mod Version: 2.4, by Valter (Coder) Valter is offline
Developer Last Online: May 2014 I like it Show Printable Version Email this Page

vB Version: 3.8.x Rating: (22 votes - 4.50 average) Installs: 422
Released: 10 Jan 2009 Last Update: 17 Jan 2009 Downloads: 2466
Not Supported Uses Plugins Auto-Template  

Info:
This hack will show how many new posts/threads have been posted in forums since 'last visit' time. "New Posts" in navbar menu will be replaced with "New Posts: x (In y Threads)" which is updated via AJAX - no page refresh. User can manually check for new posts, or you can enable auto-check which is executed in defined time interval. Optionally you can enable and configure Smart Search Menu to give users ability to search only selected forum sections. See screenshots...


Installation:
Import product XML: AdminCP > Plugin System > Manage Products > [Add/Import Product]


To set options:
Go to: AdminCP > vBulletin Options > Cyb - Advanced 'New Posts'


Versions:
v1.0 - Apr 29. 2006.
-First version
v1.5 - Jun 25. 2006.
-Added - advanced searching of new posts (see screenshots)
-Fixed known bugs, code optimized
v1.6 - Jun 26. 2006.
-Advanced searching of new posts splitted into two navbar items
v1.7 - Jun 28. 2006.
-Depending on number of new posts different phrase is used
-Added links to phrases to hack options page so you can easily find and change/translate them.
v1.8 - Aug 04. 2006.
-Release of this hack for vB v3.6
v1.9 - Sep 28. 2006.
-Added Product Version Checking
-Fixed links to phrases in ACP (used to easily customize phrases)
-Added option to change text color
-Fixed bug (unneeded extra space after "SSM" in navbar menu)
-Product name changed to "Cyb - Advanced 'New Posts'"
NOTE: Before upgrading save somewhere content of "Menu Items" field to restore it after upgrade. It will be removed during upgrade process.
v2.0 - Jul 31. 2007.
-Added "No New Posts" to show when there is no new posts after user last visit
-Smart Search Menu (SSM) improved (no more need to write lines of code, just put forum IDs in setting field)
-SSM automatically hidden when there is no new posts
-A lot of improvements and optimization done, including:
*two templates removed
*improved integration with different styles (to avoid manual template edits)
v2.1 - May 03. 2008.
-Compatible with vBulletin 3.7
-Minor bugs fixed
v2.2 - Jan 14. 2009.
-New: New post check is now done via AJAX - no page refresh ;-)
-New: Auto-check for new posts every x seconds
-Ability to set order of items in Smart Search Menu
-Minor bugs fixed
v2.3 - Jan 15. 2009.
-New: Set how often user can manually check for new posts
-New: Option to colorize text only when there are new posts
-New: Option to disable product in selected styles
-Fixed some minor bugs
v2.4 - Jan 18. 2009.
-Added permissions check to fix problems where sometimes incorrect numbers are shown
-Fixed bug where unexpected content is shown on user session expiration


Mark as installed to get support and updates.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	anp.png
Views:	8741
Size:	25.4 KB
ID:	92588Click image for larger version

Name:	acp.png
Views:	2090
Size:	71.4 KB
ID:	92764

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
AJAX - Advanced Forum Statistics ry215 vBulletin 3.7 Add-ons 190 07 Jul 2011 21:31
[AJAX] SmnLikQuick v2.0 - Advanced Announcements Block Bree vBulletin 3.7 Add-ons 475 05 May 2011 20:51
[AJAX]ChangUonDyU - Advanced Statistics spitb19 Modification Graveyard 22 29 Jan 2009 07:35

Comments
  #2  
Old 12 Jan 2009, 18:13
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
After installing this mod I get an error when clicking on New Posts. It says it can't find the search.php?do=getnew file.
Reply With Quote
  #3  
Old 12 Jan 2009, 20:07
Blue91's Avatar
Blue91 Blue91 is offline
 
Join Date: Apr 2002
Good hack! Installed.

Request for you...

Can it be made so the forums are listed in the order they are inserted into the "hack options" list? Right now, it orders them alphabetically.

Also, can it be made so that the forums listed are ONLY shown if they have new posts made in them? Otherwise, they aren't shown on the dropdown? This way I could add every forum and only the ones posted in latest would show!

Thanks!
Reply With Quote
  #4  
Old 12 Jan 2009, 20:19
Blue91's Avatar
Blue91 Blue91 is offline
 
Join Date: Apr 2002
Also, it works 100% on my forums index (www.pomoforacing.com/forums). However, the "new posts" link does not work on my main page (vbAdvanced cmps).

On the forums index, the link goes to http://www.pomoforacing.com/forums/search.php?do=getnew

On the home page (vbadvanced cmps), the link goes to http://www.pomoforacing.com/search.php?do=getnew (note the absence of "forum"). As a result, I get a "can't be found". How can I fix this?

Thanks!
Reply With Quote
  #5  
Old 12 Jan 2009, 21:37
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
Ah! That's the problem I'm having! It works in the main forum, but not vBadvanced. Good catch Blue91.
Reply With Quote
  #6  
Old 12 Jan 2009, 21:47
Trek Trek is offline
 
Join Date: Sep 2003
Funny, I was working on coding something like this today as my second mod ever... now I don't need to. Thanks again!

Although, I'm kinda pissed that I have to think of something new to mess around with!
Reply With Quote
  #7  
Old 12 Jan 2009, 21:54
Trek Trek is offline
 
Join Date: Sep 2003
Ok, I installed, but have some issues.

The issues are, I use a custom style. It changes the default style without a problem. The bigger issue is, if it's enable, it breaks my custom style display.

I know this isn't really a fault of the mod, but am looking for any help you can provide as I'd like to use this!

My custom style has the navbar info in the header template, not the navbar template (Don't ask me why, I didn't make it, I just bought it).

This mod will remove the "new Posts" in the header, but it's not replaced with anything. so it's basically gone.

Can you tell me what I would need to insert into my header section to display this correctly in my custom style?
Reply With Quote
  #8  
Old 12 Jan 2009, 21:55
thunderclap82 thunderclap82 is offline
 
Join Date: Dec 2008
UPDATE: I've gotten the link working properly in vBadvanced, but it doesn't seem to be displaying the new message number correctly.

To fix the link search your style(s) for search.php

In the list select cyb_advancednewposts

Find the href="search.php?" and replace with href="/<forum dir>/search.php?"

This will get the links working properly under vBadvanced.
Reply With Quote
  #9  
Old 12 Jan 2009, 22:20
Blue91's Avatar
Blue91 Blue91 is offline
 
Join Date: Apr 2002
That got me fixed thunderclap82. Good job. I just changed it so I haven't gotten enough posts yet since I did it to see if the message number is correct.

Hopefully Cyb can help me with the other inquiries that I had about this mod!
Reply With Quote
  #10  
Old 12 Jan 2009, 23:24
Trek Trek is offline
 
Join Date: Sep 2003
Cybernetec: Do you do any custom work? Meaning I could toss a couple bucks your way? There's no way to contact you privately so... I'm leaving this message.

Anyway, let me know. I just want this mod tweaked to work with my forum templates.
Reply With Quote
  #11  
Old 13 Jan 2009, 00:15
Blue91's Avatar
Blue91 Blue91 is offline
 
Join Date: Apr 2002
thunderclap82.... as it turns out, by adding forums/ in front of the search.php callout like you said, my newposts link on the actual forums doesn't work now.

So I'm back to square one, as described in post #4. Can someone out there help?

I suck at coding but I'm starting to wonder if I'm going to have to turn the entire cyb_advancednewposts template into an if/then statement. I have no idea how to do that (yet).
Reply With Quote
  #12  
Old 13 Jan 2009, 00:19
TimberFloorAu's Avatar
TimberFloorAu TimberFloorAu is offline
 
Join Date: May 2008
Real name: Blue
Blue91 have you added this hack string to vb advanced in admincp.

ie. the bit where you specify prefix urls.?
__________________

My Hacks [ click ] | Steve ~ Administrator for British Expats AustraliaBound.org/forum | Test our forum - user; don pass; pass123
Sports Tipping Mod - coming February 2010 ~ Show your Interest !
Reply With Quote
  #13  
Old 13 Jan 2009, 00:27
Infopro Infopro is offline
 
Join Date: May 2003
Wink

Originally Posted by thunderclap82 View Post
UPDATE: I've gotten the link working properly in vBadvanced, but it doesn't seem to be displaying the new message number correctly.

To fix the link search your style(s) for search.php

In the list select cyb_advancednewposts

Find the href="search.php?" and replace with href="/<forum dir>/search.php?"

This will get the links working properly under vBadvanced.
Change /<forum dir>/ to

{$vbulletin->options[bburl]}/
Reply With Quote
  #14  
Old 13 Jan 2009, 00:49
Infopro Infopro is offline
 
Join Date: May 2003
Lightbulb

I also had to change this:
<div class="vbmenu_popup" id="cyb_forumsearch_menu" style="display:none">

To this:
<div class="vbmenu_popup" id="cyb_forumsearch_menu" style="display:none;margin-top:3px" align="$stylevar[left]">

Still trying to locate the space in toolbar just before the "New Posts" text.
Attached Images
File Type: jpg newpostswierdgap.jpg (14.0 KB, 206 views)
Reply With Quote
  #15  
Old 13 Jan 2009, 01:01
Blue91's Avatar
Blue91 Blue91 is offline
 
Join Date: Apr 2002
Originally Posted by TimberFloorAu View Post
Blue91 have you added this hack string to vb advanced in admincp.

ie. the bit where you specify prefix urls.?
I wouldn't know where to add it. It looks like I got the search issue taken care of though (thanks infopro).

Now the issue is like thunderclap82 mentioned above... the "numbering" feature doesn't work with the main page. It just says "No New Posts". However, it works fine with the forums index, showing how many new posts there really are.

*shrug*
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 16:30.

Layout Options | Width: Wide Color: