Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VSa - Advanced Forum Statistics (AJAX) Details »»
VSa - Advanced Forum Statistics (AJAX)
Mod Version: 7.1, by Valter (Coder) Valter is offline
Developer Last Online: Apr 2014 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (225 votes - 4.76 average) Installs: 2353
Released: 14 Feb 2010 Last Update: 02 Aug 2012 Downloads: 17327
Supported DB Changes Uses Plugins Auto-Template  

Info:
AJAX Forum Statistics:
-Latest Posts
-Latest Forum News
-Most Viewed Threads
-Hottest Threads
-Most Popular Forums
-Latest Classified Ads
-Latest Blog Entries
-Latest Group Posts
-Newest Members
-Top Posters
-Top Thread Starters
-Top Referrers
-Top Reputations
-Top Thanked
-Top Infractions
-Profile Visits
-Latest Social Groups
-Latest Donations

You can turn on/off individual stats, count data from last x days for some of them if you wish, trim titles/usernames to save page space, make several other functionality/make-up customizations... See screenshots.


You can have Main Stats box shown on several pages...
It's shown by default on forumhome (to disable it set "Main Top Stats box on ForumHome" to "None")
To activate another location:
a) add THIS_SCRIPT name to "Stats on pages" field in product options
b) add template name to "Stats in templates" field in product options
c) add "{vb:raw vsatopstats}" to the template you added Stats to


Notes:
-To set options go to: vBulletin Options > VSa - Advanced Forum Statistics
-"Top Thanked" requires Abe1's "Post Thanks" or Scandal's "Thumbs Up?" products to work
-"Latest Donations" requires "VSa - PayPal Donate" hack to work
-To move Top Stats box somewhere else on forumhome: 1.-Set placement setting to "None" 2.-Add "index" to "Stats on pages" setting 3.-Add "FORUMHOME" to "Stats in templates" setting 4.-Add "{vb:raw vsatopstats}" wherever you wish in FORUMHOME template.
-If Top Stats box is messed up because of long usernames or thread/forum titles be noted that you can trim them in ACP options.
-When forum/thread titles or usernames are trimmed, mouse-over will show you full version.


Installation:
-Import XML file (as product) through AdminCP: Plugin System > Manage Products > [Add/Import Product]


Versions:
v1.0 - Jun 12. 2006.
-First release
v6.6.1 - May 14. 2009.
-Latest vB 3.x version
v7.0 - Feb 14. 2010.
-First vB4 release
-Fixed some previous version bugs, optimized code
v7.0.1 - Feb 16. 2010.
-Fixed: Newpost/lastpost linking in 'Latest Posts'
-Fixed: Errors with PHP 5.3
-Fixed: AFS table messed up in footer
-Fixed: Several style errors, including XHTML incompatibilities
-New: Auto-insert on forumhome location - Below Forums
v7.0.2 - Feb 22. 2010.
-Fixed: Several style issues for unregistered users
-Fixed: 'Latest Donations' issues
-Fixed: Import error on some configs
-Fixed: Minor bugs
v7.0.3 - Apr 12. 2010.
-Fixed security bug (user able to set number of results manually)
v7.0.4 - Jan 14. 2012.
-Fixed: Status icons must be GIFs
-Fixed: Status icon overlay problems in Chrome and Safari
-Fixed: Drop-down menu items invisible until highlighted
-Fixed: Last unread post links not compatible with vBSEO
-Fixed: Search Member's posts shows results as threads
-Added: Rich thread prefix support
-Improved: CSS compatibility
-Minor bugs fixed
v7.0.5 - Jan 15. 2012.
-Links in Latest Posts are now fully SEO compatible
-New option: Automatically disable auto-refresh if server load is higher than X
v7.0.6 - Jan 17. 2012.
-Fixed: Prefixes linked in some thread stats
v7.0.7 - Jan 22. 2012.
-New: Show Stats in selected forum only
-Fixed: Some style issues
-Improved: Product menu style
-Improved: Menu disappears on click
-Changed background color variable: 'editor_background' used for better compatibility with custom styles
v7.0.8 - May 27. 2012.
-Fixed: QL Enable Stats link in vB 4.2
v7.0.9 - Jul 07. 2012.
-Fixed: Hide on misc.php requests not related to Stats
v7.1 - Avg 02. 2012.
-New: Top Thanked now works with "Thumbs Up?" system by Scandal
-Note: Above still works with "Post Thanks" system by Abe

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	stats1.jpg
Views:	18403
Size:	178.7 KB
ID:	112315Click image for larger version

Name:	stats2.jpg
Views:	13026
Size:	153.8 KB
ID:	112316Click image for larger version

Name:	menu.jpg
Views:	8339
Size:	65.4 KB
ID:	112317Click image for larger version

Name:	more.jpg
Views:	9248
Size:	73.7 KB
ID:	112318Click image for larger version

Name:	acp1.jpg
Views:	6253
Size:	109.4 KB
ID:	112319Click image for larger version

Name:	acp2.jpg
Views:	5167
Size:	117.0 KB
ID:	112320

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Cyb - Advanced Forum Statistics Valter vBulletin 3.8 Add-ons 1216 09 Dec 2013 05:26
Cyb - Advanced Forum Statistics Valter vBulletin 3.7 Add-ons 651 02 Sep 2013 12:25
Cyb - Advanced Forum Statistics Valter vBulletin 3.6 Add-ons 1599 15 Feb 2013 02:33
Cyb - Advanced Forum Statistics Valter vBulletin 3.5 Add-ons 116 16 May 2010 02:57

  #91  
Old 16 Feb 2010, 07:40
Ticinofelino's Avatar
Ticinofelino Ticinofelino is offline
 
Join Date: Jul 2006
Originally Posted by mrdexx View Post
When I have the stats-mod enabled, it looks and works fine for anyone logged in however when viewed as a guest/non-logged in user, the stats area overlaps the initial forum area, and also overwrites the notice area...
I'm having exactly the same problem... sigh
Reply With Quote
  #92  
Old 16 Feb 2010, 07:49
chrisdaman chrisdaman is offline
 
Join Date: Oct 2002
Yes, if viewing unregistered/not logged in, it severely displays wrong.

Also, another bug I noticed is that when you have goto to last unread post enabled instead of goto to first post or last post, it goes to an "invalid thread page". I have vbseo enabled, which alters the thread urls, so this might be a reason for that?
Reply With Quote
  #93  
Old 16 Feb 2010, 07:50
junaid junaid is offline
 
Join Date: Oct 2005
I also notice same issue
__________________
Facebook
My forum
Reply With Quote
  #94  
Old 16 Feb 2010, 07:59
FaiSao_963 FaiSao_963 is offline
 
Join Date: Dec 2009
Thaaaaaaaaaank's
Reply With Quote
  #95  
Old 16 Feb 2010, 08:33
synseal's Avatar
synseal synseal is offline
 
Join Date: Apr 2009
Real name: Ben Dover.
Originally Posted by Giray View Post
Minor note, but make sure index is with a lower case 'i' or it still won't work. 'index' worked.
Thanks for that Giray, I had it as capital "I" and just like you said it didn't show, after changing it to "index" it shows fine now and AVS looks great,


thanks for the update Valter.


Originally Posted by chrisdaman View Post
Yes, if viewing unregistered/not logged in, it severely displays wrong.

Also, another bug I noticed is that when you have goto to last unread post enabled instead of goto to first post or last post, it goes to an "invalid thread page". I have vbseo enabled, which alters the thread urls, so this might be a reason for that?
I have mine disabled for guests anyway, maybe an idea for you to do the same until it's fixed?.

Last edited by synseal : 16 Feb 2010 at 08:45.
Reply With Quote
  #96  
Old 16 Feb 2010, 08:34
Valter Valter is offline
 
Join Date: Aug 2005
Originally Posted by chrisdaman View Post
when you have goto to last unread post enabled instead of goto to first post or last post, it goes to an "invalid thread page". I have vbseo enabled, which alters the thread urls, so this might be a reason for that?
It may be that vBSEO causes wrong linking in LP.

On clean forums proper URLs are shown and links points where it' supposed to.
Reply With Quote
  #97  
Old 16 Feb 2010, 08:44
aapkae aapkae is offline
 
Join Date: Oct 2006
I have a problem in this Mod .. i install it but when i login my forum this mod dosn't shows .... and when i logout then shows this mod
Reply With Quote
  #98  
Old 16 Feb 2010, 09:32
synseal's Avatar
synseal synseal is offline
 
Join Date: Apr 2009
Real name: Ben Dover.
Originally Posted by Valter View Post
It may be that vBSEO causes wrong linking in LP.

On clean forums proper URLs are shown and links points where it' supposed to.
Just noticed this myself also using vBSEO, I get this

No Thread specified. If you followed a valid link, please notify the administrator
Reply With Quote
  #99  
Old 16 Feb 2010, 09:40
betts02's Avatar
betts02 betts02 is offline
 
Join Date: Jun 2009
Again, another great mod and working 100% on my forums so far

cheers
Reply With Quote
  #100  
Old 16 Feb 2010, 09:53
JVCode's Avatar
JVCode JVCode is offline
 
Join Date: Oct 2006
Only one thing stopping me using this mod... I need to be able to display 'Latest Threads'. I think that's the only option not available with this mod lol.
Reply With Quote
  #101  
Old 16 Feb 2010, 10:19
Philippe J Philippe J is offline
 
Join Date: Sep 2007
I was waiting for this great mod since I've upgraded, thanks !

I have a request : in a two rows layout, I would like to shorten the width of the two blocks. I don't need so much space there, I need more on the latest posts box.

Thanks again, and sorry for my bad english !
Reply With Quote
  #102  
Old 16 Feb 2010, 11:09
steve1966 steve1966 is offline
 
Join Date: Dec 2007
thanks nominated rated
Reply With Quote
  #103  
Old 16 Feb 2010, 11:24
Britmovie Britmovie is offline
 
Join Date: Mar 2008
No Thread specified. If you followed a valid link, please notify the administrator

I get this and I have vbseo. In the last version I never had it v7
Reply With Quote
  #104  
Old 16 Feb 2010, 11:39
Britmovie Britmovie is offline
 
Join Date: Mar 2008
Ok attached is a capture of my front page when logged out www.britmovie.net/britforum

Note the messed up top. This is even with permissions so guests can not see it?
Attached Images
File Type: jpg Capture.jpg (109.1 KB, 65 views)
Reply With Quote
  #105  
Old 16 Feb 2010, 11:41
Britmovie Britmovie is offline
 
Join Date: Mar 2008
Just a point that may help. I have vbseo and although when set to last post clicking on link or arrow gave first post, the version before this did work with vbseo?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 18:46.

Layout Options | Width: Wide Color: