Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Watermark Generator Details »»
Watermark Generator
Mod Version: 1.1, by Disasterpiece (Coder) Disasterpiece is offline
Developer Last Online: Jul 2014 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (20 votes - 4.80 average) Installs: 130
Released: 18 May 2011 Last Update: 09 Jun 2011 Downloads: 915
Not Supported DB Changes Uses Plugins Additional Files Is in Beta Stage  

Quick Info

This mod adds a watermark to album and attachment images.
The watermark is customizable via image files or specified text.
Processed images are cached and the original files remain untouched, so you can modify or remove the watermark anytime you want.


Features

- Intelligent Caching
- Uses standard vBulletin methods, therefore no file modifications necessary
- Settings-Preview with a sample image in Adminpanel
- Generative plugin behaviour, works with most other mods which use the same hooks or use attachment images elsewhere

Installation


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Changelog

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Additional Info

The Mod is currently in BETA. This means, that we tested it on a test environment (vb 4.0.x to 4.1.3) but has not yet undergo excessive stress test.
Keep an eye out for updated versions until the final release!
If you encounter any bugs, missing or misplaced features, let us know!

F.A.Q

- I don't see changes in my live images!
> To see changes on the image files you have to clear your browser's cache!
In firefox it's enough to force a fresh reload via STRG+F5 and on other browsers STRG+F5 or SHIFT+F5 should work.
If you don't perform this step, your browser will show the old cached version and maybe the watermark won't show or changes won't apply.

- My png/gif watermark isn't transparent, instead I get a black background!
> PNG-8 is known for having transparency problems, GIF in some cases as well.
Fall back to PNG-24 with Alpha channel (all modern image tools should be able to save as PNG-24)
If you have trouble creating a working png-24 with alpha channel, you can send me a PM with a link to your watermark and I'll convert it to png-24 for you.

- I have trouble with special characters or non-latin charactersets!
> The addon is using standard php functionalities for the text. If for any reason you have trouble with special chars, I suggest using a transparent png-24 with the text from an external image tool instead.

Support / Branding

We provide quality vbulletin software modifications for zero costs. To help our mod to be well-known, a backlink is added to your forum footer by the plugin, where the plugin is used in any way.
You must not remove the copyright/backlink code!
However, if you like to support us, you are allowed to remove the footer note with a small donation (10$ minimum).
If you choose to do so, we'll contact you via the email provided by paypal with instructions on how to remove the footer note.
A link to paypal donation service can be found on the top right area of this post.

Feel free to contact an author of the mod if you have any questions or suggestions.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	plwatermark_2.jpg
Views:	2484
Size:	105.4 KB
ID:	129186Click image for larger version

Name:	plwatermark_3.jpg
Views:	2867
Size:	120.2 KB
ID:	129187Click image for larger version

Name:	plwatermark_admin12.jpg
Views:	1453
Size:	108.0 KB
ID:	129188Click image for larger version

Name:	plwatermark_admin11.jpg
Views:	2793
Size:	68.3 KB
ID:	129189

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 18 May 2011, 03:43
Dr.osamA's Avatar
Dr.osamA Dr.osamA is offline
 
Join Date: Aug 2004
Location: Syrie
Real name: Dr.osama
thank you bro

tested ,but for some unknown reason does not work
- attacment not showing
- not support Arabic incoding
- when i use Watermark Cache Management that give me => cant find phrase


BRB
__________________
Reply With Quote
  #3  
Old 18 May 2011, 08:58
TEMPESTADE TEMPESTADE is online now
 
Join Date: Dec 2010
tested ,but for some unknown reason does not work
Reply With Quote
  #4  
Old 18 May 2011, 10:33
inigo inigo is offline
 
Join Date: May 2010
Problem with the png image, it looks completely black the rectangule of the image in the watermarked images.

v 4.1.2.

I am trying to test with text, but I prefer image watermark. with text, is it possible to put a % of the size of image instead of the size of the text? (because perhaps it was 300 px image and 1024 px other, so itīs difficult to give only one text size.

Thanks, great mod,
Reply With Quote
  #5  
Old 18 May 2011, 13:50
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
@Dr.osamA:

Did you test the settings via preview first? Is the watermark rendered on the sample image?
Try the steps below so we can find out why your attachments aren't displayed.

@TEMPESTADE, inigo:

Is it possible that you don't have the GD lib installed?


To all others where the attachment doesn't show:
You can upload the testattachments.php file from this post into your forum root dir.
Then navigate to the file via browser and add the parameter i1 to it so it looks like this:

http://someforum.tld/forum/testattachments.php?i1=13

Replace 13 with any image id which is big enough so the watermark should be displayed!
Now if any errors occur, the script will output them, other than the attachment.php which disables error reporting completely. This way it's easier for me to pinpoint the problem.
Attached Files
File Type: php testattachments.php (5.8 KB, 50 views)

Last edited by Disasterpiece : 23 May 2011 at 19:29.
Reply With Quote
  #6  
Old 18 May 2011, 14:26
inigo inigo is offline
 
Join Date: May 2010
The GD lib is correctly running (I use it in vbgallery too:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The image appears in the correct place, with correct size, but is a black rectangule. Any other idea?

Thanks,
Reply With Quote
  #7  
Old 18 May 2011, 14:44
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Originally Posted by inigo View Post
The GD lib is correctly running (I use it in vbgallery too:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

The image appears in the correct place, with correct size, but is a black rectangule. Any other idea?

Thanks,
Did you use a .png or a .gif for the watermark?
Did you set the alpha channel correctly?
If png: Is it a 8-bit png or a 24-bit png?

I attached a test image from which i know that the watermark generator can display. Can you test it out and tell me if it's applied correctly or has a black background too?
Attached Images
File Type: png wmtest.png (6.5 KB, 42 views)
Reply With Quote
  #8  
Old 18 May 2011, 14:48
billstelling's Avatar
billstelling billstelling is offline
 
Join Date: Apr 2011
Awesome mod! Thanks..
wm.jpg

working on everything but cms article pages. works on promoted articles but mot ones created just for the front page and not originating from the forum.
cms/content.php/

Last edited by billstelling : 18 May 2011 at 14:58.
Reply With Quote
  #9  
Old 18 May 2011, 15:58
inigo inigo is offline
 
Join Date: May 2010
I have been testing, and the problem appears to be the PNG8, because the same image saved as PNG-24 is working.

Your test image was ok, but with no trasparency.

So the problem is solved, PNG-24 working, but I have to do more tests, because there are some of the images without watermark,... and I think is because the browser's cache.

so I will tell you when I can test deeply,

Thanks,
Reply With Quote
  #10  
Old 18 May 2011, 17:40
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
Works great in vB 4.1.3!!!
Thanks!

Been looking for this for over 2 years now
Reply With Quote
  #11  
Old 18 May 2011, 20:06
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
1 idea...
Is it possibe to also watermark the INLINE pictures added to a post?

As far as i can see, only the attached pictures are watermarked.
I have now disabled inline attachements on my forum.
Reply With Quote
  #12  
Old 19 May 2011, 11:04
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Originally Posted by inigo View Post
I have been testing, and the problem appears to be the PNG8, because the same image saved as PNG-24 is working.

Your test image was ok, but with no trasparency.

So the problem is solved, PNG-24 working, but I have to do more tests, because there are some of the images without watermark,... and I think is because the browser's cache.

so I will tell you when I can test deeply,

Thanks,
Yes, PNG-8 seems to be a problem right now, I'll look into it.
Sadly, the php functions for image prcessing are limited, so its hard to find advanced tools without relying on external libaries not everyone has.

For now, PNG-24 should work with full transparency, so I recommend to use it, also for the case if you run into charset issues with non-latin characters.

Originally Posted by Stefan118 View Post
1 idea...
Is it possibe to also watermark the INLINE pictures added to a post?

As far as i can see, only the attached pictures are watermarked.
I have now disabled inline attachements on my forum.
I was sure that the inline post uses the same attachment method. Which inline-images do you mean?
Those where people simply attach an image, grab the url to the fullsize picture and add that to the post?
Or do you mean linking images from 3rd party sites?


Quick note: To see changes on the image files you have to clear your browser's cache!
In firefox it's enough to force a fresh reload via STRG+F5 and on other browsers STRG+F5 or SHIFT+F5 should work.
If you don't perform this step, your browser will show the old cached version and maybe the watermark won't show or changes won't apply.
Reply With Quote
  #13  
Old 19 May 2011, 17:56
goxy63 goxy63 is online now
 
Join Date: Oct 2008
How this affects images that user chooses as background image for his profile?
Reply With Quote
  #14  
Old 19 May 2011, 18:01
Stefan118 Stefan118 is offline
 
Join Date: Dec 2010
Originally Posted by Disasterpiece View Post
I was sure that the inline post uses the same attachment method. Which inline-images do you mean?
Those where people simply attach an image, grab the url to the fullsize picture and add that to the post?
Or do you mean linking images from 3rd party sites?


Quick note: To see changes on the image files you have to clear your browser's cache!
In firefox it's enough to force a fresh reload via STRG+F5 and on other browsers STRG+F5 or SHIFT+F5 should work.
If you don't perform this step, your browser will show the old cached version and maybe the watermark won't show or changes won't apply.
At the folowing link (second post) you can see what i ment with inline attachments.

http://www.papegaaienforum.nl/showth...ich-aan-u-voor.
Reply With Quote
  #15  
Old 19 May 2011, 18:44
Disasterpiece's Avatar
Disasterpiece Disasterpiece is offline
 
Join Date: Apr 2007
Originally Posted by goxy63 View Post
How this affects images that user chooses as background image for his profile?
That is a good question, didn't think of that. I'll check it out and update if necessary.

Originally Posted by Stefan118 View Post
At the folowing link (second post) you can see what i ment with inline attachments.

http://www.papegaaienforum.nl/showth...ich-aan-u-voor.
Well, they're external links, which means these images aren't hosted on your server. So there is no need to (and in fact, you shouldn't) add a watermark to it, because they aren't "yours".
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 14:47.

Layout Options | Width: Wide Color: