Register Members List Search Today's Posts Mark Forums Read

Closed Thread
 
Mod Options
  #211  
Old 19 Aug 2004, 15:30
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
Everything looks fine so far. One thing though, I want this table centered at 100%. I was hoping it could be done with this CMPS script, but if it can't I might have to consider uninstalling (since that is all I wanted it for).
Still it's a nice setup. Keep up the good work.

ps, screenshot attached.
Attached Images
File Type: jpg this.jpg (151.2 KB, 33 views)
__________________
dgane.com - about me & my life
  #212  
Old 19 Aug 2004, 15:57
KW802's Avatar
KW802 KW802 is offline
 
Join Date: Jul 2003
Real name: Kevin
Originally Posted by Davey
Everything looks fine so far. One thing though, I want this table centered at 100%. I was hoping it could be done with this CMPS script, but if it can't I might have to consider uninstalling (since that is all I wanted it for).
Still it's a nice setup. Keep up the good work.

ps, screenshot attached.
Davey,

It should be easy enough to center but we'd need to know what method did you take to produce what you're seeing so far. Did you create a module and are then displaying only that module or did you create a new page and are using the Custom Template option of the new page, or .... ?
  #213  
Old 19 Aug 2004, 17:42
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
I created a new page, and it gave it a template. The template seems to follow the "Custom Page Content" on the left.

ps, see attch. and the note on the attach screen.
Attached Images
File Type: jpg cmps_acp.jpg (290.4 KB, 27 views)
__________________
dgane.com - about me & my life
  #214  
Old 19 Aug 2004, 18:42
KW802's Avatar
KW802 KW802 is offline
 
Join Date: Jul 2003
Real name: Kevin
Originally Posted by Davey
I created a new page, and it gave it a template. The template seems to follow the "Custom Page Content" on the left.

ps, see attch. and the note on the attach screen.
ACP --> vBa CMPS --> Edit Modules and then using the little arrows underneath the "Custom Page Content" module move it to the center column.

Now, bear in mind, that's assuming that you didn't create any other custom pages using the Custom Page Content that you want to keep on the left. If you did then you'll need to create a new module that does an include on the cmps_guild_members template and then edit your new page to display that new module (your new page would then have "Custom Page Content" clicked off and your new module clicked on).


Edit: PS - You missed blurring out one of the URL references (in the description for "Page Identifier"); if you don't want it known you might want to whack the attachment.
  #215  
Old 19 Aug 2004, 19:19
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
Ah yes, I see. Thanks.
lol it doesn't really matter about that URL biz.
Not sure why I edited really. :P
__________________
dgane.com - about me & my life
  #216  
Old 19 Aug 2004, 19:26
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
I don't understand how I can get my navigation bar on the left, and my guild_members in the middle. It appears that they both fall under Custom Page Content (navigation bar is in the middle now where i don't want it.)
I tried creating a new module to place the navigation template to be called from it and placed the navigation module on the left, but it doesn't work for some reason.
This is complicated stuff.
__________________
dgane.com - about me & my life

Last edited by Davey : 19 Aug 2004 at 19:29.
  #217  
Old 19 Aug 2004, 20:06
KW802's Avatar
KW802 KW802 is offline
 
Join Date: Jul 2003
Real name: Kevin
Originally Posted by Davey
I don't understand how I can get my navigation bar on the left, and my guild_members in the middle. It appears that they both fall under Custom Page Content (navigation bar is in the middle now where i don't want it.)
I tried creating a new module to place the navigation template to be called from it and placed the navigation module on the left, but it doesn't work for some reason.
This is complicated stuff.
The Custom Page Content option is a little bit confusing (it took me a bit to get the hang of what it really does) but in a rule of thumb you could go by is that if you want an item to appear on more than one page, like your navigation bar, then create a new module for it that references your template but if you have a one-off page, just as what you're doing here, then using the Custom Page Content feature will eliminate having to create an unique module just for that one page.

For what you're trying to I'd recommend (a) moving your navigation stuff to be in a new module so that you could then reference it from multiple pages; (b) change the Custom Page Content module back to the middle column; and then (c) on your new page you created go ahead like you did it above of having your cmps_guild_members template in the Custom Page Content field of the page. The end result should your navigation panel in the left column and your guild members module shown in the middle.

Once you get the hang of the Custom Page Content usage it becomes really easy to add new pages but, I'll admit, when I first installed vBa CMPS the concept threw me off and I had to get some insight from Tigga before I really understood it.

Edit: What kind of problem did you have when you tried making your new navigation module? If you let us know the steps you took and the results you got I'm sure we can get you up & running.
  #218  
Old 19 Aug 2004, 21:42
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
OK you're being very helpful, but like you said this is quite complicated, and difficult to explain for a n00b like me :P
check attachments.

cmps_listofmemb.jpg: This is the listing of members when you visit index.php?p=members. This is working as planned. On a sidenote, I wondered if this is possible to grab all the users who belong in the usergroup '8' automatically. But if this is not possible, it's not a problem.

cmps_navmod.jpg: This is the module I created for the navigation bar.

cmps_custpage.jpg: This is how the Custom Page Content looks.

cmps_nonav.jpg: The nav bar should be where the "online users" bit is.

cmps_page_home.jpg: This is how the home 'page' setup looks.

cmps_page_members.jpg: This is how the guild members 'page' setup looks.

cmps_temp_members.jpg: This is the members list template. As you can see, the contents have been hard coded into the html. I don't know where to begin trying to make that automated (select the users from that usergroup and insert them manually, like I said this probably can't be done so therefore I am not too bothered). This comes out okay.

cmps_temp_nav.jpg: This is the navigation template.

If you need any more info, just ask.
Attached Images
File Type: jpg cmps_custpage.jpg (149.0 KB, 9 views)
File Type: jpg cmps_listofmemb.jpg (131.4 KB, 19 views)
File Type: jpg cmps_navmod.jpg (186.7 KB, 12 views)
File Type: jpg cmps_nonav.jpg (199.7 KB, 25 views)
File Type: jpg cmps_page_home.jpg (167.4 KB, 12 views)
File Type: jpg cmps_page_members.jpg (179.6 KB, 9 views)
File Type: jpg cmps_temp_members.jpg (183.5 KB, 5 views)
File Type: jpg cmps_temp_nav.jpg (154.2 KB, 7 views)
__________________
dgane.com - about me & my life
  #219  
Old 19 Aug 2004, 22:34
KW802's Avatar
KW802 KW802 is offline
 
Join Date: Jul 2003
Real name: Kevin
Originally Posted by Davey
cmps_navmod.jpg: This is the module I created for the navigation bar.

cmps_temp_nav.jpg: This is the navigation template.
You're 99.9% of the way there! I'm headed out the door but a quick look at the pics you included and the problem with your NavBar looks like it's just a matter of what names you used.

Try this....

(a) Rename your cmps_home_nav template to be adv_portal_cmps_home_nav instead; all of the vBadvanced CMPS templates should be prefixed with "adv_portal_" as part of the name.

(b) Change your "NavBar" module to clear the field named "Templates Used" so it's blank. Since the module is 'including' the template already in the "Or Template to Include" section you don't have to specify it again. Don't make any other changes to the module other than clearing out the "Templates Used" field.

(c) Change your "Default / Homepage" page to clear the field named "Page Template" so it's blank. You only need to fill that in if you are using the Custom Page Content module. On your home page you're not using that module currently so the value for "Page Template" would be blank and the "Custom Page Content" should be unchecked like you have it now.

Make those changes, save everything, and your navigation bar should start appearing on your homepage.

For your "Guild Members" page everything is working fine but if you want the navigation bar to appear on that page also then change the page, after you did the steps above, so that the "Navbar" module is checked on. The only other thing I'd do is rename your "cmps_guildmembers" template to "adv_portal_cmps_guildmembers" so that all of your vBadvanced templates are kept together. If you do rename it then be sure to update the "Page Template" field on the "Guild Members" page to the new name.

Give that a go and you should be OK. If something is still broken I'll be back at a computer again in about 5 or 6 hours so I'll check in then.
  #220  
Old 20 Aug 2004, 00:36
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
That worked amazingly. OMG, you've been fantastic!
I hate to ask too much, but what are your comments on making the members list automatically selecting all members from group id '8'? Is this possible for a n00b like myself? lol
__________________
dgane.com - about me & my life
  #221  
Old 20 Aug 2004, 01:03
KW802's Avatar
KW802 KW802 is offline
 
Join Date: Jul 2003
Real name: Kevin
Originally Posted by Davey
That worked amazingly. OMG, you've been fantastic!
I hate to ask too much, but what are your comments on making the members list automatically selecting all members from group id '8'? Is this possible for a n00b like myself? lol
Dave, cool to see that you got the navigation & new page working. Unfortunately I'm still learning about VB myself so I don't know how to do the member list. Sorry.
  #222  
Old 20 Aug 2004, 01:11
Davey Davey is offline
 
Join Date: Nov 2002
Real name: David Gane
Ah okay np.
__________________
dgane.com - about me & my life
  #223  
Old 20 Aug 2004, 03:39
Rahzel_hx Rahzel_hx is offline
 
Join Date: Aug 2004
Real name: Brandon
i get a weird error anyones have soem suggestions "Warning: chdir(): No such file or directory (errno 2) in /home/spiritno/public_html/cmps_index.php on line 19

Warning: main(./global.php): failed to open stream: No such file or directory in /home/spiritno/public_html/cmps_index.php on line 25

Fatal error: main(): Failed opening required './global.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/spiritno/public_html/cmps_index.php on line 25"

EDIT #1:
I don't know what i did but i fixed that problem but none of the images show up now >_< (meaning banner, and buttons) This is the button that won't show up on portal but show up in fourm here is the file path for it images/icon/icon1.gif

Edit #2: When i have the board turned off it can't find a picture >_> but when it is turned back on everything loads weird eh?
Well Great Hack i love it XD

Last edited by Rahzel_hx : 20 Aug 2004 at 05:37.
  #224  
Old 20 Aug 2004, 10:08
weirdpixels's Avatar
weirdpixels weirdpixels is offline
 
Join Date: Aug 2003
Originally Posted by Rahzel_hx
I don't know what i did but i fixed that problem but none of the images show up now >_< (meaning banner, and buttons) This is the button that won't show up on portal but show up in fourm here is the file path for it images/icon/icon1.gif
Make sure you have put the full path to those images, in all your styles
e.g. you will need to change images/icon/icon1.gif to http://www.yourdomain.com/forum/images/icon/icon1.gif
  #225  
Old 20 Aug 2004, 11:01
Rahzel_hx Rahzel_hx is offline
 
Join Date: Aug 2004
Real name: Brandon
Thanx thats what i did it, turnd out to jsut be that style, but when i close the forums some of the pics don't show up still and i have full urls, but that doesn't matter when they are closed only staff can see it anyways ^___^...btw how do i edit custom page content
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 22:26.

Layout Options | Width: Wide Color: