Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vBSupport v2.0.0 Beta 2 Details »»
vBSupport v2.0.0 Beta 2
Mod Version: 2.0.0 B2, by CMX_CMGSCCC (Member) CMX_CMGSCCC is offline
Developer Last Online: Sep 2014 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.5.4 Rating: (10 votes - 4.60 average) Installs: 276
Released: 10 Aug 2005 Last Update: 11 Jun 2007 Downloads: 1023
Supported DB Changes Uses Plugins Template Edits Additional Files Is in Beta Stage  

vbSupport v2.0.0 BETA 2 by CMX (http://www.cmgsccc.com)
Official Homepage - http://www.vbplaza.com


v1.1 of this modification was found to contain an SQL injection. If you run v1.1 of this modification, you are hereby advised to update to v1.1a of this modification. To update from v1.1 to v1.1a, grab the v1.1a ZIP and overwrite the vBSupport.php file on your server with the new version.

Note that while no other vulnerabilities were noticed by vBorg Staff, this does not mean that such things do not exist. vBorg Staff fixed the one SQL injection according to these rules. Any other fixes that may be needed now or in the future are left to the original author.

-- vBorg Staff



Welcome to the latest hack by CMX for your vBulletin Message Board. This is a fully featured Ticket based support system for you website. If you had installed the older version of vBSupport v1.1, then you already have an idea what this sytem is all about.

Basically, this system will allow your Forum Members to create new support tickets using the same login as your vBulletin forums login for your users. There have been many improvements from the older v1.1 vBSupport System I made a while back.

New Features for v2.0.0+:
1) Permission Checks are better implemented and are more useful now.
2) AJAX Open/Closing tickets by double clicking the thread icon when listing tickets.
3) AJAX Ticket Title editing just like the forums Thread editing as well.
4) Post Quick Reply is now using the AJAX system where possible to post replies to tickets.
5) You can now Edit posts inline using the AJAX system as well.
6) Inline Moderation when listing tickets includes Delete Ticket, Open Ticket, Close Ticket.
7) You can now delete individual Posts from Tickets via the Inline Moderation as well.
8) MASSIVE performance load improvements. On my forums with 200,000 members, it would take 4 seconds to view a ticket due to a very strenuous query. Now it loads tickets in 0.13 seconds.
9) Category Administration has now been moved into the Admin CP instead of on the vbSupport page itself.
10) Everything should be fully phrased now as well.

Other Features:
1) IF you have installed the older vBSupport version, it will auto uninstall it for you. (It will NOT delete the old tickets!)
2) Admin CP -> vbSupport Maintenance -> Import Old Tickets is now in and working to import the old tickets if you had vBSupport installed.
3) A ton of permissions per Usergroup to set the settings up the way you want them.

vbSupport v2.0.0 BETA 2 Updates:
1) Bugfix: Quick Reply functions properly when you have the Quick Reply option enabled for Yes - Click Required.
2) Bugfix: Normal Reply/Closed button is there when viewing a ticket.
3) Bugfix: Admin CP Deleting a ticket now functions properly.
4) Bugfix: AJAX Edit feature does not display an alert(postid) anymore.
5) Bugfix: Active On/Off works for each category when enabled/disabled from the Admin CP.
6) Bugfix: Usergroup Permissions are now working for Allowed Usergroups & Denied Usergroups.
7) Bugfix: Changed some templates that linked to the wrong PHP files.
8) Bugfix: New Thread template is cleaned up a bit and it displays properly in Firefox too now.
9) Bugfix: Active phrase now is installed as a vbSupport phrase.


PLEASE NOTE: This is the very first release of vbSupport 2.0.0. Which means that this is a BETA release. I will try to correct any issues found ASAP.

I have vbSupport v2.0.0 BETA 1 running on my production site at www.cmgsccc.com, so I should be able to find most bugs since there are over 200,000 registers members there and it will get put to the test quite a bit. However, if you find something, please post it here.

By installing this BETA version, it will uninstall the previous vBSupport system automatically. It will leave the old ticket tables upon installation. It should import the older Ticket Categories that you had before as well.

I would also like to recommend that you backup your MySQL database, just in case a mishap occurs as this is BETA.

ALSO: The older version vBSupport v1.1 will be here for download until v2.0.0 comes out of BETA. vBSupport v1.1 is NOT in the BETA stage, only vbSupport v2.0.0 is in the BETA stage.

Upgrading Instructions From vBSupport v1.x
NOTE: These are ONLY applicable if you are upgrading from vBSupport v1.x!

1) Delete all of the older vBSupport files from your server. If you are not sure which files they are, the vBSupport v1.1 is still available for download here so you can download that and look at the files in there.

2) Upload all of the files in the upload folder to your forums ROOT folder. Make sure that if it asks about any files, that you set Overwrite to overwrite all files as well.

3) In your Admin CP, goto Plugin System -> Manage Products -> Add/Import Products at the bottom -> Select the XML file that you have downloaded in the package named product-vbsupport.xml -> Set Allow Overwrite to YES -> Import.

4) Perform the template edits below and you have vbSupport v2.0.0 up and running!

5) Refresh your forums Admin CP page.

6) Admin CP -> vbSupport Maintenance -> Import Old Tickets if you want to save the older tickets. Otherwise you can skip this feature.


New Installation Instructions:

1) Upload all of the files in the upload folder to your forums ROOT folder. Make sure that if it asks about any files, that you set Overwrite to overwrite all files as well.

2) In your Admin CP, goto Plugin System -> Manage Products -> Add/Import Products at the bottom -> Select the XML file that you have downloaded in the package named product-vbsupport.xml -> Set Allow Overwrite to YES -> Import.

3) Perform the template edits below and you have vbSupport v2.0.0 up and running!


Template Edits:

A) Template 'navbar':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Below:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

B) Template 'postbit_legacy':

Find:
[code]
<if condition="$show['postcount']">#<a href="showpost.php?$session[sessionurl]p=$post[postid]&amp;postcount=$post[postcount]" target="new" rel="nofollow" id="postcount$post[postid]" name="$post[postcount]"><strong>$post[postcount]</strong></a></if>
[code]

Add Above:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

C) Template 'postbit':

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add Above

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

ENJOY!!

-CMX

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #556  
Old 11 Jun 2007, 02:11
sinisterpain's Avatar
sinisterpain sinisterpain is offline
 
Join Date: Feb 2006
Real name: Glenn
If I understand the email I recieved, the update applies if you have version 1.1 installed and not the 2.0 beta version. If you have version 1.1 installed you should install the 1.1a version. If Im wrong then the vb.org admins need to clarify things since their is a 2.0 version that was released.
__________________

My vBulletin Mods
Reply With Quote
  #557  
Old 11 Jun 2007, 02:12
sinisterpain's Avatar
sinisterpain sinisterpain is offline
 
Join Date: Feb 2006
Real name: Glenn
Originally Posted by Delphiprogrammi View Post
hi folks,

This does work fine ..... wanna know how i did that ? allthroug it looks like smilies are not working.Problems i noticed with the system and fixed while i whas busy anyway
  • The MySQL error "unknown column 'level' in field list
  • Fixed Problem with AJAX inline threadtitle editing
  • Fixed Problem with AJAX open/close threads
  • Fixed the admincp part "categorys" (wrong MySQL query) The datastore is function correctly now and no longer give errors
  • ....
The admincp error is not a mistake by the developer.vBulletin changed the way the datastore works between versions 3.5.x and 3.6.x that's why it no longer worked

don't ask me why i put so much time in a hack that's not even mine.This hack whas (is) to good to let it go away and die ! anybody with me on this one ?
Why dont you post up your changes? I had already posted that the problem was with the datastore so I made a post here with some changes but it did not seem to work for all.
__________________

My vBulletin Mods
Reply With Quote
  #558  
Old 11 Jun 2007, 02:23
beduino's Avatar
beduino beduino is offline
 
Join Date: Dec 2005
Real name: Joao
Hello sinisterpain,
tks for your answer, first of all!
In fact i don't install vbsupport yet, because the possible problems in security. But I'm interested in install, of course. If i undertand [i think you're right ] the update was in version 1.1 [even i don't seeing any new file in package...]
Anyway,
tks
Beduino
ps. you have install 1.1 version in vb 367?
Reply With Quote
  #559  
Old 11 Jun 2007, 03:16
puertoblack2003's Avatar
puertoblack2003 puertoblack2003 is offline
 
Join Date: Aug 2005
thanks for th eupdate works well for 6.7
__________________
Android Custom Creations
Reply With Quote
  #560  
Old 11 Jun 2007, 19:35
L'ingegnere L'ingegnere is offline
 
Join Date: Jun 2006
I have this problem at the top of the page I have this..

Warning: unserialize() expects parameter 1 to be string, array given in /vbsupport.php on line 116

Warning: unserialize() expects parameter 1 to be string, array given in /vbsupport.php on line 117
I don't knoe why the line 116 and 117 is:
$vbulletin->vbs_category = unserialize($vbulletin->vbs_category);
$vbulletin->vbs_admin = unserialize($vbulletin->vbs_admin);
I tried to disable the necessary of a category but nothing
Reply With Quote
  #561  
Old 11 Jun 2007, 20:32
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by sinisterpain View Post
Why dont you post up your changes? I had already posted that the problem was with the datastore so I made a post here with some changes but it did not seem to work for all.
i'm not allowed to post them according by the rules.The original seems to be busy with other things but that doesn't mean i can go ahead and violate the rules
Reply With Quote
  #562  
Old 11 Jun 2007, 21:03
sinisterpain's Avatar
sinisterpain sinisterpain is offline
 
Join Date: Feb 2006
Real name: Glenn
Originally Posted by Delphiprogrammi View Post
i'm not allowed to post them according by the rules.The original seems to be busy with other things but that doesn't mean i can go ahead and violate the rules
Not sure I follow you, If the author basically abandoned the hack and you have some code changes that fix problems how is that a violation of the rules?
__________________

My vBulletin Mods

Last edited by sinisterpain : 11 Jun 2007 at 21:11.
Reply With Quote
  #563  
Old 11 Jun 2007, 21:54
Delphiprogrammi Delphiprogrammi is offline
 
Join Date: Feb 2004
Real name: Erik
Originally Posted by sinisterpain View Post
Not sure I follow you, If the author basically abandoned the hack and you have some code changes that fix problems how is that a violation of the rules?
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
and vBulletin (.org) is pretty strict in that policy.I'll give you a hint through look at your database table named datastore then look in /includes/functions_vbsupport.php update_datastore() function that table contains two fields data and serialize however in that function is only one (requirerd) parameter set / updated so an error will occour

Last edited by Delphiprogrammi : 11 Jun 2007 at 21:57.
Reply With Quote
  #564  
Old 21 Jun 2007, 12:53
NineVB NineVB is offline
 
Join Date: May 2007
Question

Originally Posted by gullystation View Post
When Im editing the navbar and I put this code in :


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

then this comes up:



Can someone help me please?
I found this problem too. The code as from the readme file, is missing a closing ].

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

should be

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Hope this helps.
Reply With Quote
  #565  
Old 25 Jun 2007, 17:37
sinisterpain's Avatar
sinisterpain sinisterpain is offline
 
Join Date: Feb 2006
Real name: Glenn
Originally Posted by Delphiprogrammi View Post
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
and vBulletin (.org) is pretty strict in that policy.I'll give you a hint through look at your database table named datastore then look in /includes/functions_vbsupport.php update_datastore() function that table contains two fields data and serialize however in that function is only one (requirerd) parameter set / updated so an error will occour
If your posting on vb.org within the author's mod for a fix of problems, what you quoted does not apply since you are not redistributing, copying or publishing elsewhere.
__________________

My vBulletin Mods
Reply With Quote
  #566  
Old 01 Jul 2007, 20:44
shungo shungo is offline
 
Join Date: Nov 2002
Hey,

Since upgrade to 3.6.7, ajax functions seem not working at all.

And if i click on advanced edit, nothing appears in message box.

Anyone for help please ?

Best regards
__________________
Not everything that is faced can be changed, but nothing can be changed until it is faced.
Reply With Quote
  #567  
Old 04 Jul 2007, 18:47
DigitalXWeb DigitalXWeb is offline
 
Join Date: Apr 2002
Originally Posted by TheJackal56 View Post
Has anyone got a fix or hack to allow user to submit attachments for 3.6.5?
I would be interested in having attachments working as well in 3.6.7, I have everything else working fine except those.

Last edited by DigitalXWeb : 04 Jul 2007 at 19:09.
Reply With Quote
  #568  
Old 10 Jul 2007, 17:17
silvermerc silvermerc is offline
 
Join Date: Apr 2006
Real name: Ross
So this doesnt work on 3.6.7?
Reply With Quote
  #569  
Old 10 Jul 2007, 18:14
DigitalXWeb DigitalXWeb is offline
 
Join Date: Apr 2002
Originally Posted by silvermerc View Post
So this doesnt work on 3.6.7?
Not 100%. Most of the the things work but there are a few glitches due to version differences.
Reply With Quote
  #570  
Old 15 Jul 2007, 15:53
LewisAinslie LewisAinslie is offline
 
Join Date: Apr 2007
Real name: Scott Robertson
Does this work? I keep getting Error when trying to access the view thread

http://community.gamerjuice.co.uk/vb...ewthread&tid=3

Thats the error

Last edited by LewisAinslie : 15 Jul 2007 at 16:53.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 20:19.

Layout Options | Width: Wide Color: