PDA

View Full Version : Disable BBCode per Usergroup


Alan @ CIT
07 Nov 2005, 19:59
Requested: http://www.vbulletin.org/forum/showthread.php?t=100012

What is it?
This add-on allows you to disable BBCode on a usergroup basis.

Features
It currently supports disabling BBCode for:

Posts (new threads, replies and post edits)
Signatures
Private MessagesYou can disallow each of these per usergroup. By default, all usergroups are set to enabled.

Installation

Upload bitfield_qbbcode.xml to /includes/xml in your forums directory
Install product-cit_qbbcode.xml as normalUninstallation

Delete bitfield_qbbcode.xml - if you don't do this first, you will recieve errors
Un-install the product using Product ManagerImportant: Unfortunately, my leased vBulletin licence has now expired, and I won't be renewing it until September which means I will be unable to reply to this thread, or update this mod until then. I'm hopeful that the great vBulletin.org community will step in to answer any questions in my absence though :) See you all in early September! :D

Virtuosofriend
07 Nov 2005, 20:10
very good.

WNxWakko
07 Nov 2005, 20:23
I uploaded the Bitfield, Then ran the plugin, then I even rebuilt the bitfield and still the option is not showing anywhere in the usergroup.

Alan @ CIT
07 Nov 2005, 20:32
Strange. You definatly uploaded the bitfield_qbbcode.xml file to the /includes/xml directory in your forum?

If so, remove the bitfield file, then un-install the product from Product Manager, and try it again.

Also, do you recieve any errors? Either during the install/un-install, or when editing a usergroup?

WNxWakko
07 Nov 2005, 21:25
I receive no errors. Yes the bitfiel_qbbcode.xml went into the correct directory.

Also after installing, for some reason IMG code and BB code was turned off board wide.

Alan @ CIT
07 Nov 2005, 21:31
And the options definatly aren't there when you edit a usergroup?

Should be a group entitled "BBCode Permissions", with 3 options below:

* Can Use BBCode in Posts
* Can Use BBCode in PMs
* Can Use BBCode in Signatures

Edit: It'll be right near the top somewhere.

Thanks,
Alan.

Snake
07 Nov 2005, 21:39
Very useful indeed. Thanks.

WNxWakko
07 Nov 2005, 22:42
Nope, ive checked several usergroups, nothing there. Ive uninstalled, reinstalled and nothing. Your default yes dont work either. All my forums end up with img and bb off regardless to the forum permission settings which clearly say yes.

vB code is Off
Smilies are On
[IMG] code is Off
HTML code is Off

When I uninstall, my settings go back to normal being

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Sinistra
08 Nov 2005, 00:47
Yeah very useful thanks for the hack

Alan @ CIT
08 Nov 2005, 08:32
Wakko, sorry mate, don't know what to tell you - works fine here.

CHIngs
08 Nov 2005, 21:47
Wakko, sorry mate, don't know what to tell you - works fine here.

CAN YOU SHOW A SCREENSHOT?

Because I installed it and I cannot see it.

WNxWakko
08 Nov 2005, 22:22
screenshot what? Its not there, nothing to screenshot.

Alan @ CIT
09 Nov 2005, 08:34
Screenshot of the usergroup permissions, and where they're likely to be attached.

CHIngs
09 Nov 2005, 20:55
Screenshot of the usergroup permissions, and where they're likely to be attached.

I know what the problem is, I think.

You are using version 3.5.0 of vBulletin, so it works, did you test it on 3.5.1?

The PHP part of it works as it is supposed to, but the HTML part isint.

Alan @ CIT
09 Nov 2005, 21:29
Quite right, I've just upgraded to 3.5.1, and it isn't showing for me. Infact, most of the custom usergroup permissions for various hacks aren't showing on my test board.

I will investigate :)

WNxWakko
27 Nov 2005, 01:23
Any word on this yet? have you fixed it to work on 3.5.1? Id really like to use this mod.

Alan @ CIT
02 Dec 2005, 20:10
Sorry, forgot all about this. I've got a fixed version ready, just need to write the install code for it. I'll try and get it finished and released this weekend.

Alan @ CIT
02 Dec 2005, 21:17
Ok, quicker than expected - version 1.1 has been released.

Version 1.1 is fundamentally different from Version 1.0 in the way it works. The usergroup options are now no-longer "Can use BBCode". They are now "Disallow use of BBCode".

By default, all usergroup options are set to "No", which means everyone will be able to use BBCode as normal. To block a certain usergroup from using BBCode in posts, sigs or PMs, edit that usergorup and set "Disallow BBCode in ..." to "Yes".

If you notice any problems, let me know - it appears to be working ok for me on 3.5.1 :)

IrPr
15 Jan 2006, 15:57
how to disable certain Custom BBCodes?

ricker
17 Jan 2006, 06:20
*edit* from not working to officially working in 3.5.3 :) not sure what the issue was but the options show up now - thanks! *installs*

simalert
20 Jan 2006, 16:15
Is there any chance getting this to work on a selected BBCode basis please?

I have a moderator tag on my board [mod] for moderator comments, but obviously anyone could in theory use them (although we would warn them about it).

What I would prefer is some way to stop them using the [mod] tag unless they were in certain groups, but I would want them to be able to use the rest of the BBCode.

Is this something that could be added?

mightyhitter
06 Apr 2006, 06:58
I'd appreciate if someone can show me how to restore the registered users permission back to riginal configuration.
I have install this hack, but later uninstall it but looks like I cannot revert permission back to normal.

simalert
06 Apr 2006, 09:05
I'd appreciate if someone can show me how to restore the registered users permission back to riginal configuration.
I have install this hack, but later uninstall it but looks like I cannot revert permission back to normal.
I'd try reinstalling it, putting the permissions back to how you want them and then uninstalling it.

Alan @ CIT
14 May 2006, 21:41
I'd appreciate if someone can show me how to restore the registered users permission back to riginal configuration.
I have install this hack, but later uninstall it but looks like I cannot revert permission back to normal.

When you uninstall it, be sure to remove the XML file you added in the install, then rebuild the bitfields.

That should do it.

Thanks,
Alan.

zooki
21 Jun 2006, 19:04
Thank you Alan! this is something near to what i needed...

Is it possible to disable a Usergroup from posting URLs?? That would be icing on the cake....

I have a site which sometimes attracts negative even racist comments and links which i must stop from troublemakers.

Chedy
12 Jul 2006, 20:50
I thought I would pose a question as well as this could be THE mod I have been searching for. Is this only for BB Code, or is it also for IMG CODE.

Basically I have been searching for a way to allow IMG tags for certain Usergroups, but not for new members.

Zelos
14 Jul 2006, 08:44
Will this work in 3.6?