PDA

View Full Version : Rotating banners


attroll
30 Jan 2006, 03:25
I created this simple and easy hack for a rotating banner block. All you have to do is create a template and add a plugin location and your done.

1. Go to your ADMINCP and create a template called "banner" and insert the attacked code:

<!-- Begin rotating ad code -->
<script language="Javascript"><!--
function image() {
};
image = new image();
number = 0;
// imageArray
image[number++] = "<a href='http://www.yoursite.net/forum/payments.php'><img src='http://www.yoursite.net/forum/sponsors/donatebanner.gif' border='0'></a>"
image[number++] = "<a href='http://www.hikersupply.com'><img src='http://www.yoursite.net/forum/sponsors/hikersupply.gif' border='0'></a>"
image[number++] = "<a href='http://www.modelt.net'><img src='http://www.yoursite.net/forum/sponsors/modeltbanner.gif' border='0'></a>"
image[number++] = "<a href='http://appalachiantrailservices.com/'><img src='http://www.yoursite.net/forum/sponsors/atservicesbanner.gif' border='0'></a>"
image[number++] = "<a href='http://www.thepacka.com/'><img src='http://www.yoursite.net/forum/sponsors/cedartreebanner.gif' border='0'></a>"
// Carry on adding images - as many as you want
increment = Math.floor(Math.random() * number);
document.write(image[increment]);
//-->
</script>
<!-- End rotating ad code -->

2. Now still in your ADMINCP go to PLUGIN SYSTEM-->ADD NEW PLUGIN
HOOK LOCATION is "global_start"
TITLE is "banner"
PLUGIN PHP CODE:
eval('$banner = "' . fetch_template('banner') . '";');
Do not forget to make the plugin active.

3. Now you can go into any template you want and where ever you put the $banner your rotating banners will appear.

4. Most people want to put this in the top right corner of the forums. If this is what where you want it then. go into you ADMINCP templates and into you header:

Find:

<td align="$stylevar[right]">
&nbsp;

Under that insert:
$banner
Now you done. All you have to do is edit your template your created with the links and banners you want to use.

You can add more rotating banners then what is in the code. All you have to do in insert more lines with banners in the right location in the code. That should be self explanatory.

Note:
You can make your link open in a seperate browser window by adding the target='ad' in the line as shown below.
image[number++] = "<a target='ad' href='http://www.hikersupply.com'><img src='http://www.yoursite.net/forum/sponsors/hikersupply.gif' border='0'></a>"

Dreamchaser
30 Jan 2006, 03:57
Seems Interesting and something that I needed to add to my forums!
Thanks for the hack :)!

* First to Install :D

Dreamchaser
30 Jan 2006, 04:22
I have one small suggestion or you may call it a request !

You have provided a way to add images and link them to various sites, what if I wanted to add various codes like, google adsense, yahoo and other publisher codes which provide them as JavaScript, and I need to add 5 such codes, so each time the page loads, different ads appear.

Any help on this ? Thanks in advance ! Btw, I installed this and works fine :)

Regards,
DC

icare
30 Jan 2006, 04:52
I did exactly what is dictated above but cant see any banners..... :ermm:

attroll
30 Jan 2006, 04:58
I have one small suggestion or you may call it a request !

You have provided a way to add images and link them to various sites, what if I wanted to add various codes like, google adsense, yahoo and other publisher codes which provide them as JavaScript, and I need to add 5 such codes, so each time the page loads, different ads appear.

Any help on this ? Thanks in advance ! Btw, I installed this and works fine :)

Regards,
DC

If you using google adsense then you have no choice what ads appear anyways. They are random ads and read the content of your site to pick what ads are displayed. I don't know much about Yahoo because they are still in the test stages and I can not find where to apply for them to get them. I would like to get Yahoo ads so I could answer you question and use them. But I would be willing to bet that they work on the same principle as google adsense.

If you could explain more about what you mean I could probably answer your question better.

CAMS
30 Jan 2006, 05:43
just wat i was looking for after some other code wasnt working properly :)

cheers and installed

CopoGuy
30 Jan 2006, 06:43
Awesome (and simple) mod! Thank You!

Has anyone tried to add the target="_blank" piece to the banner's URL (so it opens the banner link in an external browser window?)
example:

// imageArray
image[number++] = "<a href='http://www.bannerurl.com" target="_blank">


The default script works great but when I try to do it that way the banner disappears on the forum page. Perhaps I have a typo?

attroll
30 Jan 2006, 17:17
Awesome (and simple) mod! Thank You!

Has anyone tried to add the target="_blank" piece to the banner's URL (so it opens the banner link in an external browser window?)
example:

// imageArray
image[number++] = "<a href='http://www.bannerurl.com" target="_blank">


The default script works great but when I try to do it that way the banner disappears on the forum page. Perhaps I have a typo?

You can make it open in a seperate browser window by adding the target='ad' in the line as shown below. Sorry I did not explain that. I left it out because I wanted to make this hack very easy.

image[number++] = "<a target='ad' href='http://www.hikersupply.com'><img src='http://www.yoursite.net/forum/sponsors/hikersupply.gif' border='0'></a>"

I have just added this to the documentation.

LisaD1
30 Jan 2006, 17:47
Installed and works great!! Thanks

LEAD_WEIGHT
30 Jan 2006, 17:56
Does this not do the same? or does yours have more unique qualities?
http://www.vbulletin.com/forum/showthread.php?t=170826

TruthElixirX
30 Jan 2006, 18:08
Look man, he made something and shared it for free. If something already does it who cares. If you have nothing ot contribute shut up. I'm getting tired of seeing posts like this "well this already does this"

Dells and Gateways d othe same thing. As does IPB and vBulletin. Its a matter of choice. Contribute or don't post at all.


Thank you for the hack. A client of mine might be needing this soon.

LEAD_WEIGHT
30 Jan 2006, 18:27
:speechless:

You are a fool for answering that way! I was asking a legitimate question from the coder and not some lame member who has nothing, but time to troll threads and start flaming everyone. Stick to your own hacks and let ppl ask their own question. :disappointed:

CopoGuy
30 Jan 2006, 19:17
Attroll,
The target='ad' modification worked perfectly.
Thanks again for sharing! Exactly what I needed
something nice and simple.

LisaD1
30 Jan 2006, 20:27
Does this not do the same? or does yours have more unique qualities?
http://www.vbulletin.com/forum/showthread.php?t=170826
No matter how many times we tried to get that one to work, it wouldn't. First try on this one and bam it works great. So I think it is a great thing to have many different ways to do the same thing.

Snake
30 Jan 2006, 21:09
/me clicks on install

Mr Chad
30 Jan 2006, 23:11
this doesnt always have to be an image does it?
image[number++] = "Hello"

Gripemaster
04 Feb 2006, 14:09
So I suppose if we want them centered, we would just have to change:

<td align="$stylevar[right]">
&nbsp;

To:

<td align="$stylevar[center]">
&nbsp;

Correct? I would prefer mine be centered on the top of the page.

Gripemaster
04 Feb 2006, 15:15
Nevermind... Got it firgured out with a little tweaking... thank you very much!!! *Clicks Install* :)

attroll
04 Feb 2006, 15:21
this doesnt always have to be an image does it?
image[number++] = "Hello"

You could do it that way but the word Hello would not be a link. If you wanted the word Hello to be a link you would do it this way
image[number++] = "<a href='http://www.yoursite.net'>Hello</a>"

TruthElixirX
19 Feb 2006, 18:04
Is there anyway to get the banners to rotate in order, and not randomly?

Krumbz
19 Feb 2006, 23:18
How would I put it in my footer?

Krumbz
19 Feb 2006, 23:51
Figured it out nevermind.

jadkar
13 Mar 2006, 00:40
Hmmmm...this seems really easy but for some reason it's not showing up at all. Is there anyone else who is having problems with this? All my photos have the correct paths (I would assume I would get a dead link anyway). I even tried renaming the hook just incase I had a reserved word or something...still no go. Any help would be much appreciated

jadkar
13 Mar 2006, 02:49
^^^^^

Please don't mine me :knockedout:

I'm so used to dealing with IIS at work that I forgot my hosting server is case senstive...... dddduuuuuuuhhhh

All fixed now.... work great!! thanks

cuphongle
15 Mar 2006, 23:35
how would i create a new template in "admincp"

Wizardjv
18 Mar 2006, 19:22
Is there any chance to get this to work on VB 3.5.4? I have tryed and it seems it will not work...So if anyone knows of a way I can do this on a newer version it would be greatly appreciated

attroll
18 Mar 2006, 22:11
Is there any chance to get this to work on VB 3.5.4? I have tryed and it seems it will not work...So if anyone knows of a way I can do this on a newer version it would be greatly appreciated
I have not upgraded my foums to 3.5.4 yet. But I don't understand why it would not work. What is it not doing or is it doing anything?

Wizardjv
20 Mar 2006, 22:03
It doesnt show or do nothing at all...I have installed and reinstalled like 3 to 4 times to rule out error on my part nothing....So I figured it was cause not compatiable...Ive used this before on older version...on new version nothing :(..so I dont know...But I really like your work and would love to be able use it on the newest version Thank You for your time and reply

trancetopia
20 Mar 2006, 22:40
I'm trying to get this to work on 3.5.4 also but it's not displaying anything. If you have simple text such as "hello" or "show me" it will display fine but if you use the example urls you have included it will show nothing.

Very odd!

trancetopia
20 Mar 2006, 22:52
I've got this to work now. For some reason if you put the width and hight attributes in the img tag, none of the banners will display. If nothing is showing just leave out these attributes and they will display.

She Unlimited
21 Mar 2006, 07:13
Where can I find the plug in system in the AdminCP?

attroll
21 Mar 2006, 07:48
Where can I find the plug in system in the AdminCP?

It should be in the left menu area and the third one from the bottom.

She Unlimited
21 Mar 2006, 07:55
Hm, that is strange. The 3rd from the bottom is Tasks? Is that the main category name?

Thank you!

attroll
21 Mar 2006, 08:17
Hm, that is strange. The 3rd from the bottom is Tasks? Is that the main category name?

Thank you!
I see your problem. You are running vBulletin 3.0.7. This hack was designed for 3.5 and higher. But I can tell you what to do to get it working on your version.

Replace step #2 in this hack with this.

2. Put the following command in your phpinclude_start template:
eval('$banner = "' . fetch_template('banner') . '";');

She Unlimited
21 Mar 2006, 08:34
Great, thank you, I have tried both in the header but they stretch out the template...I wonder if I can add this to the navbar?

snowman872
22 Mar 2006, 00:25
This hack seems to be working fine, but at the bottom of my board, I am getting the uncached template message:

Uncached templates: banner (1)

Is this normal? Is there a way to make it go away?

Thanks!

Edit - Hmmm it was working, until I added more than one banner. Now no banners appear. Are we supposed to edit the "number=0" or "image[number++]" incrementially or something?

Wizardjv
22 Mar 2006, 01:03
I've got this to work now. For some reason if you put the width and hight attributes in the img tag, none of the banners will display. If nothing is showing just leave out these attributes and they will display.

How did you go about removing them....I dont have any attributes in the img tag and still refuses to work....Any help would be greatly appreciated

mattyk72
24 Mar 2006, 17:18
how do I cache the template?

DJCobol
26 Mar 2006, 17:13
Thanks for this. I've gotten it working on the header, but when I tried adding the "$banner" variable to my right column area it doesnt work. Any help?

Freak0204
29 Mar 2006, 19:17
This isn't working for me. Nothing is showing up.

attroll
30 Mar 2006, 07:05
how do I cache the template?

Why do you need to cache the template?

attroll
30 Mar 2006, 07:07
Thanks for this. I've gotten it working on the header, but when I tried adding the "$banner" variable to my right column area it doesnt work. Any help?

What right column are you talking about. Are you referrring to you front page?

attroll
30 Mar 2006, 07:09
This isn't working for me. Nothing is showing up.
Did you get this working because I am looking at your forums and I see a banner showing?

TruthElixirX
30 Mar 2006, 13:10
I have not upgraded my foums to 3.5.4 yet. But I don't understand why it would not work. What is it not doing or is it doing anything?
My board has upgraded to 3.5.4 and I can confirm it is working just like normal. :)

KevNJ
30 Mar 2006, 16:55
Can we have a link to see this is working order ?

DJCobol
30 Mar 2006, 22:25
What right column are you talking about. Are you referrring to you front page?

I have this plugin (http://www.vbulletin.org/forum/showthread.php?t=94495) installed on my board. Whenever I put the "$banner" code snippet in so that it would show up over there, nothing shows up. But it does work in the header. See example here. (http://www.michiganspeed.com)

DJCobol
03 Apr 2006, 21:58
anything yet, or am I the only one with this problem

attroll
04 Apr 2006, 06:38
anything yet, or am I the only one with this problem
Sorry it took so long to reply. If you are using CMPS for you front page then you need to go into your ADMINCP-->vBA CMPA-->Default Settings and scroll down until you see PORTAL OUTPUT GLOBAL VARIABLES and in that block put this

banner

foulplay
04 Apr 2006, 09:33
This is not showing on 3.5.4 I followed the steps to the "T"

attroll
04 Apr 2006, 18:15
This is not showing on 3.5.4 I followed the steps to the "T"
I have it working in 3.5.4 on my test site. So I know it works i=on hte latest version.

On a side not make sure you have edited the right style or all styles. If you add this to a style make sure you are viewing the style you have added it to.

mamboking
11 Apr 2006, 17:44
Hi everyone,

I have a question I hope someone can answer. Is there a benefit to loading banners this way opposed to call the javascript direct? I hope I am asking this coreectly.

I use a similiar script and was wonder if I would benefit from loading it this way My Site (http://www.mamboston2.com/)

DJCobol
26 Apr 2006, 01:05
Sorry it took so long to reply. If you are using CMPS for you front page then you need to go into your ADMINCP-->vBA CMPA-->Default Settings and scroll down until you see PORTAL OUTPUT GLOBAL VARIABLES and in that block put this
That didn't change anything. I tried adding "banner', then "$banner", then both, and nothing worked. Any other ideas? Its like the PHP code isn't even being evaluated in that section of code.

joeychgo
26 Apr 2006, 12:32
Nicely done.

I like this hack and reviewed it on vBulletin FAQ (http://www.vbulletin-faq.com) here: A Simple Random Banner Rotator (http://www.vbulletin-faq.com/forum/showthread.php?t=295)

Good Job.

attroll
26 Apr 2006, 17:55
Nicely done.

I like this hack and reviewed it on vBulletin FAQ (http://www.vbulletin-faq.com) here: A Simple Random Banner Rotator (http://www.vbulletin-faq.com/forum/showthread.php?t=295)

Good Job.
Thank you joeychgo. I did not know your site existed. I am in the middle of having a major addon created for my web site that has really consumed me and when I get a chance I will register on you site and check it out.

Thanks

Murty
27 Apr 2006, 13:11
Hey, cool hack. One query though. I want the rotating banner to be my main logo (eg [left]) this is my code for the header:

<!-- logo -->
<a name="top" id="top"></a>
<table width="$stylevar[outertablewidth]" align="center" border="0" cellspacing="0" cellpadding="0">
<tr>
<td width="15" style="background-image:url($stylevar[imgdir_misc]/left.gif)"><img src="$stylevar[imgdir_misc]/left.gif" width="15" border="0" alt="" /></td>
<td width="100%">

<table border="0" width="100%" cellpadding="0" cellspacing="0" align="center" class="aria_header_bg">
<tr>
<td align="$stylevar[left]" valign="top" height="126"><a href="$vboptions[forumhome].php?$session[sessionurl]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>
<!-- /logo -->

So yeah, i have tried a few things, any ideas?

Murty
27 Apr 2006, 13:44
Dont worry, i got it working. For anyone else wanting to do the same. do this:

1) take out this bita looking code:
<td align="$stylevar[left]" valign="top" height="126"><a href="$vboptions[forumhome].php?$session[sessionurl]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>

2) put this in:
<td>$banner</td>

funinthesun
28 Apr 2006, 21:02
Excellent! Thank you very much!

CMY
30 Apr 2006, 21:40
Hi gys-

Am I doing something wrong in this particular section? I've followed all other directions perfectly but it's still not showing up. (VB 3.5.4)

Thanks,
Chris

mattyk72
01 May 2006, 15:38
Is it possible to have mutliple sets of rotators?

For example, can I have a banner rotator at the top of my page with lets say 5 ads going, and then a seperate rotator at the bottom of my page with 5 different ads going too?

mattyk72
03 May 2006, 15:26
Is it possible to have mutliple sets of rotators?

For example, can I have a banner rotator at the top of my page with lets say 5 ads going, and then a seperate rotator at the bottom of my page with 5 different ads going too?

anyone?

attroll
03 May 2006, 16:39
Is it possible to have mutliple sets of rotators?

For example, can I have a banner rotator at the top of my page with lets say 5 ads going, and then a seperate rotator at the bottom of my page with 5 different ads going too?

I don't see why it could not be done you would have to create the same thing over again but maybe do somethuing like this.

1. Go to your ADMINCP and create a template called "banner2" and insert the same code that you used in your first template but make the changes to the banners you want showing this this particular one.

2. Now still in your ADMINCP go to PLUGIN SYSTEM-->ADD NEW PLUGIN
HOOK LOCATION is "global_start"
TITLE is "banner2"
PLUGIN PHP CODE:
eval('$banner2 = "' . fetch_template('banner2') . '";');

3. Insert the following code in your footer:
$banner2

attroll
03 May 2006, 16:49
Hi gys-

Am I doing something wrong in this particular section? I've followed all other directions perfectly but it's still not showing up. (VB 3.5.4)

Thanks,
Chris

I don't know what your missing without actually looking at you web site and your ADMINCP. It looks like you have the code correct in your header. It sounds like it is one of two things. You might want to make sure that your plugin system is activated. It comes turned off when you first install VB. You also may want to make sure that the plugin that you created for this hack is activated.

mattyk72
03 May 2006, 19:06
I don't see why it could not be done you would have to create the same thing over again but maybe do somethuing like this.

1. Go to your ADMINCP and create a template called "banner2" and insert the same code that you used in your first template but make the changes to the banners you want showing this this particular one.

2. Now still in your ADMINCP go to PLUGIN SYSTEM-->ADD NEW PLUGIN
HOOK LOCATION is "global_start"
TITLE is "banner2"
PLUGIN PHP CODE:
eval('$banner2 = "' . fetch_template('banner2') . '";');

3. Insert the following code in your footer:
$banner2

That's kinda what I had in mind, I'll give it a try, thanks.

I was just wondering if anyone else has done the same thing.

Angeleyes
31 May 2006, 02:30
I can't figure out how to "create a new template" in the AdminCP. Can someone help me???

attroll
31 May 2006, 05:00
I can't figure out how to "create a new template" in the AdminCP. Can someone help me???
Log into your ADMINCP --> Styles & Templates.
Now Click on the drop down menu for the default style.
Click Add New Template.

Angeleyes
31 May 2006, 15:57
::smacks head:: Wow... I'm an airhead. I honestly feel like such an idiot- thank you SOOOO much! ::hugs attroll:: :)

Angeleyes
01 Jun 2006, 01:17
Okay... I did everything I was supposed to do... except I'm trying to put the banner rotator under the nav bar. It's not working though :( Nothing is happening. The plugin is active, I have plugins enabled and everything.

Angeleyes
01 Jun 2006, 01:18
does it matter if I'm using a custom template?

attroll
01 Jun 2006, 05:14
does it matter if I'm using a custom template?

What do you meant by custom template?
Did your create the plugin and make it active?
What is your web site url?

Angeleyes
01 Jun 2006, 20:15
What do you meant by custom template?
Did your create the plugin and make it active?
What is your web site url?


I'm sorry- I meant custom style.

I did create the plug-in and make it active. I went over your directions like 10 times! :confused:

my website url is www.iheartpaws.com/forums

Thank you so much for your patience with me... I feel like such a dummy.

attroll
02 Jun 2006, 07:06
Angeleyes

You may have made the pluing active but have you activated the Plugin/Hook System?

To do this you need to go to ADMINCP --> vBulletin Options --> Plugin/Hook System and put the dot in YES and save.

Angeleyes
02 Jun 2006, 17:47
I checked that- and I did have it on already. I turned it on right before I started following your directions in this thread.

Nordraserei
15 Jun 2006, 21:46
Works great. Thanks, lad. :banana:

sam anders
17 Jun 2006, 13:55
thanks for this added and works a dream just what i was after :)

mac27
07 Jul 2006, 03:05
I have it installed on v3.5.4.

Great hack, but I am wondering is it suppose to rotate through the banners without refreshing the forum page? (An automatic rotate)

Thanks

Maxman1544
26 Jul 2006, 15:25
Does this work with 3.6?

Thanks.

attroll
02 Aug 2006, 06:20
Does this work with 3.6?

Thanks.
I don't know. Hopefully someone else will answer. I do not install any of the beta vB software until it is has come out of beta testing. Ths reason being is that my site it to big to be constantly upgrading every time vB finds a issue with there beta software.

Evolution06
02 Aug 2006, 20:57
No it isn't working with 3.6 at the moment just installed it.

mattyk72
03 Aug 2006, 02:56
will this work with flash banners too?

ShackMaster
03 Aug 2006, 06:48
I'm trying to use

<if condition="$forumid == 28">$banner</if>

but it's not working... no banners show up in 3.5.4

Plugin/Hook activated.... got several working already... followed all instructions other than trying the "if" condition.

Any ideas?

Thanks!

soletrader
21 Aug 2006, 06:01
anyway to get this to work with 3.6?

vbreal
13 Sep 2006, 22:04
can i use this to rotate my main banner

attroll
14 Sep 2006, 06:45
can i use this to rotate my main banner
You sure can if you put the code in the correct spot.

vbreal
15 Sep 2006, 16:00
cool i got it to work. but it puts this gap in between my banner and the forum. Its not much. Just a few pixels but its bugs me every time i see it haha
I have attached a picture of it and my code. if it can be fixed cool. if not i will just have to deal with it. I appreciate the mod.

thanks


<!-- Begin rotating ad code -->
<script language="Javascript"><!--
function image() {
};
image = new image();
number = 0;
// imageArray
image[number++] = "<a href='http://www..com/forum.php'><img src='http://www..com/images/misc/tdphoto.jpg' border='0'></a>"
image[number++] = "<a href='http://www..com/forum.php'><img src='http://www..com/images/misc/tlphoto1.gif' border='0'></a>"
// Carry on adding images - as many as you want
increment = Math.floor(Math.random() * number);
document.write(image[increment]);
//-->
</script>
<!-- End rotating ad code -->


<!-- logo -->
<a name="top"></a>
<table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
<tr>
<td align="$stylevar[center]">$banner</td>
<td align="$stylevar[right]">
</td>
</tr>
</table>
<!-- /logo --> <!-- content table -->
$spacer_open $_phpinclude_output

ChavMagnet
29 Sep 2006, 20:43
Bag Of Wank lol

dklassen
13 Oct 2006, 05:38
Not sure what you mean when you say "Go to your ADMINCP and create a template called "banner" and insert the attacked code."

I'm using 3.6.2 and I can create a new template but where do I put the code?

Shazz
13 Oct 2006, 07:07
Didn't work on my 3.6.. There are many rotating banner codes, just have to find the right one

attroll
13 Oct 2006, 07:09
Not sure what you mean when you say "Go to your ADMINCP and create a template called "banner" and insert the attacked code."

I'm using 3.6.2 and I can create a new template but where do I put the code?

Maybe I did not explain it clear enough. Let me try it here.

Go to you ADMINCP
Go to Styles & Templates
Add New Template
Title the template "banner"
Insert the the code that is listed after you have made your modifications to it with your links.

dklassen
13 Oct 2006, 17:36
Thanks, got it working.

What template do I put the $banner in if I want the ads do display in one specific forum?

attroll
13 Oct 2006, 18:00
Thanks, got it working.

What template do I put the $banner in if I want the ads do display in one specific forum?
The only way to make this work in one specific forum would be to create another style and assign that style to that forum and to put the $banner in the header template of just that one style.

BruZZi
25 Oct 2006, 03:30
Installed.

It works great on my (upcoming) forum thanks. :) :) :)

Two questions...

Is there a way to get the banners rotate in order ???

How can I change the color of the border ?

.

attroll
25 Oct 2006, 06:15
Installed.

It works great on my (upcoming) forum thanks. :) :) :)

Two questions...

Is there a way to get the banners rotate in order ???

How can I change the color of the border ?

.

Yes you can.

In you banner template.

Find:
<!-- Begin rotating ad code -->

Above that add:

<table border=#CCCCCC">
<tr>
<td width="100%">


Now find:
<!-- End rotating ad code -->

Below that add:
</td>
</tr>
</table>

To change the border color replace the color in this code here:
border=#CCCCCC"

BruZZi
26 Oct 2006, 01:05
Thanks attroll. :)

TonyRio
08 Jun 2007, 19:33
Thank you much.. this was just what I was looking for.

However, is there anyway to get rid of the "PHP Code:" that shows up to the left of the banners?

rollinjunk
17 Jun 2007, 22:21
how come i cant figure out how to make a template to begin with ???


i kow im missing something

attroll
17 Jun 2007, 22:57
how come i cant figure out how to make a template to begin with ???


i kow im missing something

Go to your ADMINCP--> STYLES & TEMPLATES--> STYLE MANAGER. Now pick the style you want to put it in. I recommend you DEFAULT or the top level style and then click the drop down menu and click on ADD NEW TEMPLATE. You can not get any more easier then that.

ArchangelX
03 Sep 2007, 05:50
I have one Flash banner in my sponsors group. How do I modify the code to work with it? Thank you.

ArchangelX
04 Sep 2007, 04:31
No dice, huh?

attroll
04 Sep 2007, 05:36
I have never played with flash so I am sorry I don't know where to start.

ArchangelX
04 Sep 2007, 05:57
Thanks, don't worry...I mucked about with it for the past day, and I finally figured out the sequence that worked.

Here's what I used for the code for flash. Now I'm no coder, so this may be really off, but it works on my site in both IE and FF. Thanks for the help...I hope this helps others! Of course, change the colors and dimensions for your file.


image[number++] = "<embed src= 'Enter your source file here' bgcolor='#FFFFFF' width='240' height='85'/>"

fridaypassion
09 Jan 2008, 20:56
How do I get the image displayed to centre? I am wanting it to appear below my main logo which is also centred

thanks!

attroll
10 Jan 2008, 05:06
How do I get the image displayed to centre? I am wanting it to appear below my main logo which is also centred

thanks!

How did you get your main logo centered? You shouold be able to do it the same way you main logo was centered. If I could see your header I could help you out but I do not know how you have your header template setup.

fridaypassion
10 Jan 2008, 18:53
Hi

thanks for the reply this is my current header template:

<!-- logo -->
<a name="top"></a>
<table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
<tr>
<td align="center"><a href="$vboptions[forumhome].php$session[sessionurl_q]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a></td>
<td align="center">


</td>

</table>

<!-- /logo -->
<td align="center">



<!-- content table -->
$spacer_open

$_phpinclude_output

attroll
13 Jan 2008, 07:37
I would try something like this. If this is not what you want let me know.
<!-- logo -->
<a name="top"></a>
<table border="0" width="$stylevar[outertablewidth]" cellpadding="0" cellspacing="0" align="center">
<tr>
<td>
<center>
<a href="$vboptions[forumhome].php$session[sessionurl_q]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a><br />
<a href="$vboptions[forumhome].php$session[sessionurl_q]"><img src="$stylevar[titleimage]" border="0" alt="$vboptions[bbtitle]" /></a>
</td>
</center>
</td>
</tr>
</table>
<!-- /logo -->
<!-- content table -->
$spacer_open
$_phpinclude_output

Chance4Today
30 Jun 2008, 05:00
I wonder if this works with the 3.7.0 patch 2? anyone know. I am looking for a banner changer

wanting a extra navbar but not any drop down or anything just another navbar to clean up mine has too many

attroll
30 Jun 2008, 06:45
I wonder if this works with the 3.7.0 patch 2? anyone know. I am looking for a banner changer

wanting a extra navbar but not any drop down or anything just another navbar to clean up mine has too many
I do not see why it wouldn't. Nothing has changed since VB 3.5 that I can see that would keep this from working.

I have to admit though. I no longer use this mode that I created. I have switch to GARS for my banner rotation. It is not free software but it works good for setting the start and stop times that you want each banner to display.