PDA

View Full Version : Problem.


Olli460
24 Jun 2006, 18:24
This problem is probably one that has been addressed before and I will look after I post this. Whenever it goes to alter my admin tables I get this error.

Database error in vBulletin 3.5.4:

Invalid SQL:

ALTER TABLE `administrator`
ADD `rpgadminperms` INT( 10 ) UNSIGNED NOT NULL DEFAULT '0';

MySQL Error : Duplicate column name 'rpgadminperms'
Error Number : 1060
Date : Saturday, June 24th 2006 @ 06:20:30 PM
Script : http://emuv2.com/forums/installer/index.php
Referrer :

I saw someone saying to edit the config file to allow using queries and I did that and yet I still get the error. Can someone help?

Revan
25 Jun 2006, 11:36
Did you have this hack installed before and uninstalled it? Because a known error in the previous versions was that that field wouldn't be dropped like it should.
Do this: In ./installer/hacks/rpg_integr_hack/install.php find:
$this->exec_queries('alter');
Add above:
$this->failsafe = true;

That should hide the errors and allow the script to install properly.

Olli460
27 Jun 2006, 22:48
Thanks for the help, it worked. I have another problem now...but Im pretty sure its been answered. Ill look around for the answer. Again, thanks alot man its really appreciated.