PDA

View Full Version : Administrative and Maintenance Tools - [APM] Advanced Product Management 3.0.4


mtha
22 Jul 2006, 02:05
[APM] Advanced Product Management 3.0.4


/*================================================*\
|| ########################################## ||
|| # Advanced Product Management [APM] v3.0.4 by HacNho
|| # Copyright (C) 2006 by HacNho, All rights reserved.
|| # ----------------------------------------------------------
|| # For use with vBulletin Version 3.6.0 RC2 and later
|| # http://www.vbulletin.com (http://www.vbulletin.com/) | http://www.vbulletin.com/license.html
|| # Discussion and support available at
|| # http://www.vbulletin.org/forum/showthread.php?t=121792
|| ########################################## ||
\*=================================================*/

Hack Version: 3.0.4.060925
Compatible vB version: 3.6.x
http://www.vbulletin.org/forum/showthread.php?t=121792


NOTE:
- The old related URL is removed due to the present of default URL field. old value is Not pasted over.

APM for vBulletin 3.5.x:
http://www.vbulletin.org/forum/showthread.php?t=95741

APM for vBulletin 3.7.x (and 3.8.x)
http://www.vbulletin.org/forum/showthread.php?t=197071


DESCRIPTION:

A center product area which allow you to manage all codes/plugins/templates/phrases/settings /crons for any product.
It also add some additional fields to the product, just to save more information with a product
Release Date
Product Author
Extra Information

The extra information is only available if you install APM, and use APM to export/import other product.
It does not have any conflict with original product. You still can use APM to import standard product, or use standard product tool to import APM's product files.

INSTALL:
1. Upload all files in UPLOAD folder to your server
2. Import XML product (product-adv_product_management_XXX.xml) using vBulletin standard product import tool.
3. Refresh menu panel to display Advanced Product Management link in Plugin System section

{optional} - Re-import product-adv_product_management.xml using APM import product tool, with Allow Overwrite = Yes
This step is inserting more information into the product.
* CAUTION: DONOT use APM to import product-adv_product_management.xml BEFORE step 2.

UPGRADE:
1. Upload all files in UPLOAD folder to your server (replace the old files
2. Import XML product with "Allow Overwrite" option checked
3. Enjoy!


HISTORY:
v1.0: Initial release
v1.1: Improve count queries, thanks to KirbyDE, some bugs fix
v1.2: Add collapsible blocks into product detail

2005.10.02: version 2.0: Alot of improvement. After editting, redirect back to product manager

2005.11.05: version 2.0.3: change some function names, due to changes in vB3.5.1 / it may not work for 3.5.0

2006.07.21: version 3.0.0 - release for vB 3.6.0
2006.08.22: version 3.0.2: Add CRON to the APM - change dependency
2006.09.21: version 3.0.3 - with small fixes
2006.09.25: version 3.0.4 - fix "install code - invalid product" bug (p=1081739&postcount=38)

mtha
22 Jul 2006, 02:06
reserved for future use!

Milad
22 Jul 2006, 02:38
Thanks, I was waiting for your MOD.

Thank you

jackalz
22 Jul 2006, 02:46
Great, thanks.

Jim O
22 Jul 2006, 03:20
When attempting to install using vB 3.6.0 RC2 receieved error message:
vBulletin Message


The following dependencies were not met:

1. This product is not compatible with version 3.6.0 Release Candidate 2 of vBulletin. (Compatible starting with 3.6.0)
I needed to change

<dependencies>
<dependency dependencytype="vbulletin" minversion="3.6.0" maxversion="" />
</dependencies>
to

<dependencies>
<dependency dependencytype="vbulletin" minversion="3.6.0 RC2" maxversion="" />
</dependencies>

D.Ilyin
22 Jul 2006, 08:40
mtha thanks! Was waiting this hack :)

Allan
22 Jul 2006, 08:43
Congrat, great hack ;)

Hornstar
22 Jul 2006, 09:20
Thanks for the update. Really enjoy this addon.

MrZeropage
22 Jul 2006, 15:10
Thanks, have been waiting for this :)

Atakan KOC
22 Jul 2006, 23:32
Thanks mtha :)

Snake
23 Jul 2006, 13:53
Yay finally for 3.6! Thanks man! :D

Paul M
23 Jul 2006, 18:47
The dependancy in the XML is still wrong - you cannot install this on an RC2 board without editing it.

When you next do an update, it would be handy to include cron jobs associated with the product as that is now a feature of 3.6. :)

Code Monkey
24 Jul 2006, 04:46
Another good addition would be the option to export a product xml in 3.54 format.

Billspaintball
24 Jul 2006, 05:41
Ohh yeah!
Thanks, been hanging out for this :)

Also, I second Paul M and JumpD's suggestions :)

aLReeMi
24 Jul 2006, 08:38
greeeeat,

thanks

mtha
25 Jul 2006, 08:41
The dependancy in the XML is still wrong - you cannot install this on an RC2 board without editing it.

When you next do an update, it would be handy to include cron jobs associated with the product as that is now a feature of 3.6. :)

Updated the attachment, with XML fix.

will see about the cron jobs. I dint use vb 3.6.0 myself, so havent discover its new functions yet :D


Another good addition would be the option to export a product xml in 3.54 format.

I think you still can export the product, and it will still can be imported in 3.5.4 (in theory, I think). extra information will be ignored.

backward export/import wont do any good, as new features will be ignored, and hacks for 3.6.0 may not work for 3.5.4

cheesegrits
26 Jul 2006, 04:58
An excellent product! This is the way the product manager should work.

Installed AND Nominated.

mtha
26 Jul 2006, 21:16
When you next do an update, it would be handy to include cron jobs associated with the product as that is now a feature of 3.6. :)


As per request, CRON JOBS is now associated with the product are available in APM.

Have fun!

Code Monkey
30 Jul 2006, 18:49
I think you still can export the product, and it will still can be imported in 3.5.4 (in theory, I think). extra information will be ignored.

backward export/import wont do any good, as new features will be ignored, and hacks for 3.6.0 may not work for 3.5.4

No, there are problems with the extra phrase info and the plugin order. My experience is they need to be removed.

Right now, if you develop a hack on 3.6 it is a chore to edit the xml for 3.54. As with every upgrade many peeps will not be upgrading.

As far as hacks not having backward compatability. Well, I'm sure the author will know if it is or not and love to be able to export a clean 3.54 xml if it is.

Paul M
30 Jul 2006, 19:03
As per request, CRON JOBS is now associated with the product are available in APM.Excellent, I am about to update. :)

BTW, the zip seems to refer to 3.0.3, but the text only refers to 3.0.2 ?

cheesegrits
31 Jul 2006, 16:18
When updating APM, does it matter whether we use APM itself or the standard PM to re-import the product?

-- hugh

Paul M
31 Jul 2006, 16:19
No, it doesn't matter.

cheesegrits
31 Jul 2006, 18:20
No, it doesn't matter.

Paul M - Thanks. I didn't think it did, but thought I'd better check. I just upgraded (using the APM), worked fine.

mtha - any chance we could get associated product XML at least displayed, and maybe the option to create a basic bitfield or cpnav skeleton? I don't expect full XML editing in the APM (yet!! LOL!), but it would be nice to at least have a table showing any associated XML files, and the ability to peek at them without having to jump on ssh or download them.

I've said it before, but I'll say it again .. this product rocks. I created my first new product with it yesterday (a bbcode to allow me to print vB options in posts (http://www.vbulletin.org/forum/showthread.php?p=1040951#post1040951)), it took less than an hour to create the whole thing, complete with usergroup permissions, admincp options, plugin and phrasing. The APM was a huge time saver, especially for me as a relative newcomer to vB coding.

I have a whole heap of features I'd love to see added to the APM, but I'll save those for now, and try and come up with a coherent feature request list rather than just brain dumping! The product XML just came out top of the list from yesterdays experience.

Thank you once again for such a useful and (IMHO) much needed product.

-- hugh

cheesegrits
31 Jul 2006, 18:41
Small little issue ...

If you forget to fill out the Version field when adding install / uninstall code, it doesn't throw any errors, and the feedback says the changes have been saved ... but they haven't.

-- hugh

cheesegrits
31 Jul 2006, 18:57
Another small issue ... and sorry about my post-fest today ...

When you update the ZIP with a new version, would you mind including the version number in the top level folder (AdvancedProductManager_303 or whatever)? And (as Paul M points out) change the version number in the text file?

It would just make product updating and housekeeping slightly easier. Which is, after all, one of the things the APM is all about. :D

-- hugh

mtha
01 Aug 2006, 20:01
I did it in rush for you guys, didnt actually have time to clean it up. it's kinda messy, isnt it? sorry 'bout that.
I will try to clean it up (... now right now :( )

cheesegrits
02 Aug 2006, 23:34
I did it in rush for you guys, didnt actually have time to clean it up. it's kinda messy, isnt it? sorry 'bout that.
I will try to clean it up (... now right now :( )

Please, no apologies necessary! I'm just pointing out a few trivial issues.

Speaking of which. I do have one slightly more than trivial issue I just noticed with one of the projects in my list. It's a fairly large on (the first beta release of SirAdrian's vBlogetin). The APM outputs it fine, except that it truncates the output at the end of the first setting group.

The product has three distinct settings groups, but APM gets as far as the last entry in the first group, and stops there. It doesn't even print the content of the last entry in that first group, it just prints the title line.

There is no Save button, and the usual footer stuff (including the debug info) is missing as well.

I've tried APM on an equally sizeable product (PhotoPlog) which has a similar amount of plugins, phrases, templates, etc, and that works fine. So i don't think it's any kind of overall size limit.

I'm examining the product XML at the moment, to see if there is possibly something strange in the XML itself which might be getting APM's undies ina bundle.

More News When There Is News,

-- hugh

cheesegrits
07 Aug 2006, 02:06
Another issue I've run across ... I don't know if this is APM, or a generic vB problem, but when I try and create a new template in a new product I'm working on, when it saves it tells me "Invalid product ID", even tho I have definitely selected my new product from the dropdown on the new template page.

-- hugh

pauloo
09 Aug 2006, 15:24
Thank you

Stoebi
14 Aug 2006, 12:16
Hi,

thx a lot for the very nice addon. I've three wishes.

1. A way to add/change the autor in phrases
2. A way to add/change version numbers in phrases
3. A way to add/change phrase date in phrases

Regards, Stoebi

Spiffware
21 Sep 2006, 11:54
has anyone try to install this on 3.6.1 to see if it worked?

mtha
21 Sep 2006, 12:25
it seems to work on 3.6.1, but need revised and small fixes. I will try to work on it next week.

Spiffware
21 Sep 2006, 12:59
ok thanks

Kriminal
21 Sep 2006, 16:02
has anyone try to install this on 3.6.1 to see if it worked?

It works in 3.6.1

mtha
22 Sep 2006, 01:49
Hack Version: 3.0.3.060921
Compatible vB version: 3.6.0 (and later)

With small fixes and clean up.

Does work with vB 3.6.1

mtha
22 Sep 2006, 01:54
Excellent, I am about to update.
BTW, the zip seems to refer to 3.0.3, but the text only refers to 3.0.2 ?
Fixed

mtha - any chance we could get associated product XML at least displayed, and maybe the option to create a basic bitfield or cpnav skeleton? I don't expect full XML editing in the APM (yet!! LOL!), but it would be nice to at least have a table showing any associated XML files, and the ability to peek at them without having to jump on ssh or download them.
well, no. not at the current time.


If you forget to fill out the Version field when adding install / uninstall code, it doesn't throw any errors, and the feedback says the changes have been saved ... but they haven't.
Dont see that error, or it's been fixed on the way :)


Speaking of which. I do have one slightly more than trivial issue I just noticed with one of the projects in my list. It's a fairly large on (the first beta release of SirAdrian's vBlogetin). The APM outputs it fine, except that it truncates the output at the end of the first setting group.

The product has three distinct settings groups, but APM gets as far as the last entry in the first group, and stops there. It doesn't even print the content of the last entry in that first group, it just prints the title line.

There is no Save button, and the usual footer stuff (including the debug info) is missing as well.

I couldnt find vBlogetin on the site here, so cant test. anyway, I clean up and fix some table on vboptions. Try again and see if it is fixed.


Another issue I've run across ... I don't know if this is APM, or a generic vB problem, but when I try and create a new template in a new product I'm working on, when it saves it tells me "Invalid product ID", even tho I have definitely selected my new product from the dropdown on the new template page.


Dont see the problem. Try to upgrade to the newest version and see if you still get the error?



1. A way to add/change the autor in phrases
2. A way to add/change version numbers in phrases
3. A way to add/change phrase date in phrases

They are all in phrases, aint they?

Spiffware
23 Sep 2006, 06:30
ok installed and it seems to work ill let you know if i get any issues but so far its fine.

Paul M
23 Sep 2006, 22:00
If I try and add install code I just get an "Invalid Product Specified" error when clicking save.

Edit - this only seems to be if previous install code exists.

Spiffware
24 Sep 2006, 04:45
if u read his txt uninstall out virsion and install new one it works fine.

stcont
24 Sep 2006, 09:21
Help error :(
(vBulletin 3.6.1)

Parse error: parse error, unexpected '}' /forum/admincp/apm_product.php on line 2855


{
if (empty($setting["$grouptitle"]))
{
continue;
}

// add a group for each setting group we have settings for

$xml->add_group('settinggroup', array('name' => htmlspecialchars($group['grouptitle']), 'displayorder' => $group['displayorder']));

foreach($setting["$grouptitle"] AS $set)
{
$arr = array('varname' => $set['varname'], 'displayorder' => $set['displayorder']);
if ($set['advanced'])
{
$arr['advanced'] = 1;
}
$xml->add_group('setting', $arr);

if ($set['datatype'])
{
$xml->add_tag('datatype', $set['datatype']);
}
if ($set['optioncode'] != '')
{
$xml->add_tag('optioncode', $set['optioncode']);
}
if ($set['validationcode'])
{
$xml->add_tag('validationcode', $set['validationcode']);
}
if ($set['defaultvalue'] !== '')
{
$xml->add_tag('defaultvalue', $set['defaultvalue']);
}
if ($set['blacklist'])
{
$xml->add_tag('blacklist', 1);
}
$xml->close_group();
}

$xml->close_group();
} <= 2855 line

mtha
25 Sep 2006, 06:11
Help error :(
(vBulletin 3.6.1)

Parse error: parse error, unexpected '}' /forum/admincp/apm_product.php on line 2855


Interesting. seems like you were getting error when exporting a product, right?

I cant reproduce the problem.

Could you tell me exactly what you were doing, when getting that error message, or which product you are trying to export.

is there anything special about the product.
can you export the product using standard vB's export?

stcont
25 Sep 2006, 06:32
click & links http://homepadge/forum/admincp/apm_product.php
error Parse error: parse error, unexpected '}' /forum/admincp/apm_product.php on line 2855
Decision: coments this code

/*

{
if (empty($setting["$grouptitle"]))
{
continue;
}

// add a group for each setting group we have settings for

$xml->add_group('settinggroup', array('name' => htmlspecialchars($group['grouptitle']), 'displayorder' => $group['displayorder']));

foreach($setting["$grouptitle"] AS $set)
{
$arr = array('varname' => $set['varname'], 'displayorder' => $set['displayorder']);
if ($set['advanced'])
{
$arr['advanced'] = 1;
}
$xml->add_group('setting', $arr);

if ($set['datatype'])
{
$xml->add_tag('datatype', $set['datatype']);
}
if ($set['optioncode'] != '')
{
$xml->add_tag('optioncode', $set['optioncode']);
}
if ($set['validationcode'])
{
$xml->add_tag('validationcode', $set['validationcode']);
}
if ($set['defaultvalue'] !== '')
{
$xml->add_tag('defaultvalue', $set['defaultvalue']);
}
if ($set['blacklist'])
{
$xml->add_tag('blacklist', 1);
}
$xml->close_group();
}

$xml->close_group();
}
*/
error no // but also not all functions hacks work

mtha
25 Sep 2006, 06:55
click & links http://homepadge/forum/admincp/apm_product.php
error Parse error: parse error, unexpected '}' /forum/admincp/apm_product.php on line 2855
Decision: coments this code

error no // but also not all functions hacks work

I dont think you understand my question. I need to know exactly what you were doing, when getting that error, so I can check my code and see what's wrong with it.

I already check the line 2855, and there's nothing wrong there (in that area), so I need more information (as above questioned - if you want support).

is there anyone else getting the same error?

mtha
25 Sep 2006, 07:11
If I try and add install code I just get an "Invalid Product Specified" error when clicking save.

Edit - this only seems to be if previous install code exists.

Fixed in version 3.0.4

Paul, try it out and see if it works now. thanks

Paul M
25 Sep 2006, 10:34
Yes, that seems to have fixed it. :up:

sezmar
25 Sep 2006, 15:02
I get this error when viewing product ZSEO

Fatal error: Call to undefined function: fetch_style_title_options_array() in
/homepages/XX/XXXX/htdocs/testvbb/admincp/apm_product.php(215) : eval()'d code on line 1

any ideas?

Paul M
25 Sep 2006, 23:44
That's a function in adminfunctions_options.php, so I would guess that file need adding to the includes at the start of apm_product.php.

Paul M
03 Oct 2006, 03:51
Another minor thing - when the plugin system is disabled, clicking on Advanced Product Management just gives a completely blank screen.

mtha
07 Oct 2006, 01:15
Another minor thing - when the plugin system is disabled, clicking on Advanced Product Management just gives a completely blank screen.
I think I have that fixed on the latest version, or maybe I just have it fixed on my local :) anyway, will check and upload the new file.

adwade
11 Oct 2006, 18:03
It also add some additional fields to the product, just to save more information with a product
Release Date
Product Author
Extra Information

The extra information is only available if you install APM, and use APM to export/import other product.

So do you just need to Re-Import all your .xml files (overwrite?) and let the APM get a read of everything then to have ALL the information you can?

Very Nice Product by the way!

mtha
13 Oct 2006, 17:33
So do you just need to Re-Import all your .xml files (overwrite?) and let the APM get a read of everything then to have ALL the information you can?

Very Nice Product by the way!

yes IF the importing product was export by APM, containing such extra information. Otherwise, there's no different between one way or the other.

adwade
13 Oct 2006, 20:46
Understand, and it's nice that you allow access to 'manually' enter some of that information as we know of it. I was able to add links for all my products now, and have an fast-n-easy way to find out the latest about them. Cheers, AD

NiTRoN
05 Nov 2006, 21:45
just installed.. this thing is awsome.. make figuring out which product or plugin controlls what template a breeze.. sweet!

adwade
18 Nov 2006, 21:53
I'm getting this message:

vBulletin Message

Version check failed. No version number was found at this location. The URL for the version check may be incorrect, or the server may be experiencing problems. Please try again later.

Just on 'some' products I have installed.(for instance, [APM] Advanced Product Management works just fine)

The message above appeared when I tried to check on Lv vB Event Forums. I currently have v3.0 installed, yet Mod Version: 3.3 is available.

I have:

Product URL http://www.vbulletin.org/forum/showthread.php?p=1047676

- and -

Version Check URL http://www.vbulletin.org/forum/misc.php?do=checkversion&t=1047676

Is that correct?

nitro
02 Dec 2006, 18:27
Looks like a great addition.

One thing I have noticed is there is still no way to assign existing custom templates in a style to a product without being in debug. Anyway this type of function could be added to the templates part of the APM. For example it could have a button/link named (assign existing templates) which you select the style to list only non vb additional templates from, then by checkbox select any of those custom templates you want to stuff into the master style and assign to said product ?

hoopsta
23 Dec 2006, 21:17
anyone having trouble getting it to show up in the post bits? I am using 3.6 and also vplaza. When i do the edits they do not show up in postbits. The awards only show up at the admin.php

adhari_com
22 Jan 2007, 14:40
how to delete a setting or settings group?

Mr_Snob
22 Jan 2007, 15:14
this is a great system for me i have been via this hack my hacks made
thanks for this great hack mtha :)

mtha
23 Jan 2007, 18:42
I'm getting this message:

Just on 'some' products I have installed.(for instance, [APM] Advanced Product Management works just fine)

The message above appeared when I tried to check on Lv vB Event Forums. I currently have v3.0 installed, yet Mod Version: 3.3 is available.

I have:

Product URL http://www.vbulletin.org/forum/showthread.php?p=1047676- and -

Version Check URL http://www.vbulletin.org/forum/misc.php?do=checkversion&t=1047676Is that correct?

Version check URL is incorrect.
it must be:http://www.vbulletin.org/forum/misc.php?do=checkversion&t=123416 (http://www.vbulletin.org/forum/misc.php?do=checkversion&t=1047676)


Looks like a great addition.

One thing I have noticed is there is still no way to assign existing custom templates in a style to a product without being in debug. Anyway this type of function could be added to the templates part of the APM. For example it could have a button/link named (assign existing templates) which you select the style to list only non vb additional templates from, then by checkbox select any of those custom templates you want to stuff into the master style and assign to said product ?

No, I dont think I will do that, because the custom templates is in specific style, and product's templates are in master style. Changing styles might cause even more troubles/confusions.

anyone having trouble getting it to show up in the post bits? I am using 3.6 and also vplaza. When i do the edits they do not show up in postbits. The awards only show up at the admin.php
Wrong place to ask hoopsta

how to delete a setting or settings group?
Do you have debug ON? then there's option to delete a setting/group in there, where you see the settings.

thincom2000
10 Feb 2007, 05:54
I get an error "Invalid Product Specified" when I try to Add a New Template to a product. And then it just ends up saving it as a vBulletin custom template.

Also settings are not being exported. ???

As for possible new features:
The ability to edit a setting once created.
The ability to edit the default phrase text once created.

No, I dont think I will do that, because the custom templates is in specific style, and product's templates are in master style. Changing styles might cause even more troubles/confusions.

You don't have to change styles, just add it to the master style as well.

da420
10 Feb 2007, 06:53
I am having the same problems as thincom2000... I would love to use this hack as it would my life a ton easier.... lol

thincom2000
10 Feb 2007, 07:56
I figured it out. You need to enable debug mode in order for those problems to go away. Also I think some of the features I suggested are there with debug mode.

I didn't want to actually enable it, so I modified all of the APM files to get rid of the if ($vbulletin->debug) conditionals. A much easier way is actually enabling debug mode, which I said I didn't want to do.

My reasons are as follows: Debug Mode annoys the crap out of me. First of all there's no setting to enable/disable it. And once enabled, it uses a really unsightly version of the Microstats plugin.

Abe1
07 Mar 2007, 05:48
When you export this a product using this hack, the template version number does not tag along. Comes out empty.

thincom2000
03 Apr 2007, 03:38
Also this has a really high memory footprint. For some reason tonight my host decided to impose a limit of 10MB when before I had no limit. This is the only script in my entire site that tries to exceed the new limit.

rjmjr69
05 Apr 2007, 07:40
Also this has a really high memory footprint. For some reason tonight my host decided to impose a limit of 10MB when before I had no limit. This is the only script in my entire site that tries to exceed the new limit.


I dont see any jump in memory allocation with this installed. hhmm maybe something else you have?

This is just amazing i do not know how I missed this one. Thank you so much works just fine with 3.6.5

thincom2000
05 Apr 2007, 08:01
Merely installing it wouldn't make a difference in memory usage because it doesn't add any plugins itself. I just mean that when the admin page loads, it consumes a lot of memory, because it fetches every plugin, phrase, template, and setting for every product at once.

hambil
11 Apr 2007, 12:29
Using the system to create hacks and then export them. However, there is an interesting problem when creating new versions. I recently updated my vbTrends hack from version 1.2.6 to version 2.0.0. There where a lot of changes, and one of those was an edit to the forumhome_vbtrends template. The template shows as red (modified) in the style template list.

When I do the export from APM the old unmodified template is exported.

nitro
13 Apr 2007, 20:34
Using the system to create hacks and then export them. However, there is an interesting problem when creating new versions. I recently updated my vbTrends hack from version 1.2.6 to version 2.0.0. There where a lot of changes, and one of those was an edit to the forumhome_vbtrends template. The template shows as red (modified) in the style template list.

When I do the export from APM the old unmodified template is exported.
When working with templates you would need to move into debug mode to edit the code in the products templates in the master style and not the regular child styles. When you export a product either via this addon or from the regular vbulletin product exporter it will include the respective templates from the master style only.

MrZeropage
08 Aug 2007, 21:28
you should add support for Andreas' TMS :)

TheBlackPoet
10 Aug 2007, 19:28
i installed this a while ago.. i recently had a dbase failure.. and had to find this again.... i cant tell you how much i come to depend on this particular hack...!!!

TrIn@dOr
10 Aug 2007, 20:14
I'm very interested in the "phrases by product" thing... is included here, but do any1 knows if exist something like that "alone"?

Thanks.

AWJunkies
02 Jan 2008, 02:47
this is the best MOD ever by far for any programmer or developer!!! AND just FYI works for 3.6.8 P2

69lakalle
02 Jan 2008, 05:58
wooooooooow i will install it when i upgrade to 3.7

cheesegrits
21 Jan 2008, 18:07
FYI, works fine on 3.7b3.

I've been a happy user since the 3.5 version. This is a must for all vB coders!

-- hugh

Hasann
10 Mar 2008, 00:15
I create often my hacks with this system
it's great system and works fine with vBulletin versions 3.7.0 beta

Boofo
31 Mar 2008, 23:59
I can't work on a site that doesn't use this. It drives me crazy. This is a must have! ;)

Paul M
01 Apr 2008, 01:22
It has at least one bug still, but other than that I agree - this gets installed on any site I maintain.

Boofo
01 Apr 2008, 01:53
What bug is that?

And it would be nice to have the wider template edit like in vb3.7, too.

cheesegrits
09 Apr 2008, 15:09
FYI, works fine on 3.6.9 as well.

-- hugh

Paul M
09 Apr 2008, 17:59
What bug is that?.
Multi choice settings are not displayed correctly in the vb options section.

Boofo
09 Apr 2008, 18:15
Ahh, yes, I did notice the radio type settings aren't parsed correctly.

fariborz
16 May 2008, 20:20
Please upgrade your version. I like this MOD.
Thanks

Boofo
23 May 2008, 18:04
I'm getting a strange thing going on with this now. It was running fine on up to today and now the listing doesn't show the column for the settings, although the settings column is in the header. It shifted the listings to the left by one column and the last column is showing as missing. Has anyone else run into this or know how I can fix it?

Paul M
23 May 2008, 20:13
Do you have this installed ;

http://www.vbulletin.org/forum/showthread.php?t=133366

it messes with the column headers.

Boofo
23 May 2008, 20:26
Yes I do, but I swear that was working fine with it enabled before. I just disabled it and it fixed it. So, not good to use it then, huh?

And thanks for the fix, Paul.

Paul M
23 May 2008, 21:57
Its always interfered with APM, thats why I knew straight away.

Boofo
23 May 2008, 22:11
I would have sworn it was working before. Time to get the ol' eyes checked, I guess. ;)

markp_2000
26 May 2008, 01:45
Disregard. Solved.

fariborz
24 Jun 2008, 02:26
Hello Boofo,
Please release you new version for 3.7.1.
I'm waiting for your new version of product.

Boofo
24 Jun 2008, 02:59
This one works fine with 3.7.1. It is the same one I am using.

MrZeropage
27 Sep 2008, 19:25
I would LOVE to see an updated version - or vBulletin 3.8.0 having those advanced things included ;)

BigJohnny
02 Nov 2008, 21:52
I think it works with 3.7.3 ... ive got it installed and it seems to be working ok so far, but my forum isnt in use yet.

Paul M
03 Nov 2008, 01:18
I have this working on 3.7 and 3.8.

Hornstar
07 Nov 2008, 22:26
yeah should be something that vb has as standard.

Delphiprogrammi
12 Nov 2008, 15:59
Multi choice settings are not displayed correctly in the vb options section.

yeah you're right verry annoying any idea to correct that ?

Delphiprogrammi
14 Nov 2008, 17:24
yeah you're right verry annoying any idea to correct that ?

never mind i fixed it myself multichoice options do show correctly now

BigJohnny
16 Nov 2008, 14:48
how did you fix it?

Delphiprogrammi
16 Nov 2008, 16:39
how did you fix it?

have a good look at print_settinggroup() and print_setting_row() in /includes/adminfunctions_options.php now look at the apm function print_settinggroup_apm() you will notice the difference.If not i'll contact the author to see if i can get permission to release my fix

mtha
24 Nov 2008, 00:13
sorry i've been so busy with my work, haven't got time for these stuff here

just a quick clean up for vB 3.7.x (and should also work for 3.8.x)

http://www.vbulletin.org/forum/showthread.php?t=197071

7lanet
27 Nov 2008, 00:57
Is it possible to add the option of a mending the settings and modify words

mtha
27 Nov 2008, 22:45
Is it possible to add the option of a mending the settings and modify words
7lanet
dont understand what you are talking about

7lanet
28 Nov 2008, 00:58
i want
===================
[Edit][Delete][Add setting]
http://www.7lanet.com/up/out.php/i10759_resimxx3.gif

mtha
28 Nov 2008, 21:37
i want
===================
[Edit][Delete][Add setting]



are you kidding, right?

- did you install the product? it doesn't show that you installed.
- i already have those edit/delete/add setting in the setting&option section.

7lanet
28 Nov 2008, 21:44
yes i install the product
but [Edit][Delete][Add setting] I donot found In option

7lanet
28 Nov 2008, 21:55
[Edit][Delete][Add setting] I donot found In option
http://www.7lanet.com/up/out.php/i10769_1.gif (http://www.7lanet.com/up)
i install the product
http://www.7lanet.com/up/out.php/i10768_2.gif (http://www.7lanet.com/up)

mtha
28 Nov 2008, 22:50
yes i install the product
but [Edit][Delete][Add setting] I donot found In option

1. I would appreciate if you click INSTALLED.

2. i released a new version for vb 3.7. I am not going to support for older versions.

3. permission to edit/add/delete options is vbulletin standard permission. you need to have DEBUG mode ON in order to be able to edit/add.