PDA

View Full Version : Major Additions - Menu Control


Marky
01 Aug 2006, 22:47
Hey all,

Since this is the beta, and most of the information is included in the manual, I won't go into too much detail.

This is Menu Control 1.3 for vBulletin version 3.6.0 RC 3.

There may be a few bugs, and so it is important you must tell me about any you find!

Version 1.4 Menu Control is in production still and will be available for vBulletin 3.5 AND 3.6 very soon!

When Version 1.4 is released, I will use this thread to update it in.

In this version, I have updated some of the admin option descriptions for easier editing, but other than that it is the same as the 3.5 version.

Enjoy!

- Marky

Neal-UK
01 Aug 2006, 23:36
This looks great, well done.

A nice easy way to add new nav options on other skins too. This was one thing that put me off having a few skins but with this mod it will be much easier.

Neal-UK
01 Aug 2006, 23:42
Slight problem when viewing another area of my site though: http://www.gbpride.co.uk/gallery/

Draygonia
02 Aug 2006, 01:08
Awwww, it doesnt work with 3.5.4? Darn... I would love to have this for 3.5.4!

Marky
02 Aug 2006, 09:00
Awwww, it doesnt work with 3.5.4? Darn... I would love to have this for 3.5.4!
http://www.vbulletin.org/forum/showthread.php?t=104725

I believe that version works in 3.5.4 ;)

Slight problem when viewing another area of my site though: http://www.gbpride.co.uk/gallery/

You'll have to add $menucontrol under $navbar in the gallery templates.

Neal-UK
02 Aug 2006, 15:23
can't find the main gallery template whilst searching for $navbar. I'll have to speak to the owner of Photoplog I think.

Other than that little problem, it's an excellent modification that makes it so much easier having more skins ;-)

Marky
02 Aug 2006, 21:12
Good stuff :) It probably would be better talking to Photoplog because I've never used it before :)

Snake
03 Aug 2006, 18:24
Thanks Marky! :)

nanaimobar
04 Aug 2006, 03:51
Problem with Menu Image display in IE when "Images" is turned on in admin and no image selected for some links. IE displays ugly empty box where image should appear but FireFox works properly and does not display empty box. Tested on vb3.6 Gold. To correct IE problem I inserted meaningless images.

twitch
04 Aug 2006, 04:40
looking forward to the next release for 3.6
nice work

JayJay
05 Aug 2006, 19:52
With the Colour option turned off, links appear black in Internet Explorer but as the right/skin default colour in FF. Any ideas why this may be the case?

hyony
06 Aug 2006, 11:24
still waiting menu dropdown ;)

Marky
07 Aug 2006, 01:37
Problem with Menu Image display in IE when "Images" is turned on in admin and no image selected for some links. IE displays ugly empty box where image should appear but FireFox works properly and does not display empty box. Tested on vb3.6 Gold. To correct IE problem I inserted meaningless images.
In the next version I have on my "betaboard", this has been fixed! It will be included in the next version ;)

With the Colour option turned off, links appear black in Internet Explorer but as the right/skin default colour in FF. Any ideas why this may be the case?

Hmm ill look into it ;)

--

I have the beta version 4 on a beta board and I should be able to finish it by this week. I may not include the dropdown menus in this version unfortunatly. I believe that it'll be a big addition to the mod and it should be in 2.0. So 1.4 will include bug fixes and a few new useful options :) It will be available on 3.5 and 3.6 :)

JayJay
09 Aug 2006, 12:26
Thanks :)

Eagle Creek
12 Aug 2006, 18:57
Nice!

But I have two questions:

1. Is this also possible:
https://www.vbulletin.org/forum/external/2006/08/12.jpg

2. When I only have one menu item, will it be centered?

JayJay
12 Aug 2006, 23:23
I worked out the solution to my "problem" as it were ;) When I updated I had not replaced the 1.2 template code in the navbar to "$menucontrol" instead. Silly me :)

Cajun
13 Aug 2006, 17:07
Nice, but have one problem. I am using vbadvanced and vbulletin. The menu shows on my forums but not on the vbadvanced pages. How can I get the menu to show on my vbadvanced pages?

Neal-UK
13 Aug 2006, 22:23
Nice, but have one problem. I am using vbadvanced and vbulletin. The menu shows on my forums but not on the vbadvanced pages. How can I get the menu to show on my vbadvanced pages?

paste the code into the header template instead and it works fine

Cajun
13 Aug 2006, 22:56
paste the code into the header template instead and it works fine

Found a fast way to add the menu to vbadvanced page.

In Portal Output Global Variables add this:

menucontrol

Marky
14 Aug 2006, 08:56
Nice!

But I have two questions:

1. Is this also possible:
http://s20.photobucket.com/albums/b227/EagleCreek/?action=view&current=navbar_4.png&refPage=&imgAnch=imgAnch8

2. When I only have one menu item, will it be centered?
1. Yep
2. Yep :)

1. Find: <!-- breadcrumb, login, pm info --> in navbar template
Add Below: $menucontrol

--

To make the menu appear on your vBAdvanced portal add:

menucontrol

to your Portal Output Global Variables :)

--

Next version still in the making, will be released this week :)

Cajun
15 Aug 2006, 05:03
How can I get the menu to show in ibparcade pages?

Cajun
15 Aug 2006, 05:05
Also found when viewing someons Ip using the ip link in the forums that page will not display the menu.

optrex
21 Aug 2006, 16:48
Does anyone else have the problem with "new posts" page not showing the menu bar? Any idea why?

redlabour
22 Aug 2006, 18:34
Sorry, useless hack.

It has no "center" Function if you only add 2 Links both are completely on the left.

optrex
23 Aug 2006, 08:49
Change where you put the urls - try putting your 2 links in 4 and 5

Marky
24 Aug 2006, 11:18
Sorry, useless hack.

It has no "center" Function if you only add 2 Links both are completely on the left.
Saying that it's a "Useless hack" because it doesnt have a center function is pretty stupid... I would edit it so that when there wasn't any other links the first one was completely centered, but it seems it would be a waste of time seeing as you could use links 4 and 5 for example. It might happen one day if im bored lol :p

mikephung
26 Aug 2006, 21:03
thanks , it a great hack! It userfull for me!

headshotx
26 Aug 2006, 21:56
I Install this , but this image :

https://www.vbulletin.org/forum/

this whit default config . :S:S:S

Reece^B
26 Aug 2006, 22:06
Go to:
Options > Menu Control > Link Nine > Link Nine Image

And see if there is a URL there, if so then remove it. :)

headshotx
26 Aug 2006, 22:22
i have this in link 9 :

http://img95.imageshack.us/img95/1275/dibujo1eq9.jpg

The default config .

:cross-eyed:

hotwheels
27 Aug 2006, 01:41
Great mod marky.........This is a very useful mod friend.

Marky
27 Aug 2006, 12:39
I Install this , but this image :

http://img156.imageshack.us/img156/713/dibujorj2.jpg

this whit default config . :S:S:S
Would you post your menucontrol template please :)

headshotx
27 Aug 2006, 19:35
This is my menucontrol template :

<!-- Menu Control - Version 1.3 Final -->
<div align="center">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="0" border="0" width="100%" align="center" style="border-top-width:0px">
<tr align="center"><if condition="$vboptions[menu_status]">
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_one']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_one']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_one_colour']}"></if>{$vboptions['menu_item_one']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_two']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_two']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_two_colour']}"></if>{$vboptions['menu_item_two']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_three']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_three']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_three_colour']}"></if>{$vboptions['menu_item_three']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_four']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_four']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_four_colour']}"></if>{$vboptions['menu_item_four']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_five']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_five']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_five_colour']}"></if>{$vboptions['menu_item_five']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_six']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_six']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_six_colour']}"></if>{$vboptions['menu_item_six']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_seven']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_seven']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_seven_colour']}"></if>{$vboptions['menu_item_seven']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_eight']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_eight']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_eight_colour']}"></if>{$vboptions['menu_item_eight']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td>
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_nine']}">
<if condition="$vboptions[menu_image_switch]"><img border="0" src="{$vboptions['menu_image_nine']}"> </if><if condition="$vboptions[menu_colour_switch]"><font color="#{$vboptions['menu_item_nine_colour']}"></if>{$vboptions['menu_item_nine']}<if condition="$vboptions[menu_colour_switch]"></font></if></a></td></if>
</tr>
</table>
</div>
<!-- / #End Menu Control - Version 1.3 Final -->

optrex
28 Aug 2006, 21:59
Headshotx, If you right click on the image and go to properties - what is the address?

Gnappy
29 Aug 2006, 00:19
thanks, for me is useful ^^

headshotx
29 Aug 2006, 05:06
Headshotx, If you right click on the image and go to properties - what is the address?

This :

http://img176.imageshack.us/img176/552/dibujotl5.jpg

:( =(

optrex
30 Aug 2006, 09:18
Do you have images turned on? If so turn them off.

optrex
30 Aug 2006, 09:23
If turning off images does not work then do the following:

Turn on images
in the image url type clear.gif

this will then use the default vB clear.gif in the image position.

mikephung
30 Aug 2006, 22:14
Hello,
I have installed, and find that is usefull for me,but i only want to have 5, or 6 links, how can i disable another ? In the attachment , i found that in your Menu Controll Setting ,there a two button at every link-settings, there're "Edit" and "Delete" , so how can i enable them,
So please help me to solve this problem
thank in advance,
regard,
mike

Marky
31 Aug 2006, 08:56
Hello,
I have installed, and find that is usefull for me,but i only want to have 5, or 6 links, how can i disable another ? In the attachment , i found that in your Menu Controll Setting ,there a two button at every link-settings, there're "Edit" and "Delete" , so how can i enable them,
So please help me to solve this problem
thank in advance,
regard,
mike
The Edit and Delete links were for development purposes. To only have 5 or 6 links showing just don't add anything in the other links. The showing links will centralise.

optrex
31 Aug 2006, 15:56
Marky,

How would I go about installing a 2nd menu control? I think I would move the $menucontrol and $menucontrol2 to the header template to avoid confusion with the main forum navigation, but what would I need to change in the xml file to create a seamless 2nd navigation bar?

mikephung
31 Aug 2006, 22:56
The Edit and Delete links were for development purposes. To only have 5 or 6 links showing just don't add anything in the other links. The showing links will centralise.
I have done like you showed, but the problem is not the showing links, that's image, i added the link and the image, so not the name, because itīs okay so, but when i have only 6 image, and i want to display them completely , full on the menu (it mean that i want to split in 6 equal partition ), itīs impossible ,
i tried to edit the xml file with 6 link only, it didn't work,
So please show me as possible , if i can make it in 6 equal partition with 6 image
Big thanks for your support,
regard,
Mike

G_Man
01 Sep 2006, 03:01
I put $menucontrol in my footer at the very bottom. Using for Links to other sites and working beautifully.

Cheers!!!

Marky
01 Sep 2006, 21:05
Marky,

How would I go about installing a 2nd menu control? I think I would move the $menucontrol and $menucontrol2 to the header template to avoid confusion with the main forum navigation, but what would I need to change in the xml file to create a seamless 2nd navigation bar?
Yeah you'd need to edit the xml file. If you wish, I'll build a new .xml file so you can add an additional Menu Control? Just say you want it, and I'll get started.

I have done like you showed, but the problem is not the showing links, that's image, i added the link and the image, so not the name, because itīs okay so, but when i have only 6 image, and i want to display them completely , full on the menu (it mean that i want to split in 6 equal partition ), itīs impossible ,
i tried to edit the xml file with 6 link only, it didn't work,
So please show me as possible , if i can make it in 6 equal partition with 6 image
Big thanks for your support,
regard,
Mike

Do you mean you just want 6 images as links? And you mean that you want them spread out?

I put $menucontrol in my footer at the very bottom. Using for Links to other sites and working beautifully.

Cheers!!!

Glad you like it :) Thanks ^^

Mr Peabody
02 Sep 2006, 05:48
Just 1 suggestion.
Would be great if you could set individual for the way it opens links in windows. It wouls be handy for things like flash chat where its better if it pops up into a new window.
Cheers
:)

mikephung
02 Sep 2006, 09:20
Do you mean you just want 6 images as links? And you mean that you want them spread out?

Yes, i'd like to spread them out, only 6 image not more ,not less.
Can you please customize it for me , or show me how to do that?
thanks you very much,
best regards,
Mike

jw00dy
02 Sep 2006, 10:35
Having a second menu would be very cool. Then I could make it different then the one I have now and put it at the bottom.

optrex
02 Sep 2006, 12:10
Yeah you'd need to edit the xml file. If you wish, I'll build a new .xml file so you can add an additional Menu Control? Just say you want it, and I'll get started.


YES yes yes, please :laugh:

Marky
02 Sep 2006, 17:55
Just 1 suggestion.
Would be great if you could set individual for the way it opens links in windows. It wouls be handy for things like flash chat where its better if it pops up into a new window.
Cheers
:)
I've already coded this into the next version and so it will 100% be there when it's released ;)

---

Yes, i'd like to spread them out, only 6 image not more ,not less.
Can you please customize it for me , or show me how to do that?
thanks you very much,
best regards,
Mike

Okey sure, I get where your coming from. Unfortunatly, I have no free time today, but I'll edit the xml file for you and hopefully reply with the attachment tommorow :)

Having a second menu would be very cool. Then I could make it different then the one I have now and put it at the bottom.

YES yes yes, please

As with the above message, I'll code it for you and hopefully have it done by tommorow complete with instructions ;)

*Runs off to work some more*

jw00dy
02 Sep 2006, 21:31
Thanks Marky. Your help is really appreciated.

adwade
03 Sep 2006, 19:52
I've already coded this into the next version and so it will 100% be there when it's released ;)


I notice Is in Beta stage is still indicated. I've been watching/waiting to try this mod over the past month. Any idea when it'll be released as a non-beta product? S-W-E-E-T MOD by the way!

optrex
03 Sep 2006, 19:59
I think it maybe an oversight, but the next upgrade is due over the next 24 hours, thansk to Marky and his committment ;)

Marky
03 Sep 2006, 23:09
Sorry for the delay but I was called to go into work today and so didnt have time. Tommorow I don't have too much time but I'll try my best. Sorry if you're disappointed.
And on the beta stage thing, next version it should be out of beta - which wont be long at all ;)

adwade
03 Sep 2006, 23:23
Tommorow I don't have too much time but I'll try my best.
And on the beta stage thing, next version it should be out of beta - which wont be long at all ;)
That's fine, take-your-time. I'm sure everyone would rather have it right vs. quick!:D I was just wondering how close it was getting to an official product release, and out of the beta stage. I KNOW I'll be D/L'ing & Installing once it's finally ready. Many Thanxx for all your work on this! SUPER MOD

DrJot
08 Sep 2006, 11:09
Nice one, just Installed!

And i am very happy now:) Thanks!

:)

spazz191
12 Sep 2006, 01:30
Marky,
I have to say that this is one of my favorite add-ons. I DO have question though, I use the VBImageHost add-on...is there a way to add the link into this add-on. I only ask because VBImageHost uses drop menus.

optrex
12 Sep 2006, 21:34
Any update on the 2nd menu Marky?

LBSources
12 Sep 2006, 22:50
If turning off images does not work then do the following:

Turn on images
in the image url type clear.gif

this will then use the default vB clear.gif in the image position.Thanks.. that did the trick for me..

RichieBoy67
15 Sep 2006, 02:14
I have it installed and working perfectly but I am trying to add sme dropdowns. I installed a popup and that worked fine but I cannot get this dropdown to work...

Can anyone help??

It is for the imagehosting mod... Here is the code..


<td id="vbimghost" class="vbmenu_control"><a href="#vbimghost" >$vbphrase[vbimghost_title]</a>
<script type="text/javascript"> vbmenu_register("vbimghost");</script></td>




<div class="vbmenu_popup" id="vbimghost_menu" style="display:none">
<table cellpadding="4" cellspacing="1" border="0">

<tr><td class="thead">$vbphrase[vbimghost_title]</td></tr>
<tr><td class="vbmenu_option"><a href="$vboptions[bburl]/vbimghost.php?do=myimages">$vbphrase[vbimghost_menushimg]</a></td></tr>
<tr><td class="vbmenu_option"><a href="$vboptions[bburl]/vbimghost.php?do=upload">$vbphrase[vbimghost_menuupimg]</a></td></tr>
<tr><td class="vbmenu_option"><a href="$vboptions[bburl]/vbimghost.php?do=userlist">$vbphrase[vbimghost_menulistuser]</a></td></tr>
</table>
</div>
<!-- / Image Host Popup -->


Thanks :)

harmor19
15 Sep 2006, 05:08
I have some suggestion but I'm going to limit them because I have a similar hack.

Don't limit the administrator to only nine links. You could debate that it would stretch the navbar but that's where my second suggestion comes in.
When the admin has 10 links it'll automatically create a new navbar and start another list of links.

optrex
15 Sep 2006, 09:22
I'm hoping thats what is keeping Marky quiet this last week or so - lol

Reece^B
20 Sep 2006, 09:38
Spoke to Marky the other night, his been busy.
But I don't think this works with 3.6.1 as it's not working on mine.

Reece

optrex
20 Sep 2006, 11:27
works ok for me on 3.6.1 but then mine is in the header !!!

this gives me many positives.

It works with vba and galleries
I dont get it dissapearing on certain pages
It keeps my additional links away from my forum navigation links

Reece^B
20 Sep 2006, 17:47
I think its time I have another Look.
There must jsut be a small error somewhere.

jw00dy
20 Sep 2006, 18:12
Works fine on my 3.6.1 version as well.

Reece^B
22 Sep 2006, 01:47
This is annoying now, even added a new style and it still wont show. *Calls Marky* ;)

optrex
22 Sep 2006, 09:34
Just to check you have the coding right, drop

$menucontrol

in the header to see if that shows. Might point you in a different direction depending onthe results.

Reece^B
22 Sep 2006, 11:09
Nope I dont get nothing even when I add that. I have no idea what happend to it. Mystery.

optrex
22 Sep 2006, 11:13
odd. try disabling your other plugins to see if thre may be a conflict.

Reece^B
22 Sep 2006, 11:16
Good idea. Report back in a mo.

Reece^B
22 Sep 2006, 11:27
No Joy, included some screenies.

optrex
22 Sep 2006, 11:43
the screenshot shows vba, shoutbox and thumbs - you sure you turned everything off?

Re-upload the xml with overwrite on and move add antoher $menucontrol to the last line in your header, see where that gets you.

Reece^B
22 Sep 2006, 11:59
That screen shot was after i turnt them all back on.
I have rewrite the XML with overwrite on. Il try the last line, but cant see it doing anything.

optrex
22 Sep 2006, 12:01
did you revert ALL your templates for the 3.6.1 upgrade?

Reece^B
22 Sep 2006, 12:04
I dont think so, however I was using a different style when I upgraded. Then I decided to go back to the default.

optrex
22 Sep 2006, 12:05
I would recommend doing that first - there were a number of changes. Check the versions when you do it so that you can copy your mods across to the newer template.

Reece^B
22 Sep 2006, 12:07
But I did add a new style. Wouldnt that have fixed that problem. It still didnt show on that though.

Emanet-Kaos
23 Sep 2006, 06:12
my forum aint live yet but it will be next week, thanks marky !

Viceroy
24 Sep 2006, 21:49
Is one being created for 3.6.1 or will this work on 3.6.1? Thanks!

jw00dy
25 Sep 2006, 02:31
It's working on my 3.6.1, but I've had it installed since 3.5.3, and it's just upgraded along with me.

optrex
25 Sep 2006, 09:10
Is one being created for 3.6.1 or will this work on 3.6.1? Thanks!

It will work on 3.6.1 as long as you revert the templates properly. However, I found a fairly simple way of creating a third navbar in the end by looking at the navbar template.

Just look at whats inbetween the <!-- nav buttons bar --> comments - its fairly easy to work out. The results can be seen by following my sig.

Reece^B
25 Sep 2006, 17:46
Optrex's Hack is great. Thanks man, I will be using that now.

fringehead
25 Sep 2006, 23:27
I use embedded gallery and the menu breaks my gallery. I had to edit the navbar for my gallery to work properly by placing this before each link:
$vboptions[bburl]/

Here is a sample link from the your template:

<tr align="center"><if condition="$vboptions[menu_status]">
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_one']}">


How would I add this prefix to each link? I have tried adding it but get a template error... Any help would be appreciated!

Thanks,

Sean

fringehead
26 Sep 2006, 00:11
If I can't modify this to work, is there anyway to NOT show the menu on my gallery?

Thanks,

Sean

optrex
26 Sep 2006, 09:06
I use embedded gallery and the menu breaks my gallery. I had to edit the navbar for my gallery to work properly by placing this before each link:
$vboptions[bburl]/

Here is a sample link from the your template:

<tr align="center"><if condition="$vboptions[menu_status]">
<td class="vbmenu_control"><a target="{$vboptions['menu_window']}" href="http://{$vboptions['menu_link_one']}">


How would I add this prefix to each link? I have tried adding it but get a template error... Any help would be appreciated!

Thanks,

Sean

instead of using index.php, for instance as a link address in menu control, use www.yoururl.com/index.php

that surely does just the same as manually adding [bburl] in the template.

Neal-UK
26 Sep 2006, 09:40
Will there be an update so that you can add a second navbar? I've filled all nine spaces ;-(

morrow
29 Sep 2006, 11:58
Nice hack. Can't seem to get it working with VBA though.

Neal-UK
29 Sep 2006, 12:39
Nice hack. Can't seem to get it working with VBA though.

Place it in the header template

morrow
02 Oct 2006, 03:42
Place it in the header template
Tried that, but I can't get it to display directly under the present nav bar. it displays above the welcome box and there is a space in between the welcome box and the menu.

dupont24
05 Oct 2006, 01:07
Marky,

How would I go about installing a 2nd menu control? I think I would move the $menucontrol and $menucontrol2 to the header template to avoid confusion with the main forum navigation, but what would I need to change in the xml file to create a seamless 2nd navigation bar?


Any word.....I would really appreciate a second menu control...:)

optrex
05 Oct 2006, 10:40
Nothing seems to have come from this for ages. I ended up creating my own - see sig ;)

KevNJ
07 Oct 2006, 23:34
* installs *

* click install *

flawless!

Draygonia
08 Oct 2006, 23:31
Does this work on 3.6.2?

optrex
09 Oct 2006, 09:42
yes it does, the only known issues are with plugins such as vba and photoplog and also some parts of the forum such as "new posts" search, where it seems to disappear.

Draygonia
09 Oct 2006, 16:53
And those are the 2 products im getting :(

Is it a big issue? And does it work with the second navbar code I just put in?

KevNJ
11 Oct 2006, 00:59
I only have 4 extra links but it still shows 5 empty links as well as the 4 I want posted. Along with them not showing with vbgallery, groups, and other mods.

basskiller
11 Oct 2006, 21:11
I have it woking fine on 3.6.2
I do have a question though. I wanted to add all my ... lets say fun links to this navbar as too keep them seperated from the help/control navbar
http://www.worldclassbodybuilding.com/forums/
I have made my way around the sessions code in the Vbookie as to just be able to add the link.
But with the Mp3 player. It has a pop-up and just won't work without modifying the actual navbar code.

right now I have it in the primary navbar .. is there a way to make this happen?



I can not place this as a link through the admincp/ Menu Control Version 1.3 Settings
<!-- vbMp3 Player Start -->
<script type="text/javascript">
<!--

function OpeniPod(){
iPod = window.open('ipod.htm','iPod','directories=no,height=430,width=190,location=no,m enubar=no,resizable=no,status=no,toolbar=no')

return false;
}

-->
</script>
<td class="vbmenu_control"><a href="#" onclick="return OpeniPod()">vbPlayer</a></td>
<!-- vbMp3 Player End -->

optrex
11 Oct 2006, 22:07
I'm not sure where marky has gone with regards to supporting this. He would be able to help you more. I imagine the link does nto work due to the lack handling of Javascript coding from menu control. Is the # the actual url or just there as an example?

If it is needed, the # charater may not be recognised either. But have you tried putting it in as www.forumurl/# rather than just #

alternatively you'd need to look at adding a multiple menu.

KevNJ
12 Oct 2006, 02:53
*uninstalls due to not working with some mods/hacks*

*install optrex mutple menu's*

basskiller
13 Oct 2006, 00:44
*uninstalls due to not working with some mods/hacks*

*install optrex mutple menu's*
I'm thinking I'll follow your lead.

Very simple yet very effective mod
Thanks optrex,
bass

NFLfbJunkie
15 Oct 2006, 03:11
I have installed this MOD but I am having problems with the top menu border (see attachment). The top menu's border has no border and the bottom one is thicker the the normal thin border. I can't figure out how to fix.

optrex
16 Oct 2006, 10:14
With Menu Control, this is due to the fact that the program was designed to be placed in a certain position on your nav bar, therefore the box was given no border at the top, and a border at the bottom. Here this is emphasised by you seeing this output when positioned differently.

NFLfbJunkie
16 Oct 2006, 19:04
But how can I fix the border? I already figure out how to put the top border (changing a 'px0' value to 'px1' in the navbar template. But I still have the double line border on the bottom of the top navigtion bar.

optrex
16 Oct 2006, 21:09
create a line bottom border px0 at a guess.

NFLfbJunkie
16 Oct 2006, 21:15
Any idea where I would create / find where to put this and what the code should be?

optrex
16 Oct 2006, 21:24
Not really, you could try just on the same line as the top border bit

NFLfbJunkie
16 Oct 2006, 21:26
I figured it out. This is the beginning code that I have:

<!-- Menu Control - Version 1.3 Final -->
<div align="center">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="0" border="0" width="100%" align="center" style="border-top-width:1px">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="0" border="0" width="100%" align="center" style="border-bottom-width:0px">

optrex
16 Oct 2006, 21:31
I figured it out. This is the beginning code that I have:

<!-- Menu Control - Version 1.3 Final -->
<div align="center">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="0" border="0" width="100%" align="center" style="border-top-width:1px" style="border-bottom-width:0px">


Shouldn't need it twice. This should tidy things up

NFLfbJunkie
16 Oct 2006, 21:37
I tried that and it centered everything on the page.

NFLfbJunkie
16 Oct 2006, 21:41
Tried it again; now it works. Thanks Optrex.

ccmoon
04 Nov 2006, 02:32
Hi Mark, How do I make the 10th link? I saw only 9 in this mod.
Thanks

LaCN
05 Nov 2006, 20:01
It's nice, but it's stuck to my Calender menu-option... :(
Can't I place some $var on the spot where I want my dropdown menu ?
Because my menu-options differ per usergroup.

And some space between the image and the text would be nice, for next version :)

dcasux
24 Nov 2006, 23:53
Everything is working fine for me with the exception of ibProArcade.

How can I get this to work?

I added $menucontrol under $navbar in the ARCADE template, but the variable must not be defined once entering the arcade code.

Anyone have any thoughts?

optrex
25 Nov 2006, 19:38
you could try moving it to your header, but there are known bugs with some pages and plugins.

dcasux
08 Dec 2006, 02:32
From the lack of replies from the coder, I'm assuming this product will not be updated or supported any longer?:tired:

Uninstalled

Marky
30 Dec 2006, 12:10
From the lack of replies from the coder, I'm assuming this product will not be updated or supported any longer?:tired:

Uninstalled
Please read this post:
http://www.vbulletin.org/forum/showpost.php?p=1147444&postcount=53

I appologise again, but Im unable to continue production until I get a new licence. I will post once production is continued :)

JAYEMULE
28 Jan 2007, 02:31
Oh glad I found this :) I had it a while back on an older vb version and have missed it. I will give it another go.
Thanks :)

efil
21 Feb 2007, 22:31
Found a fast way to add the menu to vbadvanced page.

In Portal Output Global Variables add this:

menucontrol

Hi,
It's not working for me.

optrex
22 Feb 2007, 10:52
Marky is not able to support atm, whats wrong?

rezapci
28 Feb 2007, 05:28
any update for this version?

Mupetz
08 Jun 2007, 20:47
Well, anyone made it work with ibpproarcade?

optrex
15 Jun 2007, 10:46
Don't think so. Its also not supported atm, so no chance of development. Best to hardcode, see sig for details

Marky
24 Oct 2007, 22:27
Support for this modification has now resumed. Appologises for the lack of support. I have now returned, since I have a vBulletin licence!

Version 1.4 will continue development - any suggestions or bugs you find, please post them ASAP so I can finish it off :)

Coleccromos
24 Oct 2007, 22:48
Thank you for this idea clik install

shadowevil
14 Jun 2008, 14:31
Does this work with 3.7.1 ??

SnapOff Racing
15 Jun 2008, 07:26
Does this work with 3.7.1 ??

I'm using the old version that is on THIS PAGE (http://www.vbulletin.org/forum/showthread.php?t=104725) with 3.7.1 and it works fine. I just ran across this version and I can't figure out what's the difference. But in any case that old version works fine on 3.7.1 I dunno about this version though. Looks like support kinda died off on this version :confused:

nanaimobar
06 Dec 2008, 04:56
How do I make the text in the menu links larger? I looked at mod using the product manager but didn't see any coding for text size.
PS: Marky, glad to see you're working on an update as I really like this mod and am using it on latest version.

JimR
20 Feb 2009, 19:03
Does this version support relative links somehow? I really dislike absolute urls, although I realize that they let you create links to outside websites.

Was this a trade-off decision made in the past at some point? I remember a much older version that had relative links... and only that.

I have edited the menucontrol template, removing all the 'http://' additions it makes to the links. This allows me to use relative and absolute links. I haven't found any tradeoffs either. Comments welcome!