PDA

View Full Version : Add-On Releases - Subscribed/Favorite Forums Module [vba CMPS module]


Skedoozy
02 Oct 2006, 22:19
I got tired of hoping someone would make this one and made it myself.

This was done on vBa CMPS v2.2.0 & Vb 3.6.1 but it should work with at least Vb 3.5.4 and above.

Subscribed/Favorite Forums Module 1.0 For vBa CMPS by Skedoozy (http://www.altign.com)

Installation Instructions

1. Upload favoriteblock.php to you /modules directory.

2. Create a new template. In your admin cp go to Styles & Templates > Style Manager > Add New Template. Name the template "adv_portal_fav" and paste the following in to it.

<tr align="center" valign="bottom">
<td class="thead" width="2%">&nbsp;</td>
<td class="thead" align="$stylevar[left]" width="80%">$vbphrase[forum]</td>
<td class="thead">$vbphrase[last_post]</td>
<td class="thead">$vbphrase[threads]</td>
<td class="thead">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead" width="20%">$vbphrase[moderator]</td>
</if>
</tr>
$forumbits
<br />
3. Goto your vBa CMPS > Add Module > phpfile

Module Title: Favorite Boards(or Subscribed Boards if you prefer)
Column: Center
Display Order: Where you want it to display
Active: Yes
Update All Pages: Yes
File to Include: favoriteblock.php
Module Parent: none
Identifier: fav
Templates Used: adv_portal_fav
Clean File Output: No
Use Module Shell Template: Yes. Leave rest of settings to default and set your usergroups how you want.

4. Save. You are done.

dragonhart
02 Oct 2006, 22:48
Sweet...........thank you......Dragonhart

memomemo
02 Oct 2006, 23:08
Sir favorite forum empty.

Please help

https://www.vbulletin.org/forum/ (http://www.yuklerim.com/)

Lionel
03 Oct 2006, 06:33
does not work for me. I have forums under root e.g. site.com/forums/ and all links are pointing to site.com/showthread.php etc... plus javascripts errors too

Skedoozy
04 Oct 2006, 11:23
Sir favorite forum empty.

Please help

http://www.yuklerim.com/uploads/04bd309531.jpg (http://www.yuklerim.com/)

Do you have any subscribed forums added?

Skedoozy
04 Oct 2006, 11:29
does not work for me. I have forums under root e.g. site.com/forums/ and all links are pointing to site.com/showthread.php etc... plus javascripts errors too

My forums are under root.. ie .com/showthread.php

Change the following line in favoriteblock.php

require_once('./includes/functions_user.php');

to

require_once('./forums/includes/functions_user.php');

That is the only link that is coded at all. The rest of the links are pulled from your own settings.

Don't understand the javascript error as there is no java involved at all.

Floris
04 Oct 2006, 11:56
I was working on this yesterday for a vb customer :) And now I can just get it from here: even better! Thanks for the hard work and for sharing. Nice stuff

memomemo
04 Oct 2006, 23:03
Yes I am an many subscribed forums added


http://www.forumsitesi.info/forum/index.php

center last of all


Do you have any subscribed forums added?

Skedoozy
04 Oct 2006, 23:07
I'm not sure what it could be then unless your functions_user.php file is eleswhere then indicated in the favoriteblock.php.

memomemo
04 Oct 2006, 23:16
I'm not sure what it could be then unless your functions_user.php file is eleswhere then indicated in the favoriteblock.php.
require_once('./includes/functions_user.php'); = Ok but thread empty

require_once('./upload/includes/functions_user.php'); = page empty

require_once('../includes/functions_user.php'); = page empty

memomemo
04 Oct 2006, 23:18
HImm sory
This hack for subscripton.

Ok working.
Thank you.

memomemo
04 Oct 2006, 23:23
Sir this hack activite but javascript error line : 2045?

I am subscribed forums added. After page refresh javascript error.

Skedoozy
07 Oct 2006, 01:25
I don't understand the javascrit error as it contains no javascript in any of it.

DivisionByZero
22 Oct 2006, 01:23
pure junk... lousy coder... omits SEVERAL E_NOTICE's

Skedoozy
22 Oct 2006, 01:52
Thanks.. ;)

JohnBee
04 Sep 2007, 16:36
Very exciting hack!

I installed it and got it working, however I found an interesting side effect :)
Whenever I place it above or bellow my center column(above my forums) the moment I add(subscribe) a forum to the container, all of my remaining forums compact as though my "Depth of Forums - Forum Home" settings are set to 0

Any ideas what would cause this?
Better yet, could you have a look at it and let me know what might be causing this?

Running on a default vb, fresh out of the box.

suewh
23 Dec 2007, 21:49
Worked perfectly :)

trigatch4
13 Apr 2008, 16:25
Trying to accomplish this EXACT thing but don't have vBadvanced CMPS or whatever and I'm running vB 3.7... is it possible? If anyone can help I'd be unbelievably grateful.