PDA

View Full Version : New Posting Features - GTSmiliebox - Move Smilies Below Editor


Princeton
17 Oct 2006, 12:28
NEW 1.1.0 VERSION (product-gtsmiliebox.xml)

No edits are necessary. If upgrading from a previous version you can revert the "editor_toolbar_on" and "editor_smiliebox" template.

Custom modification brought to you by Joe Velez (aka Princeton vbulletin.org Admin).

Please support by donating, "Mark As Installed", and/or "Nominate for MOTM".

Sites with a lot of simlies and fixed-width layouts occasionally run into the "smilie-box-stretch-outside-box" problem.

View attachment image to see what I mean.

Instructions:

* Upload product-gtsmiliebox.xml via Plugins & Products Manager and you are done.

You may also be interested in:
GTQuotes - A Custom bbcode_quote Template (as seen on vbulletin.org) (http://www.vbulletin.org/forum/showthread.php?t=170348)
Enhanced USERCP Interface (http://www.vbulletin.org/forum/showthread.php?t=136321)
GTPrivate Message Quickreply (http://www.vbulletin.org/forum/showthread.php?p=1341037#post1341037)
Custom Sig Permissions (http://www.vbulletin.org/forum/showthread.php?t=133834)
Rules Near Editor (http://www.vbulletin.org/forum/showthread.php?t=129349)
Smiliebox Below Editor (http://www.vbulletin.org/forum/showthread.php?t=129306)
Moderated Members Tagged (http://www.vbulletin.org/forum/showthread.php?t=156720)To change editor width:
http://vbulletin.com/docs/html/main/stylevar_formwidth (form width)
http://vbulletin.com/docs/html/main/...r_messagewidth (http://vbulletin.com/docs/html/main/stylevar_messagewidth) (message width)

http://vbulletin.com/docs/html/main/...rmwidth_usercp (http://vbulletin.com/docs/html/main/stylevar_formwidth_usercp) (usercp form width)
http://vbulletin.com/docs/html/main/...gewidth_usercp (http://vbulletin.com/docs/html/main/stylevar_messagewidth_usercp) (usercp message width)

shadowevil
17 Oct 2006, 13:12
first post ... *installed*

beduino
17 Oct 2006, 14:46
Hello,
this is a very useful mod!
tks
b.

bandare
17 Oct 2006, 14:51
brilliant hack. Really has cleaned up my site a lot - thanks - working great!

OziloZ
17 Oct 2006, 16:08
good job :up:

nymyth
17 Oct 2006, 16:38
doesnt seem to work properly with the "fav. smileys hack".....it still appears as a square box underneath the reply box.....any ideas?

Peace

Jay...
17 Oct 2006, 16:45
yeah how can i lay the smilies out like in your first attachment? its still shows the smilies in a box below the post editor like this attachment

Princeton
17 Oct 2006, 21:48
go to ADMINCP / vBulletin OPTIONS / Message Posting Interface Options

change Smiliebox Smilies Per Row

Tulsa
18 Oct 2006, 03:15
Well, I love this hack. :cool:

Veer
18 Oct 2006, 09:08
Thanks, Installed.

ChurchMedia
18 Oct 2006, 19:46
Very cool! Thanks!

Stromba
19 Oct 2006, 01:28
Verry nice, thanks Princeton

Ev!L ErN!E
20 Oct 2006, 11:14
ok where do you find this:

OPTIONAL
This template edit moves the "More" link.
REPLACE editor_smilibox TEMPLATE WITH:

piratelady
21 Oct 2006, 15:32
Nice! Any idea how to make this work in the Quick Reply box as well?

Thanks!

mholtum
21 Oct 2006, 16:41
This is great! Thank you so much.

twincamfxd
01 Nov 2006, 06:33
Very clean looking, Thanks!!!!!

*clicks install

Smoothie
11 Nov 2006, 16:30
Good! Installed.

silent shadow
24 Nov 2006, 19:53
Thanx for the mod....

quick question.

is it possible to do the same and add a smilie box to the left or right hand side at the quickreply box?


Ive seen it on older versions of vb.....thought id ask :)

sunnycher
26 Nov 2006, 14:16
Installed!! Thank you!!

maxicep
27 Nov 2006, 12:34
thanks installed.

Natalie@Club
28 Nov 2006, 10:51
Excellent hack, thank you very much :D

Purple Weeble
04 Dec 2006, 05:51
Will this work with 3.6.4?

Sorry if dumb question...this is all new to me.

Princeton
04 Dec 2006, 12:15
yes it does :)

cagefighter
06 Jan 2007, 03:07
I got smilies to go to the bottom, but how do I get them to go away from the right side. I got them both places now.

cagefighter
06 Jan 2007, 05:34
nevermind fixed it

Princeton
06 Jan 2007, 14:26
thanks for the update :up:

glad you got it working

marcsmith73
12 Jan 2007, 00:24
It's working, but I am getting a double smile box in my replys.

Princeton
12 Jan 2007, 18:29
go over the instructions again ... you probably ADDED instead of REPLACE

ubblite
13 Jan 2007, 07:08
Last Update: 07. Jan 2007

What changed?

Biek
20 Jan 2007, 11:19
Very nice, it's one of those things you don't miss until someone invents it. Good job!

voter
21 Jan 2007, 16:16
You can have smilies above textbox when use


<if condition="$smiliebox">
<tr>
<td class="controlbar">$smiliebox</td></td>
</tr>
</if>
<tr valign="top">
<td class="controlbar"><textarea name="message" id="{$editorid}_textarea" rows="10" cols="60" style="width:$stylevar[messagewidth]; height:{$editor_height}px" tabindex="1" dir="$stylevar[textdirection]">$newpost[message]</textarea></td>
</tr>

PoetJA-1975
21 Jan 2007, 17:35
Great share Princeton - Thanx!

Jacquii.

Shazz
28 Jan 2007, 16:30
thanx
/me installs

Nathan2006
01 Feb 2007, 09:47
Hi Princeton,

Thanks I really like this :)

Just one small problem I'm having is I have a large space on the right >>>>

Is there anyway of making the box centered?

Thanks again

Install :)

Princeton
01 Feb 2007, 12:28
edit your stylevars ... STYLE MANAGER / Stylevars

if that doesn't work post a screenshot / url

DementedMindz
01 Feb 2007, 14:06
Hi Princeton,

Thanks I really like this :)

Just one small problem I'm having is I have a large space on the right >>>>

Is there anyway of making the box centered?

Thanks again

Install :)

I have the same problem but its only on the private messages part where it shows a large space on the right its strange if you put it in dreamweaver it shows it as a iframe but if you look at the source there is no iframe. Princeton did you edit something to make it not show the large box on the private messages page?

DementedMindz
01 Feb 2007, 14:14
ok figured it out it was User Control Panel Message Area Width (pixels) in the STYLE MANAGER / Stylevars

DementedMindz
01 Feb 2007, 21:14
ok I found a bug. If you go to Edit Options (http://www.vbulletin.org/forum/profile.php?do=editoptions) in you usercp and your on Standard editor (Message Editor Interface). And then you go to private message someone and you click on Switch Editor Mode in a private message the box gets huge and if you click it again it does not go back to the original size. Its like it here too on vbulletin.org also.

Princeton
01 Feb 2007, 22:59
this mod shouldn't have an affect on anything as this is merely a table/row edit

post a screenshot ...
browser? version?
OS?

DementedMindz
01 Feb 2007, 23:08
you can test it out on this site right here just goto Edit Options in you usercp then chose Standard editor and once that is done go to compose a message in private messages or go to send one and click on Switch Editor Mode and it will do the same on this site right here too. it happens on ie and firefox.

Princeton
01 Feb 2007, 23:12
nothing happens ... tested on IE 7 and Firefox

please post screenshots

DementedMindz
01 Feb 2007, 23:14
Here is a screen shot of vbulletin.org private message area on firefox its horrible but on ie it only has about a inch extra on the side.

59891

Nathan2006
02 Feb 2007, 08:16
edit your stylevars ... STYLE MANAGER / Stylevars

if that doesn't work post a screenshot / url

Thank you Princeton all working great now :)

Here is a screen shot of vbulletin.org private message area on firefox its horrible but on ie it only has about a inch extra on the side.

59891


I worked it out lol

I had the same problem with the pm box :D

As Princeton said go to "Style Manager" > Stylevars > then change the sizes in the
boxes (Screenshot Added) ;)

ahmee4
03 Feb 2007, 19:55
very nice.. thanks :)

Quantnet
10 Feb 2007, 07:20
This is awesome. click installed

Would you be able to add a row of smilies on Quick Reply box, above your Posting Rules ?

Princeton
10 Feb 2007, 16:18
LOL ... that's a totally different mod

it may already be available - not sure ... have you done a search?

Quantnet
10 Feb 2007, 17:28
I was under the impression that you left out the smilies change to Quick Edit. You have Rules Near Editor (applied to all editor box ) and GTSmilies (applied to all editor except Quick Reply)

I have seen drop down Smilies box on Quick Edit mod before but they are not as nearly nice as yours. Also, it requires you to click on drop down menu and choose one at at time. Not nearly as efficient.

I have even tried this myself by

FIND IN editor_toolbar_on:

<if condition="THIS_SCRIPT!='profile'">
<div class="smallfont" align="center"><strong>$vbphrase[posting_rules]</strong>:
<phrase 1="misc.php?$session[sessionurl]do=bbcode" 2="$bbcodeon">$vbphrase[vb_code_is_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=showsmilies" 2="$smilieson">$vbphrase[smilies_are_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=bbcode#imgcode" 2="$imgcodeon">$vbphrase[img_code_is_x]</phrase>,
<phrase 1="$htmlcodeon">$vbphrase[html_code_is_x]</phrase>
</div>
</if>
<input type="hidden" name="wysiwyg" id="{$editorid}_mode" value="$editortype" />

ADD BEFORE

<tr>
<td class="controlbar">$smiliebox</td></td>
</tr>


But obviously, it does not work...

GPS_Flex
10 Feb 2007, 20:53
Very nice. It solved the problem I was having and made thinks a little more user friendly. Awsome mod.

Princeton
12 Feb 2007, 17:01
I was under the impression that you left out the smilies change to Quick Edit. You have Rules Near Editor (applied to all editor box ) and GTSmilies (applied to all editor except Quick Reply)

I have seen drop down Smilies box on Quick Edit mod before but they are not as nearly nice as yours. Also, it requires you to click on drop down menu and choose one at at time. Not nearly as efficient.

I have even tried this myself by

FIND IN editor_toolbar_on:

<if condition="THIS_SCRIPT!='profile'">
<div class="smallfont" align="center"><strong>$vbphrase[posting_rules]</strong>:
<phrase 1="misc.php?$session[sessionurl]do=bbcode" 2="$bbcodeon">$vbphrase[vb_code_is_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=showsmilies" 2="$smilieson">$vbphrase[smilies_are_x]</phrase>,
<phrase 1="misc.php?$session[sessionurl]do=bbcode#imgcode" 2="$imgcodeon">$vbphrase[img_code_is_x]</phrase>,
<phrase 1="$htmlcodeon">$vbphrase[html_code_is_x]</phrase>
</div>
</if>
<input type="hidden" name="wysiwyg" id="{$editorid}_mode" value="$editortype" />

ADD BEFORE

<tr>
<td class="controlbar">$smiliebox</td></td>
</tr>


But obviously, it does not work...
that's a totally different modification

You could always place a request in the Modification Not Available? forum.

Sofia
13 Feb 2007, 08:14
Thanks for this modification :)

rolfw1
13 Feb 2007, 21:46
Thanks Princeton, nice mod. :)

dbirosel
20 Feb 2007, 22:25
I love this mod... but theres a problem. My Smilies are acting like columns, not rows. I wanted 2 rows but it became vertical and now its 2 columns. My forum totally stretched.

Would you want me to post a SShot?

Princeton
20 Feb 2007, 22:27
Edit your vboptions / Message Posting Interface Options to change the number of smilies displayed per row.

dbirosel
20 Feb 2007, 22:32
I did... it was default at 3 and changed it at 2. but its not rows. It's like vertical rows. Let me get SShot.

dbirosel
20 Feb 2007, 22:34
Here's how it looks like:

http://img513.imageshack.us/img513/4041/verticalsmiliesyn2.jpg (http://imageshack.us)


And also is it possible to place the POST ICONS on the right side?

GeekDrew
20 Feb 2007, 22:38
What you did was decrease the default 3 columns to 2 columns. You want to *increase* that number to however many columns you want, and it will calculate the number of rows automatically.

dbirosel
20 Feb 2007, 22:55
What you did was decrease the default 3 columns to 2 columns. You want to *increase* that number to however many columns you want, and it will calculate the number of rows automatically.
Ahh I see how it is now.. thanks alot!!

Hopefully someone creates a similar mod for the quick reply!

Princeton
21 Feb 2007, 12:17
thank GeekDrew ... appreciate the help :up:

Quantnet
21 Feb 2007, 22:16
Hopefully someone creates a similar mod for the quick reply!
I hope so. I did ask Princeton but he said we need to request it as it's a different mod.

rjmjr69
25 Feb 2007, 12:14
Nice installed.

Princeton
27 Feb 2007, 13:56
I hope so. I did ask Princeton but he said we need to request it as it's a different mod.
Have you placed a request in the "MODIFICATION NOT AVAILABLE" forum?
.. it may get done if you do.

Personally, I don't like the idea.

ahmednadir
27 Feb 2007, 21:02
great MOD
thanks a dozen
INSTALLED

RedGTiVR6
03 Mar 2007, 02:34
installed!

thanks a million!

mamashid
22 Mar 2007, 04:35
Nice, thanks!!!

fox3nova
23 Mar 2007, 22:28
great, I just need it .

topten
09 Apr 2007, 02:40
thanks mate!

rickyreter
09 Apr 2007, 06:15
Great have installed:)

htdesignz
09 Apr 2007, 17:07
very cool !!! Thanks so much :)

deezelpope
09 Apr 2007, 17:47
Beautiful and flawless! Thank you...was looking for this!!:up:

Dr.NoTime
09 Apr 2007, 18:57
Much better now! Thanks.

Muellmann
09 Apr 2007, 23:21
Thank you for this, you're awesome! :up:

AuroraStorm
10 Apr 2007, 12:55
It makes a big difference...thanks!

Daky
30 Apr 2007, 23:50
Very nice, i love it.

Thanks!

FIM
15 May 2007, 05:36
work in 3.6.5 nice thanks man

*installed*

Fungsten
25 May 2007, 21:25
On my test server.

bongwater
04 Jun 2007, 17:13
this is great. Now that the smileys moved from the right to the bottom, Im noticing some "available" space on the right where those smileys used to be.

Question -- I would like to insert google adsense code (skyscraper) in that area. Where in the template would the code be inserted?

Princeton
05 Jun 2007, 13:21
eeeek, bad idea
but you are free to edit the editor_toolbar_on and editor_toolbar_off templates until your hearts content

CMGU
15 Jun 2007, 15:57
thanks very nice

Shazz
15 Jun 2007, 16:08
5 Star rating :)

radarhunter
15 Jun 2007, 16:31
now this is the STATUS


after i`ve applied the hack provided by you :(

deezelpope
15 Jun 2007, 16:34
This is NOT the author's issue...it's yours...I told you to increase your number of smilies...I suggest you edit your above post.:mad:

radarhunter
15 Jun 2007, 16:41
i did the number from 100 to 30 the result is the same :mad:

deezelpope
15 Jun 2007, 16:43
Ok...how many TOTAL smilies do you have installed in your smilie manager?

radarhunter
15 Jun 2007, 16:47
okay there is my problem

Thanks a million Ma`am

deezelpope
15 Jun 2007, 16:59
https://www.vbulletin.org/forum/external/2007/06/17.gif

iogames
16 Jun 2007, 15:53
Ok I read the whole thread, maybe someone was having the same problem...
The hack works flawless, but when you remove the smilies-box from the right the whole Editor stays in the same place, I mean... I want/need it centered... I went to Styles manager > Stylevars and it's a different solution... I don't want to change the size of the editor or adjust it to the box...
Now that the smilies-box is in the bottom, the space used for it before make my whole editor be aligned a little to the left...

I was clear? [lol]

iogames
16 Jun 2007, 16:06
Maybe the problem will be here [somewhere ;)]

editor_clientscript template:

<!-- EDITOR SCRIPTS -->
<script type="text/javascript" src="clientscript/vbulletin_textedit.js?v=$vboptions[simpleversion]"></script>
<script type="text/javascript">
<!--
var fontoptions = new Array($vBeditJs[font_options_array]);
var sizeoptions = new Array($vBeditJs[size_options_array]);
var smilieoptions = new Array(); smilieoptions = { $vBeditJs[smilie_options_array] };

var istyles = new Array(); istyles = { $vBeditJs[istyle_array] };

var smiliewindow_x = 240;
var smiliewindow_y = 280;

var ignorequotechars = $vboptions[ignorequotechars];

// vB Phrases
vbphrase["wysiwyg_please_wait"] = "$vbphrase[wysiwyg_please_wait]";
vbphrase["wysiwyg_initialized"] = "$vbphrase[wysiwyg_initialized]";
vbphrase["wysiwyg_command_invalid"] = "$vbphrase[wysiwyg_command_invalid]";
vbphrase["moz_must_select_text"] = "$vbphrase[moz_must_select_text]";
vbphrase["moz_edit_config_file"] = "$vbphrase[moz_edit_config_file]";
vbphrase["enter_tag_option"] = "$vbphrase[enter_tag_option]";
vbphrase["must_select_text_to_use"] = "$vbphrase[must_select_text_to_use]";
vbphrase["browser_is_safari_no_wysiwyg"] = "$vbphrase[browser_is_safari_no_wysiwyg]";
vbphrase["enter_option_x_tag"] = "$vbphrase[enter_option_x_tag]";
vbphrase["enter_text_to_be_formatted"] = "$vbphrase[enter_text_to_be_formatted]";
vbphrase["enter_link_text"] = "$vbphrase[enter_link_text]";
vbphrase["enter_list_type"] = "$vbphrase[enter_list_type]";
vbphrase["enter_list_item"] = "$vbphrase[enter_list_item]";
vbphrase["must_enter_subject"] = "$vbphrase[must_enter_subject]";
vbphrase["message_too_short"] = "$vbphrase[message_too_short]";
vbphrase["enter_link_url"] = "$vbphrase[enter_link_url]";
vbphrase["enter_image_url"] = "$vbphrase[enter_image_url]";
vbphrase["enter_email_link"] = "$vbphrase[enter_email_link]";
vbphrase["complete_image_verification"] = "$vbphrase[complete_image_verification]";
vbphrase["iespell_not_installed"] = "$vbphrase[iespell_not_installed]";
vbphrase["click_quick_reply_icon"] = "$vbphrase[click_quick_reply_icon]";
vbphrase["insert_all"] = "$vbphrase[insert_all]";

//-->
</script>
<!-- END EDITOR SCRIPTS -->

<!-- EDITOR STYLES -->
<link rel="stylesheet" type="text/css" href="clientscript/vbulletin_editor.css" />
<style type="text/css">
<!--
.vBulletin_editor {
background: {$istyles[pi_button_normal][0]};
padding: $stylevar[cellpadding]px;
}
.imagebutton {
background: {$istyles[pi_button_normal][0]};
color: {$istyles[pi_button_normal][1]};
padding: {$istyles[pi_button_normal][2]};
border: {$istyles[pi_button_normal][3]};
}
.ocolor, .ofont, .osize, .osmilie, .osyscoloar, .smilietitle {
background: {$istyles[pi_menu_normal][0]};
color: {$istyles[pi_menu_normal][1]};
border: {$istyles[pi_menu_normal][3]};
}
.popup_pickbutton {
border: {$istyles[pi_menu_normal][3]};
}
.popup_feedback {
background: {$istyles[pi_menu_normal][0]};
color: {$istyles[pi_menu_normal][1]};
border-right: {$istyles[pi_menu_normal][3]};
}
.popupwindow {
background: {$istyles[pi_menu_normal][0]};
}
#fontOut, #sizeOut, .popup_feedback div {
background: {$istyles[pi_menu_normal][0]};
color: {$istyles[pi_menu_normal][1]};
}
.alt_pickbutton {
border-left: 1px solid {$istyles[pi_button_normal][0]};
}
.popup_feedback input, .popup_feedback div
{
border: 0px solid;
padding: 0px 2px 0px 2px;
cursor: default;
font: 11px tahoma;
overflow: hidden;
}
-->
</style>
<!-- END EDITOR STYLES -->

Princeton
18 Jun 2007, 12:39
on a default style, you just have to modify the editor $stylevars within the Style Manager / StyleVars / Sizes and Dimensions

iogames
18 Jun 2007, 18:30
Sorry, can you be more specific? [lol]
I moved all the VALUES in the section you mentioned, no result... and I'm working in the basic style, haven't install any skin/style, just modified the standard...

Princeton
19 Jun 2007, 14:14
here's some info that might help:

http://vbulletin.com/docs/html/main/stylevar_formwidth (form width)
http://vbulletin.com/docs/html/main/stylevar_messagewidth (message width)

http://vbulletin.com/docs/html/main/stylevar_formwidth_usercp (usercp form width)
http://vbulletin.com/docs/html/main/stylevar_messagewidth_usercp (usercp message width)

if changing the above options doesn't work than I suggest reverting your template and starting over

Silvio
20 Jun 2007, 23:17
Installed! Princeton you made really gorgeous templates mod. I installed them all on a vb3.6.7pl1 and I got really sattisfied!

Please Princeton - with your magic graphical phantasy - Redraw entirelly, for this folk, that hugly 'more' Window that opens when you would like to see more smiles.:p


lol

pls accept my apologises for my itanglish.
and my best regards

take care
ciao

Silvio
21 Jun 2007, 01:58
Pls help me on PM writing pane.
In Post writing pane everithing is perfect is just in the PM one.

With mine itanglish will be difficult to explain what i need . lol so it is better to attach an image describing the problem.

ty really for attention

ciao

deezelpope
21 Jun 2007, 09:23
Silvio~if you look a few posts back, the information you need is there.

Princeton
21 Jun 2007, 13:57
Pls help me on PM writing pane.
In Post writing pane everithing is perfect is just in the PM one.

With mine itanglish will be difficult to explain what i need . lol so it is better to attach an image describing the problem.

ty really for attention

ciao
To change the editor width, you will need to edit Style Manager / (your style) / StyleVars.

To change editor width:
http://vbulletin.com/docs/html/main/stylevar_formwidth (form width)
http://vbulletin.com/docs/html/main/...r_messagewidth (http://vbulletin.com/docs/html/main/stylevar_messagewidth) (message width)

http://vbulletin.com/docs/html/main/...rmwidth_usercp (http://vbulletin.com/docs/html/main/stylevar_formwidth_usercp) (usercp form width)
http://vbulletin.com/docs/html/main/...gewidth_usercp (http://vbulletin.com/docs/html/main/stylevar_messagewidth_usercp) (usercp message width)

obmob
21 Jun 2007, 16:04
Nicely done, thanks! :D

Silvio
23 Jun 2007, 01:48
Ty so much. really of help! I solved it.:up:

qqqqw
24 Jun 2007, 12:34
Well i have some problem,

i used that optional mod.

to move "more" link...

after editing editor_smilibox template

"more" link has been replaced by newthread link

it shows "more" button, button redirects to newthread :(

Princeton
24 Jun 2007, 18:20
Well i have some problem,

i used that optional mod.

to move "more" link...

after editing editor_smilibox template

"more" link has been replaced by newthread link

it shows "more" button, button redirects to newthread :(
check the phrase "more" ...
other than that it could be caused by a search/replace via another modification

qqqqw
25 Jun 2007, 12:31
Will you help me more in this ?

i mean i couldnt find that phrase. I am sure that i have done any mistake in copy-paste method.

Princeton
25 Jun 2007, 22:16
if the phrase doesn't exist .. add it via Phrase Manager

o0Hubba0o
26 Jun 2007, 23:26
check the phrase "more" ...
other than that it could be caused by a search/replace via another modification

Umm...the phrase more is there, but it has no reference to a link in it:

Varname $vbphrase[more]
Text More

Attatched is a screenshot while I was hovering over the more link, the pop up doesn't show but it's there saying "showing x amount of smilies out of x amount", so that's good. But the link you see below that shows up when you hover the more link. That url that's showing is the same as the url in the browser at that time.

I recently removed all mods and hacks to start fresh so the chances of that being the problem is extremely slim on this particular forum. I never noticed this (since I don't use the more link too often heh) until after upgrading to vB 3.6.7. Not saying that is the cause, but didn't notice having this problem until after the upgrade.

EDIT: This is an issue on my other forum too, also latest version of vB, but heavily modded.

Princeton
27 Jun 2007, 02:35
the url should be the same page (the link is an open window javascript) ... this is a default vbulletin feature .. this modification just moves it

qqqqw
27 Jun 2007, 09:21
I'm really a newbie here. Please tell me . What should i write while adding new phrase and what should be as setting ?

Princeton
27 Jun 2007, 15:31
I'm assuming the phrase "more" doesn't exist in your site.

go into ADMINCP / Languages & Phrases / Phrase Manager (click Add New Phrase) /

add the following (leave everything else alone)..

Varname : more
Text: More

Ohiosweetheart
27 Jun 2007, 17:14
This is fantastic, really helps when designing a narrower vB theme.
Thank you Princeton!

qqqqw
28 Jun 2007, 04:40
Thank You Very Much For Your Help,

Its Working Very Well Now...

yaoren
24 Jul 2007, 19:51
**Installed**

And working fine on 3.6.7

Thanks :D

tminus
27 Jul 2007, 06:51
Installed and working on 3.6.8, just had to change the 'Message Area Width' & 'User Control Panel Message Area Width' in Admin Control Panel/Styles & Templates/Style Manager/StyleVars to expand the message area out again. Thanks!

Ohiosweetheart
30 Jul 2007, 21:19
How do I extend the text editor in the Private message area out?
I've done all of the fixes recommended at vb.com. Nothing helps this.

All of the other text areas are fine! New thread, New reply, quote, edit - everything is great. See screenie below.

But to compose a PM, reply or forward a PM - it looks like my screenie below.

Ohiosweetheart
30 Jul 2007, 21:41
ACK I found the problem. After applying this mod (and especially after the upgrade to 3.6.8), you have to go into StyleVars and increase the width (pixels) at User Control Panel Message Area Width

Bulent Tekcan
30 Jul 2007, 22:31
Announce new bug on editor_toolbar_on template

http://www.vbulletin.com/forum/project.php?issueid=22747&page=2

Wulfnoth
31 Jul 2007, 12:48
Are there any changes in 3.6.8 for this mod here?

Scalemotorcars
31 Jul 2007, 21:01
Works great thanks for sharing.:up:

SCRIPT3R
01 Aug 2007, 20:08
Are there any changes in 3.6.8 for this mod here?
yes there are; hopefully to be updated soon.

Hams
01 Aug 2007, 23:53
Nice, thanks Princeton

kaptanblack
02 Aug 2007, 00:52
Good good.thanx guy.installed

Kaycee123
06 Aug 2007, 05:38
This is a great little mod - I was just thinking today how this would be good, and here is the modification to do it!! Thanks:up:

Nickbe
06 Aug 2007, 09:02
GREAT MOD

I love this mod thanks

Princeton
08 Aug 2007, 15:54
thank you .. you may want to click MARK AS INSTALLED to receive any future notifications

helldorado
12 Aug 2007, 01:49
I downloaded my copy of vBulletin the night of the 29th, so I think I have the version after the message box fix. So my code looked a little different than the code listed in the search and replace.

The original code
<tr valign="top">
<td class="controlbar" width="100%" style="padding-right:8px"><textarea name="message" id="{$editorid}_textarea" rows="10" cols="60" style="width:100%; height:{$editor_height}px" tabindex="1" dir="$stylevar[textdirection]">$newpost[message]</textarea></td>
<!--width:$stylevar[messagewidth]-->
<if condition="$smiliebox"><td class="controlbar">$smiliebox</td></if>
</tr>

Replaced with
<tr valign="top">

I also had to go vBulletin options in the Admin CP -> Message Posting Interface Options and change the options for number of smilies per row before they would perfectly line up.
<td class="controlbar" width="100%" style="padding-right:8px"><textarea name="message" id="{$editorid}_textarea" rows="10" cols="60" style="width:100%; height:{$editor_height}px" tabindex="1" dir="$stylevar[textdirection]">$newpost[message]</textarea></td>
<!--width:$stylevar[messagewidth]-->
</tr>
<if condition="$smiliebox">
<tr><td class="controlbar" width="100%" style="padding-right:8px">$smiliebox</td></tr>
</if>


I also had to go to the Admin CP under vBulletin Options -> Message Posting Interface Options and update the numbers for smilies displays before they would appear in a row.

nnjj.net
12 Aug 2007, 10:12
looking forwared to see tha update for 3.6.8

nnjj.net
13 Aug 2007, 15:52
any news about the update?

Princeton
15 Aug 2007, 14:29
what exactly are you referring to??

nnjj.net
15 Aug 2007, 22:56
I mean is the changes will be the same for 3.6.8?

VIPER-MAN
15 Aug 2007, 23:08
Excellent !!!

wizardan
15 Aug 2007, 23:12
I mean is the changes will be the same for 3.6.8?
Works like a charm in 3.6.8

Princeton
18 Aug 2007, 19:07
yes, it will work for 3.6.8

wickland
22 Aug 2007, 22:08
Great hack, that clears up a lot of box expansion problems and brings in even more similies. Installed and 5 stared.

Thanks!
Best Regards

NFLfbJunkie
31 Aug 2007, 15:26
Unlike the message posting area for normal threads/posts, which I adjusted after installing this MOD, the blog message posting area does not stretch all the way to the right with having the smilies on the bottom. Is there a way to fix this?

deezelpope
31 Aug 2007, 15:36
Um...the solution is posted up above by Princeton.:)

NFLfbJunkie
31 Aug 2007, 15:40
I have already adjusted my message posting width to compensate for the empty space left behind after moving the smilies to the bottom. However, the Blog's message posting width, for some reason, isn't affected.

Cigarcritic
05 Sep 2007, 19:17
This works great as long as all the smilies are the same size and one row. Using two rows, the smilies will throw the spacing off with the larger smilies.

deezelpope
05 Sep 2007, 20:58
You just rearrange them...then you can have bigger ones.

bigevil
10 Sep 2007, 22:36
How do you get this to take effect within the AdminCP editor boxes?

keithsan
11 Sep 2007, 12:42
great mod, thx

TheTrust
12 Sep 2007, 12:12
This is nice,,, thank you

Princeton
18 Sep 2007, 16:27
NEW 1.1.0 VERSION UPLOADED (product-gtsmiliebox.xml)

No edits are necessary. If upgrading from a previous version you can revert the "editor_toolbar_on" and "editor_smiliebox" template.

puertoblack2003
18 Sep 2007, 21:16
thanks updated*** i hope all hacks can be like this

FIM
18 Sep 2007, 22:09
thanks man

obmob
19 Sep 2007, 00:02
1.1.0 is a bug fix or something? o.o

ShawneyJ
19 Sep 2007, 02:55
nice :)

momo2
19 Sep 2007, 16:34
Thanks for the update

nnjj.net
20 Sep 2007, 14:08
updated thanks

brvheart
21 Sep 2007, 15:25
would be great to get one like this for quickreply as well :)

*installs* great work Princeton!

beduino
22 Sep 2007, 14:24
Hello,
Unlike the message posting area for normal threads/posts, which I adjusted after installing this MOD, the blog message posting area does not stretch all the way to the right with having the smilies on the bottom. Is there a way to fix this?
with me this happens too.

Um...the solution is posted up above by Princeton.:)
unfortunately the edits works to vbulletin - to blogs no :rolleyes:

I have already adjusted my message posting width to compensate for the empty space left behind after moving the smilies to the bottom. However, the Blog's message posting width, for some reason, isn't affected.

i try re-import the product [overwriting] and don't fix it.
if anybody can help ...
tks in advance
Beduino

wpeloquin
23 Sep 2007, 02:23
NEW 1.1.0 VERSION UPLOADED (product-gtsmiliebox.xml)

No edits are necessary. If upgrading from a previous version you can revert the "editor_toolbar_on" and "editor_smiliebox" template.
what exactly was updated?

tommyxv
23 Sep 2007, 23:19
This mod is causing the comment/edit comment text box in PhotoPost Pro 6.0 not to show up at all. :(

Wheezy
24 Sep 2007, 01:26
This is really nice; thanks for sharing!

Princeton
24 Sep 2007, 15:29
This mod is causing the comment/edit comment text box in PhotoPost Pro 6.0 not to show up at all. :(
add photopost to the ignore array - please look at the plugin

Bulent Tekcan
24 Sep 2007, 15:50
I'm already revert my templates and upload this product,but it is not working.But text version still working

Any idea for this ?

tommyxv
24 Sep 2007, 22:15
add photopost to the ignore array - please look at the plugin

I can't seem to figure out how to do this...:confused: Could you show me how?

Thx

toejam
24 Sep 2007, 23:12
Just what I needed, thanks.

Princeton
27 Sep 2007, 14:39
sorry tommyxv,
the ignore array is another mod ... you will have to manually edit the template
I don't use photopost so I am of little help to you. :(

tommyxv
29 Sep 2007, 13:31
sorry tommyxv,
the ignore array is another mod ... you will have to manually edit the template
I don't use photopost so I am of little help to you. :(

I went back to the doing the edit template version, and everything works fine again. Maybe that could be of help???

Either way...this mod is great.

Thx!

PurpleButterfly
30 Sep 2007, 18:32
Wow, that was the easiest mod EVER! Love the feature, clicked install and nominated for MOTM! Thanks so much! *smooch* :D

Dr. Bantham
06 Oct 2007, 14:07
Great mod. I upgraded from the manual template edit version, but now it appears to be causing other custom code within the editor_smiliebox template to be ignored. I have the following code placed at the end of this template:div class="smallfont" align="center">[<a href="$vboptions[photoplog_script_dir]/index.php$session[sessionurl_q]" onclick="openWindow('$vboptions[photoplog_script_dir]/selector.php?$session[sessionurl]e=$editorid', 585, 215, 'selector'); return false;">$vbphrase[photoplog_images]</a>]</div>If I disable your mod, the above code addition works correctly. It is for the PhotPlog Pro system, and adds a link to initiate the pop-up selection of images for embedding.

Princeton
09 Oct 2007, 18:24
If you have a modified template, I recommend sticking with the manual edits.

BioWaffen
11 Oct 2007, 12:43
It is working with vB 3.6.4 too, so maybe you change this compitable to 3.6.X ?

Princeton
11 Oct 2007, 12:53
good idea :up:
made the change

YHB
17 Oct 2007, 16:44
Installed. I Love This, Thanks!

kiwivc
20 Oct 2007, 20:26
Excellent...looks great thanks :)

rizelim
21 Oct 2007, 22:06
Thanks

Arrogant-One
18 Nov 2007, 04:11
Hi Princeton

Is there a way that I can choose which Smilies appear below the editor box? Right now it just displays the number set in VBulletin Options randomly (I suspect).

Also, is there a way to centre the smileys? For instances, I have 2 lines worth, but in the second line it appears like this (* are smilies):

**************
****

Where the four * are, can I centre it better under the first line of smilies?

Last question, why is there an xml product for this mod when it seems to be entirely done by template modifications?

Thanks,

AO

BadgerDog
19 Nov 2007, 13:11
Nice mod.... :up:

Tested it, but it conflicts with vbImage mod and their code disappears.

Thanks anway.... :)

Regards,
Badger

Stax
19 Nov 2007, 19:30
Thanks it cleans the site up nice

RFViet
19 Nov 2007, 20:06
thanks

SNATCH3R
20 Nov 2007, 06:17
thanks....installed...working fine :)

GhoHan
21 Nov 2007, 07:21
nice mods, installed.

solved our problems completely.

mmllc
21 Nov 2007, 10:39
quick and easy mod, thanks :-)

gezgas
12 Dec 2007, 00:29
are you supposed to either upload the product or the template modification or do both?

seems to me that only doing the template modifcation that are in the txt file it works.

Princeton
12 Dec 2007, 12:56
are you supposed to either upload the product or the template modification or do both?

seems to me that only doing the template modifcation that are in the txt file it works.one is manual instructions the other is automatic (the choice is yours)

gezgas
12 Dec 2007, 17:27
k thanks:)

great mod btw.

softvnzla
17 Jan 2008, 03:01
thanks click installed!!

princeedward
25 Jan 2008, 19:30
click installed!!! thanks a bunch...

;)

viper007
02 Feb 2008, 06:42
can one help help .. i want to place my smiles in seprate pop in shout box.. can u plzzz tell me how to do it .. am waiting to ur reply .. plzz help mee.

Thelonius Beck
03 Feb 2008, 08:53
Great man! Thanks! *Installed*

RedGTiVR6
27 Feb 2008, 18:50
any ideas if this works with 3.7?

rnixon
02 Mar 2008, 16:14
A good change, QED, many thanks.

icona
04 Mar 2008, 00:37
Installed! :up::up:

jGas
05 Mar 2008, 07:31
thanks a lot..it's a really nice modification!

cassis2k
05 Mar 2008, 13:44
any ideas if this works with 3.7?

It's ok for me on 3.7.0 beta 5 ^^

Thx for this hack

youradhere4222
05 Mar 2008, 22:40
One thing that I don't like is when you first hit reply the side loads and it's visible for a few seconds until it collapses.

glennybee
12 Mar 2008, 16:08
Thanks Princeton!

Top mod, well impressed!

Looks so much better!

sugresmax
15 Mar 2008, 06:47
Very nice hack.
Thank you Joe

wizardan
24 Mar 2008, 18:44
Sweet and clean in 3.7 RC1:)

kpmedia
05 Apr 2008, 02:04
Excellent!

ZomgStuff
08 Apr 2008, 22:15
How come the effects won't go away if I uninstall this?

ZomgStuff
08 Apr 2008, 22:30
I figured it out, this doesn't un-edit the editor toolbar_on template.

diettalk
13 Apr 2008, 12:28
Can this be reworked to go on vB's blog?

thepub
02 May 2008, 19:00
works fantastic with 3.7.0 RC 4

kho91
04 May 2008, 19:10
i have a probleme with this hack , it don't word with 3.7.0

myown
05 May 2008, 20:29
can some one confirm that it works with 3.7 Gold?

Princeton
06 May 2008, 16:21
3.7 version available
http://www.vbulletin.org/forum/showthread.php?t=178327

Konstantinos
31 Jul 2008, 11:31
yes this conflicts with photopost pro comments.php . need fix :)

Nadeemjp
13 Nov 2008, 04:09
will this work with 3.7.4?

abrecher
11 Jan 2009, 16:31
Is there anything out there like this for 3.8 please ?

fulviods
23 Feb 2009, 09:45
Works On 3.8.1?

DieselMinded
05 Mar 2009, 06:30
On Show Thread....

Simile Box Quick Reply

is not cached

I have a smiles box outline on blogs and PM quick reply but theres no smilies in them

What mod did i install and what not to screw this stuff up?

rrudeboy
24 Jun 2009, 15:49
*installed*, kinda waiting if my members like it....

in the meantime... the post "box" is no longer centered, can i fix that ?