PDA

View Full Version : [BBCode] Thumbnails


Genjuro-Sensei
23 Dec 2006, 16:46
Hello All !

Description:
This simple BBCode let you display an image in a thumbnail when clicking on it it open the original image in a new window, very usefull when making tutorials and it's nice looking too ;)

Installation:

As always, Admin CP -> Custom BBCodes -> Add new BBCode
*Title: Thumbnail
*BBCode: tmb
*Code remplacement:
<table cellspacing="0" cellpadding="0" align="center" style="background-color:#000000; border:1px #000000 solid; color:#ffffff; font-size:11px;">
<tr>
<td align="center"><a href="{param}" target="_new"><img src="{param}" border="0" alt="Thumbnail" title="Thumbnail" width="300" /></a><br />Click to view the original image</td>
</tr>
</table>
*Example: image_url
*Description: Displays an image as a thumbnail when clicking on it, it opens the original image in a new window.
*Use second parameter: No
*Button image: http://img296.imageshack.us/img296/3975/tmbdb3.gif

Enjoy ;)

Allan
23 Dec 2006, 17:10
Great, click Install ;)

Jarllax
24 Dec 2006, 07:02
Works great! Installed.

Sophonax
24 Dec 2006, 14:31
Installed~ <3

hotwheels
25 Dec 2006, 22:23
very interesting.......will look at later for install.......thanks

sorry01
02 Jan 2007, 15:55
Tankssss works great....

ep13
19 Jan 2007, 13:48
how do u get it so it puts them in align instead of middle.

so its like

[ ][ ][ ][ ]

instead of

[ ]
[ ]
[ ]

grecostimpy
20 Jan 2007, 18:05
Excellent!

RFViet
28 Feb 2007, 19:55
Cool !!

BadgerDog
22 Mar 2007, 15:49
Is there way of "left" justifying the pics?

I put in "left" instead of "center" and it seemed to create an odd effect. I think for "left", it needs to have a carriage return at the end of each pic. How can I add that?

Thanks

Regards,
Badger

Triky
22 Mar 2007, 18:17
how do u get it so it puts them in align instead of middle.

so its like

[ ][ ][ ][ ]

instead of

[ ]
[ ]
[ ]

Is there way of "left" justifying the pics?

I put in "left" instead of "center" and it seemed to create an odd effect. I think for "left", it needs to have a carriage return at the end of each pic. How can I add that?

Thanks

Regards,
Badger
Try to remove the align="x".

BadgerDog
22 Mar 2007, 18:28
Try to remove the align="x".

I changed align="left" to align=""

plus

I changed td align="center" to "td align="left"

It now works like a charm, at least in my testing...

I also set the width="200" from 300. If I go smaller it leaves a thick black margin on the right side of the thumbnail. I've been trying to figure out how to get the thumbnail pic much smaller, except leave the border even all way round...

Nice mod... :up:

Thank you...

Regards,
Badger

Triky
22 Mar 2007, 18:32
I changed align="left" to align=""


It works becouse the browser recognize that property like uncomplete, and so it doesn't show it, it doesn't work. :)
So, you can completly remove it.

BadgerDog
22 Mar 2007, 18:35
It works becouse the browser recognize that property like uncomplete, and so it doesn't show it, it doesn't work. :)
So, you can completly remove it.


Thanks again... it's a big help in our forum... :up:

Any quick way (I'm barely computer literate :D ) to get the thumbnails smaller, yet maintain an even black border all way round?

Regards,
Badger

MAD555
23 Mar 2007, 12:20
Really interesting...

Atakan KOC
26 Mar 2007, 07:48
Thanks....

rayw
28 Mar 2007, 04:17
Thanks a lot for this, great idea!

I made a few small change to the HTML though.

Zia
28 Mar 2007, 06:15
what about the image size?

Triky
28 Mar 2007, 08:55
Zia, whay you mean, exactly?

Triky
29 Mar 2007, 12:39
The problem is that if you put the tag lik this: gg it show a bad non-image thumb. How could we solve this? Another problem.. if you put the [tmb] tag into a [code] box, it show always a non-image thumb. Arg!

Majest
05 May 2007, 12:00
Installed.

Chris-777
05 May 2007, 14:17
/me clicks install

Would also like to get it smaller, say 100x100, without the black border. I also added in a height="200" to make it an even square. :)

fordp
28 Jul 2007, 19:09
But could you be more specific as to how to install it? (I'm a newbie)
ie., what exactly to put in fields:
Title =
Tag=
Replacement=
Example=
Description=
Use= Yes/No
Button Image=

Thanks

cheat-master30
28 Jul 2007, 19:47
While I eventually managed to get this working, I did find that it would break Gallery hosted images when surrounding them with this code, regardless of the gallery script used. I tried images uploaded with both Photoplog and Coppermine image gallery to no success, even when other images from the same domain (mine) would come up normally. And yes, this was even when I tried the address gained from CPanels file editor option.

xman_79
28 Jul 2007, 21:15
Installed .
Very useful .
Thanks.

RVM
30 Jul 2007, 03:33
I uploaded the button to forum/images/editor but what do I use as the url in that field?

(such a newbie lol)

fordp
31 Jul 2007, 11:58
Gave up. Not installed. :(

KRaL_JAcK_
04 Aug 2007, 20:18
Installed.. Thanks .. Working on 3.6.8.. great post..