PDA

View Full Version : Profile Enhancements - YouTube in Profile


BlizzardHQ
21 Dec 2007, 13:32
This will allow you to stream a YouTube video in your profile.

Demo: http://www.blizzardhq.com/forums/member.php?u=2

Please click install :)

BlizzardHQ
21 Dec 2007, 13:33
~ Reserved ~

BlizzardHQ
21 Dec 2007, 13:40
Also this was released by me a while back ( http://www.vbulletin.org/forum/showthread.php?t=133263 ). But I got out of the forum scene for a bit and no longer able to post under Eggie due to not knowing my old password :(

Magnumutz
21 Dec 2007, 13:43
Do you mind allowing guests to see how it would look in the default style?

BlizzardHQ
21 Dec 2007, 13:46
Do you mind allowing guests to see how it would look in the default style?

Sorry, I haven't done any changes in the default style. Once I'm done modding this style, I will be deleting default. It is only in place currently in case of style mess ups.

katilkuzu
21 Dec 2007, 14:17
thank you and installed it is really looking soo nice :)

UncoderMom
21 Dec 2007, 14:31
Nice! Thanks!

Tagged!

BlizzardHQ
21 Dec 2007, 14:54
thank you and installed it is really looking soo nice :)

Thank you for the input :D

Magnumutz
21 Dec 2007, 16:16
Sorry, I haven't done any changes in the default style. Once I'm done modding this style, I will be deleting default. It is only in place currently in case of style mess ups.
Ok, no problem... i just wanted to make an idea on how it would.
I'll try it on my board.

Snake
21 Dec 2007, 16:19
Thanks for the release!

BlizzardHQ
21 Dec 2007, 16:41
Ok, no problem... i just wanted to make an idea on how it would.
I'll try it on my board.

If you put it just right of your profile picture it fits perfect. My profile pics are set at 240 width and it fits perfect.

obmob
21 Dec 2007, 17:36
Hmm... the video appears behind the profile right column. o.o

BlizzardHQ
21 Dec 2007, 17:53
11 downloads, but only 3 have clicked install :(

Trigr
21 Dec 2007, 19:51
i, for the life of me, cant get this to work.


would someone mind telling me where they put it on theirs, like the actual template edit? Ive tried this in various spots on my memberinfo template and its just not working.


i appreciate the help. would like to use this since it could help promote use of the CP features.

yahoooh
21 Dec 2007, 21:03
thanks

Alien
21 Dec 2007, 21:26
Very nice!

Appreciate it!

MustangLisa
22 Dec 2007, 03:05
Thanks for this! It was the first thing asked for when I set up the new 3.7 beta in our test forum.

MustangLisa
22 Dec 2007, 03:31
i, for the life of me, cant get this to work.


would someone mind telling me where they put it on theirs, like the actual template edit? Ive tried this in various spots on my memberinfo template and its just not working.


i appreciate the help. would like to use this since it could help promote use of the CP features.

Yeah, I am curious where to place it to appear on the right of the screen name/avatar/profile pic as seen on the profile page. Thanks!

BlizzardHQ
22 Dec 2007, 11:05
What I did on mine was I moved the info in the second col to above the profile pic and used that table for the video.


before:

------------------------------- username ----------------------
| profile | online status | friends list |
| pic here | Rank | |


My custom changes:

Username ----------------------- --------------------
Online status | you tube video | | friends list |
Forum Rank
------------------------
| profile pic |
| table width=250 |

Hope that helps

BlizzardHQ
22 Dec 2007, 11:31
Since that came out really crappy. Here is a screenie of it.. top one (white) is default and bottom (dark) is my custom changes I made to make it fit

ShawneyJ
22 Dec 2007, 17:55
Excellent

whitetigergrowl
22 Dec 2007, 20:18
What I did on mine was I moved the info in the second col to above the profile pic and used that table for the video.


before:

------------------------------- username ----------------------
| profile | online status | friends list |
| pic here | Rank | |


My custom changes:

Username ----------------------- --------------------
Online status | you tube video | | friends list |
Forum Rank
------------------------
| profile pic |
| table width=250 |

Hope that helps


Would it be possible to paste the code for that? That's confusing as all heck. lol

The Ottoman
26 Dec 2007, 21:38
i, for the life of me, cant get this to work.


would someone mind telling me where they put it on theirs, like the actual template edit? Ive tried this in various spots on my memberinfo template and its just not working.


i appreciate the help. would like to use this since it could help promote use of the CP features.



I would really like to get this to work as well, but I can't seem to.

WTF.

ShawneyJ
27 Dec 2007, 05:07
no matter where i put the code in member info it does not disply.

whitetigergrowl
29 Dec 2007, 16:49
Yeah, this code is utterly useless without better instructions.

Kaleem
02 Jan 2008, 02:01
Yea its not working no matter where i m trying to put this :s

ChU v2
02 Jan 2008, 03:07
Looks good, I'll bookmark to try later.

For those of you that it's not working, have you tried editing the field number with your own.

IE. Field1 change to your field number. etc etc

Romeos Tune
02 Jan 2008, 03:30
My new fields are 5 and 6. I've changed those from 1 and 2 in the code but still can't get it to work. Seems simple but no go for me.

lighti
02 Jan 2008, 05:04
I too am having issues with it. I've changed the field #'s around and it doesn't do anything =\

whitetigergrowl
02 Jan 2008, 06:04
Looks good, I'll bookmark to try later.

For those of you that it's not working, have you tried editing the field number with your own.

IE. Field1 change to your field number. etc etc

Yes. But it appears this is another plug-in that goes unsupported. Go figure.

xXTheOneRavenXx
09 Jan 2008, 07:14
Yes, I am having the same problem as well. I have changed the field numbers, etc... But it just does not want to work. Good concept though. If you could give some idea where in the MEMBERINFO template would be a good "suggested" location for it (actual line of code that would come right before this one would be inserted) that would be excellent. But for those of us less fortunate to actually understand every line of code in the template, this code is absolutely useless with it's current instructions.

passwords
13 Jan 2008, 10:39
same problem here .

whitetigergrowl
14 Jan 2008, 03:36
I like how it says its supported....yet theres no support. >_<

A dead hack anyone?

teenhut
15 Jan 2008, 18:29
I can't even see the demo now.

BoredOutOfMyMin
20 Jan 2008, 23:15
Here is the sidebar if anyone can fix this-

<div id="sidebar_container">
<!-- sidebar -->
$template_hook[profile_right_first]
$blocks[stats_mini]
$template_hook[profile_right_mini]
$blocks[friends_mini]
$blocks[albums]
$template_hook[profile_right_album]
$blocks[groups]
$blocks[visitors]
$template_hook[profile_right_last]
<!-- / sidebar -->
</div>

therogueforums
25 Jan 2008, 13:34
Looks interesting, to say the least. I'd like to try it out, but see a lot of rather negative feedback. Perhaps an update from the coder? Or updated instructions?

At any rate, I'll hold off on this until an update is made.

A+ for effort and initiative, though!

Alfa1
30 Jan 2008, 22:16
It would be great if it would work.

ShawneyJ
31 Jan 2008, 06:33
Supported? wtf wheres the support lol.

Alfa1
01 Feb 2008, 01:42
I am afraid that support lasted about 1 day.

Brandon Sheley
01 Feb 2008, 02:06
doesn't work for me either

EvErDrEaMs
04 Feb 2008, 13:52
tryed everything no go.

seangworld
05 Feb 2008, 01:13
demo link doesnt work.

Bilderback
05 Feb 2008, 03:42
not working for me in beta 4
Does $post have to be changed to $prepared?

seangworld
05 Feb 2008, 08:14
i want to have my members be able to add youtube to their profiles but i require a demo to make sure it looks good and it works right.

none of you are providing a link to even your own sites as a demo.

Freesteyelz
05 Feb 2008, 10:55
I checked the codes. The reason why it's not working is there are missing elements in it. To fix it do the following:

Find (2 times):


src="http://www.youtube.com/v/$post[field1]"



Replace it (2 times) with:



src="http://www.youtube.com/v/$userinfo[fieldx]&rel=1"



Replace "x" with the Custom Profile Field ID.


I basically had the same idea as BlizzardHQ but did it on my own. For my profile I used the 3.7 codes so the look will adjust according to how I customize it. I would show the profile but you need to be logged in. The attachments should suffice. :)

stangger5
05 Feb 2008, 17:01
I made a right side YouTube box in member profile..It uses the 3.7 code for the look also..

You can have a look at my profile,,,you dont need to register..thefulcrumpoint.org (http://www.thefulcrumpoint.org/member.php?u=31)

seangworld
05 Feb 2008, 17:35
wow very nice stangger. im hoping you used this same code in this thread!
and i wasnt aware ipbarcade was working for 3.7, i was waiting for that too....

you've been a huge help, thanks man.

i just bookmarked your site as well for other hacks you got...

Alfa1
05 Feb 2008, 21:17
I made a right side YouTube box in member profile..It uses the 3.7 code for the look also..

You can have a look at my profile,,,you dont need to register..thefulcrumpoint.org (http://www.thefulcrumpoint.org/member.php?u=31)
How did you do that?

Freesteyelz
05 Feb 2008, 22:30
Hey, stangger5. Nice. :up:

I'm curious...Did you use plugins or did you edit the PHP files? When I did the Mini_YouTube I used PHP edits :(.

My efforts to reproduce what you did are in attachment:


*The one difference is that the title "My YouTube Video" is using a Custom Profile Block. Users can choose their own title. :)

seangworld
06 Feb 2008, 02:39
im not getting it to work.

<if condition="$post[field5]">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar

[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="tcat">$userinfo[username]'s Video <if condition="$post

[field2]">&nbsp;-&nbsp;$post[field6]</if></td>
</tr>
</table>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar

[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="alt2" style="border-bottom:0px solid $stylevar[tborder_bgcolor]"

width="200" colspan="2">
<center>
<object width="425" height="350"><param name="movie"

value="http://www.youtube.com/v/$post[field5]"></param><param name="wmode"

value="transparent"></param><embed src="http://www.youtube.com/v/$userinfo[field6]&rel=1"

type="application/x-shockwave-flash" wmode="transparent" width="425"

height="350"></embed></object>
</center></td></tr></table></if>


and how would i properly place it so it shows up on my side bar under the stats?

Freesteyelz
06 Feb 2008, 04:20
$post will only work in postbit. Replace it with $userinfo...You'll have to do it several times. Also refer post #45 (http://www.vbulletin.org/forum/showpost.php?p=1436641&postcount=45) again, you missed one edit. :)

You can add the Table elements in MEMBERINFO template:


<div id="sidebar_container">



Because stangger5 implemented YouTube in the right column first I don't want to release mine. Just in case he's planning on releasing it as a mod.

seangworld
06 Feb 2008, 05:37
im so confused now.

can you just pm me your edits?

stangger5
06 Feb 2008, 18:25
Hey, stangger5. Nice. :up:

I'm curious...Did you use plugins or did you edit the PHP files? When I did the Mini_YouTube I used PHP edits :(.

My efforts to reproduce what you did are in attachment:


*The one difference is that the title "My YouTube Video" is using a Custom Profile Block. Users can choose their own title. :)

I made a plug-in...I added the option for users to choose their own title...;)
I should have it ready to post by tonight..

Freesteyelz
07 Feb 2008, 00:00
Sweet. I'll check it out soon. :)

Alfa1
07 Feb 2008, 09:37
Very nice.

Brandon Sheley
23 Feb 2008, 02:47
I made a plug-in...I added the option for users to choose their own title...;)
I should have it ready to post by tonight..

hows that going ?

DieselMinded
09 May 2008, 16:17
/me must have this please release a working version

DieselMinded
09 May 2008, 17:19
Ok Pieces of this and pieces of that and i got this working !!



Create a New User Profile Field - Single-Line Text Box
Title - YouTube Video In Your Profile
Description - You can give your YouTube a title here
Hidden - Yes
Searchable - NO
Memberlist - NO

Note the Field Number not the order number

Mine was field 12

Edit This code with your field number (Replace all the 12's)

<if condition="$userinfo[field12]">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="tcat">$userinfo[username]'s Video <if condition="$post[field12]">&nbsp;-&nbsp;$userinfo[field12]</if></td>
</tr>
</table>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="alt2" style="border-bottom:0px solid $stylevar[tborder_bgcolor]" width="200" colspan="2">
<center>
<object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/$userinfo[field12]"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/$userinfo[field12]" type="application/x-shockwave-flash" wmode="transparent" width="230" height="230"></embed></object>
</center></td></tr></table></if>
<br>

Then
Put it in Member Info Template Between
<!-- sidebar -->
and
<!-- / sidebar -->

Like so : (I moved the Friends Down )
<!-- sidebar -->
$template_hook[profile_right_first]
$blocks[stats_mini]
$template_hook[profile_right_mini]
<if condition="$userinfo[field12]">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="tcat">$userinfo[username]'s Video <if condition="$post[field12]">&nbsp;-&nbsp;$userinfo[field12]</if></td>
</tr>
</table>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="alt2" style="border-bottom:0px solid $stylevar[tborder_bgcolor]" width="200" colspan="2">
<center>
<object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/$userinfo[field12]"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/$userinfo[field12]" type="application/x-shockwave-flash" wmode="transparent" width="230" height="230"></embed></object>
</center></td></tr></table></if>
<br>
$blocks[albums]
$template_hook[profile_right_album]
$blocks[friends_mini]
$blocks[groups]
$blocks[visitors]
$template_hook[profile_right_last]
<!-- / sidebar -->


Adjust your size with

width="230" height="230"

(the last bit of code)

murdoc
23 May 2008, 15:19
Hello there :D

i have a little prob mine is not showing, i dont know what to do

take a look

http://gamerswastelands.co.za/member.php?u=1

chennairam
02 Jul 2008, 12:31
can i ask sir ?
where can i put this code ?

save and replace $post[field1] with the field (like $post[field8]

Sorry im new in forum

Alfa1
03 Jul 2008, 11:45
I made a plug-in...I added the option for users to choose their own title...;)
I should have it ready to post by tonight..
Any news?

Stuntman Mike
03 Jul 2008, 19:00
everything diesel minded said made it work...however, for some reason, the other fields, which were biography stuff so members could put their birthdays in and stuff, are gone. is there another place to replace the field code for these? The only thing in my about me is the link and title of my youtube video. Editable fields are gone.

Good thing is, the youtube video is in my sidebar!