PDA

View Full Version : Miscellaneous Hacks - Force Intro On Register


Aniron
23 Dec 2007, 15:02
This will force new members to fill out an intro when they register to your site. Very handy to make sure they are seen and with luck helps them feel welcome.

To install:
Create a new multiple-line text box profile field with the following settings.
Title: (your choice but should reflect it is intro)
Description: (once again your choice)
Max length: (has to be more then your minimum you will set later)
Field Required:Yes, at registration and profile updating
Private field: yes (can be no if you wish)

Rest of the fields are at your discretion. Make sure you make note of the new field id

Import product-introonregister in Manage Products

Now go to vBulletin Options->Into On Register Option and set the values.

Thats it, I have been using it for some time and thought others may like it.

Aniron
23 Dec 2007, 15:04
[Reserved Post]

BlizzardHQ
23 Dec 2007, 15:20
Does it post what they enter to a new thread? Screenie or working demo would be helpful.

Aniron
23 Dec 2007, 15:38
It posts it to a new thread in a forum you choose in the options.

BlizzardHQ
23 Dec 2007, 15:57
neat :)

/me clicks install

Aniron
23 Dec 2007, 15:59
You may want to re download , I found a phrase issue (it would always say 250) lol. Fixed now.

FleaBag
23 Dec 2007, 22:06
It is a great idea, although I would rather not 'force' an intro, rather request one - I don't want new users just typing anything in the box to pass validation, resulting in rubbish new threads.

hocphp
24 Dec 2007, 00:59
thank you for released !

Aniron
24 Dec 2007, 03:14
It is a great idea, although I would rather not 'force' an intro, rather request one - I don't want new users just typing anything in the box to pass validation, resulting in rubbish new threads.
You could always make it an optional field in register set the required to 0 and then if they used it they did if not , not forced?

But I have found those who post rubbish in it also prove what they will contribute to the community.

princeedward
24 Dec 2007, 16:15
nice...mark and click install...is it possible to have also smilies selection or add on it?...something like that popup smilies...i guess it would be nice... ;)

MrPHD
24 Dec 2007, 17:41
Reserver and installed , Regards.

Aniron
24 Dec 2007, 18:50
You could always make it an optional field in register set the required to 0 and then if they used it they did if not , not forced?

But I have found those who post rubbish in it also prove what they will contribute to the community.
Hmm I would have to think on it. As it is for introductions I never thought of smiles.

But if they posted : ) it would show as a smile. * will ponder it.

FleaBag
24 Dec 2007, 18:58
You could always make it an optional field in register set the required to 0 and then if they used it they did if not , not forced?

But I have found those who post rubbish in it also prove what they will contribute to the community.

Thank for the info Aniron - and that's a very good point! I hadn't thought about it like that.

wingrider
24 Dec 2007, 22:09
I have been trying to make this work as non-mandatory by putting '0' in the minimum required field and setting the entry to optional. When I post anything in the box, I get an error that says, "You must enter at least 0 characters for the intro." Any ideas?

Aniron
24 Dec 2007, 22:50
Give me a minute to fix that.

Aniron
24 Dec 2007, 23:05
Ok , try the new file. It should no longer have that error.

wingrider
24 Dec 2007, 23:13
OK, I'll let you know how it works out.

wingrider
24 Dec 2007, 23:22
Sorry, Aniron, I get a database error when I hit the Register button. Nothing is posted in the Introductions forum, but the new user shows up in the ACP. I'll check back later to see if you have made some refinements.

By the way, it's very unusual for me to get a database error... usually runs perfectly.

Don

Triky
24 Dec 2007, 23:48
If you would use your forum as a GDR, it would be great for something like a "new character registration" process; you sign up and you describe and explain your character personality, etc., etc., etc. (maybe with more than one field, this is sure), then it will be posted on your *New Characters* forum, like a sort of *personal card*.

Aniron
26 Dec 2007, 17:20
Sorry, Aniron, I get a database error when I hit the Register button. Nothing is posted in the Introductions forum, but the new user shows up in the ACP. I'll check back later to see if you have made some refinements.

By the way, it's very unusual for me to get a database error... usually runs perfectly.

Don
I have not been able to replicate the db error. Can you tell me what it says?

ChU v2
02 Jan 2008, 03:11
This is a fantastic idea, great for like member intro forums. bookmarked to install later. Thanks!

TPOCJames
05 Jan 2008, 21:36
Love the hack, but you might want to specify in the Options when linking to the forum whether you only put the forumid or the full link. I was confused about that.

Bexter
12 Jan 2008, 15:49
Hmmm, awesome idea, i like it a lot :D

Im gonna install this me thinks, make it optional of course though ;) :)

cajunboy2208
12 Jan 2008, 19:22
Reserved, this is just the type of thing I have been looking for.
Thanks much.

Roxie
12 Jan 2008, 22:07
I don't want old members to have to fill this in when they update their profiles. Any way around this?

Alfa1
13 Jan 2008, 17:46
I have a 'new member introductions' thread, which works much better than a new thread for every member.
Could you add an option to post introductions in a thread?

Aniron
15 Jan 2008, 01:00
I don't want old members to have to fill this in when they update their profiles. Any way around this?
I will have to look into that, I had not had that trouble as all my members had to sign up with it..
I have a 'new member introductions' thread, which works much better than a new thread for every member.
Could you add an option to post introductions in a thread? That is possible, I will put it in a to do for this weekend.

sp0okz
15 Jan 2008, 16:48
doesnt with cyb rules installed

mamashid
16 Jan 2008, 15:51
can you explain where i do this at:

Create a new multiple-line text box profile field with the following settings.
Title: (your choice but should reflect it is intro)
Description: (once again your choice)
Max length: (has to be more then your minimum you will set later)
Field Required:Yes, at registration and profile updating
Private field: yes (can be no if you wish)

Aniron
16 Jan 2008, 16:04
can you explain where i do this at:
That is done in admincp in userfields, you just add a new one.

mamashid
16 Jan 2008, 16:10
userfields?

That is done in admincp in userfields, you just add a new one.

saf-t scissors
19 Jan 2008, 20:38
I tried changing the hook location from register_addmember_complete to register_activate_process (so that the new thread doesn't appear until after email verification), but got db errors.

Mama: You need to set up an intro field in the AdminCP under "User Profile Fields" -> "Add New User Profile Field", then reference that field number in the Intro On Register options under vBulletin Options.

msvi007
26 Jan 2008, 06:28
I set up the profile field and followed the instructions and still get errors
Fatal error: Existing data passed is not an array
Called set_existing in /includes/functions_databuild.php on line 279
Called build_forum_counters in /register.php(361) : eval()'d code on line 96
Called eval in /register.php on line 361
in /includes/class_dm.php on line 235

Arsenalfan
27 Jan 2008, 14:39
Thanks works a treat! :D

Brandon Sheley
01 Feb 2008, 02:30
Love the hack, but you might want to specify in the Options when linking to the forum whether you only put the forumid or the full link. I was confused about that.

ditto ?

CBTS Pennywise1
01 Feb 2008, 15:51
What I'm I supposed to add for it to post in my Welcome Block forum. I tried the forum name, id and url nothing works.

Zi55
07 Feb 2008, 09:52
Developer Last Online: Feb 2008
Please answer my PM's Aniron .

UltraFanatics
12 Feb 2008, 23:08
I have a problem with this, when a user trys to register it gives an error message on the page (like a default web error)

The user still registers if you go back to the home page but also no post has been posted?

UltraFanatics
12 Feb 2008, 23:18
Now fixed.

You need to add the ID guys.

Zi55
16 Feb 2008, 11:35
Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .Please answer my PM's Aniron .

Pamela
29 Feb 2008, 00:20
*clicks install*

Just what I was looking for! Thanks!!!

Oh and I agree that a smilie box would definitely be an awesome upgrade to this! :D

traxxadd
04 Apr 2008, 09:26
Hey it would be a great mod if dude could spell LOL:D

basilrath
04 Apr 2008, 09:45
Strange but the thread intro shows on forum but when you click on it .....nothing there?

GTX2
05 Apr 2008, 21:52
two questions:

1) Will this work on 3.6.4 ?
2) Will registered users be redirected to their own intro post after registering?

thanks

UltraFanatics
14 Apr 2008, 18:45
When a users enters something into the intro is it then meant to show on their personal profile page?

I've had this mod running for a while now and I love it but Im sure it used to show on their pages but now it doesn't?!

Have I lost the plot or what lol

dreads
24 Apr 2008, 15:46
This is a great way to stop those spam bots :D

Mrdby
30 Apr 2008, 11:45
does this have bugs?

IvyKeepMommy
30 Apr 2008, 14:53
I haven't found any... love this mod and it works wonderully!

Mrdby
30 Apr 2008, 20:32
i don't see the edit or delete button along the side of each step like shown in your picture.

http://www.vbulletin.org/forum/attachment.php?attachmentid=73626&stc=1&thumb=1&d=

sigh
05 May 2008, 17:13
I love the idea - we've been mandating intros for almost a year, and letting members vote newbies in with the rep system. Our biggest problem was getting people to post an intro message to vote on :)

So far, this hack is working in my tests. Love it!!

Mrdby
21 May 2008, 01:55
So Its Good?

Mrdby
21 May 2008, 02:13
this doesn't work...i'm trying to register and make sure that it works..and NOTHING`! Keeps telling me i need more chracters.

Mrdby
21 May 2008, 02:17
ok nvm got it working~!

abrecher
08 Jun 2008, 08:48
This is a great concept. I attempted to install on 3.7.1. I followed all directions but it didn't show up at all on my signup form ?

Mesohu
08 Jun 2008, 09:58
It would be great if you add some features like:
- Fields like:
-- Name
-- Location
-- Age
-- Hobby's
-- How did you find uS ?
etc...
And if you can add an option to change/add/delete these fields from the Settings of this MOD it would be great.

And to add an option to change the value of Forced in the reg. YES and No optionally (not forced for the introduction) ...

Chance4Today
08 Jun 2008, 12:11
I just downloaded it and imported it and got a error message trying to import. Any ideas

BigDog56
08 Jun 2008, 13:18
Installed, works like a charm on 3.7.1! Thank You!

Trichomes
08 Jun 2008, 13:34
Hi,

This is a great mod, and its installed fine for me, can i make a couple of request's?

1) can I have the field sent in an email to me the "super admin" so I can screen new members, spamming has been a nightmare recently and this could help me with new memberships.

2) can we have an option for registration page only, not on editing a profile later on.

Thanks so much if you can help out with this, I feel as well as a great tool to introduce your self, this doubles up as a great member verification tool.

Thanks

T

rtedgar
08 Jun 2008, 14:20
Hi Everyone,

The correction for the error that wingrider is getting when he registers a new user and the intro not being posted into the forum is that when setting the intro on registration options in the VBulletin option, the last field asks for the forum that the intros should be written to. This should be the forums ID# not the forums name. There is no notation in the field that would let you know that and I finally figured it out after 15 new registrations. Hope this helps.

Bob

Mrdby
08 Jun 2008, 15:56
works fine for me on 3.7.1

theparentpack
12 Jun 2008, 02:10
When entering the values in vb options do we enter the title, ID# or url of the forum that the introductions should be posted to?

theparentpack
13 Jun 2008, 21:48
Before installing this hack I had my forum set up to moderate the first post of every user. Once the first post was moderated they were promoted to the next membership level and no longer moderated. Now that I have them posting their intro in their registration this post is not moderated. Any ideas about how to have this post moderated?

Captain Tycoon
14 Jun 2008, 15:35
Is it possible to make it so that instead of having one field for the intro, can we have 2 or more? For example, one field which asks for the full name and one field which asks for the age and then both fields are merged/posted into the introduction.

April7
15 Jun 2008, 04:54
Thank you. I think I am going to like this alot. :) Great idea.

theparentpack
20 Jun 2008, 19:29
The forced intro does not increase their post count by 1. Is there any way to get this hack to count the forced intro as a post count?

Also, I have been moderating new members first posts to filter spam. I noticed that the forced posts are flying in under the radar. Is there any way to make these posts follow the moderation I have set up for initial posts?

So in a nutshell I would like to know if there is any way to moderate the forced post, and have it count in the post count of the member who posted it?

Mrdby
20 Jun 2008, 23:37
love the hack

BigDog56
29 Jun 2008, 17:46
Works great on 3.7.2 But now it seems I am getting people who are using this to spam me. Is there a way to make their post moderated?

Alfa1
29 Jun 2008, 20:52
I have a 'new member introductions' thread, which works much better than a new thread for every member.
Could you add an option to post introductions in a thread?

That is possible, I will put it in a to do for this weekend.

Any news on this?

Mrdby
10 Jul 2008, 23:30
http://www.vbulletin.org/forum/showthread.php?t=170323 think you can add this? That way people know how many characters they are typing so they won't hit submit and either have to many or to less?

basilrath
12 Jul 2008, 15:37
To much spam...............

skierjosh
15 Jul 2008, 23:30
We also have forum moderation turned on, it would be great if you could make it so intro threads aren't posted until the user is accepted.

Mrdby
16 Jul 2008, 13:39
Can you add a character counter and a spam buster on the next release. Someone just did an intro and posted links all in it... and it’s good idea to have a character counter so you can see how many words you are typing during the intro.

denman75
16 Jul 2008, 16:56
does noet work with 3.7.2
the product does installs
but there are no edit tabels at all
and its not showing the messages to new users

karlm
16 Jul 2008, 19:33
Two questions:
1) My new members are not allowed to post without moderation, however this hack enables their first post to go through without screening by a moderator. Is there a means to make the post go into the moderation queue instead of going straight on the forum in public? This could be bad if spammers get a whiff of it.
2) It would be very advantageous if new members could type their own title instead of 'xxxx intro' - which is rather... uniform and boring for the naked eye to look upon when entering the 'introductions forum'. Is there any chance of looking into modifying this hack somewhat to allow for members to type their own intro title/topic?

Otherwise, an awesome hack. Cheers for sharing this.

karlm
16 Jul 2008, 19:35
Is it possible to make it so that instead of having one field for the intro, can we have 2 or more? For example, one field which asks for the full name and one field which asks for the age and then both fields are merged/posted into the introduction.
Excellent idea. I thought very similar myself (practically identical) but have no idea how to impliment it, sadly.

l3it3r
17 Jul 2008, 13:28
works wonderfully!

OS Master
29 Jul 2008, 02:56
I love this mod, but there is just one thing that annoys me.

When someone uses this mod, I can see the "thread" in the "Latest Posts" column of my intro forum. When I click on the link, I get this message:

No Thread specified. If you followed a valid link, please notify the administratorHere is the link by "Latest Posts":
http://www.usingyouros.com/forum/showthread.php?goto=newpost&t=425

Here is the URL of the error message:
http://www.usingyouros.com/forum/showthread.php?p=0#post0

Cloverfield
07 Aug 2008, 22:24
YES OS Master, I get the same error. If you go INSIDE the section, THEN click the thread title, it is fine, but clicking it from the forum index page gives you a nasty error. Also, is there anyway that this 'thread' can count as a post please?

BucWiLd
08 Aug 2008, 05:10
thanks

masons_mum
08 Aug 2008, 10:01
installed and working great :)

Cloverfield
12 Aug 2008, 18:35
What is the title of the new thread?

[Username] Intro


I still want to know why the thread doesn't count as a post!

Daisyboo
01 Sep 2008, 17:11
Love it, but uninstalled for now until the forced post follows the moderation settings for my forum (double activation)

n95gps
02 Sep 2008, 19:56
hi
thank you so much for this hack

i have a request please

i would like to change the title of the thread

it say " username intro"

i want to change intro into something else

how can i do that please

theparentpack
23 Sep 2008, 16:42
I am using this currently and love it, however, my concerns with it are the following:

~ The intro post does not count toward the members posts and I have to manually add a post count to their profile.

~ The forced intro is not moderated

~ The newly registered member is not automatically subscribed to the post therefore they do not know when someone replies, or that the post exists at all.

HELP!!!

maleficarum
23 Sep 2008, 20:28
Very nice, installed.

masons_mum
23 Sep 2008, 21:33
you can change the title of the intro post to whatever you like. open the xml to edit it. Find 'intro' and change to whatever you want. Worked for me :)

Cloverfield
24 Sep 2008, 01:01
The post count thing is still an issue.

JenniferK
19 Oct 2008, 20:27
I wanted moderation as well as not making old members use this when updating profile, so here is my solution. Though I am still having trouble getting this this to work. Note: I approve all new members anyway, so this helps me decide if it's someone I will activate.

I created a new forum for the intros to go to that is not visible on the forum listing, but is open for posting. The idea is that I verify that the intro is not garbage or spam, then just move posts to the real intro forum (mass move if there are several).

When creating the profile field, I kept it as not required so existing members are not forced to use it. If a new member leaves it blank (I say it is required in the description), they won't get activated. In the options I set the minimum characters to 0.

So I did a test register and all looked OK, but nothing posted. Can someone help me with this? Do I need to make the permissions for the forum open to guest posting for this to go through?

profanitytalker
20 Oct 2008, 10:19
reserve

Battle_Ring
28 Nov 2008, 20:30
I get this as well

No Thread specified. If you followed a valid link, please notify the administrator

Mrdby
30 Nov 2008, 19:46
still works on 3.7.4 whoever needs help PM ME.

Mrdby
30 Nov 2008, 19:57
love this mod~!

Nadeemjp
01 Dec 2008, 01:04
i installed it but wasnt sure whether this works on 3.7.4 pl1 or not.
does it?

Mrdby
01 Dec 2008, 02:06
i installed it but wasnt sure whether this works on 3.7.4 pl1 or not.
does it?

works fine

RedTrinity
01 Dec 2008, 22:51
This mod just stopped working on our forums and I don't know why :( New registrations are filling out the intro field, but they aren't starting up as new topics - even though the settings are right.

I just tried signing up a test account and got a blank page when I submitted my registration successfully.... the account was created and everything else ok regardless, though.

But yeah no more intro topics. Even uninstalling/reinstalling hasn't fixed it.

Support for this problem would be appreciated.

ETA: Never mind, got it working again. It was this mod (http://www.vbulletin.org/forum/showpost.php?p=1676707&postcount=117) responsible for the blank page, and it was causing this hack to stop functioning properly. Sorry for the false alarm!

JenniferK
05 Dec 2008, 21:24
I wanted moderation as well as not making old members use this when updating profile, so here is my solution. Though I am still having trouble getting this this to work. Note: I approve all new members anyway, so this helps me decide if it's someone I will activate.

I created a new forum for the intros to go to that is not visible on the forum listing, but is open for posting. The idea is that I verify that the intro is not garbage or spam, then just move posts to the real intro forum (mass move if there are several).

When creating the profile field, I kept it as not required so existing members are not forced to use it. If a new member leaves it blank (I say it is required in the description), they won't get activated. In the options I set the minimum characters to 0.

So I did a test register and all looked OK, but nothing posted. Can someone help me with this? Do I need to make the permissions for the forum open to guest posting for this to go through?

Anyone?

Mrdby
05 Dec 2008, 22:43
Anyone?

send me your information or yahoo id ot something on PM. I can take a look. :)

intospain
15 Dec 2008, 12:05
Thanks, downloaded and installed. :D

DJScorpio
15 Dec 2008, 14:51
is there a way so that members that are already on there.. i.e signed up before i put the hack on.. make it so that they have to update there field.. when they go to post or view a thread it will redirect them to update there profilee.. and this must be done or they cant continue...?

vics
15 Dec 2008, 20:25
Does this work for 3.8 RC1? Cheers

dynamite
17 Dec 2008, 22:36
Haven't tried RC1, but it works on Beta 1

SuperTaz
18 Dec 2008, 00:27
Any updates on this?

militarytuners
04 Jan 2009, 23:14
Let me give this a trial run.

apiasto
05 Jan 2009, 00:05
any word on moderation ?

hjogi
09 Jan 2009, 01:13
does this works for 3.8?

wman
30 Jan 2009, 22:15
does this works for 3.8?

Yes. :)

Adeawan
02 Feb 2009, 00:54
Thanks
installed

tei727
06 Feb 2009, 17:27
I love this mod, but there is just one thing that annoys me.

When someone uses this mod, I can see the "thread" in the "Latest Posts" column of my intro forum. When I click on the link, I get this message:

Here is the link by "Latest Posts":
http://www.usingyouros.com/forum/showthread.php?goto=newpost&t=425

Here is the URL of the error message:
http://www.usingyouros.com/forum/showthread.php?p=0#post0

I get this as well

No Thread specified. If you followed a valid link, please notify the administrator

just installed on 3.8.1 and works fine except for the above. did anyone figure out a fix?

darknusens
11 Feb 2009, 06:48
All I get is the following: * You must enter at least 250 characters for the intro. but the intro box in the registration form is not there?? where is it? I am using vbulletin 3.8.1

SVTCobraLTD
11 Feb 2009, 13:23
Installed, not working for 3.6.x?? Same problem as darknusens, no box showing up.

darknusens
12 Feb 2009, 06:05
Installed, not working for 3.6.x?? Same problem as darknusens, no box showing up.

Hey dude, I figured it out, lol it's cause we didn't follow the instructions properly..

k this is what you need to do..

You need to create a new "multiple-line text box profile field" to get that box that is missing. To create it you need to go to your admin control panel and:

1. Scroll down till you see a box that says "User Profile Fields"

2. Click where it says "Add New User Profile Field"

3. In the drop down box select "multiple-line text box"

4. Input the following settings

Title: (your choice but should reflect it is intro)

Description: (once again your choice)

Max length: (has to be more then your minimum you will set later)

Field Required: Yes, at registration and profile updating

Private field: yes (can be no if you wish)

Rest of the fields are at your discretion. Make sure you make note of the new field id

Import product-introonregister in Manage Products

Now go to vBulletin Options->Into On Register Option and set the values.

All done! :D

one more thing, where it says "Forum for the intro's to go" in the vbulletin options setting... it needs to be just the last number of the url where your introductions are stored

For example the url where my introductions are stored is at:

http://gamerzcreed.com/forums/forumdisplay.php?f=8

So all I needed to do was put the 8 in the "Forum for the intro's to go" box, not the whole url. If you still can't get it to work, let me know. ;)

SVTCobraLTD
12 Feb 2009, 15:06
Guess reading the instructions would help some.

Now its installed but getting security token error
Your submission could not be processed because a security token was missing or mismatched.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

SVTCobraLTD
16 Feb 2009, 20:27
Guess reading the instructions would help some.

Now its installed but getting security token error
Your submission could not be processed because a security token was missing or mismatched.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

Anyone have any idea?

SVTCobraLTD
04 Mar 2009, 18:45
Got the error above resolved. This makes the post when they sign up, however, does it send them a notification email when they get a response? I see it still leaves their post count at 0.

SVTCobraLTD
05 May 2009, 13:21
Any way to get this to automatically add the new user to their introduction post??

mommiesrus
22 Jun 2009, 03:01
When someone uses this mod, I can see the "thread" in the "Latest Posts" column of my intro forum. The name of poster is different than all other threads - includes hyphen followed by duplicate name)

Stephanie Intro
by Stephanie - Stephanie

When I click on the link, I get this message:

Here is the link by "Latest Posts":
http://getyourdailydose.com/showthread.php?goto=newpost&t=11

When that link is clicked it is redirected to this URL:
http://getyourdailydose.com/showthread.php?p=0#post0

..with the following error:

"vBulletin Message
No Thread specified. If you followed a valid link, please notify the administrator"




Does anyone have any suggestions?

wmlvb
16 Jul 2009, 19:55
is there a way so that members that are already on there.. i.e signed up before i put the hack on.. make it so that they have to update there field.. when they go to post or view a thread it will redirect them to update there profilee.. and this must be done or they cant continue...?


I would like to know this too! Anyway we can do this? Maybe Force them to fill out that field next time they sign in?

wmlvb
16 Jul 2009, 20:40
Do you know what would be an awesome add on tot his mod?

A automatic hyperlink to the intro created placed in the users signature! Any one have a clue how to make something like that happen? Thanks

wmlvb
22 Jul 2009, 00:21
Hey when the thread is created it is show the user has zero posts in postbit for the user still! This is causing the users not to be notified that they have a intro thread and when member are welcoming them they do not see the notifiacion! anyone know how to make the Thread created in registration to show as a posts in the users profie/postbit?

Cybershaolin
24 Aug 2009, 05:58
I love this hack, thanks for having created it. :)

But, I have some problems, as for some of the members have already noticed. Here they are"

1- User posts count is not updated and still shows 0 posts
2- Link to the newpost does not work on the forumhome and link to the lastpost brings you to the wrong thread on the forumhome. Same on the forum display happens. (These are very annoying).
3- Forumhome lastpost poster shows incorrect username like "by Mike - Mike" instead of just "by Mike"
4- Lastpost post icon is shown as a Poll instead of default icon (or some of our own choice would be great).

Besides that, it's still a great hack but I would like to get these problems resolved. Does anybody could help?

vwdforum
13 Sep 2009, 10:41
Can the above be fixed?

Zi55
17 Sep 2009, 01:56
Be careful of this guys , he is a big fraud .
Thanks ,
Zi55

wmlvb
24 Sep 2009, 06:18
Be careful of this guys , he is a big fraud .
Thanks ,
Zi55

what do you mean??

SVTCobraLTD
24 Sep 2009, 17:29
Anyway to get the users post to be an instant subscription? Right now I just add the subscription manually but its a pain.

^SuiCyde^
17 Oct 2009, 10:33
anyone figure out how to get the registration "intro thread" to show up as a post so that when you click on it from the forumhome it doesn't say no thread specified.......

did anyone find a fix?

SVTCobraLTD
02 Nov 2009, 18:12
Anyone running on 3.8.4?

wmlvb
06 Nov 2009, 00:22
Anyone figure this out yet?? I really need this to work right. Someone please help.

Battle_Ring
24 Nov 2009, 17:49
Yep i get No Thread specified. If you followed a valid link, please notify the administrator as well Boo

Mythotical
25 Nov 2009, 02:51
I have gotten the instant subscription working, the addon creator did not include code to update subscription table in the database. I am now working on the post count issue and the issue regarding clicking on the link from the forum and it saying that it is not a valid thread id, I have yet to have that issue and this addon is working on 3.8.x fine.

EDIT: Ok I have ran into the invalid thread id issue. I am looking for a resolution to it but that will have to wait till tomorrow.

Cybershaolin
25 Nov 2009, 03:32
Well, you're probably running into the same issues reported here before, but problem is the hack doesn't look like it's still supported, even if it's tagged as it would be. :confused:



1- User posts count is not updated and still shows 0 posts
2- Link to the newpost does not work on the forumhome and link to the lastpost brings you to the wrong thread on the forumhome. Same on the forum display happens. (These are very annoying).
3- Forumhome lastpost poster shows incorrect username like "by Mike - Mike" instead of just "by Mike"
4- Lastpost post icon is shown as a Poll instead of default icon (or some of our own choice would be great).

Mythotical
25 Nov 2009, 18:58
Well, you're probably running into the same issues reported here before, but problem is the hack doesn't look like it's still supported, even if it's tagged as it would be. :confused:

I am attempting to fix all issues and get ahold of the addon developer to get permission to take over this addon.

ldma
29 Nov 2009, 15:25
Ok, my issue with this mod is, that while I love the concept, it is ripe for spammers to exploit...the problem is that I require email activation and this allows posts without activation being nweccessary meaning that anybody could make thread just making a false registration. Good idea but unpractical for my needs.

Mythotical
29 Nov 2009, 19:15
Ok, my issue with this mod is, that while I love the concept, it is ripe for spammers to exploit...the problem is that I require email activation and this allows posts without activation being nweccessary meaning that anybody could make thread just making a false registration. Good idea but unpractical for my needs.

You are incorrect, if you have those set to go into a forum where its moderated and no one else can see it then how will spammer know it exists unless you openly state that it happens. Going into a moderated forum is safe and keeps spammers from exploiting it.

Mythotical
07 Dec 2009, 18:52
Here is a fix for Forced Intro on Register, this will fix all the of the listed problems above. If everyone likes, please don't hesitate to donate to help keep me and my site going for these type of fixes and addons.

Go to:
AdminCP > Plugins & Products > Manage Products > Add/Import Product

Browse to get the file then make sure you select YES for Allow Overwrite then click Import.

Enjoy
Steve

SVTCobraLTD
09 Dec 2009, 18:22
Anyone try the above revised product?

Mythotical
09 Dec 2009, 18:33
I have tested it on my test site and a live site. I will have the owner of the live site post here for you SVTCobra

wmlvb
09 Dec 2009, 18:47
Anyone try the above revised product?
:up:

Yes I can confirm. My newest members are now automatically subscribed to the thread that is generated during registration. They are showing one post and the are finding the thread and replying back. IT is an awesome mod

You can see my many posts above begging for a fix. I really needed this mod to work.

Steve M spent a lot of time working on this fix for me. Please help support his efforts by donating. Also if you are looking for a good coder for other fixes and customization to mods, PM Steve M. He does excellent work.:)

SVTCobraLTD
10 Dec 2009, 11:54
:up:

Yes I can confirm. My newest members are now automatically subscribed to the thread that is generated during registration. They are showing one post and the are finding the thread and replying back. IT is an awesome mod

You can see my many posts above begging for a fix. I really needed this mod to work.

Steve M spent a lot of time working on this fix for me. Please help support his efforts by donating. Also if you are looking for a good coder for other fixes and customization to mods, PM Steve M. He does excellent work.:)

Thank you for that information. And a huge thanks to Steve M for the fix.

Mythotical
10 Dec 2009, 14:44
You are welcome SVT.

SVTCobraLTD
15 Dec 2009, 14:20
Working on 3.6.8 with new mod by Steve M. However look at the screen shot, next to Last Post, there is nothing. Just thought I would mention that.

Mythotical
15 Dec 2009, 15:26
Oh boy, another bug, I will get it fixed as soon as I have a minute away from my work and other updates.

BansheeDK
24 Dec 2009, 01:40
My users love this mod. Will it be available for 4.0?

gollo
13 Aug 2010, 12:27
is available for VB4 ?

fxwoody
23 Sep 2010, 13:30
Really like this little plugin ;) Work well and simple for the members to fill up! Tho, i have a good question, my Forum is bilingual and got french and english introduction sub-forums! Is there a way that we can add to the codes for it to go into the proper forum ID depending on if they make and english intro or french one???

I know most of them adjust their language preference before making the registration, so , if set to french goes into ....french forum ID #etc and if english goes to other one???

Anyway's of doing this with the plugin???

Tks

bada_bing
23 Sep 2010, 18:07
Does this mod work for vb 3.8.x and if not will it be updated looks like a nice feature.

akxt660
27 Sep 2010, 19:19
Have a way to do the users put the location info on the registration?

firefoxextreme
13 Nov 2010, 18:20
Works perfect on VB 4.08 heehee

fxwoody
21 Feb 2011, 14:21
I don't know if SteveM is still available to work on this mod but it would be really cool if it would be updated to 4.1.x :(

I tried Steve's mod but end up with bad results:
Parse error: syntax error, unexpected '(', expecting T_VARIABLE or '$' in /home/xxxxx/public_html/test/register.php(338) : eval()'d code on line 66

Wouldn't mind to donate to the one who will fix it ;)

zeus_r6
01 Mar 2011, 01:23
I was using this on 3.8.x and it was awesome...would love to see it updated to 4.1.x as well :)

vwdforum
13 Mar 2011, 11:36
Yep I would love to see and ungrade to 4.12

zeus_r6
13 Mar 2011, 15:03
Miss this hack bigtime!

jonohara
21 Mar 2011, 02:05
id like to see this work on 4.1x

zeus_r6
21 Mar 2011, 05:36
+100000

vwdforum
08 May 2011, 19:40
This is working on my vb 4.1.2

Is it possible for the member to be subscribed to their intro thread so they know when a person replies?

zeus_r6
08 May 2011, 23:11
Well look at that...just reinstalled it and it's working on my 4.1.2

fxwoody
28 Sep 2011, 12:17
confirmed that it work in 4.1.3
little problem with postcount only.....doesn't add it :(

vwdforum
12 Feb 2012, 11:06
This is working on my vb 4.1.2

Is it possible for the member to be subscribed to their intro thread so they know when a person replies?


Another push to get this implement, this is a great mod!

vwdforum
02 Mar 2013, 22:28
Another push to get this implement, this is a great mod!

any chance of adding this suggesting?

joeychgo
08 Aug 2013, 05:26
works fine on 4.21