PDA

View Full Version : New Posting Features - UnC Move Post Icons Above Message Area.


UncoderMom
31 Jan 2008, 14:14
I have seen this requested many times here and never have seen anyone post the template modification for it. I recently decided to do it myself and thought I'd share.

Already it has increased its use 10 fold!


OPEN templates newthread and newreply and do the following edits.
SAME EDITS FOR BOTH TEMPLATES


Find

<!-- / subject field -->

After add

$posticons

Scroll down and find

$posticons

Delete it.

Save and your done,

Very simple! Thats it!

Allan
31 Jan 2008, 15:10
Install on my forum, thank, good idea :)

valdet
31 Jan 2008, 19:36
Thats a neat little trick. Thanks.

UncoderMom
31 Jan 2008, 20:17
Your welcome!

You can do it in the pm reply's too.. if you want.

Thomas P
27 Mar 2008, 11:41
Does tabbing still work?

UncoderMom
02 Apr 2008, 05:21
Not sure what you mean by tabbing? are you usingg a custom modification? If you are link me to it and Ill look where their edits are. Likely they are IN the posticon template itself and everything should be fine :)

Thomas P
02 Apr 2008, 10:04
I tested this on our internal test forums.

Please try to use the TAB key to change from thread titel to thread message, then to post icons and then to send message.
In my tests tabbing (changing the focus) from post icon to send button doesn't work.
I'm send back to the message text window.

Thanks :)

UncoderMom
02 Apr 2008, 14:34
Okay I tested and I see what your saying.. but actually even though it bounces back up to the no icon section.. if you press enter and have the thread title filled in and message is long enough it enters. I use tab to enter all my threads and never noticed that lol.

My test went like this hit new thread > hit tab (takes me to title box) type title > hit tab again (takes me to icons) arrow key to the icon I want > hit tab again (takes me to message box) type message) hit tab again and it goes back to up to the no icon. Press enter it submits the thread (even though the tab is positioned on the no icon). It doesnt change to no icon either. It stays what I previously chose.

One thing though. I always had to click post icon as tabbing took me straight to enter (default vb). Seems no matter what you do.. sometimes you gotta click. lol Like for the new tags system.

I'm not sure how to make it tab to enter instead of back to no icon but I will investigate.

It works.. as long as you dont look. LOL

Aclikyano
06 Apr 2008, 17:42
thx got it!

Charlie98902
28 May 2008, 02:59
Thanks works on 3.7.0 gold as well.

Super Jinni
28 May 2008, 03:44
nice idea, I like it

installed

thanks

Charlie98902
29 May 2008, 02:32
You can go into styles>>>edit template>>>>>Private Message Template>>>>pm_newpm and do the same if you want to move it up in there too. Thought I would pass this on.

carrlos
29 May 2008, 02:55
Great idea!

UncoderMom
30 May 2008, 13:17
Your welcome!

trigatch4
11 Jul 2008, 15:09
Awesome, thanks!

Is it possible to make the icons appear in a "dropdown box" next to the "Thread Title" instead full list in columns?

mystic10
15 Jul 2008, 22:12
I WAS WONDERING IF U CAN help me with this code...i have 20 icons...i want to only show 7 and the rest i want to give option for more...just like the smiles...u choose how many u want to display and the rest u need to click more and it will take u to another page...

UncoderMom
17 Nov 2008, 01:19
I WAS WONDERING IF U CAN help me with this code...i have 20 icons...i want to only show 7 and the rest i want to give option for more...just like the smiles...u choose how many u want to display and the rest u need to click more and it will take u to another page...

I probably could but not any time soon, sorry. Holidays and moving limit my time online these days. *sigh*

dmknights
17 Nov 2008, 07:27
*Installed*
Any Chance of moving the smilies too?

UncoderMom
18 Nov 2008, 18:18
*Installed*
Any Chance of moving the smilies too?

Do you want the smilies IN the gray part, just above the editor tool bar or do yo uwant the smilie box moved out of the gray and above the "message area below the "title".



You have to edit your editor_toolbar_on template.

Try something like this

Find
<td id="$editorid" class="vBulletin_editor" width="100%">

After add

<if condition="$smiliebox">$smiliebox</if>

scroll down find

<if condition="$smiliebox"><td class="controlbar">$smiliebox</td></if>

delete it.

That will give you the smiles in the same gray table, just on the top.

Not sure if its "right" but it works lol.

dmknights
18 Nov 2008, 18:30
its nothing to do with the toolbar, but ive discovered how to do it

UncoderMom
18 Nov 2008, 18:32
hmmm I guess I misunderstood you then.

Glad you figured it out though! :)

robbiefritz
12 Jan 2009, 00:08
Very nice. I can see where this will help especially for folks new to forums and posting. Thanks

yingzhou
14 Jan 2009, 09:38
nice ideas.