PDA

View Full Version : Forum Display Enhancements - Thread Listing Background Colors Like vBulletin.org


Hasann
03 Apr 2008, 01:46
Thread Listing Color Status Like vB.Org by Hasann

What does it?:

Thread Listing Color Status: This option allows you to color code threadbits based on specific status of the thread:

New Thread or Post
Sticky Thread
Poll Thread
Posted Thread
Popular Thread
Closed Thread
New Announcement
Normal Old Thread


Currently Feature List:


Fully Phrased
Compatible with all Styles
Compatible with "Modification System" Hack
Added Per User Function: this hack does work per selected user
The system can be turned on and off.
You can set own background colors per threadbits based on specific status of the thread


Install Instructions:

just import product .xml file via product manager that's all it :eek:

Available Languages

English
Türkce


Note: this hack replaces the old threadbit template with the new threadbit_bgcolors template also it replaces the templates. If you before made any template edits for threadbit template do it also for threadbit_bgcolors template too

If you like this modification -> Please just clicks install and MOTM buttons

Comments, suggestions, translations, bugs, etc... are very welcome! Support is only given to people who have clicked INSTALL.

Hasann
03 Apr 2008, 01:47
First post reserved for new features!

SEOvB
03 Apr 2008, 02:08
Another good hack, thanks Hasann!

asj
03 Apr 2008, 02:15
Plain boat !!

TTG
03 Apr 2008, 02:50
Installed, but had to disable 'cos the forum footer right side graphic disappears !? .. see attached :-

ssslippy
03 Apr 2008, 04:23
I wanna say thanks for this. I think its a freaking awesome system.

MR-2ZZ
03 Apr 2008, 06:38
screws up my footer :(

Hasann
03 Apr 2008, 08:22
Installed, but had to disable 'cos the forum footer right side graphic disappears !? .. see attached :-

screws up my footer :(

pm me your site addresses

codershark
03 Apr 2008, 08:23
This Hack create a empty leftside columne :( and delete the background of the footer

Hasann
03 Apr 2008, 08:38
Installed, but had to disable 'cos the forum footer right side graphic disappears !? .. see attached :-

screws up my footer :(

This Hack create a empty leftside columne :( and delete the background of the footer

updated and fixed buddies please re-import new xml file overwrite

I hope template bugs fixed now

codershark
03 Apr 2008, 08:50
the new xml dont repair the mistakes.

Hasann
03 Apr 2008, 08:54
the new xml dont repair the mistakes.

Note: this hack replaces the old FORUMDISPLAY template with the new FORUMDISPLAY_BGCOLORS template also it replaces the templates. If you before made any template edits for FORUMDISPLAY template do it also for FORUMDISPLAY_BGCOLORS template too

yilmaz
03 Apr 2008, 09:26
Best thanks to the great thing is you are the best

samet54
03 Apr 2008, 11:19
harıka guzel birşey muhtesem oldu ya elıne saglık

impuLsive
03 Apr 2008, 11:26
MySQL Error : Unknown column 'bgcolorspermissions' in 'field list'

I get that error when trying to update permissions for my admin group, so I uninstalled it for now. Changing permissions in forums works fine though.

Hasann
03 Apr 2008, 11:33
MySQL Error : Unknown column 'bgcolorspermissions' in 'field list'

I get that error when trying to update permissions for my admin group, so I uninstalled it for now. Changing permissions in forums works fine though.

updated and fixed please re-import new xml file overwrite

KURTZ
03 Apr 2008, 11:39
*Kurtz watches this hack :D really nice job!

anyway i'm wondering and suggest you a feuature: if i wanna colorize only the Announce or the Sticky (i don't care about the normal threads) can i do that? hope you understand :)

iyihost
03 Apr 2008, 11:53
Good Hasann it's perfect hack

HaYLaZ
03 Apr 2008, 12:37
good job;)

TTG
03 Apr 2008, 12:45
Note: this hack replaces the old FORUMDISPLAY template with the new FORUMDISPLAY_BGCOLORS template also it replaces the templates. If you before made any template edits for FORUMDISPLAY template do it also for FORUMDISPLAY_BGCOLORS template too

Latest xml still creates footer problems on my site.
Can you omit the footer template edits from the xml and let us do them manually to see if we can solve the problem !?

choccyclaire
03 Apr 2008, 13:40
Why didn't whoever creates the plugins for vbulletin post this? :p

I will try later. :)

Hasann
03 Apr 2008, 13:47
*Kurtz watches this hack :D really nice job!

anyway i'm wondering and suggest you a feuature: if i wanna colorize only the Announce or the Sticky (i don't care about the normal threads) can i do that? hope you understand :)
yes I can do this feature
Latest xml still creates footer problems on my site.
Can you omit the footer template edits from the xml and let us do them manually to see if we can solve the problem !?
yes you can make manually template edit

first step is delete the FORUMDISPLAY_BGCOLORS template from this hack
and search in FORUMDISPLAY template this code

<if condition="$pagenav"><td align="$stylevar[right]">$pagenav</td></if>

than add above this code


<if condition="$vbulletin->options['enable_thread_listing_color_legend_box'] == 1">
<td align="$stylevar[left]">
<table class="tborder" cellpadding="3" cellspacing="$stylevar[cellspacing]" border="0">
<tr>
<div class="smallfont" align="$stylevar[left]"><strong>$vbphrase[hasann_color_legend]</strong>:</div>
<td class="newpost" align="center"><span class="smallfont">$vbphrase[hasann_new_post]</span></td>
<td class="stickythread" align="center"><span class="smallfont">$vbphrase[hasann_sticky_thread]</span></td>
<td class="pollthread" align="center"><span class="smallfont">$vbphrase[hasann_poll_thread]</span></td>
<td class="postedthread" align="center"><span class="smallfont">$vbphrase[hasann_posted_thread]</span></td>
<td class="popularthread" align="center"><span class="smallfont">$vbphrase[hasann_popular_thread]</span></td>
<td class="closedthread" align="center"><span class="smallfont">$vbphrase[hasann_closed_thread]</span></td>
<td class="announcement" align="center"><span class="smallfont">$vbphrase[hasann_announcement_thread]</span></td>
</tr>
</table>
</td>
</if>


and make this template edit 2 times
Why didn't whoever creates the plugins for vbulletin post this? :p

I will try later. :)

what do you mean ??

TTG
03 Apr 2008, 14:35
and make this template edit 2 times


Not quite sure where I need to add the template edits "2 times" !?

Hasann
03 Apr 2008, 14:42
Not quite sure where I need to add the template edits "2 times" !?
There are two times this code in forumdisplay template
in FORUMDISPLAY template find

<if condition="$pagenav"><td align="$stylevar[right]">$pagenav</td></if>

add this code above

<if condition="$vbulletin->options['enable_thread_listing_color_legend_box'] == 1">
<td align="$stylevar[left]">
<table class="tborder" cellpadding="3" cellspacing="$stylevar[cellspacing]" border="0">
<tr>
<div class="smallfont" align="$stylevar[left]"><strong>$vbphrase[hasann_color_legend]</strong>:</div>
<td class="newpost" align="center"><span class="smallfont">$vbphrase[hasann_new_post]</span></td>
<td class="stickythread" align="center"><span class="smallfont">$vbphrase[hasann_sticky_thread]</span></td>
<td class="pollthread" align="center"><span class="smallfont">$vbphrase[hasann_poll_thread]</span></td>
<td class="postedthread" align="center"><span class="smallfont">$vbphrase[hasann_posted_thread]</span></td>
<td class="popularthread" align="center"><span class="smallfont">$vbphrase[hasann_popular_thread]</span></td>
<td class="closedthread" align="center"><span class="smallfont">$vbphrase[hasann_closed_thread]</span></td>
<td class="announcement" align="center"><span class="smallfont">$vbphrase[hasann_announcement_thread]</span></td>
</tr>
</table>
</td>
</if>

TTG
03 Apr 2008, 14:50
There are two times this code in forumdisplay template
in FORUMDISPLAY template find



That's what I thought but the code :-

<if condition="$pagenav"><td align="$stylevar[right]">$pagenav</td></if>

only appears once in my forumdisplay template.
I also noticed that if I re-add the template "FORUMDISPLAY_BGCOLORS" .. the above code only appears once ?

If I add the additional code above the above listed code line in forumdisplay, I get a blank page when trying to access any forum !?

macc
03 Apr 2008, 16:03
hello!

how to delete forumdisplay_bgcolors template (mean in admin cp)?

reg

macc

FleaBag
03 Apr 2008, 22:01
Great hack Hasann. Thank you.

Teşekkür ederim!

Hasann
03 Apr 2008, 22:07
That's what I thought but the code :-

<if condition="$pagenav"><td align="$stylevar[right]">$pagenav</td></if>

only appears once in my forumdisplay template.
I also noticed that if I re-add the template "FORUMDISPLAY_BGCOLORS" .. the above code only appears once ?

If I add the additional code above the above listed code line in forumdisplay, I get a blank page when trying to access any forum !?
I will fix all bugs until tomorrow and release the new version
hello!

how to delete forumdisplay_bgcolors template (mean in admin cp)?

reg

macc
that is in your admincp -> styles manager
Great hack Hasann. Thank you.

Teşekkür ederim!

vauww matthew where you can so good turkish :p

macc
03 Apr 2008, 22:47
hello!

i know that is in styles manager in admin cp ... but how to delete??


reg

macc

Hasann
03 Apr 2008, 22:53
hello!

i know that is in styles manager in admin cp ... but how to delete??


reg

macc

wait until tomorrow comes up the new version

macc
03 Apr 2008, 23:00
no problem ..i think just what you said before ...at delete that forumdisplay_bgcolors template and use forumdisplay template and put there code... will just test ...


regards

macc

Reeve of shinra
03 Apr 2008, 23:12
I like the idea, but it just isnt practical for me unless I can select the color I want the background to be while making the thread.

This also breaks my tables :(

Bounce
03 Apr 2008, 23:43
Either I'm doing something wrong or I'm stoopid...

I don't see the difference ?

I've enabled every setting needed but no colours show :eek:

EDIT: To get this to work I had to edit my own user cp

Thread Listing Color Status and set to YES...

Is there a way it could be default yes ?

I'm presuming its this:
# Added Per User Function: this hack does work per selected user

Mike-D
04 Apr 2008, 00:15
It's the same like here: Threadbit Coloring Based on Thread Status (http://www.vbulletin.org/forum/showthread.php?t=142857)

Bounce
04 Apr 2008, 00:24
It's the same like here: Threadbit Coloring Based on Thread Status (http://www.vbulletin.org/forum/showthread.php?t=142857)

vB Version: 3.6.5 thou mate :up:

Derek Chai
04 Apr 2008, 06:02
Nice! Can you do it where the user can specify the color. In any topic?

ssslippy
04 Apr 2008, 14:13
Is there a query I can use to apply this to all the forums?

KURTZ
04 Apr 2008, 14:14
yes I can do this feature



OK dude, i'm waiting new develops ... :D

*MOD TAGGED

BuRaCh
06 Apr 2008, 07:21
:up:Superb Friend;)
installed.

Legendery.
06 Apr 2008, 19:08
Good job sir..
Im downloading...
Thanks :)...

Sworm
10 Apr 2008, 17:52
This mod don't work on Vbulletin 3.7RC2!

Tom_S
11 Apr 2008, 11:10
It isn't working for me on 3.7RC1 Hmm...I went over and over it and it is installed correctly. I will give it another try later.

codershark
11 Apr 2008, 11:14
bad coded .....

Tom_S
13 Apr 2008, 00:23
I went back through it 3 more times and it is installed correctly and it does not work with my 3.7.0 RC1

EDIT:
My mistake. It does work. I missed the part of each member evidently has to turn this option on for themselves which does not make any sense. That should be an admin option. This mod makes far too much work for the admin to get it to function.

Tom_S
13 Apr 2008, 00:51
That sounded completely ungrateful and I did not intend for it too Hasann. It is an excellent mod. It is just my opinion that for ease of use those things could be considered.

Thank you ever so much for all of your hard work on all the mods you have made as I find everything you do very useful and I appreciate your work very much. :)

Hasann
13 Apr 2008, 01:05
This mod don't work on Vbulletin 3.7RC2!

It isn't working for me on 3.7RC1 Hmm...I went over and over it and it is installed correctly. I will give it another try later.

bad coded .....

That sounded completely ungrateful and I did not intend for it too Hasann. It is an excellent mod. It is just my opinion that for ease of use those things could be considered.

Thank you ever so much for all of your hard work on all the mods you have made as I find everything you do very useful and I appreciate your work very much. :)

don't judge too quickly :(
it does work if you make all admincp settings correctly
anyway thank you for your opinion Tom_S :)

Tom_S
13 Apr 2008, 05:24
It would be better in my opinion if it was defaulted to already have it so users were seeing the settings and if they did not want them they had to shut them off instead of turning them on.

Also the settings in each forum already defaulted to being used turned on instead of having to go in to each one and turn it on it would be easier to go into the ones we didn't want them in and turn them off. Less time consuming that way.

The same for each usergroup. All on.

If everything was defaulted to being already on it just would be much easier to turn off what was not needed than to go and turn on everything that you do want on.

Just a thought ;)

flipstyle
14 Apr 2008, 16:39
Hi Hasann,

When I was trying to figure it out to get it all running it took me a while to see the colors. Since I have a lot of categories Tom_S has a good point about having everything turned on by default. It would take me hours just to have all the forum categories & subforms turned on. Also Is there anyway to have the user color legend (in the usercp edit options) set to yes by default so everyone has it on. If you know any way how to turn everything to default -yes- please let me know that would really help out. Thanks.

I really like your plugin. Good work I appreciate it.
(I'm using it on vBulletin 3.7 RC3 and works with no problems)

flipstyle
15 Apr 2008, 18:54
Hey Tom_S if you want to change all the settings to Yes.
One method is to use phpmyadmin and run a query and set everything to 1.

Just an Idea for a future version. Users should be able to choose their own colors that they want for the thread in their edit options.

Tom_S
15 Apr 2008, 23:21
I appreciate that and know I can do that but I would rather Hasann did that with the mod as with any mod I am sure there will be updates in the future and I would hate to have to continue to fix it as I know my old mind will forget. ;)

I may do that though if it isn't done however. Thanks again. :)

MuGiSouL
16 Apr 2008, 16:06
thnx,installed hasann kardeşim

TTG
17 Apr 2008, 16:43
Is this working correctly now without messing up the footer template ?

KURTZ
17 Apr 2008, 17:46
i'm waiting some new features ... :P

baymortgage99
20 Apr 2008, 08:04
Colored stickys

I love it

flipstyle
02 May 2008, 05:37
When I upgraded to vB 3.7 Gold I got this message. (I only had this plugin running.)

Your submission could not be processed because a security token was missing.
(You will see this message when you try to use any of the moderation drop down options, for example detele thread.)

To fix this problem you have to edit the xml file.
Upload and then overwrite.

Find:
<form action="inlinemod.php?forumid=$forumid" method="post" id="inlinemodform">

Add this below it:
<input type="hidden" name="securitytoken" value="$bbuserinfo[securitytoken]" />

I did some testing so far its working.
The only thing I noticed that the plugin did change was the order of the moderation drop down options. Theres nothing wrong with that just had to let you guys know.

Hasann do yo know how I can set a color for moved threads? (it keeps showing up as the poll thread color)

baymortgage99
02 May 2008, 13:08
I missed the part of each member evidently has to turn this option on for themselves which does not make any sense. That should be an admin option. This mod makes far too much work for the admin to get it to function.


Where does the user have the option to turn this on?

I installed the hack but dont see in the admin control panel or where registered users can turn this on ???:confused:

baymortgage99
02 May 2008, 13:35
Not sure I got this one properly installed or if Im misisng something on the settings

I set it per forum, per user group

Anything else? Am I maybe missing?

I dont see this working

flipstyle
02 May 2008, 17:54
The last step to be able to see if is to turn it on in your user cp.

You have to goto Usercp > Edit Options - Thread Listing Color Status - Set to Yes

All the settings defaults are set to No.
So that means for new registrations and existing accounts will all be set to the option no by default.

I made a post a while ago about changing the settings all at once:
http://www.vbulletin.org/forum/showpost.php?p=1491378&postcount=49

baymortgage99
03 May 2008, 23:30
The last step to be able to see if is to turn it on in your user cp.

You have to goto Usercp > Edit Options - Thread Listing Color Status - Set to Yes

All the settings defaults are set to No.
So that means for new registrations and existing accounts will all be set to the option no by default.

I made a post a while ago about changing the settings all at once:
http://www.vbulletin.org/forum/showpost.php?p=1491378&postcount=49

Your right , thats it ! Is there a way to have the default set as "YES" ?

wolfstream
17 May 2008, 01:53
While in theory this is good, it's not good, simply because of the number of "hoops" that one has to jump through to get it working, and, well, the fact that it just DOESN'T work on 3.7 at all.

Why should an admin have to edit 50+ forums to get this working?
Why should an admin have to edit hundreds of users to get this working?
Why should an admin have to edit numerous usergroups to get this working?

In theory, a good idea. In practice, not so much.

Lindsey
18 May 2008, 05:18
Stable? Works on Stable?

flipstyle
21 May 2008, 01:52
While in theory this is good, it's not good, simply because of the number of "hoops" that one has to jump through to get it working, and, well, the fact that it just DOESN'T work on 3.7 at all.

Why should an admin have to edit 50+ forums to get this working?
Why should an admin have to edit hundreds of users to get this working?
Why should an admin have to edit numerous usergroups to get this working?

In theory, a good idea. In practice, not so much.

You have a good point. I hope the coder will look into it sometime soon and some of my ideas that I posted before.

xorex
28 May 2008, 06:03
Great hack !! thanx

I have one problem:

Does not work Thread Thumbnail (http://www.vbulletin.org/forum/showthread.php?t=174973) where it is used Listing Background Colors Any suggestion?

goddess_dix
29 May 2008, 01:21
Stable? Works on Stable?
security tokens are missing for mod dropdowns, so i wouldn't install on stable unless you want to compare it to the current template and add them manually.

Aurore
31 May 2008, 05:51
Nice but needs improvements :)

Mike-D
31 May 2008, 11:16
While in theory this is good, it's not good, simply because of the number of "hoops" that one has to jump through to get it working, and, well, the fact that it just DOESN'T work on 3.7 at all.Exactly! Try using Threadbit Coloring Based on Thread Status (http://www.vbulletin.org/forum/showthread.php?t=142857). With that Hack I've never got any problems. Especially not in vB 3.7. This hack runs strong without any problems till today :)

PGAmerica
16 Jun 2008, 00:04
Well, it seems that all are agreed that we need to allow for the users to have this option set to "yes" be default. And there are ways to do an sql query to set all current users to "yes", but this does not solve the problem with new users.

OK, I figured it out. If you want to make all the options set to "yes" by default. That is,
Enable for this forum category thread listing background colors? (Forum Manager)
Can this Usergroup Use the Forumdisplay Thread Listing Background Color? (Usergroup Manager)
Thread Listing Background Color Legend (UserCP)All you have to do is the following:
Step 1:
Edit the "product-thread_listing_bgcolors_english.xml" file
Step 2:
Look for $vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "forum ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '0 NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "usergroup ADD COLUMN bgcolorspermissions INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL");
and replace it with $vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "forum ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "usergroup ADD COLUMN bgcolorspermissions INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");

Step 3:
Upload the new product via the "Manage Products" link in your ACP
Step 4:
Enter the "Usergroup Manager" and edit any of the usergroups. This will rebuild the BitFields.

If you have already done this, just uninstall it, make the changes and then reinstall it.

It just worked for me perfectly.

Captain Tycoon
16 Jun 2008, 17:24
Is it possible to make it so that guests can also see the background colours on the threads without having to register?

Including, is it possible so members won't have the choice whether they can or cant see the background colours on the threads.

PGAmerica
16 Jun 2008, 19:29
Goto the usergrop manager and edit the "Unregistered" group. It is at the bottom

Captain Tycoon
17 Jun 2008, 10:07
Goto the usergrop manager and edit the "Unregistered" group. It is at the bottomIt doesnt work :( Does it work for you?
Including, is it possible so members won't have the choice whether they can or cant see the background colours on the threads.
How about this? I want the option to be forced so they can't choose not to see the thread listing background colours.

beduino
21 Jun 2008, 16:37
hello,
a question:
how we can change the default options AFTER install?

a suggestion:
Include in readme how we can change forumdisplay to build a forumdisplay_bgcolors. A lot of people have forumdisplay already changed and maybe is useful some instruction how we can change the template.

But - tks a lot :D
joao barroca
aka beduino

puertoblack2003
01 Aug 2008, 17:51
Well, it seems that all are agreed that we need to allow for the users to have this option set to "yes" be default. And there are ways to do an sql query to set all current users to "yes", but this does not solve the problem with new users.

OK, I figured it out. If you want to make all the options set to "yes" by default. That is,
Enable for this forum category thread listing background colors? (Forum Manager)
Can this Usergroup Use the Forumdisplay Thread Listing Background Color? (Usergroup Manager)
Thread Listing Background Color Legend (UserCP)All you have to do is the following:
Step 1:
Edit the "product-thread_listing_bgcolors_english.xml" file
Step 2:
Look for $vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "forum ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '0 NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "usergroup ADD COLUMN bgcolorspermissions INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL");
and replace it with $vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "forum ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");
$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "usergroup ADD COLUMN bgcolorspermissions INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");

Step 3:
Upload the new product via the "Manage Products" link in your ACP
Step 4:
Enter the "Usergroup Manager" and edit any of the usergroups. This will rebuild the BitFields.

If you have already done this, just uninstall it, make the changes and then reinstall it.

It just worked for me perfectly.



thanks that worked

puertoblack2003
01 Aug 2008, 18:22
had security token issues but fixed it from this post #55 (http://www.vbulletin.org/forum/showpost.php?p=1505346&postcount=55)

thecricketzone
04 Aug 2008, 22:13
^agree its a nice hack but its a hassle to get it to work. i think ive followed every step but it still doesnt show up and there should be a way to set this for all users from ACP in any single usergroup. So I am uninstalling :(

mcyates
04 Aug 2008, 22:21
Not showing for me either.

Deadly Assassin
09 Aug 2008, 10:02
Uninstalled, could not get this to sit right. It keeps messing up my footer etc.

Nice idea though

akonze
10 Aug 2008, 10:35
This is a very interesting hack. I have two questions:

1. Is it possible to only color a some thread? Lets say only sticky and new threads, or do I always have to color all threads?

2. I saw the settings in the user cp. Can it be turned off, that the user can switch this on/off on his own?

Zimbru
13 Aug 2008, 16:29
This is a very interesting hack. I have two questions:

1. Is it possible to only color a some thread? Lets say only sticky and new threads, or do I always have to color all threads?

2. I saw the settings in the user cp. Can it be turned off, that the user can switch this on/off on his own?

That will be very nice.
Im looking for something wich change colors only for new posts.

There is one only for sticky here: http://www.vbulletin.org/forum/showthread.php?p=1596860#post1596860

If anyone can help me with newposts , let me know please. Thanks

ssslippy
16 Aug 2008, 23:39
I have fixed the security and footer issue waiting for authors permission to post a fix in this thread. Also updated the other code in the moderation drop down as it was wrong.

Basically if anyone wants to fix the footer issue the whole area between
<!-- controls below thread list --> and <!-- / controls below thread list --> should be copy and pasted and then reinsert the code where ever you wish.
<if condition="$vbulletin->options['enable_thread_listing_color_legend_box'] == 1">
<td align="$stylevar[left]">
<table class="tborder" cellpadding="3" cellspacing="$stylevar[cellspacing]" border="0">
<tr>

<td class="newpost" align="center"><span class="smallfont">$vbphrase[hasann_new_post]</span></td>

<td class="stickythread" align="center"><span class="smallfont">$vbphrase[hasann_sticky_thread]</span></td>

<td class="pollthread" align="center"><span class="smallfont">$vbphrase[hasann_poll_thread]</span></td>

<td class="postedthread" align="center"><span class="smallfont">$vbphrase[hasann_posted_thread]</span></td>

<td class="popularthread" align="center"><span class="smallfont">$vbphrase[hasann_popular_thread]</span></td>

<td class="closedthread" align="center"><span class="smallfont">$vbphrase[hasann_closed_thread]</span></td>

<td class="announcement" align="center"><span class="smallfont">$vbphrase[hasann_announcement_thread]</span></td>

</tr>
</table>
</td>
</if>

ssslippy
17 Aug 2008, 16:34
Here is the fixed version with the security update. Please note I had to relocate the bottom legend to down a block to avoid the footer issue.

inciarco
05 Sep 2008, 10:07
Thanks Hasann for this Great Mod. :up:

Your Mods are Excellent. :up::up:

One Tip that some Forumers have been asking in previous Posts.

To Enable the Mod for all the Forums is just a Matter of Editing the Following Plugin:

Admin Control Panel -> Plugin Manager -> Product : Forumdisplay Thread Listing Background Colors -> Parse Templates

Removing the Conditional Code Line

$foruminfo['bgcolors'] AND

that is the One that Checks for that Option that otherwise should be set for Each Forum.

That's it.

My Best Regards.

:)

inciarco
05 Sep 2008, 10:16
That was a Way to Get over the Forums Options, but perhaps Hasann could share with us a Query to Run it on vBulletin to Set to 1 the Options for All the Forums to Display the Thread Listings.

That would be a Better Choice, because wouldn't alter the Code and also the Option could be changed back to "No" for any Desired Forum.

I Hope Hasann can Help us with that Query. :confused:

My Best Regards.

:)

inciarco
06 Sep 2008, 01:45
This Mod causes a "Security Token" Error when Enabled on a Forum that Has it Activated, and Trying to Use Moderator/Administrator Features to "Move", "Stick" and other Features to a Thread. :confused:

Exact Error Says: "Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error."

When Choosing Not to Use the Mod on the User Control Panel Options, and trying to make the same Moderation Actions, then the Error doesn't Triggers.

Should be nice to Review the Code to see what could be Causing this Problem with the Security Tokens, when the Moderator/Administrator has the Mod Turned On and tries to Perform Moderation Actions on Threads.

I Hope this Bug Gets Fixed.

(Edit: I've seen that This Mod seems to Use another Version of the "FORUMDISPLAY" Template, or Masive Rewrite it, because when I tried to Include a Button next to the New Thread Button, I was completely Unable to do it, also when I tried to Place it in other Location on the Template nothing happened, so I think perhaps that Usage of Other Template and/or Massive Rewrites of the Current One, could be the Ones Causing the "Security Token" Error Problem).

My Best Regards.

:)

ssslippy
06 Sep 2008, 02:02
It uses its own templates, I attached an updated to fix this.

inciarco
06 Sep 2008, 05:06
It uses its own templates, I attached an updated to fix this.

It Doesn't Work. The Error Persists.

I'll Keep the Original Version, and Wait for a Solution from the Original Developper like this one (in the Mod of Report PM for vB36x for it to Work on 37x): http://www.vbulletin.org/forum/showpost.php?p=1578236&postcount=72

The Original Version also has more Features.

My Best Regards.

:)

GoTTi
21 Sep 2008, 01:58
can all forums be set to the yes option for enabled to use the bg colors automatically instead of me doing it 1 at a time?

Hasann
19 Oct 2008, 15:56
all reported bugs fixed and upgraded for vBulletin v3.7.3

profanitytalker
20 Oct 2008, 10:23
reserve

Hasann
20 Oct 2008, 16:25
Im waiting for your feedback :)

Thug
26 Oct 2008, 16:32
this didnt work for me at all

KOKS@LN
29 Oct 2008, 06:27
Thank you very beautiful were the

rob01
29 Oct 2008, 07:06
i try, but i cant see the background color change.. any ideas?

sensimilla
29 Oct 2008, 12:19
i try, but i cant see the background color change.. any ideas?

You have to enable it in UserCP

sensimilla
29 Oct 2008, 12:23
Seems its not working very good with vb 3.7 and prefixes, any ideas ?

TIA

behcet
29 Oct 2008, 13:01
Teşekkürler.
İstediğimiz forum kategorileri içerisinde kullanabiliyormuyuz ?
Günlük ve yeni konuları gösterirkende kullanılıyormu ?

lms
29 Oct 2008, 19:08
Dejo el archivo product-thread_listing_bgcolors_spanish.xml para los que lo quieran usar en español. Solo he modificado las frases.
************************************************************************
I leave the file product-thread_listing_bgcolors_spanish.xml for those who want to use in Spanish. I just changed the sentences.

Sorry for my bad english (google traductor)

Salud2

J105C
22 Nov 2008, 15:18
Does not even work at all with me either, vb 3.7.3 and enabled in acp... nothing changes, herm

puregraf
24 Nov 2008, 06:32
^^ also the same, not working.

Hasann
25 Nov 2008, 00:32
if not working please uninstall it

Simsi
10 Dec 2008, 10:56
On the latest version of the XML file, to default this to "Yes" in every user's CP options, I had to modify "product-thread_listing_bgcolors_english.xml" before install (or upgrade) as follows:

Changed the line:

$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '0' NOT NULL");

To:

$vbulletin->db->query_write("ALTER TABLE " . TABLE_PREFIX . "user ADD bgcolors INT( 10 ) UNSIGNED DEFAULT '1' NOT NULL");

.
Worked like a dream for me and also worked on existing forum users.

Axe_Grinder
14 Dec 2008, 06:39
After reading through all this... I still really like this hack. I have it installed and it works great.

What I would like to know... is, has anyone found a way to turn this on globally? I have tried every work around in here and haven't gotten any of them to work globally yet.

If I have to use it on a per user basis I will... But, I would love to just be able to turn it on and let them decide to turn it off.

That and I would like to set it that way for unregistered users as well.


Any ideas?

Great work Hasann :) Awesome!

rockinaway
14 Dec 2008, 11:13
Very nice modification! However, I have disabled the colour legend overall. How do I remove the option from the users control panel as well?

yasser4101
14 Dec 2008, 11:23
Good job
:)
Thanks

KevinL
03 Jan 2009, 06:52
I want to install this again, but I would like to do all the template edits manually. Is this possible? I just have to much stuff changed to use this and have it work correctly....like thread thumbnails and even prefixes...

Any help would be great...please.

Thanks

Raptor
08 Apr 2009, 00:39
is there a way to disable having colors for any of these ?

I would like to disable popular thread

trotskid
11 Mar 2010, 10:41
Hi. How can delete some color codes from UCP like sticky thread or poll thread, just like vb.org?

thanks