PDA

View Full Version : how do i fix this


lasto
05 Apr 2008, 07:42
mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: User ***** has already more than 'max_user_connections' active connections
***********/includes/class_core.php on line 274


Is there somewhere i up the connections to the database or is this a Host problem.

SEOvB
05 Apr 2008, 07:49
You need to be able to edit your my.cnf file


And what you're to good to ask me over MSN! :p

lasto
05 Apr 2008, 08:04
no m8 :)

tbh i never even noticed u online :)

Dismounted
05 Apr 2008, 10:26
Basically, there are too many connections happening to the MySQL daemon - a busy site. You will need to contact your host.

Paul M
05 Apr 2008, 11:01
Your host has set a limit on the connections one mysql user can have and you've exceeded it. Either its too low a value or something is hogging connections (or your just too busy).

lasto
05 Apr 2008, 12:20
im on a dedicated server.Is it dangerous to raise it to high ?

royo
05 Apr 2008, 12:56
Depends on how many resources you have.

alphadeity
05 Apr 2008, 16:04
It can be dangerous to set it too high. Raise it up a little bit at a time and see how it runs. I would also disable to search spiders/bots from crawling your forum.

lasto
05 Apr 2008, 16:39
the errors have only been coming since i installed Vbseo.But if i disable spider/bots etc wont that be defaeting the object.I have raised it a little now anyway so will see if it has any effect or stops the errors.

Cheers everyone for replying.

King Kovifor
05 Apr 2008, 16:49
Try disabling vBSeo, or going to them for help. Since their product may be causing high server load.

Yogesh Sarkar
05 Apr 2008, 18:09
It can be dangerous to set it too high. Raise it up a little bit at a time and see how it runs. I would also disable to search spiders/bots from crawling your forum.
Wouldn’t that seriously mar the growth of the forum? I mean if you restrict the search engine spiders, you will eventually get delisted. Its much better to just upgrade hardware and optimize software than stop the search engine bots.

SEOvB
08 Apr 2008, 11:28
Yes it'd totally defeat the purpose of any and all SEO work.

You simply need to raise the max connect user setting and if needed add a crawl delay to the robots.txt to just slow them down :D

ssslippy
08 Apr 2008, 12:14
VBSeo is a huge resource eater. Make sure you have your rewrite rules inside the .conf files and go to VBSeo on how to tweak it so it doesnt eat your server alive.

I can guarentee this is causing the issues for you.

SEOvB
10 Apr 2008, 03:14
I bet its not causing the issue. As vBSEO doesnt add users connecting the the DB, it may add a query here or there, but not an actual user to take up the max_connection slot

ssslippy
10 Apr 2008, 13:01
VBSeo can add some 15 queries per page easy especially if u have all the fancy features on.

Marco van Herwaarden
11 Apr 2008, 10:35
I bet its not causing the issue. As vBSEO doesnt add users connecting the the DB, it may add a query here or there, but not an actual user to take up the max_connection slot
max_connection has nothing to do with "actual users". If it adds a query, it will have to make a connection to the database (unless it reuses an existing connection).