PDA

View Full Version : Forum Home Enhancements - Flipped tabs = Swivel tabs = INVERTED TABS


Deepdog009
12 Apr 2008, 00:52
Flipped tabs = Swivel tabs = INVERTED TABS
*********************************

Installation
********
uninstall old inverted tabbars
*********************

ATTENTION:
*********

Download Inverted Tabbar Tutorial...
Read Instructions please...



Ver...>>> 0.1.0


Admin turn inverted tabs on/off...
Admin option less or more tabs on/off...
Admin option insert title tips...
Admin option insert url's...
Admin option insert Tabbar title...


Ver...>>> 0.1.1


Code fixes
Admin turn on/off 4,6,8 tabs...


Ver...>>> 0.1.2


Admin options CSS [float- left or right]...
Admin options CSS [link hover and link colors for text]...


Ver...>>> 0.1.3


Admin options dropdown menus setup...
Admin five dropdown menus...


Ver...>>> 0.1.4


Admin options add 10 tabs...
Admin on/off 10 tabs...
Fixed margin at top,,, auto template...
Admin more css options...


$invertedtabbar is the $var that is placed into HEADER or FORUMHOME templates...
At top of Header Template as shown below...>>> Set margin-top to {0} for header placement...


$invertedtabbar

<!-- logo -->
<a name="top"></a>

*************************************************

Or place into Forumhome Template as shown below...>>>

$invertedtabbar

<br />
<!-- end what's going on box -->

{Make sure IMAGE PATH is set correctly in admin and Tabbars will turn on}



*************************************************
This release is dedicated 2 those that want 2 try CUSTOM tabs...
*************************************************

If you want to add more tabs???
*************************

Updated newest release with CMPS setup... Use on Frontpage or FORUMHOME...

DEMO (http://www.detupc.net/foro)

Good luck 2 ya!

iogames
12 Apr 2008, 02:16
Interesting :rolleyes:

bada_bing
12 Apr 2008, 03:07
Looks good any chance this works with vb 3.5.x ???

gwerzal
12 Apr 2008, 11:31
looks good, testing it out now.

Deepdog009
12 Apr 2008, 18:29
Folks I forgot to update 2 use with php4...

I set it up using php5 so give me some time 2 make some corrections and then I will upload new update...

And yes it should work with older vbulletin versions with some minor changes to xml code...

Give it a go after I release new update...

macc
12 Apr 2008, 20:00
hello!

have installed and folowed instructions but works not! come any tabs on my forumhome!
where put exactly $vars ?
have vbulletin 3.7 rc-2 !

in admin cp - inverted tabbars 3.7(have a lots }}}}} and {{{{{ on all places)

reg

macc

Deepdog009
13 Apr 2008, 00:28
hello!

have installed and folowed instructions but works not! come any tabs on my forumhome!
where put exactly $vars ?
have vbulletin 3.7 rc-2 !

in admin cp - inverted tabbars 3.7(have a lots }}}}} and {{{{{ on all places)

reg

macc


Place $vars here....>.>>> ((( FORUMHOME ))) $invertedtabbar </br> <!-- End whos online -- >

************************************************************************

Also in header template @ top with {margin: 0; } so that it klings to top of screen...


************************************************************************

Make sure your IMAGE PATH is correct and U downloaded folder 2 correct location...

TTG
13 Apr 2008, 01:40
How could I center the tabbar above the toolbar ?

tiekie
13 Apr 2008, 01:56
This looks great but i need it work in 3.6.8 ... is there any chance you can release one for 3.6.8 if this one dont work ?

DDad
13 Apr 2008, 13:00
Still working on this and one of your other ones on our test forum but getting this one to work.
Notes for you,
When I go from 6 to 8 tabs, the 8 tabs won't show in the admin and in the forum only 2 tabs show. 6 tabs works fine.(fixed)
I have to put it in a code to align it to the right.
Colors don't match our site. (we're changing colors on our site to match your tabs)

I'm not complaining just letting you know! :up:

updated
uninstalled/ reinstalled

Deepdog009
13 Apr 2008, 15:09
Still working on this and one of your other ones on our test forum but getting this one to work.
Notes for you,
When I go from 6 to 8 tabs, the 8 tabs won't show in the admin and in the forum only 2 tabs show. 6 tabs works fine.(fixed)
I have to put it in a code to align it to the right.
Colors don't match our site. (we're changing colors on our site to match your tabs)

I'm not complaining just letting you know! :up:

updated
uninstalled/ reinstalled

**************************************************

DDad when you setup the tabs to show in forumhome you must turn on both SIX and EIGHT together and then all will show up...

Yeah it seems that many have tried this mod,,, but because they have troubles with the IMAGE PATH they gave up and moved on...

I added an update that should help with the IMAGE PATH and make it easier to show tabbars now...

Yes you can add CSS code to make changes,,, thats cool...
If more people use this I will update it with better CSS options from the admin panel...

I have a update coming soon over at Mini Tabbars that should also make them easier to setup...

Thanks DDad;)

**************************************************

TTG How can you center the tabbar above the toolbar ?

Well yes,,, by using CSS you can go ...>>> float : left,,, right,,, center or margin over left or padding over left,,, center or right....>>>

name of item to float {/* header element float */
float: left;
margin: 0px 5px 10px 3px;
padding: 5px 5px 5px 5px
background: #eee8aa;
border-right: 2px dotted #cd853f;
border-bottom: 2px dotted #cd853f;
}

**************************************************

I will maybe update one more time with better CSS control,,, L8ter...

**************************************************

tiekie this mod does work 3.6 and maybe even 3.5,,, but go over to 3.6 and there's an update for it...

Good luck 2 ya!

DDad
13 Apr 2008, 15:25
I think what happened is I had a drop in my connection and something didn't upload right.
I'll keep messing around with it and keep you updated if I find any problems.

Update
Everything is working... went in and changed the left to right and reuploaded the product.

What ever you do from here is extra!

macc
14 Apr 2008, 18:23
Hello!

how get links open in new window ? i mean links in tabs when click on them?

reg

macc

DDad
14 Apr 2008, 22:14
Put this
"target="_blank"
at the end of your url

it should look like this
forum/"target="_blank"
or
forum/blogs"target="_blank"
so on and so on....

Deepdog009
15 Apr 2008, 05:43
Ddad thanks 4 any assists...

I will update this mod once more with better CSS options and its a Done Deal...;)

myown
05 May 2008, 08:02
thanks looks interesting

peterle1
05 May 2008, 11:38
Could we add a drop down navigation to these tabs?

Astrof
04 Jun 2008, 14:29
DeepDog ...

This is a wonderful mod, but your instructions are impossible to understand.

Please write them so that everyone can know what you mean and how to do the necessary steps as your hack is extremely important to everyone who, like myself, has lots of subforums and needs to get this to work as soon as possible.

Therefore, I have a couple of questions that I would appreciate if you would answer so that I can understand:

1) First of all, the second installation step you describe: {2} Upload images folder to forum home root...

Yet, in the .txt file, you write that we need to upload the client script folder as well.

So, which one should we do?

And where? Please describe step-by-step what should be done, where the clientscrip files should be uploaded, if it is necessary at all.

2) Template editing.

PLEASE write EXACTLY what we have to do and WHERE.

That is, just like in all other installation instructions on vb.org: what we should find and what EXACTLY we should add or replace or whatever is needed.

You describe adding $invertedtabbar and margin 0 somewhere, but for the life of me I can't understand where or how, or get it to work. I did everything trying to decipher your instructions, but have failed.

What I need to have is those tabs ABOVE FORUM HEADER, UNDER THE NAVIGATION BAR, WITHOUT TABBARS ON THE TOP OF THE PAGE TOO. Please, instruct me what EXACTLY I have to do, what EXACTLY has to be entered and where EXACTLY.

That is, how the code line looks unmodifyed, then how it will look modifyed.

3) I don't know if this is related, but even though my image paths are right, the buttons are not showing.

Instead, I get this:

https://www.vbulletin.org/forum/external/2008/06/6.gif

vBulletin logo moved to the far right and none of the images showing, just the links.

Also, in the options you wrote "left" two times instead of left and right, but that is less important.

Thanks in advance for your help, you mod is of crucial importance to me and of a lot of us, I'm sure.

Deepdog009
05 Jun 2008, 14:23
DeepDog ...

This is a wonderful mod, but your instructions are impossible to understand.

Please write them so that everyone can know what you mean and how to do the necessary steps as your hack is extremely important to everyone who, like myself, has lots of subforums and needs to get this to work as soon as possible.

Therefore, I have a couple of questions that I would appreciate if you would answer so that I can understand:

1) First of all, the second installation step you describe:

Yet, in the .txt file, you write that we need to upload the client script folder as well.

So, which one should we do?

And where? Please describe step-by-step what should be done, where the clientscrip files should be uploaded, if it is necessary at all.

2) Template editing.

PLEASE write EXACTLY what we have to do and WHERE.

That is, just like in all other installation instructions on vb.org: what we should find and what EXACTLY we should add or replace or whatever is needed.

You describe adding $invertedtabbar and margin 0 somewhere, but for the life of me I can't understand where or how, or get it to work. I did everything trying to decipher your instructions, but have failed.

What I need to have is those tabs ABOVE FORUM HEADER, UNDER THE NAVIGATION BAR, WITHOUT TABBARS ON THE TOP OF THE PAGE TOO. Please, instruct me what EXACTLY I have to do, what EXACTLY has to be entered and where EXACTLY.

That is, how the code line looks unmodifyed, then how it will look modifyed.

3) I don't know if this is related, but even though my image paths are right, the buttons are not showing.

Instead, I get this:

https://www.vbulletin.org/forum/external/2008/06/6.gif

vBulletin logo moved to the far right and none of the images showing, just the links.

Also, in the options you wrote "left" two times instead of left and right, but that is less important.

Thanks in advance for your help, you mod is of crucial importance to me and of a lot of us, I'm sure.

Astrof,,,
Sorry guys,,, but Im not good when it comes to instructions...

Ok,,, I see your issues in your image...
*********************************

vbulletin logo moving right is caused by the mod images being to close to logo...
How to Fix?
Goto admincp and open HEADER template,,, add this...>>> <br /> <<<... underneath the $invertedtabbar var...
<br /> is a spacer tag,,, If needed add one or two until your logo moves back left...

Also because the TEXT is showing up,,, Your var placement is ok,,, but because the images aren't showing,,, you have a path problem...

Upload images to correct path and also check in Invertedtabbar options path matches images folder path...

Path to your FORUM = http://yoursite.com/forums/images/invertedtabs/
Path to your CMPS = http://yoursite.com/images/invertedtabs/

MARGIN at {0} is setup by adding CSS...
I will update this in next ver...

I will update instructions and mod by next week...

Deepdog009
14 Jun 2008, 06:58
Folks,,,

I fixed many issues, including the margin at top... Its auto template...

Read Tutorial before installing or updating new xml file...

Now working with frontpage CMPS...

Demo coming soon...

Good Luck 2 ya!

Astrof
16 Jun 2008, 12:15
Deepdog, thanks for your effort, but I figured it out myself before you posted, so I just now saw your message.

This is related to the old version of your mod, I see that you updated in the meantime, so parts of this may not be relevant anymore, but I'll post nevertheless as it might still be of some use to some.

So, to answer my own questions:



1) First of all, the second installation step you describe:

Yet, in the .txt file, you write that we need to upload the client script folder as well.

So, which one should we do?

You do not need to upload anything to the client script folder. This mod works fine without it (the version I uploaded, at least, I don't know about the new one).

2) Template editing.

PLEASE write EXACTLY what we have to do and WHERE.

$invertedtabbar needs to be placed whereever you need to place your tabs.

So, for instance, if you need to place your tabs on the very top of your forumhome page, you need to add $invertedtabbar on the very top of the FORUMHOME template:

$invertedtabbar

$stylevar[htmldoctype]
<html xmlns="http://www.w3.org/1999/xhtml" dir="$stylevar[textdirection]" lang="$stylevar[languagecode]">
<head>
<!-- no cache headers -->
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
<meta http-equiv="Cache-Control" content="no-cache" />
<!-- end no cache headers -->
$headinclude
<title><phrase


What I need to have is those tabs ABOVE FORUM HEADER, UNDER THE NAVIGATION BAR, WITHOUT TABBARS ON THE TOP OF THE PAGE TOO. Please, instruct me what EXACTLY I have to do, what EXACTLY has to be entered and where EXACTLY.

Okay, so in my case, I need the tabs to be placed above forum header under the navigation bar and under the guest welcome message shown to unregistered members, so I added $invertedtabbar in the right place and added one pair of <br> and <br /> :

<if condition="$show['guest']">
<!-- guest welcome message -->
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">
<tr>
<td class="tcat"><phrase 1="$vboptions[bbtitle]">$vbphrase[welcome_to_the_x]</phrase></td>
</tr>
<tr>
<td class="alt1">
<phrase 1="faq.php$session[sessionurl_q]" 2="register.php$session[sessionurl_q]">$vbphrase[first_visit_message]</phrase>
</td>
</tr>
</table>
<!-- / guest welcome message -->
<br />
</if>
$invertedtabbar
<br>
<br />
<!-- main -->
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center">

<br> <br /> are NECESSARY in case you don't use the tabs on the very top of forumhome so that you can preserve your layout.

I also added the tabs and a pair of <br> and <br /> under the What's Going On box on forumhome:

<!-- end what's going on box -->
$invertedtabbar
<br>
<br />
<!-- icons and login code -->
<table cellpadding="0" cellspacing="2" border="0" width="100%">
<tr valign="bottom">
<td>

I also wanted the tabs to appear in every forum and not just forumhome, so I also added $invertedtabbar to FORUMDISPLAY:

$stylevar[htmldoctype]
<html xmlns="http://www.w3.org/1999/xhtml" dir="$stylevar[textdirection]" lang="$stylevar[languagecode]">
<head>
$headinclude
<title>$foruminfo[title_clean]<if condition="$pagenumber>1"> - <phrase 1="$pagenumber">$vbphrase[page_x]</phrase></if> - $vboptions[bbtitle]</title>
<if condition="$show['inlinemod']"><script type="text/javascript" src="clientscript/vbulletin_inlinemod.js?v=$vboptions[simpleversion]"></script></if>
</head>
<body>
$header
$navbar
$invertedtabbar
<br>
<br />
<if condition="$show['forumslist']">
<!-- sub-forum list -->
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="border-bottom-width:0px">
<tr>


As you can see, I again added a pair of <br> and <br /> in order to preserve the layout and make it nicer with the spaces under the tabs.

You describe adding $invertedtabbar and margin 0 somewhere, but for the life of me I can't understand where or how, or get it to work.

Margin 0 is not necessary to make this work or have the tabs placed at the right spot in the display.


3) I don't know if this is related, but even though my image paths are right, the buttons are not showing.

Instead, I get this:

https://www.vbulletin.org/forum/external/2008/06/6.gif

You need to write the correct path. Mine was incomplete, hence the problems.

vBulletin logo moved to the far right and none of the images showing, just the links.

This is, again, due to the absense of the $invertedtabbar on the very top of FORUMHOME template.

If you have it on the very top, above everything else, then you will not have these problems.

If you don't, like I don't, then you need to use <br> and <br /> in order to instruct the template to make a new line for the tabs.


Also, in the options you wrote "left" two times instead of left and right, but that is less important.

Yes, this is a typo in the mod options in vBulletin Options. The top one is right, the bottom one is left.

Okay, so that's it.

However, I have one question:

I have a couple of parked domains for my forum and after you log in from one of those domains and click on one of the tabs to go to another address, the tabs redirect to the basic domain and the user is logged out.

Why does this happen? Is there any way around it?

Thanks in advance.

Deepdog009
23 Jun 2008, 05:54
However, I have one question:

I have a couple of parked domains for my forum and after you log in from one of those domains and click on one of the tabs to go to another address, the tabs redirect to the basic domain and the user is logged out.

Why does this happen? Is there any way around it?

Thanks in advance.[/QUOTE]

************************************************

Astrof,,,
Hmmmmmm,,, Im think its a cookie or session tracking issue...

You may need to use vbulletin link structure to fix issue,,, if that doesn't work then Im not sure why its doing that... I will look into this and post about it l8ter...

<a href="calendar.php$session[sessionurl_q]">$vbphrase[calendar]</a>

lms
22 Jul 2008, 00:05
Thanks. Work fine.

Salud2

Astrof
31 Jul 2008, 11:34
Astrof,,,
Hmmmmmm,,, Im think its a cookie or session tracking issue...

You may need to use vbulletin link structure to fix issue,,, if that doesn't work then Im not sure why its doing that... I will look into this and post about it l8ter...

<a href="calendar.php$session[sessionurl_q]">$vbphrase[calendar]</a>

Hi, Deepdog. Sorry for replying just now, but I didn't have time to come and get back to you sooner.

Have you investigated this in the meantime?

Also, another thing I'm interested in - is there any way for the tabs to appear in the showthread template? I tried inserting the var a couple of times, but it did not work.

Also, is there a way for the tabs to appear even when you go to reply to a thread (quote-reply)?

If there is a way to do both, where do I place the var?

Thanks in advance.

powerful_rogue
17 Apr 2009, 19:49
Anyone using this on their site? Wouldnt mind seeing a demo!

wwolf27
28 Apr 2009, 08:36
bump...I would like to know if it works on 3.8

yotsume
29 Jul 2009, 22:37
Interesting I might have to test this to see its functions... Is there a demo please!?

I also, need to know what version of vb this will be compatible with..... THANKS!

xinnek
16 Oct 2009, 17:37
Is there anyway to add more than 10 tabs? I need at least 5 more.

majorvbuser
20 Nov 2009, 07:17
Can this be used with 3.6 ?

netzspion
20 Jan 2010, 09:39
excuse for my bad english...:rolleyes:

i have installed your Add-on and it works very well!
Only the position is wrong.

I want to install the menue over the navbar like here (http://www.vbulletin.org/forum/attachment.php?attachmentid=78593&d=1207961503):

I've attached a picture where you can see what I mean.
There is always a distance to the navbar...

What can i do? :confused:

Thanks for the help! :up:

Gerald
www.mtb-sulzbach.de


PS: this is the code i use in NAVBAR:
<br />
$invertedtabbar
<!-- breadcrumb, login, pm info -->