PDA

View Full Version : Integration with vBulletin - Sound notification


karim004
15 Apr 2008, 01:53
a audible alert [ You've got mail ] will let you know that you have recieved a PM. also Until you open a pm, you are notified each time by a sound that plays once when you load a page.

open template navbar and find :
<if condition="$show['notifications']">
add after
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="0" height="0" id="gotmail" align="middle">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="Soundnotification.swf" />
<param name="quality" value="high" />
<param name="bgcolor" value="#ffffff" />
<embed src="Soundnotification.swf" quality="high" bgcolor="#ffffff" width="1" height="1" name="gotmail" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
</object>
right click and save this file Audible Alert (http://www.momsasone.com/Soundnotification.swf)
upload where you want just change the red text {{{ Soundnotification.swf }} with the full link

SwollenCranium
15 Apr 2008, 02:01
"also does not stop"

Wow ... .no thanks.

Rickeo
15 Apr 2008, 02:19
lmao :) nice but yea not stop

youradhere4222
15 Apr 2008, 03:40
I'd definitely install if you made it so that it only made a sound once if they were on and all of a sudden received a private message.

Also, a *ding* would be much more pleasant than the traditional 'AOL welcome'.

Magnumutz
15 Apr 2008, 07:31
Can the flash be modified to say "You've got mail" only once per page load? And this, only after the page finished loading...?

Jasem
15 Apr 2008, 20:28
Thank you very much, :)

J98680Bxxxxx
15 Apr 2008, 21:57
Installed, works fine. Audio playing only once, when the page is loading (and on page change).

Thanks karim004

karim004
15 Apr 2008, 22:30
Can the flash be modified to say "You've got mail" only once per page load? And this, only after the page finished loading...?
Magnumutz the sound plays once when you load a page.untill you read your pm

chrisdaman77
15 Apr 2008, 23:47
Dang you beat me to it. I had this on my board for a while now and was going to put it out this weekend. Although mine only runs one line of code but then again I am simple minded :rolleyes: Nice job.

Magnumutz
16 Apr 2008, 08:16
Magnumutz the sound plays once when you load a page.untill you read your pm
Ohhh, i thought that it would play like a loop... until you read it :p
Thanks for clearing that out.
Installed :D

avitor
18 Apr 2008, 11:54
where to look for this ?

open template navbar and find :

<if condition="$show['notifications']">
thank

karim004
18 Apr 2008, 12:10
where to look for this ?

open template navbar and find :

<if condition="$show['notifications']">
thank
go to template navbar and Search in Template : welcome
and check the 5 th ln
<strong><phrase 1="$bbuserinfo[username]" 2="member.php?$session[sessionurl]u=$bbuserinfo[userid]">$vbphrase[welcome_x_link_y]</phrase></strong><br />
<phrase 1="$pmbox[lastvisitdate]" 2="$pmbox[lastvisittime]">$vbphrase[last_visited_x_at_y]</phrase>

<if condition="$show['notifications']">

avitor
18 Apr 2008, 12:57
thanks karim004

princeedward
25 Apr 2008, 09:36
i don't know but i guess this mod is not workin' to vB3.6.8 PL2...or is it?...tried to find this to my navbar...but nothing to found...

<if condition="$show['notifications']">

so i add the code below here....

<strong><phrase 1="$bbuserinfo[username]">$vbphrase[welcome_x]</phrase></strong><br />
<phrase 1="$pmbox[lastvisitdate]" 2="$pmbox[lastvisittime]">$vbphrase[last_visited_x_at_y]</phrase>

it work or say...even if i don't have a pm messages to read...it played the swf sound to every page refresh...

please advice for any help...

thanks and best regards...

;)

MR.BOSS
25 Apr 2008, 09:56
i dont have this <if condition="$show['notifications']"> in vb 3.7 rc4

princeedward
30 Apr 2008, 07:34
i don't know but i guess this mod is not workin' to vB3.6.8 PL2...or is it?...tried to find this to my navbar...but nothing to found...

<if condition="$show['notifications']">

so i add the code below here....

<strong><phrase 1="$bbuserinfo[username]">$vbphrase[welcome_x]</phrase></strong><br />
<phrase 1="$pmbox[lastvisitdate]" 2="$pmbox[lastvisittime]">$vbphrase[last_visited_x_at_y]</phrase>

it work or say...even if i don't have a pm messages to read...it played the swf sound to every page refresh...

please advice for any help...

thanks and best regards...

;)BUMP!!!

Keyser Söze
07 May 2008, 18:38
i would definatly go for this if it played just once per new PM

MiahBeSmokin420
09 May 2008, 02:39
if you want something more fun for a sound

you should use this

http://StillFallinEntertainment.com/vB-Forums/MailMofo.mp3

Take it as you wish it will always be there but do not link to my file or i will just rename it and wont tell yall what the file name is.

So take the file if you want but let me catch one person accually linking it from my site meaning that you did not host it on your server and you are just adding my link to your player then yes i will remove it
and i do watch my file stats very closely so just download it and save it on your server.

Enjoy

Nice Idea By The way

Also if you are going to use the mp3 instead of the flash you will need a different code

that code is:

<object id="player" height="0" width="0" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6">
<param name="URL" value="MailMofo.mp3">
<param name="uiMode" value="full">
<param name="ShowControls" value="false">
<param name="ShowStatusBar" value="false">
<param name="ShowDisplay" value="false">

<embed type="application/x-mplayer2"
pluginspage = "http://www.microsoft.com/Windows/MediaPlayer/"
SRC="MailMofo.mp3"
name="player"
width="0"
height="0"
AutoStart="1"
showcontrols="0"
showstatusbar="0"
showdisplay="0"
uiMode="full"
visual="1">
</embed>
</object>

MiahBeSmokin420
09 May 2008, 02:42
BUMP!!!

your problem is because the notification crap was not added until vb 3.7.0 and up

anything less then 3.7.0 will not have the notifications so there for you would not be able to use this

but i could be wrong cause i updated from 3.6.7 to 3.7.0

but i really don't think that the notifications are in there i think its only a 3.7.0 and up thing

DieselMinded
09 May 2008, 05:24
Also if you are going to use the mp3 instead of the flash you will need a different code

that code is:

<object id="player" height="0" width="0" classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6">
<param name="URL" value="MailMofo.mp3">
<param name="uiMode" value="full">
<param name="ShowControls" value="false">
<param name="ShowStatusBar" value="false">
<param name="ShowDisplay" value="false">

<embed type="application/x-mplayer2"
pluginspage = "http://www.microsoft.com/Windows/MediaPlayer/"
SRC="MailMofo.mp3"
name="player"
width="0"
height="0"
AutoStart="1"
showcontrols="0"
showstatusbar="0"
showdisplay="0"
uiMode="full"
visual="1">
</embed>
</object>
[/QUOTE]


Works in FF but not IE

MiahBeSmokin420
09 May 2008, 06:48
well ie sucks anyways

but yes it dose work with IE7 i have tested it cause thats the only player that will work with both and have a visulizer (if enabled)

you are probally just missing the windows media player plugins for IE

but anyways who cares about IE ?? Its horriable and should have never been invented

i tell all my members that use IE to get FF

and i even have a message displayed to members who use IE to get FF and give them a dl link lol and its from google adsence

trust me i have been making websites for a few years now with html xhtml and all that crap and vb

personly i can code a site perfectly and look at it in FF and it looks the way its suposed to
but then if you look at it in IE its just jacked up



but anyways back on subject try finding plugins for WMP for IE that should make it work for you

DieselMinded
09 May 2008, 14:56
Im with you bro on FF i tell my members all the time , sadly my Analytics says i have double the members using IE than FF so i have to find a happy medium .

And this sound plays needs to only play on forum home as it triggers on everypage

Thread, then again on inbox , then again on the message

it keeps playing 3 times at leaset as the notification doesnt go away when your click on notifications in the nav bar you have to listen to it untill you read all your messages ect..

BLAHHHHHHH !

Find a code that works on IE and FF out the box and only plays once on initial notification and im there dude

MiahBeSmokin420
09 May 2008, 19:34
Im with you bro on FF i tell my members all the time , sadly my Analytics says i have double the members using IE than FF so i have to find a happy medium .

And this sound plays needs to only play on forum home as it triggers on everypage

Thread, then again on inbox , then again on the message

it keeps playing 3 times at leaset as the notification doesnt go away when your click on notifications in the nav bar you have to listen to it untill you read all your messages ect..

BLAHHHHHHH !

Find a code that works on IE and FF out the box and only plays once on initial notification and im there dude



well here is what you need to make it only play on the forum home page

put before the code
<if condition="THIS_SCRIPT === 'index''">

put after the code
</if>


if you want it to play on vb advanced portal as well then use this before the code

<if condition="THIS_SCRIPT === 'index' OR THIS_SCRIPT === 'adv_index'">

but as i said it should work with IE and FF
as i have test it on both and it works
so you probaly just need a windows media player plugin for it to work on IE
most people have that plugin so idk what else to say
thats the only media player that i have found to work on both IE and FF
so thats all i can help you with im sorry

Keyser Söze
13 May 2008, 18:24
yea but question is will that make it only play once

right now, u get a PM the PM popup only comes one time per new PM

T2L
15 May 2008, 11:13
I am NEW here - but im keen to test this out - and I require your assistance:
I am unsure of where to place the file within the directory structure on the server

{{{ Soundnotification.swf }} with the full link

can you give me an example of 'the full link' (is it a path to the file? ) and location for the actual swf file.
Thank you

joopster
15 May 2008, 17:11
i have 3.7 and no instance of the notifications when doing a search. anywhere else to add?

avitor
15 May 2008, 20:49
i tr whet karim varsion and is works perfectly on vb 3.7.0
no change nead to code
thanks again

joopster
16 May 2008, 14:04
I have 3.7 and not even in the default template do I have that phrase.

ShadowOne
16 May 2008, 14:37
Okay i have a fix for everyone :D...

add this

<if condition="$show['notifications']">

right before this

<if condition="$show['pmstats']">

then add this

</if>

after this

$vbphrase[private_messages_nav]</phrase></if>

then add the music code shown.....directly after


<if condition="$show['notifications']">

Note...this will also make the private message part go away if there are no PM's and it will make the sound on every REFRESH until PM is read...:D

ShadowOne
17 May 2008, 15:08
did that work for everybody?

T2L
17 May 2008, 23:23
can you give me an example of 'the full link' (is it a path to the file? ) and location for the actual swf file.
Thank you
https://www.vbulletin.org/forum/external/2011/01/5.gif

karim004
19 May 2008, 21:12
I am NEW here - but im keen to test this out - and I require your assistance:
I am unsure of where to place the file within the directory structure on the server



can you give me an example of 'the full link' (is it a path to the file? ) and location for the actual swf file.
Thank you
ok here is a easy example if your forum : www.t2l.com/forum / upload the swf file in your forum folder
so the full link = http://www.t2l.com/forum/Soundnotification.swf

revmitchell
22 May 2008, 05:07
I installed this and the sound works but I get this above the navbar:


You last visited: 7 Hours Ago at 05:28 PM object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0" width="0" height="0" id="gotmail" align="middle">

What is the problem

revmitchell
25 May 2008, 20:25
Bump

paco58
07 Jun 2008, 10:27
Installed

Someone has the message for pm in Spanish



Thank you advanced

karim004
10 Jun 2008, 11:26
I installed this and the sound works but I get this above the navbar:




What is the problem
a missing tag for object ! maybe you forgot a <

PGAmerica
14 Sep 2008, 19:51
I would use this in a heartbeat if there was an option for the user to turn it off.

abouahmed
18 Sep 2008, 23:18
thanks karim

Installed, works fine.

tecnozul
16 Oct 2008, 04:48
is excelent, thanks :)

Alfa1
24 Oct 2008, 02:39
This is excellent!

Yonatan
26 Oct 2008, 13:49
Very nice mod.
please make option on USERCP to disable that voice(not everyone like that) :)
Thanks

goxy63
31 Oct 2008, 23:47
Nice, installed than uninstaled
Reason:
User need to hear that sound atleast 3 times to shut it down, one time is ok but 3...
Also as some of you guys mentioned...USERCP to disable that option, I dont want to force some of my users to this ...

Change this and I will be happy to install it again, also to let all of my friends know about this hack (Vb friends)

GSeybold
15 Nov 2008, 11:13
can't find in my default 3.72 template

MarkD793
09 Sep 2009, 23:04
This is working fine in IE but is not working in FF

any suggestions?

songoibiza
05 Oct 2009, 01:22
Nice, installed than uninstaled
Reason:
User need to hear that sound atleast 3 times to shut it down, one time is ok but 3...
Also as some of you guys mentioned...USERCP to disable that option, I dont want to force some of my users to this ...

Change this and I will be happy to install it again, also to let all of my friends know about this hack (Vb friends)

opino igual ..

aunque no dudo que este mod acabara siendo un exito.. buen intento...:up:

ricardoNJ
05 Oct 2009, 18:45
Is there any spanish version of this Alert?

ricardoNJ
05 Oct 2009, 18:52
In Mozilla no work!

<!-- / PAGENAV POPUP -->
</if>

<if condition="$show['member'] AND $notifications_total">
<!-- notifications menu -->
<div class="vbmenu_popup" id="notifications_menu" style="display:none">
<table cellpadding="4" cellspacing="1" border="0">
<tr><td class="thead" colspan="2">$vbphrase[your_notifications]</td></tr>
$notifications_menubits
</table>
</div>
<!-- / notifications menu -->
</if>

Where I have to add it?

TheInsaneManiac
06 Oct 2009, 09:51
How would I go about adding this to alert ONLY to PMs? Cause saying youve got mail to a friend request is stupid...