PDA

View Full Version : Versions....


StepOnFrog
25 Apr 2008, 00:43
I hope this is posted in the right place; I thought, "ooooo... servers and stuff... might be better posted in here...?"

Anyway,

I, as with everyone else, have been keeping an eye on the vB 3.7.0 final release, which, unfortunately, has been put back a while, but all this time I've been concerned whether or not it'll run without problems on the server I'm on.?

vB 3.7 states that PHP 5.2.5 is recommended, as is MySQL 5.0.51, and something called an APC... (bugger me if I know what an APC is, or how I find out if there's such a thing on my server...?)

So, being me and trying to investigate all things server and vB, I checked the PHPinfo link on the Admin CP, which tells me I have PHP version 5.2.3 and MySQL and MySQLi both version 4.1.11. There's no way I can update any of these, as the servers are some dodgy two-bit company, and I can't afford to buy new and change. I have no idea if there's anything resembling APC (or a somethingorother CACHE).

I would prefer to keep with the most uptodate versions of vBulletin, and have successfully done so since I first bought vB 3.5.4 about 2 years ago.

Can anyone please indictate whether I might be able to continue the uptodate vBulletin process with the stuff I'm running on now, or whether I should just not bother...? I'd prefer to continue as I have for the past 2 years, but I don't know if i'm going to run into some odd problems later on.

Any advice would be great, and I thank you all in advance.

:-D

Dismounted
25 Apr 2008, 07:32
It is recommended that you have PHP 5.2.5+, MySQL 5.0.51+, and APC or a similar PHP cache (eg. XCache).

The minimum required versions are PHP 4.3.3 and MySQL 4.0.16. There is no requirement for a PHP cache.

Also, the vBulletin devs have indicated that vBulletin 4 will need PHP 5/MySQL 5.

StepOnFrog
30 Apr 2008, 10:28
Thanks. That was much simpler to read.