PDA

View Full Version : 500 Error in 3.7


fum1n
02 May 2008, 07:48
Okay, I recently moved Dedicated server and also upgraded to VB 3.7 from 3.6.8/9.

Here's the problem: whenever someone tries to register or post a link starting with http they get a 500 error.

I've tried removing the htaccess file and such with no success.
I also removed all products, mods etcs from the forums.

Board URL: http://project-7.net/forum/index.php
Server
Specs:
CentOS w/ AMD 5000+ and 4GB Ram.

royo
02 May 2008, 07:53
There might be a permission error on certain files.

fum1n
02 May 2008, 08:18
care to explain more about these permissions i need to set?

wolfstream
02 May 2008, 08:27
whenever someone tries to register or post a link starting with http they get a 500

If you've got mod_security rules in place, this could easily be the cause of it. What happens is mod_security tries to restrict these certain phrases to avoid hijacking. Usually this errors out @ 403, but that can be changed by the systems administrator

fum1n
02 May 2008, 08:33
If you've got mod_security rules in place, this could easily be the cause of it. What happens is mod_security tries to restrict these certain phrases to avoid hijacking. Usually this errors out @ 403, but that can be changed by the systems administratorThank you very much, upon inspection inside of my root WHM i see alot of errors in mod security on the pages i get the 500's on,


/forum/register.php?do=register HTTP/1.1 project-7.net Access denied with code 500 (phase 2). Pattern match "(ht|f)tps?:/" at ARGS:url. 500


I will attempt to fix this now.