PDA

View Full Version : MySQL Error : MySQL server has gone away


Bloggeries
15 May 2008, 15:15
I moved to a dedicated server and have been getting TONES of these. Another weird thing is if you login sometimes it says not logged in but if you click a sub cat it shows you logged in. Or if you click to go to the main forum it logs you out but you're not logged out.

Getting ~50 errors a day +. Please help!

Database error in vBulletin 3.6.4:

Invalid SQL:

UPDATE session
SET lastactivity = 1210815504, location = '/forum/forumdisplay.php?f=6', inforum = 6, inthread = 0, incalendar = 0, badlocation = 0
WHERE sessionhash = 'b2566c7eae44bfcf85f26341d25c14ba';

MySQL Error : MySQL server has gone away
Error Number : 2006
Date : Wednesday, May 14th 2008 @ 08:38:57 PM
Script : http://www.bloggeries.com/forum/forumdisplay.php?f=6
Referrer : http://www.bloggeries.com/forum/

Boofo
15 May 2008, 15:21
Contact your host as it looks like MySQL is being reset or rebooted.

Marco van Herwaarden
15 May 2008, 15:50
More likely is that the timeout for MySQL is set too low.

See this post for the possible causes of a lost connection error:
http://www.vbulletin.com/forum/showthread.php?s=&postid=310265#post310265

Boofo
15 May 2008, 16:19
That is most likely what is going on. I was just going by what happened to me on my old host.

Bloggeries
15 May 2008, 17:30
I've been discussing this with the host.

Not sure about rebooting or reset; it is on a dedicated server so I don' tknow.


Regarding Timeouts I received this from the host.

I've increased the time outs on your MySQL configuration from 20 to 60... this should help.

Any other thoughts?

Cheers,

John Stone
15 May 2008, 21:24
I've been discussing this with the host.

Not sure about rebooting or reset; it is on a dedicated server so I don' tknow.


Regarding Timeouts I received this from the host.

I've increased the time outs on your MySQL configuration from 20 to 60... this should help.

Any other thoughts?

Cheers,
20 is very low, that was probably it. You might need to increase it a bit more than you did to completely eliminate the problem. 90 works for me.

Yogesh Sarkar
18 May 2008, 16:26
Post a server optimization request on www.vbulletin.com/forum/ and implement the MYSQL settings recommended there, I am sure it would fix the issue.