PDA

View Full Version : GRRRR- More dB errors


wrestlepower
26 May 2008, 07:56
Over the past few days i've been getting lots of errors. The list of 300 errors in the cPanel is filling up every couple of hours. I posted yesterday about an error which caused the forums to go down and thankfully that issue was resolved. Then, in an effort to resolve the issue i decided to upgrade to 3.7, but now i can't complete the upgrade due to another error.


Step 2) Import latest admin help

Importing vbulletin-adminhelp.xml
Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 16 bytes) in /home/forums/public_html/includes/adminfunctions_language.php on line 189

I disabled all the hcaks yesterday and re-enabled them one by one but nothing seemed to be causing it on that front.

The error about exhausting allowed memory is one that has been showing frequently in the error logs, but i have no idea what it refers to.

As it is, the forums are turned off, and i'm getting cosntant IM etc asking when it'll be back up, but i have no idea how to resolve this one. Can anyone help?

SEOvB
26 May 2008, 08:04
edit your servers php.ini file and increase the memory limit to something over 8MB. 16MB is a good safe setting to have

memory_limit = 16M

Don't set it to large, as if you have other scripts/plugins that are poorly written it could quickly eat up your server resources

wrestlepower
26 May 2008, 08:05
where can i find the details for that mate?

SEOvB
26 May 2008, 08:15
where can i find the details for that mate?

if you are on shared hosting you may not be able to edit this file. You'll need to contact your host and make them aware of the problem. Or you maybe able to edit your .htacess file and add this line to (this only works if your host allows you)

php_value memory_limit 16M


If you have SSH access (VPS or dedicated) login as the root user and run these commands

updatedb
locate php.ini

The first command updates the search index for your server (not vBulletin search, the actual server files)

The second will find all instances of php.ini file

Most the time its some where like /usr/lib/local/php.ini or something like that.

Lastly you maybe able to set this limit on the php file itself open the adminfunctions_language.php file and at the top after <?php add

ini_set('memory_limit', '16M');

(I can not confirm this method will work with vBulletin files, as I've never had to use it, but its a last resort option if you need something fast)

wrestlepower
26 May 2008, 08:44
nope, none of those appear to work. Guess i'll just ahve to wait until the host drags himslef out of bed in the States.

Thanks for your help anyway.

snakes1100
27 May 2008, 10:21
Is this a dedicated/vps server?

If it is, post hte contents of my.cnf, typically in the /etc dir, how much ram does the server have?