PDA

View Full Version : Issues after upgrading to mysql5


MorrisMcD
27 May 2008, 14:40
In preparation of moving to vbulletin 3.7, I decided to update to the latest PHP and MySql per vb's recommendation.

No problems occurred getting the latest PHP setup. I even took it from cgi to isapi. (just in case that could have anything to do with it but I doubt it)

This is an IIS server on a Windows box as well.

Now when I reboot, the mysql service does start but I cannot reach my forum. It hangs forever and eventually times out as if it cannot reach the site or the pw configured it wrong. However, once I run an instance config wizard, no matter what I use as the settings, it will start working. However, when I run the instance config it actually does not complete because it cant stop the mysql service. So what I have done so far is go to windows task manager and end task the mysqld-nt.exe process. I then can complete the instance config and then untill I reboot everything seems fine. I left off in this situation last night. When I woke up I noticed a bunch of errors in my email with ' Data too long for column 'useragent' at row 1 Error Number : 1406
' listed as the error. I made the change in my vb config file to force sql connect. I havent seen that error again since, yet. But as stated, it seems the first time mysql is started it just doesnt actually load up completely. Any suggestions?

Actually perhaps this is also helpful info in troubleshooting. The site actually starts responding when I stop the service. The service does not stop completely, and as stated before I must end task on the process before I can start it back up. But when I start a stop call to the service, the service reads stopping forever and the site just starts working. It's almost like its trying to run as a process AND a service??? Please help

Also worth noting I guess is I had my page on who's online and upon refreshing at one point it tried to prompt me to save the online.php file instead of loading it. I kinda suspected that the force sql line being set to true fixes that but I couldnt tell if thats what was causing the errors. It hasnt happened since I fixed that config line

snakes1100
27 May 2008, 15:01
I would suggest backing up all your databases and completely uninstall mysql and reinstall it, make sure that it nukes the default mysql database as well upon uninstall, then reinstall it.

Typically if you get prompted to download a php file instead of it being parsed as a web page, thats usually on apache/iis configuration issue.

MorrisMcD
27 May 2008, 15:26
I would suggest backing up all your databases and completely uninstall mysql and reinstall it, make sure that it nukes the default mysql database as well upon uninstall, then reinstall it.

Typically if you get prompted to download a php file instead of it being parsed as a web page, thats usually on apache/iis configuration issue.
Thanks for your reply first of all...

I do wonder if I am doing everything right. After installing the new sql, I copy the data folder from the old sql install to the data dir. Is that all I should be doing? At what point should I be dropping that data folder in if that isnt right? When I copy the data folder, I am also overwriting the mysql folder and db with my old one. Should I not do that?

Things have been running great ever since I ended task on the process and restarted the service.. None of the trying to save the file either has occurred.

I guess I am just looking for guildance somewhat on when I should be putting that data folder in.. Maybe I did something wrong there thats causing the initial startup to not completely start up or something.

Thanks again for the reply.. If you can tell I am doing something wrong based on what I told you, please def point it out. I have done an uninstall and reinstall MANY MANY times with the same issue. So I am holding off doing it again until someone can explain how I should be introducing my old data folder into the new install...

Thanks again

snakes1100
27 May 2008, 16:33
I would suggest doing a mysqldump and not just copying the files themselves.

I wouldnt keep any databases except for the ones that are needed for a web site.

The mysql databses will be reinstalled when you setup mysql through the installer.

MorrisMcD
27 May 2008, 17:06
I would suggest doing a mysqldump and not just copying the files themselves.

I wouldnt keep any databases except for the ones that are needed for a web site.

The mysql databses will be reinstalled when you setup mysql through the installer.

Sorry to be a pain but do you have a link or an easy way of explaining how this process is done on a windows box? Does it even differ or do I just use the command line client? Whats the command? :ducks: (sorry and thanks) :)

snakes1100
27 May 2008, 17:16
havent used command line client in a while, but it is the same as on a linux box, should just be the following:

mysqldump --opt -u -p dbname > C:\path\to\file\dbname.sql

If i recall you still ahve to pass the -u -p options in command line client, might need to add --hostname if it b*tches

MorrisMcD
27 May 2008, 22:21
Turned out I wasnt being patient I think.. I gave it a good 10 min and everything came up.. lol

oops

But

Typically if you get prompted to download a php file instead of it being parsed as a web page, thats usually on apache/iis configuration issue.
This has happened again.. The only thing I really changed (in IIS) is the site allowing scripts rather than scripts and executables and changing from an early verision of a CGI php to the lastest isapi php...

Any thoughts? It rarely happens also.. Maybe once an hour or so

snakes1100
27 May 2008, 22:35
Sorry, not really an IIS geek.

MorrisMcD
29 May 2008, 16:22
Well I think I solved it.. haven't seen it since I did the following if anyone else has the same issue..

Go to the properties of the website in IIS...

Go to the Home Directory tab.... Click on Configuration... On the Mappings tab, find your php extension in the list, highlight it and click edit.... Uncheck the 'Verify that file exists' box

I know.. Not sure why.. But its the only thing I changed.. and it went away..

Gotta love windows