PDA

View Full Version : Forum Display Enhancements - Last Post Alignment Fix in Forum Home


Super Jinni
29 May 2008, 21:43
what is this for?

some times when we use another style beside the default style of vbulletin, th last post in the forum home be not aligned in each category and be different in width form category to another depending on the width of the title of the last post... (screenshoots below explain more).

and this simple mod is to fix that and make the width of last post table the same in every category. whatever the title width is..

1- go to you "FORUMHOME" template
2- look for the the following code:

<tr align="center">
<td class="thead">&nbsp;</td>
<td class="thead" width="100%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="175">$vbphrase[last_post]</td>
<td class="thead">$vbphrase[threads]</td>
<td class="thead">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>

3- if it there remove it and save the template. if it not there just let the template as it is without any changes.

4- go to "forumhome_forumbit_level1_nopost" template

5- find the following code:

<tr align="center">
<td class="thead">&nbsp;</td>
<td class="thead" width="100%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="175">$vbphrase[last_post]</td>
<td class="thead">$vbphrase[threads]</td>
<td class="thead">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>

6- if it there, replace it with the following:

<tr align="center">
<td class="thead" width="5%">&nbsp;</td>
<td class="thead" width="50%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="25%">$vbphrase[last_post]</td>
<td class="thead" width="10%">$vbphrase[threads]</td>
<td class="thead" width="10%">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead" width="0%">$vbphrase[moderator]</td>
</if>
</tr>

and save.

if it not there just add it exactly after the following code:

<tbody id="collapseobj_forumbit_$forumid" style="{$collapseobj_forumid}">

then save and it's done.

if you like this one and find it useful, please mark it as Installed

A.M.

pureturk
29 May 2008, 21:56
someone please tell me what this thing does?

Super Jinni
29 May 2008, 22:19
my fault

edited...

see the first post

:)

zionsworld
29 May 2008, 22:54
tnx that helped me a lot :)

kudos

Super Jinni
29 May 2008, 23:15
glad to heat that

don't forget to mark as installed

:)

mark370
31 May 2008, 07:59
Many-thanks for thiis mod Super J works a treat :up:

Super Jinni
31 May 2008, 09:01
you're welcome
glad you like it
:)

digicom
31 May 2008, 13:04
Apprciated,Thankyou:up:

popowich
31 May 2008, 16:01
A minor irritation for me has been fixed, thanks!

BTW, I think 5% looks better than 10% for threads and posts.

On wide monitors it makes a big difference, without impacting the 800x600 viewers.

-Raymond

Super Jinni
31 May 2008, 17:40
maybe you are right

for me I didn't set the width of threads and posts count only the width of forum and last post..

the most important is that to set the forum and and the last post..

but if -in some cases with some styles- you have the alignment problem in the threads and post count table, then you should set them...

and after all, it depends on the style and on how you want it to be shown up..

and it's better not to set the last post less than 21% as I test it..

s810car
01 Jun 2008, 01:11
Man, I never noticed that before, thanks for pointing that out i may have just never known lol **Installs**

Super Jinni
01 Jun 2008, 10:51
you are very welcome

:)

Bexter
02 Jun 2008, 22:30
Thanks man, I've noticed this a lot and its bugged me loads but never knew how to fix it. Will give this a go tomorrow :)

Super Jinni
03 Jun 2008, 03:04
you are welcome..

and I hope that it will be what you look for..

:)

wpeloquin
03 Jun 2008, 04:10
i never thought to put this up, but ive done the same. i went 1 step farther though, and merged the posts/threads columns into a single column ;)

Super Jinni
03 Jun 2008, 18:23
I think that is really nice

:)

se_p800
05 Jun 2008, 00:48
Just what I was looking for! Thanks, excellent job!

Super Jinni
05 Jun 2008, 03:51
you are very welcome
:)

abrecher
05 Jun 2008, 07:34
Nice Mod. It seems that Long Thread Prefixes messes things up even when you use this mod.

Super Jinni
05 Jun 2008, 18:20
aaha

I didn't think about it because I didn't face this problem yet..

I'll see what I can do about it...

:)

pjkcards
30 Jun 2008, 03:31
For step 3, which part exactly do we remove? Just the red if's, or everything between the 2 ifs?

Here (http://www.vbulletin.org/forum/showthread.php?p=1560493#post1560493) is my problem thread, any help would be greatly appreciated. Thanks

dvbusuario
30 Jun 2008, 06:11
Very goog thx.

Install!

Super Jinni
30 Jun 2008, 09:00
For step 3, which part exactly do we remove? Just the red if's, or everything between the 2 ifs?

Here (http://www.vbulletin.org/forum/showthread.php?p=1560493#post1560493) is my problem thread, any help would be greatly appreciated. Thanks

for step three you need to remove all the code mentioned in step two, which is:
<tr align="center">
<td class="thead">&nbsp;</td>
<td class="thead" width="100%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="175">$vbphrase[last_post]</td>
<td class="thead">$vbphrase[threads]</td>
<td class="thead">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>



I checked this (http://www.speedsolving.com/forumdisplay.php?f=9) website you mentioned in this (http://www.vbulletin.org/forum/showthread.php?p=1560493) thread and everything is ok as I saw..

are you still having the problem?

Super Jinni
30 Jun 2008, 09:01
Very goog thx.

Install!

you are welcome

:)

pjkcards
01 Jul 2008, 06:52
Hello,
Okay, yes, I did that. Here (http://www.speedsolving.com/forum/forumdisplay.php?f=9) is the site that is having problems...notice the subforum.

Here is a copy of my forumhome template, following by the forumhome_forumbit_level1_nopost template. Let me know if you notice anything wrong. Thanks

$stylevar[htmldoctype]
<html dir="$stylevar[textdirection]" lang="$stylevar[languagecode]">
<head>
<!-- no cache headers -->
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
<meta http-equiv="Cache-Control" content="no-cache" />
<!-- end no cache headers -->
$headinclude
<title><phrase 1="$vboptions[bbtitle]">$vbphrase[x_powered_by_vbulletin]</phrase></title>
</head>
<body>
$header
$navbar

<!-- Advertisement Code -->
<br />
<div align="center">

<script language="JavaScript" type="text/javascript">
<!--
ctxt_ad_partner = "xx";
ctxt_ad_section = "xx";
ctxt_ad_bg = "2F6084";
ctxt_ad_width = 728;
ctxt_ad_height = 90;
ctxt_ad_bc = "FFFFFF";
ctxt_ad_cc = "FFFFFF";
ctxt_ad_lc = "2F6084";
ctxt_ad_tc = "000000";
ctxt_ad_uc = "2F6084";
// -->
</script>
<script language="JavaScript" src="http://ypn-js.overture.com/partner/js/ypn.js">
</script>

</div>
<br>
<!-- / Advertisement Code -->

<!-- main -->
<if condition="$show['guest']">
<!-- guest welcome message -->
<ca-hdr>
<td class="tcat" width="100%"><phrase 1="$vboptions[bbtitle]">$vbphrase[welcome_to_the_x]</phrase></td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0;">
<tr>
<td class="alt1">
<phrase 1="faq.php$session[sessionurl_q]" 2="register.php$session[sessionurl_q]">$vbphrase[first_visit_message]</phrase>
</td>
</tr>
</table>
<!-- / guest welcome message -->
</if>

<div id="forum0_div" style="display: none;">
<ca-hdr>
<td class="tcat" width="100%">$vboptions[bbtitle]</td>
</ca-hdr>
</div>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0; display: none;" id="forum0">

$forumbits
<tbody>
<tr>
<td class="tfoot" align="center" colspan="<if condition="$vboptions['showmoderatorcolumn']">6<else />5</if>"><div class="smallfont"><strong>
<a href="forumdisplay.php?$session[sessionurl]do=markread" rel="nofollow">$vbphrase[mark_forums_read]</a>
<if condition="$vboptions['forumleaders']">&nbsp; &nbsp;
<a href="showgroups.php$session[sessionurl_q]" rel="nofollow">$vbphrase[view_forum_leaders]</a></if>
</strong></div></td>
</tr>
</tbody>
</table>
$forumhome_markread_script
<!-- /main -->
<!-- Advertisement Code -->
<div align="center">
<script language="JavaScript" type="text/javascript">
<!--
ctxt_ad_partner = "xx";
ctxt_ad_section = "xx";
ctxt_ad_bg = "2F6084";
ctxt_ad_width = 468;
ctxt_ad_height = 60;
ctxt_ad_bc = "FFFFFF";
ctxt_ad_cc = "FFFFFF";
ctxt_ad_lc = "2F6084";
ctxt_ad_tc = "000000";
ctxt_ad_uc = "2F6084";
// -->
</script>
<script language="JavaScript" src="http://ypn-js.overture.com/partner/js/ypn.js">
</script>
</div>
<!--/ Advertisement Code -->

<!-- what's going on box -->
<ca-hdr>
<td class="tcat" width="100%">$vbphrase[whats_going_on]</td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="border-top-width: 0;">

<if condition="$show['loggedinusers']">
<!-- logged-in users -->
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_activeusers')"><img id="collapseimg_forumhome_activeusers" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_activeusers].gif" alt="" border="0" /></a>
<a href="online.php$session[sessionurl_q]" rel="nofollow">$vbphrase[currently_active_users]</a>: $totalonline (<phrase 1="$numberregistered" 2="$numberguest">$vbphrase[x_members_and_y_guests]</phrase>)
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_activeusers" style="$vbcollapse[collapseobj_forumhome_activeusers]">
<tr>
<td class="alt2"><a href="online.php$session[sessionurl_q]" rel="nofollow"><img src="$stylevar[imgdir_misc]/whos_online.gif" alt="$vbphrase[view_whos_online]" border="0" /></a></td>
<td class="alt1" width="100%">
<div class="smallfont">
<div style="white-space: nowrap"><phrase 1="$recordusers" 2="$recorddate" 3="$recordtime">$vbphrase[most_users_ever_online_was_x_y_at_z]</phrase></div>
<div>$activeusers</div>
</div>
</td>
</tr>
</tbody>
<!-- end logged-in users -->
</if>
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_stats')"><img id="collapseimg_forumhome_stats" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_stats].gif" alt="" border="0" /></a>
<phrase 1="$vboptions[bbtitle]">$vbphrase[x_statistics]</phrase>
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_stats" style="$vbcollapse[collapseobj_forumhome_stats]">
<tr>
<td class="alt2"><img src="$stylevar[imgdir_misc]/stats.gif" alt="<phrase 1="$vboptions[bbtitle]">$vbphrase[x_statistics]</phrase>" border="0" /></td>
<td class="alt1" width="100%">
<div class="smallfont">
<div>
$vbphrase[threads]: $totalthreads,
$vbphrase[posts]: $totalposts,
$vbphrase[members]: $numbermembers<if condition="$show['activemembers']">,
<span title="<phrase 1="$vboptions[activememberdays]">$vbphrase[within_the_last_x_days]</phrase>">$vbphrase[active_members]: $activemembers</span>
</if>
</div>
<div><phrase 1="member.php?$session[sessionurl]u=$newuserid" 2="$newusername">$vbphrase[welcome_to_our_newest_member_x]</phrase></div>
</div>
</td>
</tr>
</tbody>
<if condition="$show['birthdays']">
<!-- today's birthdays -->
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_birthdays')"><img id="collapseimg_forumhome_birthdays" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_birthdays].gif" alt="" border="0" /></a>
$vbphrase[todays_birthdays]
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_birthdays" style="$vbcollapse[collapseobj_forumhome_birthdays]">
<tr>
<td class="alt2"><a href="calendar.php?$session[sessionurl]do=getday&amp;day=$today&amp;sb=1"><img src="$stylevar[imgdir_misc]/birthday.gif" alt="$vbphrase[view_birthdays]" border="0" /></a></td>
<td class="alt1" width="100%"><div class="smallfont">$birthdays</div></td>
</tr>
</tbody>
<!-- end today's birthdays -->
</if>
<if condition="$show['upcomingevents']">
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_events')"><img id="collapseimg_forumhome_events" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_events].gif" alt="" border="0" /></a>
<if condition="$show['todaysevents']">$vbphrase[todays_events]<else /><phrase 1="$vboptions[showevents]">$vbphrase[upcoming_events_for_the_next_x_days]</phrase></if>
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_events" style="$vbcollapse[collapseobj_forumhome_events]">
<tr>
<td class="alt2"><a href="calendar.php$session[sessionurl_q]"><img src="$stylevar[imgdir_misc]/calendar.gif" alt="$vbphrase[calendar]" border="0" /></a></td>
<td class="alt1" width="100%"><div class="smallfont">$upcomingevents</div></td>
</tr>
</tbody>
</if>
</table>
<br />
<!-- end what's going on box -->

<!-- icons and login code -->
<table cellpadding="0" cellspacing="2" border="0" width="100%">
<tr valign="bottom">
<td>
<table cellpadding="2" cellspacing="0" border="0">
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_new.gif" alt="$vbphrase[contains_new_posts]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_contains_new_posts]</td>
</tr>
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_old.gif" alt="$vbphrase[contains_no_new_posts]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_contains_no_new_posts]</td>
</tr>
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_old_lock.gif" alt="$vbphrase[a_closed_forum]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_is_closed_for_posting]</td>
</tr>
</table>
</td>
<if condition="!$show['guest']">
<!-- member logout -->
<td align="$stylevar[right]"><a href="login.php?$session[sessionurl]do=logout&amp;logouthash=$bbuserinfo[logouthash]" onclick="return log_out()"><phrase 1="$bbuserinfo[username]">$vbphrase[log_out_x]</phrase></a></td>
<!-- end member logout -->
</if>
</tr>
</table>
<!-- / icons and login code -->

$footer
</body>
</html>

forumhome_forumbit_level1_nopost template:

</table>
<if condition="$show['subforums']">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px;">
<thead>
<tr>
<td class="tcat" colspan="<if condition="$vboptions[showmoderatorcolumn]">6<else />5</if>">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumbit_$forumid')"><img id="collapseimg_forumbit_$forumid" src="$stylevar[imgdir_button]/collapse_tcat{$collapseimg_forumid}.gif" alt="" border="0" /></a>
<a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
<if condition="$show['forumdescription']"><div class="smallfont">$forum[description]</div></if>
<if condition="$show['subforums']"><div class="smallfont"><strong>$vbphrase[subforums]</strong>: $forum[subforums]</div></if>
</td>
</tr>
</thead>
<else />
<ca-hdr>
<td class="tcat" width="100%">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumbit_$forumid')"><img id="collapseimg_forumbit_$forumid" src="$stylevar[imgdir_button]/collapse_tcat{$collapseimg_forumid}.gif" alt="" border="0" /></a>
<a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
</td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0;">
</if>
<tbody>
<tr align="center">
<td class="thead" width="5%">&nbsp;</td>
<td class="thead" width="50%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="25%">$vbphrase[last_post]</td>
<td class="thead" width="10%">$vbphrase[threads]</td>
<td class="thead" width="10%">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead" width="0%">$vbphrase[moderator]</td>
</if>
</tr>
</tbody>
<if condition="$childforumbits">
<tbody id="collapseobj_forumbit_$forumid" style="{$collapseobj_forumid}">
$childforumbits
</tbody>
</if>

Brandon Sheley
01 Jul 2008, 07:27
nice mod, I'll bookmark this.. I know I've had ppl ask how to fix this on their forums..

Thanks!

/me clicks install

Super Jinni
01 Jul 2008, 11:50
Hello,
Okay, yes, I did that. Here (http://www.speedsolving.com/forum/forumdisplay.php?f=9) is the site that is having problems...notice the subforum.

Here is a copy of my forumhome template, following by the forumhome_forumbit_level1_nopost template. Let me know if you notice anything wrong. Thanks

$stylevar[htmldoctype]
<html dir="$stylevar[textdirection]" lang="$stylevar[languagecode]">
<head>
<!-- no cache headers -->
<meta http-equiv="Pragma" content="no-cache" />
<meta http-equiv="Expires" content="-1" />
<meta http-equiv="Cache-Control" content="no-cache" />
<!-- end no cache headers -->
$headinclude
<title><phrase 1="$vboptions[bbtitle]">$vbphrase[x_powered_by_vbulletin]</phrase></title>
</head>
<body>
$header
$navbar

<!-- Advertisement Code -->
<br />
<div align="center">

<script language="JavaScript" type="text/javascript">
<!--
ctxt_ad_partner = "xx";
ctxt_ad_section = "xx";
ctxt_ad_bg = "2F6084";
ctxt_ad_width = 728;
ctxt_ad_height = 90;
ctxt_ad_bc = "FFFFFF";
ctxt_ad_cc = "FFFFFF";
ctxt_ad_lc = "2F6084";
ctxt_ad_tc = "000000";
ctxt_ad_uc = "2F6084";
// -->
</script>
<script language="JavaScript" src="http://ypn-js.overture.com/partner/js/ypn.js">
</script>

</div>
<br>
<!-- / Advertisement Code -->

<!-- main -->
<if condition="$show['guest']">
<!-- guest welcome message -->
<ca-hdr>
<td class="tcat" width="100%"><phrase 1="$vboptions[bbtitle]">$vbphrase[welcome_to_the_x]</phrase></td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0;">
<tr>
<td class="alt1">
<phrase 1="faq.php$session[sessionurl_q]" 2="register.php$session[sessionurl_q]">$vbphrase[first_visit_message]</phrase>
</td>
</tr>
</table>
<!-- / guest welcome message -->
</if>

<div id="forum0_div" style="display: none;">
<ca-hdr>
<td class="tcat" width="100%">$vboptions[bbtitle]</td>
</ca-hdr>
</div>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0; display: none;" id="forum0">

$forumbits
<tbody>
<tr>
<td class="tfoot" align="center" colspan="<if condition="$vboptions['showmoderatorcolumn']">6<else />5</if>"><div class="smallfont"><strong>
<a href="forumdisplay.php?$session[sessionurl]do=markread" rel="nofollow">$vbphrase[mark_forums_read]</a>
<if condition="$vboptions['forumleaders']">&nbsp; &nbsp;
<a href="showgroups.php$session[sessionurl_q]" rel="nofollow">$vbphrase[view_forum_leaders]</a></if>
</strong></div></td>
</tr>
</tbody>
</table>
$forumhome_markread_script
<!-- /main -->
<!-- Advertisement Code -->
<div align="center">
<script language="JavaScript" type="text/javascript">
<!--
ctxt_ad_partner = "xx";
ctxt_ad_section = "xx";
ctxt_ad_bg = "2F6084";
ctxt_ad_width = 468;
ctxt_ad_height = 60;
ctxt_ad_bc = "FFFFFF";
ctxt_ad_cc = "FFFFFF";
ctxt_ad_lc = "2F6084";
ctxt_ad_tc = "000000";
ctxt_ad_uc = "2F6084";
// -->
</script>
<script language="JavaScript" src="http://ypn-js.overture.com/partner/js/ypn.js">
</script>
</div>
<!--/ Advertisement Code -->

<!-- what's going on box -->
<ca-hdr>
<td class="tcat" width="100%">$vbphrase[whats_going_on]</td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="border-top-width: 0;">

<if condition="$show['loggedinusers']">
<!-- logged-in users -->
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_activeusers')"><img id="collapseimg_forumhome_activeusers" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_activeusers].gif" alt="" border="0" /></a>
<a href="online.php$session[sessionurl_q]" rel="nofollow">$vbphrase[currently_active_users]</a>: $totalonline (<phrase 1="$numberregistered" 2="$numberguest">$vbphrase[x_members_and_y_guests]</phrase>)
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_activeusers" style="$vbcollapse[collapseobj_forumhome_activeusers]">
<tr>
<td class="alt2"><a href="online.php$session[sessionurl_q]" rel="nofollow"><img src="$stylevar[imgdir_misc]/whos_online.gif" alt="$vbphrase[view_whos_online]" border="0" /></a></td>
<td class="alt1" width="100%">
<div class="smallfont">
<div style="white-space: nowrap"><phrase 1="$recordusers" 2="$recorddate" 3="$recordtime">$vbphrase[most_users_ever_online_was_x_y_at_z]</phrase></div>
<div>$activeusers</div>
</div>
</td>
</tr>
</tbody>
<!-- end logged-in users -->
</if>
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_stats')"><img id="collapseimg_forumhome_stats" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_stats].gif" alt="" border="0" /></a>
<phrase 1="$vboptions[bbtitle]">$vbphrase[x_statistics]</phrase>
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_stats" style="$vbcollapse[collapseobj_forumhome_stats]">
<tr>
<td class="alt2"><img src="$stylevar[imgdir_misc]/stats.gif" alt="<phrase 1="$vboptions[bbtitle]">$vbphrase[x_statistics]</phrase>" border="0" /></td>
<td class="alt1" width="100%">
<div class="smallfont">
<div>
$vbphrase[threads]: $totalthreads,
$vbphrase[posts]: $totalposts,
$vbphrase[members]: $numbermembers<if condition="$show['activemembers']">,
<span title="<phrase 1="$vboptions[activememberdays]">$vbphrase[within_the_last_x_days]</phrase>">$vbphrase[active_members]: $activemembers</span>
</if>
</div>
<div><phrase 1="member.php?$session[sessionurl]u=$newuserid" 2="$newusername">$vbphrase[welcome_to_our_newest_member_x]</phrase></div>
</div>
</td>
</tr>
</tbody>
<if condition="$show['birthdays']">
<!-- today's birthdays -->
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_birthdays')"><img id="collapseimg_forumhome_birthdays" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_birthdays].gif" alt="" border="0" /></a>
$vbphrase[todays_birthdays]
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_birthdays" style="$vbcollapse[collapseobj_forumhome_birthdays]">
<tr>
<td class="alt2"><a href="calendar.php?$session[sessionurl]do=getday&amp;day=$today&amp;sb=1"><img src="$stylevar[imgdir_misc]/birthday.gif" alt="$vbphrase[view_birthdays]" border="0" /></a></td>
<td class="alt1" width="100%"><div class="smallfont">$birthdays</div></td>
</tr>
</tbody>
<!-- end today's birthdays -->
</if>
<if condition="$show['upcomingevents']">
<tbody>
<tr>
<td class="thead" colspan="2">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumhome_events')"><img id="collapseimg_forumhome_events" src="$stylevar[imgdir_button]/collapse_thead$vbcollapse[collapseimg_forumhome_events].gif" alt="" border="0" /></a>
<if condition="$show['todaysevents']">$vbphrase[todays_events]<else /><phrase 1="$vboptions[showevents]">$vbphrase[upcoming_events_for_the_next_x_days]</phrase></if>
</td>
</tr>
</tbody>
<tbody id="collapseobj_forumhome_events" style="$vbcollapse[collapseobj_forumhome_events]">
<tr>
<td class="alt2"><a href="calendar.php$session[sessionurl_q]"><img src="$stylevar[imgdir_misc]/calendar.gif" alt="$vbphrase[calendar]" border="0" /></a></td>
<td class="alt1" width="100%"><div class="smallfont">$upcomingevents</div></td>
</tr>
</tbody>
</if>
</table>
<br />
<!-- end what's going on box -->

<!-- icons and login code -->
<table cellpadding="0" cellspacing="2" border="0" width="100%">
<tr valign="bottom">
<td>
<table cellpadding="2" cellspacing="0" border="0">
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_new.gif" alt="$vbphrase[contains_new_posts]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_contains_new_posts]</td>
</tr>
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_old.gif" alt="$vbphrase[contains_no_new_posts]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_contains_no_new_posts]</td>
</tr>
<tr>
<td><img src="$stylevar[imgdir_statusicon]/forum_old_lock.gif" alt="$vbphrase[a_closed_forum]" border="0" /></td>
<td class="smallfont">&nbsp; $vbphrase[forum_is_closed_for_posting]</td>
</tr>
</table>
</td>
<if condition="!$show['guest']">
<!-- member logout -->
<td align="$stylevar[right]"><a href="login.php?$session[sessionurl]do=logout&amp;logouthash=$bbuserinfo[logouthash]" onclick="return log_out()"><phrase 1="$bbuserinfo[username]">$vbphrase[log_out_x]</phrase></a></td>
<!-- end member logout -->
</if>
</tr>
</table>
<!-- / icons and login code -->

$footer
</body>
</html>

forumhome_forumbit_level1_nopost template:

</table>
<if condition="$show['subforums']">
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px;">
<thead>
<tr>
<td class="tcat" colspan="<if condition="$vboptions[showmoderatorcolumn]">6<else />5</if>">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumbit_$forumid')"><img id="collapseimg_forumbit_$forumid" src="$stylevar[imgdir_button]/collapse_tcat{$collapseimg_forumid}.gif" alt="" border="0" /></a>
<a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
<if condition="$show['forumdescription']"><div class="smallfont">$forum[description]</div></if>
<if condition="$show['subforums']"><div class="smallfont"><strong>$vbphrase[subforums]</strong>: $forum[subforums]</div></if>
</td>
</tr>
</thead>
<else />
<ca-hdr>
<td class="tcat" width="100%">
<a style="float:$stylevar[right]" href="#top" onclick="return toggle_collapse('forumbit_$forumid')"><img id="collapseimg_forumbit_$forumid" src="$stylevar[imgdir_button]/collapse_tcat{$collapseimg_forumid}.gif" alt="" border="0" /></a>
<a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
</td>
</ca-hdr>
<table class="tborder" cellpadding="$stylevar[cellpadding]" cellspacing="$stylevar[cellspacing]" border="0" width="100%" align="center" style="margin-bottom: 10px; border-top-width: 0;">
</if>
<tbody>
<tr align="center">
<td class="thead" width="5%">&nbsp;</td>
<td class="thead" width="50%" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" width="25%">$vbphrase[last_post]</td>
<td class="thead" width="10%">$vbphrase[threads]</td>
<td class="thead" width="10%">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead" width="0%">$vbphrase[moderator]</td>
</if>
</tr>
</tbody>
<if condition="$childforumbits">
<tbody id="collapseobj_forumbit_$forumid" style="{$collapseobj_forumid}">
$childforumbits
</tbody>
</if>


I'm afraid that the template modification in this thread have nothing to do with your issue

this template modification is only to fix the last post alignment problem in forumhome only, not inside the forums in forumdisplay..

note that even here in vbulletin.org and vbulletin.com have the same issue. but I don't think that is issue.. because the subforums list in a forum is quite different from threads list in the same forum..

anyway, I think -maybe- you need to modify another template to get what you want, but I'm not sure if it gonna work as you want..

:)

maybe when I have time I'll try to see what I can do about that.

Super Jinni
01 Jul 2008, 11:52
nice mod, I'll bookmark this.. I know I've had ppl ask how to fix this on their forums..

Thanks!

* Loco.M clicks install

you're welcome

glad you find it useful

:)

357Magnum
01 Jul 2008, 18:33
you are a god!!! Thank you so much. this was pissing me off to no end on my board and nobody on here could fix it...

https://www.vbulletin.org/forum/external/2008/07/96.jpg

now is fixed. thank you thank you thank you

Super Jinni
01 Jul 2008, 22:00
you are a god!!! Thank you so much. this was pissing me off to no end on my board and nobody on here could fix it...

https://www.vbulletin.org/forum/external/2008/07/96.jpg

now is fixed. thank you thank you thank you

you are very welcome
glad I could help :)

by the way
I'm not a god
I'm just one like you.. a human
:p

iPodHacking.com
22 Jul 2008, 01:36
Thank you.

ErrorLog
24 Jul 2008, 19:58
Wow =} Thank You .. İnstalled..

moschino
01 Nov 2008, 15:33
In my forum work great with IE but still not aligned in Firefox some help? My Fórum here (www.moscal.org)

Gleedo
13 Nov 2008, 19:57
Well i made the change, but it didnt look any different, so i reverted it back.....

My forums are at www.urbanstrikeforce.com/forums/index.php

I dont have any change to make in the FORUMHOME bit

Here is my extract for forumhome_forumbit_level1_nopost:

<tr>
<td class="thead" style="width: 4%;">&nbsp;</td>
<td class="thead" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" style="width: 26%;" nowrap="nowrap">$vbphrase[last_post]</td>
<td class="thead" style="width: 5%; text-align: center;">$vbphrase[threads]</td>
<td class="thead" style="width: 5%; text-align: center;">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>


Any ideas why the suggested change did not work?

LadyStardust83
13 Nov 2008, 22:17
Hello :) .. This modification looks great but I runned into a problem and I am so confused lol .. I did the editing and have checked it like 10 times now and everything is right, but the drop down menu not showing up for me and it should do since I have sub forums. Is there a setting I have forgot or what? I am still kinda new to vBulletin. Hope someone can help me out :)

Gleedo
13 Nov 2008, 22:48
I now have the following in my "forumhome_forumbit_level1_nopost" template, but it still is not working - see live site at www.urbanstrikeforce.com/forums/index.php - im confused as to why this isnt working :(


<tr>
<td class="thead" style="width: 4%;">&nbsp;</td>
<td class="thead" style="width: 50%;" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" style="width: 26%;">$vbphrase[last_post]</td>
<td class="thead" style="width: 10%; text-align: center;">$vbphrase[threads]</td>
<td class="thead" style="width: 10%; text-align: center;">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>

Ohiosweetheart
13 Nov 2008, 23:44
I've always changed the same code in the forum display template as well.

compact123
13 Nov 2008, 23:59
Many-thanks

Gleedo
14 Nov 2008, 07:41
I've always changed the same code in the forum display template as well.

Tried that and its still not rendering correctly:confused: (i edited FORUMDISPLAY template to match)

chikkoo
16 Nov 2008, 16:12
Hi..

I found the code in go to "forumhome_forumbit_level1_nopost" template, and replced your code, still it is not aligned.

Anything else to do?

SSJB_7
31 Dec 2008, 11:21
thanks a lot it's very nice looking now

sundarmobiles
18 Jan 2009, 18:23
I dont have any change to make in the FORUMHOME bit

Here is my extract for forumhome_forumbit_level1_nopost:

<tr>
<td class="thead" style="width: 4%;">&nbsp;</td>
<td class="thead" align="$stylevar[left]">$vbphrase[forum]</td>
<td class="thead" style="width: 26%;" nowrap="nowrap">$vbphrase[last_post]</td>
<td class="thead" style="width: 5%; text-align: center;">$vbphrase[threads]</td>
<td class="thead" style="width: 5%; text-align: center;">$vbphrase[posts]</td>
<if condition="$vboptions['showmoderatorcolumn']">
<td class="thead">$vbphrase[moderator]</td>
</if>
</tr>



still it is not aligned

srkrocks
20 Jan 2009, 20:10
I was looking for this thanks a lot! :D

arabswell
24 Jan 2009, 22:55
Many thanks

2dub
09 Feb 2009, 18:57
I was wondering if this could be made to work in other columns my issue is not in the last post area. If so how would I fix my issue (see attached image)?

Thanks,
Warren

ddo36
26 May 2009, 06:59
exactly what i need!!!!!! love it!

magicman17
29 May 2009, 03:14
i need help i fu$$ed my template up and need someone to look at it asap please pm me will pay to get it fixed!!

Dingo14
22 Jun 2009, 06:08
yeah thanks for this a great fixed realigned the site back to how it should be

Zacaretas
07 Aug 2009, 09:59
I created a new style and noticed that the alignment was off. I did a quick search on Google and this thread came up. This hack fixed the problem and it was just what I was looking for. It's working on 3.8.2.

(:

scool
09 Oct 2009, 10:03
greetings to all.

Am i missing something?
i followed the steps from the developer..but still my forum home is not aligned perfectly , as i saw other forums..

my website is this one -> GameBattles.gr (http://gamebattles.gr/forum)

as you can see in index..the lines are not aligned.
i have done exactly the steps as the developer said.

can you help plz?
thanks in advance!