PDA

View Full Version : Configure a server not to receive mail


ssslippy
22 Jun 2008, 18:46
I am on a dedicated server however our server was misconfigured to receive mail so anything that it sent by the phpmailer is being sent to the server which doesnt have a mail client.

Our email is hosted by our web host.

Dismounted
23 Jun 2008, 08:21
Mail is directed by the MX records of a domain - you can changed these by editing your domain's DNS records.

ssslippy
23 Jun 2008, 22:20
Our DNS is also hosted by the webhost and that is configured to send the mail to the right spot.
However our sendmail function only wants to send to localhost.

Dismounted
24 Jun 2008, 09:27
Most likely, you are using Postfix (correct?) and has been configured to send mail to "x.com" locally. Look at the "transport_maps" option in the configuration.

IronMountain
01 Jul 2008, 19:19
Check to see if there is a mail server running like Postfix, if it is, turning it off will usually be a quick fix.

Dismounted
02 Jul 2008, 08:20
If you disable Postfix, he won't be able to send mail in the first place (if he is using its SMTP "module").