PDA

View Full Version : Forum Display Enhancements - Prefix for Sub-Forum Status Images


dannykilla
29 Jun 2008, 20:24
This allows the Prefix for Forum Status Images on Sub forums.

In the template
forumhome_subforumbit_nopost

replace all the code with this:


<img class="inlineimg" src="$stylevar[imgdir_statusicon]/subforum_$forum[statusicon].png" alt="" border="0" id="forum_statusicon_$forum[forumid]" /> <a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>

In the template
forumhome_subforumbit_post

replace all the code with this:


<img class="inlineimg" src="$stylevar[imgdir_statusicon]/$forum[imageprefix]subforum_$forum[statusicon].png" alt="" border="0" id="forum_statusicon_$forum[forumid]" /> <a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>

to change the file type simply edit the code (highlighed in RED)!

iogames
29 Jun 2008, 21:20
Finally! :):up:

irongloves
30 Jun 2008, 12:08
Well done! :up:

tunistunis
02 Jul 2008, 21:12
how to add img ?? link adresse ???

dannykilla
03 Jul 2008, 00:55
simply add a prefix to your subforum.

for an example lets say we have a subforum called "manutd"
Now in:
AdminCP > Forum & Moderators > Forum Manager > choose your sub forum in this case manutd

then in the option > Prefix for Forum Status Images
add a prefix called (this is an example)

manutd_

Now create your images, I have two images and called them the following:

manutd_subforum_new.png
manutd_subforum_old.png

Now upload these images to the directory /images/statusicon/

and thats it, if you want to change the file type of the status images simply change the file name in the code (above) to whatever you want. I have now highlighted that part in red!

I have attached some images to help some of you out!

aksolo
03 Jul 2008, 02:08
very nice thank u sir.

tunistunis
03 Jul 2008, 13:58
thanks my friend

aksolo
05 Jul 2008, 05:07
i have 1 question, this is for the subforums. and it also works for the forums status icon.
but i see on your forums that u have 3 icons. i was wondering how did u that other icon next to the forums, looks very nice.

dannykilla
05 Jul 2008, 09:23
I dont know what you mean by 3 icons?
if you mean, what I think you mean (look at image)


http://www.vbulletin.com/forum/showthread.php?t=114545

Dan

KURTZ
05 Jul 2008, 11:47
hi Danny, interesting hack, but i saw that you have a trouble with the alignment of the subforums (if you have some) ... it's possible to fix this?

thanks

dannykilla
05 Jul 2008, 11:50
@Kurtz
I have looked at my forum and I don't see any problem regarding the alignment, did you mean that you are having an alignment problem?
If so I am using Cyb's Subforum hack

http://www.vbulletin.org/forum/showthread.php?t=177954

KURTZ
05 Jul 2008, 11:54
@ Dan: i mean this alignment (check the pic attached)

dannykilla
05 Jul 2008, 12:00
Yeah I am trying to solve this at the moment lol
I'll post if I can fix it!

KURTZ
05 Jul 2008, 18:22
thx Dan ;)

aksolo
07 Jul 2008, 04:04
I dont know what you mean by 3 icons?
if you mean, what I think you mean (look at image)


http://www.vbulletin.com/forum/showthread.php?t=114545

Dan

yes thanks again my man.

nexialys
10 Jul 2008, 10:09
Yeah I am trying to solve this at the moment lol
I'll post if I can fix it!

this is quite simple actually... you can surround the $subforums with a div that have padding-left: 10px; or something similar depending on your design... nothing fancy...

dannykilla
10 Jul 2008, 10:26
I'll give it a go, thanks Nexialys

KURTZ
17 Jul 2008, 20:01
news Dan?

GaiLoan
22 Jul 2008, 04:43
@ Dan: i mean this alignment (check the pic attached)

this happen cuz by images size.

MissKalunji
23 Jul 2008, 22:05
Nice mod sadly i found it when i finished doing it myself

Thanks :)

K4GAP
24 Jul 2008, 02:09
@ Dan: i mean this alignment (check the pic attached)

Excuse me for butting in but the image on top (the ball) is so much larger causing the images below it to offset. I really think if you stick with the same size images everything would be ok.

MCAlexandre
14 Nov 2008, 22:41
Er... Seems a nice mod, but no files uploaded? :P

RobbieZ
14 Nov 2008, 23:54
Cool. Thanks

Er... Seems a nice mod, but no files uploaded? :P

Its a template change !!

JVCode
19 Nov 2008, 01:33
Not showing any images for me... even after changing the format to .gif - any help? I'm running the latest version of vBulletin (3.7.4).

Bibee
28 Nov 2008, 01:06
It's
<img class="inlineimg" src="$stylevar[imgdir_statusicon]/$forum[imageprefix]subforum_$forum[statusicon].png" alt="" border="0" id="forum_statusicon_$forum[forumid]" /> <a href="forumdisplay.php?$session[sessionurl]f=$forum[forumid]">$forum[title]</a>
for both post and nopost.
But thanks a lot this is very usefull.

khurtsiya
11 Nov 2010, 14:29
any one used this on 3.8.1?

T.Nguyen
04 Dec 2010, 19:31
After I finished these changes, then I got a problem with sub-forum columns. Look at the picture. I put 2 columns in sub-forum manager. But It's not working
https://www.vbulletin.org/forum/external/2010/12/60.png