PDA

View Full Version : Social Group and Album Enhancements - New Social Groups page layout


Lynne
05 Feb 2009, 15:08
A template edit for the Social Groups page to look more like the Profile page.

version 1.2 - 2009-02-07
Fixed some issues with the conditions being inside the div tags instead of outside. Searching discussions should now give you a full size table listing instead of the 'short' table. (And yeah, I skipped version 1.1 just cuz I felt like it!)

version 1.3 - 2009-02-12
Added View Pictures and Add Pictures at bottom of Pictures Box (thanks Theater!) and fixed issue with centering pictures in Social Groups causing pictures to display vertically in the Group Pictures page.

version 1.3.1 - 2009-02-12
Fixed a condition around an end div tag.

version 1.3.2 - 2009-03-07
Fixed a condition around the Add Pictures link.

1. Open the socialgroups_css template and FIND the following lines at the end:

-->
</style> Add the following lines ABOVE those lines:


#content_container {
width:100%;
float:left;
margin-right:-256px;
}
#content {
margin-right:256px;
}
#sidebar_container {
width:250px;
float:right;
}
.content_block {
margin-bottom:6px;
padding:1px;
}
.content_block .block_row {
padding:6px;
margin:1px 0px 0px 0px;
}
.content_block .block_title {
padding:6px;
margin:0px 0px 0px 0px;
}
.content_block h4.thead, .content_block .block_title {
padding:4px;
margin:1px 0px 0px 0px;
}
.content_block .block_footer {
text-align:right;
padding:4px;
margin:1px 0px 0px 0px;
}

Suggested change to this CSS if you use vBSEO is in the text file and in this post (http://www.vbulletin.org/forum/showpost.php?p=1761519&postcount=64). It was suggested by Vitaly, however since I don't use vBSEO, I have no comment regarding it.


2. REPLACE your socialgroups_group template with the following:

** see text file. The template contents are too long. **Please click INSTALL if you find this useful.

Lynne
05 Feb 2009, 15:09
Because it wouldn't fit in the first post....

3. OPTIONAL: If you want the pictures to show up centered in the right side bar, then FIND the following line in socialgroups_picturebit:

<table style="width:{$picturebit_width}px; margin:5px; float:$stylevar[left]" border="0" cellspacing="0" cellpadding="0"> CHANGE to:

<table style="width:{$picturebit_width}px; margin:5px; <if condition="$_GET['do'] != 'grouppictures'">float:center<else />float:$stylevar[left]</if>" border="0" cellspacing="0" cellpadding="0">

RvG2
05 Feb 2009, 15:32
wwwwwwoooooooowwwwwwwwwwwwww!!! thank you so much...

sensimilla
05 Feb 2009, 18:22
Great work :)

Calash
06 Feb 2009, 02:13
Just what I was looking for. Now all I need is to get a better postbit for the discussions area and I will be happy (Not legacy, looking to match standard postbit)

I dropped the CSS in the additional definitions area of my style and it seems to work. Any problems with keeping it there?

Theater
06 Feb 2009, 02:46
Installed, gracias.

Lynne
06 Feb 2009, 03:31
Just what I was looking for. Now all I need is to get a better postbit for the discussions area and I will be happy (Not legacy, looking to match standard postbit)

I dropped the CSS in the additional definitions area of my style and it seems to work. Any problems with keeping it there?
I don't think it's a problem unless it conflicts with the css used on the profile page. I used the same classes and definitions from the profile page, but if you modify them on the profile page, you could end up inheriting the definitions you entered in the additional definitions area.

FiMeTi
07 Feb 2009, 12:11
Great job, thx very much Lynne! :)

/edit
Thanks for the FIXX! ;=)

Lynne
07 Feb 2009, 17:37
OK, I think I had my conditions inside the divs instead of outside the divs. I played around with it and think I have it working correctly. I've attached the new version to the first post.

Thanks for the input! I'm a terrible tester - it worked fine for me and my limited way of using it. :)

Alfa1
08 Feb 2009, 03:16
Looks great!

Please consider making a Social groups index layout as well.

Theater
08 Feb 2009, 04:31
^^^ Seconded.

Lynne
08 Feb 2009, 16:46
You mean group.php? What's wrong with that page? It has the same sort of flow as member.php and group.php?groupid=x (this template edit I did).

Theater
08 Feb 2009, 18:41
A couple of things I noticed today...

1 - This isn't regarding your code because it happens when defaulted. Is it strange that registered members who are not members of a particular group themselves, are able to view the first 5 or so images, but when they go to click them it says they have to join the social group?

Dunno, just thought I'd ask... ^^^

2 - There is no View Pictures link when you are a member of the Social Group. I added the link and swapped the Add Picture phrase so it fits better.

Look for in socialgroups_group template:

<div class="alt2 smallfont block_row block_footer">
<a href="group.php?$session[sessionurl]do=addpictures&amp;groupid=$group[groupid]">$vbphrase[add_pictures_to_this_group]</a>
</div>Replace with:

<div class="alt2 smallfont block_row block_footer">
<a href="group.php?$session[sessionurl]do=grouppictures&amp;groupid=$group[groupid]">$vbphrase[view_pictures]</a> |
<a href="group.php?$session[sessionurl]do=addpictures&amp;groupid=$group[groupid]">$vbphrase[add_pictures]</a>
</div>Result if you're a member of the social group:



http://img89.imageshack.us/img89/9527/fixedlinkak2.jpg

Also, if you use the socialgroups_picturebit optional template modification to this, it will make all the images single column and vertical even on the View Pictures page where you see them all. I just reverted mine and live with the non-centered part.

Cheers,

Alfa1
08 Feb 2009, 19:19
You mean group.php? What's wrong with that page? It has the same sort of flow as member.php and group.php?groupid=x (this template edit I did).

/group.php does not show latest group threads.
Categories on /group.php seem quite chaotic, because they display in the same random way with various font size as tags on tags.php. An alphabetical listing order would be nice.
/group.php?do=categorylist does not show links for staff to delete or edit a group from the main groups overview.
/group.php?do=categorylist does not show the last post in a group. Similar to how it works for forums.
/group.php?do=categorylist does not show latest threads in that category.
Groups on /group.php are listed by icon. Rows, like on /group.php?do=categorylist show a much better overview. IMHO this should be on the main group page.
I find the location for the group search, out of place. IMHO it belongs in its own block.
/group.php does not show popular groups or active groups.

Lynne
08 Feb 2009, 19:26
1 - That is a strange way to do it. They can see the thumbnails, but not the full image.

2 - Good catch! I guess I missed that when changing those boxes around. Do you mind if I put that change in the next revision?

3 - Try this for the line in socialgroups_picturebit. Find:
<table style="width:{$picturebit_width}px; margin:5px; float:$stylevar[left]" border="0" cellspacing="0" cellpadding="0">

Replace with:
<table style="width:{$picturebit_width}px; margin:5px; <if condition="$_GET['do'] != 'grouppictures'">float:center<else />float:$stylevar[left]</if>" border="0" cellspacing="0" cellpadding="0">

Lynne
08 Feb 2009, 20:46
You mean group.php? What's wrong with that page? It has the same sort of flow as member.php and group.php?groupid=x (this template edit I did).
/group.php does not show latest group threads.
Categories on /group.php seem quite chaotic, because they display in the same random way with various font size as tags on tags.php. An alphabetical listing order would be nice.
/group.php?do=categorylist does not show links for staff to delete or edit a group from the main groups overview.
/group.php?do=categorylist does not show the last post in a group. Similar to how it works for forums.
/group.php?do=categorylist does not show latest threads in that category.
Groups on /group.php are listed by icon. Rows, like on /group.php?do=categorylist show a much better overview. IMHO this should be on the main group page.
I find the location for the group search, out of place. IMHO it belongs in its own block.
/group.php does not show popular groups or active groups.
You are talking about a lot more than just a template edit. I don't know that I'm going to be tackling that.

Theater
08 Feb 2009, 20:50
1 - That is a strange way to do it. They can see the thumbnails, but not the full image.

2 - Good catch! I guess I missed that when changing those boxes around. Do you mind if I put that change in the next revision?

3 - Try this for the line in socialgroups_picturebit. Find:
<table style="width:{$picturebit_width}px; margin:5px; float:$stylevar[left]" border="0" cellspacing="0" cellpadding="0">Replace with:
<table style="width:{$picturebit_width}px; margin:5px; <if condition="$_GET['do'] != 'grouppictures'">float:center<else />float:$stylevar[left]</if>" border="0" cellspacing="0" cellpadding="0">

Hehe, cool, I just wanted to make sure it just wasn't me then.

No, not at all. Please feel free to add away. :)

Thank you! That did the trick. :cool:

Jman423
09 Feb 2009, 22:30
Thank you for this MOD.

Do you happen to know how I could display more than just 10 members when viewing the group's main page?

Lynne
10 Feb 2009, 03:01
Thank you for this MOD.

Do you happen to know how I could display more than just 10 members when viewing the group's main page?
Right around line 1950 of the groups.php page is where the query is. I'd try changing the limit and see if that is what you want.

GCC LLC
11 Feb 2009, 15:02
Anyone know of a way to make this a fixed width page? I know Lynne mentioned adding a width to the floatcontainer but that doesn't seem to work.

drsli
11 Feb 2009, 15:50
Many thanks for the neat modification and the other hints! :)

Lynne
11 Feb 2009, 20:22
Anyone know of a way to make this a fixed width page? I know Lynne mentioned adding a width to the floatcontainer but that doesn't seem to work.
If it's not working, then you aren't applying the css correctly.

For width:
<div style="width:90%" class="floatcontainer">

For width and align center:
<div style="width:90%; margin:0 auto" class="floatcontainer">

Keesa
12 Feb 2009, 07:08
never mind. sorry.

Keesa
12 Feb 2009, 07:13
Thank you for this MOD.

Do you happen to know how I could display more than just 10 members when viewing the group's main page?


I changed it here, in group.php

" . ($vbulletin->options['avatarenabled'] ? "LEFT JOIN " . TABLE_PREFIX . "avatar AS avatar ON (avatar.avatarid = user.avatarid) LEFT JOIN " . TABLE_PREFIX . "customavatar AS customavatar ON (customavatar.userid = user.userid) " : '') .
"LEFT JOIN " . TABLE_PREFIX . "customprofilepic AS customprofilepic ON (user.userid = customprofilepic.userid) " .
"WHERE socialgroupmember.groupid = " . $group['groupid'] . " AND socialgroupmember.type = 'member'
ORDER BY user.lastactivity DESC
LIMIT 10
");

Change limit 10 to limit... whatever.

Deviant K1
12 Feb 2009, 10:06
Thanks Lynne!!

INSTALLED!

Jman423
12 Feb 2009, 13:03
Right around line 1950 of the groups.php page is where the query is. I'd try changing the limit and see if that is what you want.

Thank you very much, that worked perfectly!

FiMeTi
12 Feb 2009, 19:24
Lynne I updated the group template today.
Please take a look on the search discussions part.
When you search, the table of "group options" will increase its width and not stay in style.

thanks! :)

Lynne
12 Feb 2009, 19:36
Lynne I updated the group template today.
Please take a look on the search discussions part.
When you search, the table of "group options" will increase its width and not stay in style.

thanks! :)
All you should get when you do a search is the search box. You should not continue to have the members box or pictures box at all.

FiMeTi
12 Feb 2009, 19:42
Oh! Since I am a owner of a group, it apears. Not as guest tho, but as owner it does.
I am talking about the group options bar, where the links <<edit group>> <<delete group>> etc. are listed.

Lynne
12 Feb 2009, 21:27
Ah ha! That one..... just a sec....

OK, that took more than a sec to trace that little div tag down. I had to put a condition around it. It seems to validate now. What a !?%$! :D

Updated.... again! (Who would of thought a simple little template edit would require so many revs!)

Big-K
14 Feb 2009, 04:54
Neat Mod.

How can I increase the number of discussions on the group page.

Lynne
14 Feb 2009, 05:02
Neat Mod.

How can I increase the number of discussions on the group page.
It's an option in vboptions > social group options

Big-K
14 Feb 2009, 22:58
Thanks.

Anyone know how to make the full members list show in 3 columns - like you have in "Contacts and Friends"? See attached

Lynne
15 Feb 2009, 18:47
Thanks.

Anyone know how to make the full members list show in 3 columns - like you have in "Contacts and Friends"? See attached
You would have to modify the code for that. It's under do=viewmembers. You might be able to use the group_memberbit hook. You would probably also have to modify the templates used - memberinfo_small and socialgroups_memberlist. You may be able to just change it so the members are in a div and give the div a width and let them space themselves in the table column. You'd have to play around with it.

Gamelobby
16 Feb 2009, 19:45
Anyone know why i cant see anything in the text file for "socialgroups_group"
I save it to my PC, then extract, but then it opens and there is nothing there..?


*edit*
Nvrmnd, i got it. :)

Gamelobby
17 Feb 2009, 20:57
I have a question.. I'm not sure if this mod caused it or not, i think the issue might have been there prior, but i'll ask anyway. :)

On the profile where it lists a persons social groups that they belong to, it only shows a dash like this

User-Created Social Groups: (6)
-
-
-
-
-
-
No text links to the actual groups...? (but the dash is a link still.!?)

Any thoughts or ideas.?
Thanks

Lynne
18 Feb 2009, 01:24
You can always see if it was this mod by just reverting your template. But, no, this mod is a template mod and only touches the groups.php page. The template that spits out that group list is memberinfo_block_groups.

Gamelobby
18 Feb 2009, 22:51
I know this isn't about this mod, but any idea what might be causing it..?
<if condition="$block_data['membergroupcount']">
<div class="alt1 smallfont block_row">
<span class="group_count">($block_data[membergroupcount])</span> $vbphrase[public_usergroups]:
<ul class="list_no_decoration group_list" id="public_usergroup_list">
$block_data[membergroupbits]
</ul>
</div>
</if>
<if condition="$block_data['socialgroupcount']">
<div class="alt1 smallfont block_row">
<span class="group_count">($block_data[socialgroupcount])</span> $vbphrase[user_created_social_groups]:
<ul class="list_no_decoration group_list" id="social_group_list">
$block_data[socialgroupbits]
</ul>
</div>
</if>
<if condition="!$block_data['membergroupcount'] AND !$block_data['socialgroupcount']">
<div class="alt1 smallfont block_row">$vbphrase[you_not_member_any_groups]</div>
</if>
<if condition="$block_data['show_join_link']">
<div class="alt2 smallfont block_row block_footer"><a href="group.php$session[sessionurl_q]">$vbphrase[join_social_groups]</a></div>
</if>
You can delete this & PM me if that is better.

Thanks in advance. :)

Lynne
18 Feb 2009, 22:54
You should post for help with that issue in the main forums, not in this thread.

aztecboi2003
22 Feb 2009, 22:33
Just installed this and it looks great. Can we add polls in social groups?

tafreeh
24 Feb 2009, 04:17
can someone tell me whats goin on here...
http://www.tafreehmela.com/group.php

Lynne
24 Feb 2009, 04:35
can someone tell me whats goin on here...Maybe you should tell us and/or post an image cuz we can't see that page.

tafreeh
24 Feb 2009, 07:13
here is the screenshot....thnx
http://img255.imageshack.us/img255/5205/64158547.png

Lynne
24 Feb 2009, 15:52
It looks like the path to your images is all incorrect. Revert the template and see if it works then.

itsheinz
01 Mar 2009, 17:37
is this possible in 3.8.1?

Lynne
01 Mar 2009, 17:48
I don't run 3.8.1, but you can always try it and see. If it doesn't, then just hit Revert for the template.

Gamelobby
01 Mar 2009, 19:25
Anyone know why i cant see anything in the text file for "socialgroups_group"
I save it to my PC, then extract the zip, but then it opens and there is nothing there..?


So im getting this problem again..?
It keeps telling me that the file already exists.?
Is there double the files in the zip.?

Lynne
01 Mar 2009, 21:09
So im getting this problem again..?
It keeps telling me that the file already exists.?
Is there double the files in the zip.?
I don't understand the problem you are having. I just downloaded this myself to test it and I get one file called "Socialgroups Template_31.zip". When I double-click to unzip it, I get a folder called "Socialgroups Template" and that folder has two files in it "sg_image.png" and "socialgroups_group.txt". I suggest you remove any files you have from this mod and then redownload this and see if then it unzips for you.

Gamelobby
01 Mar 2009, 21:41
I sent it to a friend and he unzipped it for me.. so my PC is the problem. :)
I only need the txt file right.?

*edit*

Got it.!!

FYI, it works on 3.8.1 :) (except for Mass PM group)
Have a look - http://www.gamelobby.com/Forum/group.php

Lynne
01 Mar 2009, 21:46
Yeah.

Gamelobby
01 Mar 2009, 21:53
The only issue/problem i see is it takes away the option to "Mass PM group"
Can you edit the code so this is still an option.?

Lynne
01 Mar 2009, 22:33
If somebody running 3.8.1 wants to post a 'fix' to add that, then they may. But I can't really look at it until I am running a later version than I currently am (3.8.0).

itsheinz
02 Mar 2009, 02:29
installed lynne,its awsome,perfectly in 3.8.1 as well..cheers!

Gamelobby
02 Mar 2009, 06:04
installed lynne,its awsome,perfectly in 3.8.1 as well..cheers!

Does your Social groups still have the option to "Mass PM Group"..?
(If it works on your 3.8.1, that means i have another issue)

itsheinz
02 Mar 2009, 08:15
Does your Social groups still have the option to "Mass PM Group"..?
(If it works on your 3.8.1, that means i have another issue)
I dont have that option :) but its working fine in my 3.8.1

Infopro
02 Mar 2009, 13:13
You mean group.php? What's wrong with that page? It has the same sort of flow as member.php and group.php?groupid=x (this template edit I did).


I'd like to third the suggestion if I may. :)

Your changes make that page look a lot nicer, but you have to get past the main group page first which isn't so nice. This page has bothered me since it's inception. I like the idea, hate the layout.

Thanks.

Gamelobby
03 Mar 2009, 03:53
I dont have that option :) but its working fine in my 3.8.1
So it does take away that option from you too.

itsheinz
03 Mar 2009, 05:30
So it does take away that option from you too.
yah perhaps,but it doesnt matter^^

LWS
03 Mar 2009, 05:43
installed, looks great :)

Gamelobby
03 Mar 2009, 19:20
yah perhaps, but it doesnt matter^^

No.. i am wrong, the Mass PM option is a mod so you may not have it installed.. i was thinking it was part of 3.8.1. :)

I'll just have to try to re-install it.
Thanks

DobieGillis©
05 Mar 2009, 13:27
works great but when I try to add a picture using a url from Photbucket, it says invalid url

example


http://i99.photobucket.com/albums/l293/fritothebandito/medal_math-1.gif

Lynne
05 Mar 2009, 15:15
works great but when I try to add a picture using a url from Photbucket, it says invalid url

example


http://i99.photobucket.com/albums/l293/fritothebandito/medal_math-1.gif
What does that have to do with this mod? You don't add pictures with this mod. All this mod does is change the layout of the page.

DobieGillis©
05 Mar 2009, 15:17
What does that have to do with this mod? You don't add pictures with this mod. All this mod does is change the layout of the page.

ok, then. Have a nice day.

Vitaly
06 Mar 2009, 03:16
1. "Add Picture" link has improper IF nearby: user can't see "more images" link.

Please, fix. At my site i did this:

<div class="alt2 smallfont block_row block_footer">
<a href="group.php?$session[sessionurl]do=grouppictures&amp;groupid=$group[groupid]">$vbphrase[view_pictures]</a>
<if condition="$show['add_pictures_link']"><br>
<a href="group.php?$session[sessionurl]do=addpictures&amp;groupid=$group[groupid]">$vbphrase[add_pictures]</a>
</if>
</div>


2. Offered CSS is not quite universal (applied to mastertemplate via TMS). It's ok for classic skin, but breaks VBSEO's one.

This one looks a bit different, but works for both:


#content_container {
width:100%;
float:left;
margin-right:-256px;
}
#content {
margin-right:256px;
}
#sidebar_container {
width:250px;
float:right;
}
.content_block {
margin-bottom:6px;
}
.content_block .block_row {
padding:6px;
}
.content_block .block_title {
padding:6px;
}
.content_block h4.thead, .content_block .block_title {
padding:4px;
}
.content_block .block_footer {
text-align:right;
padding:4px;
}



PS. Thanks for your work :)

Lynne
07 Mar 2009, 20:51
OK, I fixed the condition around the Add Pictures link (good catch!) and also put your suggested CSS for use with vBSEO into the text file. I don't have vBSEO, so I can't comment on your suggestion there.

Xencored
16 Mar 2009, 21:55
Thanks installed :up:

PrincessFiona
25 Mar 2009, 02:44
Awesome. I absolutely love this!!! Thank you so much!!!

Kris

timinrome
27 Mar 2009, 16:01
This looks great, Lynne. Can I also ask if it's possble to allow BBcode in the description field - I want to be to link to other groups and pages on the site. Or link to key member of the group.

Thanks.

Lynne
27 Mar 2009, 16:04
That's a vBulletin thing. This is only a template change - no code changes are done at all. I know users have suggested to vB to allow html/bbcode in the description field, but it is something they will have to change - I can't change it just in a template.

timinrome
27 Mar 2009, 20:35
Installed. Looks great. many thanks.

So for the next vB upgrade, I have to go through the process again I guess?

Lynne
27 Mar 2009, 21:30
If you revert this template when you upgrade, then yes, you would have to do the copy/paste again.

Traxdata
31 Mar 2009, 20:10
does it work on 3.7.? Thanks!

Lynne
31 Mar 2009, 20:15
does it work on 3.7.? Thanks!
I think there is another Social Groups layout in the 3.7 mods forums that you can use for 3.7. I don't think this one will work out-of-the-box because 3.8 has Discussions and 3.7 did not. I'm not sure exactly how that would effect the page though since I don't have a 3.7 test forum.

FiMeTi
01 Apr 2009, 12:54
Hi Lynne!

Can you please fix or add the fixes that have been done in the new version 3.8.2?
Social Group Subscriptions Improved

//edit

hmm..looks like it is all working fine. No update on this template needed? :)

merk_aus
09 Apr 2009, 05:28
hey i am pretty sure I did all of this correctly however my social groups did not change at all on 3.8.2

Lynne
09 Apr 2009, 15:34
hey i am pretty sure I did all of this correctly however my social groups did not change at all on 3.8.2
Make sure you replace the template in the style your are using.

merk_aus
10 Apr 2009, 02:53
thanks lynne will try it all again - sorry yesterday was busy installing and changing everything around - so will try again today and will let you know.

saviola8x
17 Apr 2009, 05:53
Thanks so much

nonwa
24 May 2009, 08:59
Looking Good Thanks..

Madlike
11 Jun 2009, 19:57
Thank you
*Installed.

Sofia
13 Jun 2009, 23:27
Thank you for this template modification, Lynne. Very nice :)

kursed
14 Jun 2009, 02:30
Is there any way that I can make discussions look in a way that newer message appear first?

Lynne
14 Jun 2009, 04:40
Is there any way that I can make discussions look in a way that newer message appear first?
Not with this template edit, no. You would have to either modify the code or write some plugins to do that.

WebCraker
14 Jun 2009, 16:21
Thank you Lynne, n keep up da good work

JorgeX
23 Jun 2009, 22:49
hey i am pretty sure I did all of this correctly however my social groups did not change at all on 3.8.2

I did everything too but nothing changed =S

Please see a group http://foros.projectreality.com.ar/group.php?groupid=5&styleid=3

I did the template change on my default template (Realitymod) and nothing changed there or in teh vB Default Style

Whats wrong?

john102774
25 Jun 2009, 04:53
Thank you for this template Lynne, excellent work.

isatice
02 Jul 2009, 16:21
wow thanks , installed with no pain in less than a minute , great job dude

FReeSTER
24 Jul 2009, 14:47
I have this little problem. My forum socialgroup on the user profile looks terrible

What can have done this? or how can I fix it?

https://www.vbulletin.org/forum/external/2009/12/26.png


The boxes on the side looks bad and on top of the menu

kaanon
12 Aug 2009, 21:28
Brilliant.

Mobo
13 Aug 2009, 09:21
Nice, thank you!

EidolonAH
09 Sep 2009, 06:08
Simply perfect, thanks for the share.:)

UltraFanatics
20 Oct 2009, 18:25
This looks very tempting!

Warlord
24 Dec 2009, 04:51
I have this little problem. My forum socialgroup on the user profile looks terrible

What can have done this? or how can I fix it?

https://www.vbulletin.org/forum/external/2009/12/26.png


The boxes on the side looks bad and on top of the menu

I have a similar problem. My Side Blocks on the member profile are at the bottom of the page. I'm not sure if it is the result of this mod or not, but if others are having similar problems and they use the same id tags as the memberinfo css I'm guessing so?

Do you have any idea what could be wrong Lynne?

Lynne
24 Dec 2009, 04:57
This mod has absolutely nothing to do with the member.php page. The css for it is only added to the social groups page. So I do not know what is causing your problem.

Warlord
24 Dec 2009, 04:59
Well, I reverted all the templates, tried disabling anything that I could think would be causing this and I've still yet to track down the source of the weirdness. I don't think it's this modification though.

Warlord
24 Dec 2009, 05:39
Sorry if I might have cast any doubt on your modification Lynne. You're a phenomenal coder.

On a side note if anyone else thinks your modification had something to do with their member profile blocks being displayed incorrectly I did manage to track down the source of the problem. It's apparently a bug within the vBulletin Blog system itself.

You lose the Blogs tab on the member profile page by doing this but it corrects the problem.

In your AdminCP under Plugins & Products disable the Plugin Member Profile: Add Blog Links to standard MEMBERINFO display. My layout corrected itself just fine after I did.

COL NIL SATIS
05 Jan 2010, 19:25
Lynne quite simply outstanding!!! love it...nominated and installed

alfaowner
10 Jan 2010, 00:54
what he said on post 97

profanitytalker
21 Apr 2010, 05:03
Wow. Thank you. I think I'm going to install this hack.

Phototrope
08 May 2010, 19:00
Hi Lynne,

This is pretty much exactly what I was looking for, except that I have a VB4 installation.

Are any mods required to get this working on VB4?

Lynne
08 May 2010, 19:10
Hi Lynne,

This is pretty much exactly what I was looking for, except that I have a VB4 installation.

Are any mods required to get this working on VB4?
It already looks like this on vB4 (or close enough that I didn't feel the need to change it).

Phototrope
08 May 2010, 19:13
Yes, sorry, I realised that after I sent the post and and then found your mod update post on the VB4 area.

For the record, I prefer the way you designed the mod (ie., with the left and right sides flipped) than the way vb4 release did it.

Lynne
09 May 2010, 03:38
Yes, sorry, I realised that after I sent the post and and then found your mod update post on the VB4 area.

For the record, I prefer the way you designed the mod (ie., with the left and right sides flipped) than the way vb4 release did it.
Just change the css to float the right div left and the left div right. That should do it.

Scandal
11 Dec 2010, 16:28
Thank you very much! It is great! :)

Scandal
12 Dec 2010, 15:47
If anyone want to add the icon1.gif at the left of any discussion (like the forum threads) do the following changes.
124417

In the template socialgroups_group find
$template_hook[group_discussionlist_start_col]
Add below
<td class="thead"></td>




In the template socialgroups_discussion find
$template_hook[group_discussionbit_start]
Add below
<td class="alt1" align="center"><img src="path/images/icons/icon1.gif"></img></td>
where "path" your forum url :up:

You're done!

JacquiiDesigns
29 Dec 2010, 10:50
Hey Lynne - is this share already the default Social Groups display in vB 3.8.6 PL1

Thanks :)

Eduardo Leon
29 Dec 2010, 12:59
hey ! I get this error :

#content_container { width:100%; float:left; margin-right:-256px; } #content { margin-right:256px; } #sidebar_container { width:250px; float:right; } .content_block { margin-bottom:6px; padding:1px; } .content_block .block_row { padding:6px; margin:1px 0px 0px 0px; } .content_block .block_title { padding:6px; margin:0px 0px 0px 0px; } .content_block h4.thead, .content_block .block_title { padding:4px; margin:1px 0px 0px 0px; } .content_block .block_footer { text-align:right; padding:4px; margin:1px 0px 0px 0px; }

Lynne
29 Dec 2010, 16:57
Hey Lynne - is this share already the default Social Groups display in vB 3.8.6 PL1

Thanks :)
No. vB never changed the layout of this page in vB3.8.x

hey ! I get this error :

#content_container { width:100%; float:left; margin-right:-256px; } #content { margin-right:256px; } #sidebar_container { width:250px; float:right; } .content_block { margin-bottom:6px; padding:1px; } .content_block .block_row { padding:6px; margin:1px 0px 0px 0px; } .content_block .block_title { padding:6px; margin:0px 0px 0px 0px; } .content_block h4.thead, .content_block .block_title { padding:4px; margin:1px 0px 0px 0px; } .content_block .block_footer { text-align:right; padding:4px; margin:1px 0px 0px 0px; }
You didn't follow the instructions carefully. Go back and reread them and redo what the instructions say to do.

MagicThemeParks
15 May 2011, 16:28
Decided to use Social Groups on my new site (USHistoryForums.com (http://www.unitedstateshistoryforum.com) running 3.8.7) and this mod was a great improvement in the look of the layout! :D

DEMO: United States History Forum Group Layout (http://www.unitedstateshistoryforum.com/group.php?groupid=1)

Thanks Lynne! :up:

viper357
21 Jun 2011, 08:35
Lynne, or anybody else that can help.

I am trying to get the category description to show underneath the category heading on the main group.php page.

I have copied this line of code from the "socialgroups_categorylist_bit" template (the description shows when you click on the "view all Categories" link) , but I have no idea how or where to put it in order to show the description on the main page.

<div class="smallfont">$category[description]</div>

Thanks. :)