PDA

View Full Version : [Tip] Having Suhosin Module Problems? Try this


paintballer.ie
20 Aug 2009, 22:29
Here is a tip for any one who is having trouble with the Suhosin module in vbulletin. It was bugging me for a long time. I have it originally posted HERE (http://www.paintballer.ie/blogs/paintballer-ie/37-vbulletin-tip-php-module-suhosin-causing-problems.html) in my admin blog for my website.

I was getting the following errors:

* When trying to update the CSS of my style

Required variables have gone missing and execution can not continue. Please try again.

This error can sometimes occur as a result of Suhosin / Hardened PHP being installed on your server. If you know that you have Suhosin running and you have access to the PHP configuration, try increasing the value of the following variables:

* php_value suhosin.post.max_vars
* php_value suhosin.request.max_vars
* When working on vbadvanced
The dreaded 'Get me out of this script'

I already tried to add items to the .htaccess file in my root folder and that resulted in a 500 internal server error. I also tried to change around a php.ini file in my forum root, but that did not help.

Here is that my host did and solved it:
1. Open notepad or any text editor
2. Copy the code below into it
3. php_flag suhosin.cookie.encrypt Off
php_value suhosin.request.max_vars 2048
php_value suhosin.post.max_vars 2048
4. Save and php.ini
5. Upload to your admincp folder

The difference being to add it to the admincp folder and not your forum root. It seemed to make all the difference.

I hope it helps some one.
http://www.paintballer.ie

docvader
13 May 2010, 10:06
Worked for me. Thanks!

BlueCheri
03 Oct 2010, 10:04
Yes buddy, it is working.

Thanx a tons.