PDA

View Full Version : Suite Style - IPB3 Style to vB4


Webmist
22 Jan 2010, 01:49
IPB3 Style on vB4 Suite

A simple port featuring styling from IPB3. Features some new thread marker icons. Changed around the search box to allow more room for the navigation bar to spread out if sites have more than normal tabs. Be aware that for the tab size it is 120px for the tab image alone. Don't make your site width shorter than your navbar tabs width. Otherwise you'll break it. For any additional header image it's suggested to use the following template to insert them into. AdminCP->Styles & Templates->Style Manager->IPB Style->Edit Templates. Select Ad Location Tempaltes->ad_global_header1. It's a blank template so just insert the image code.

To Install:
PLEASE Revert all templates before upgrading. I've scaled down on templates that are modified to 3 (additional.css, vbulletin-chrome.css, and footer.css)


* GoTo AdminCP->Styles & Templates->Download / Upload Styles and import the xml file into a new style
* FTP the image folder into your root forum directory. This will create a directory images/IPB.


I've checked out the layout for IE 7, Firefox 3, Safari 4, and Chrome. Any other browsers I haven't see what it looks like. IE6 may have some issues because of the png files.


Included is the zip file:
Image Directory with images.
XML File to import
PSD logo to add your own logo/graphics



Supported Layouts for vBulletin
-CMS
-Forums
-Blogs

To check out a live demo go here. (http://www.junejackson.com/forum/forum.php?styleid=4)


Version 1.01 for vB4.0.1


Verson 1.02 for vB4.0.2

Corrected collapse headers.
Straightened Out Icon Legend on forum display
Fixed Width should be adjustable within reason
Search taken out of navbar and placed in header.
Formatted the Blog and CMS to match the forums.


Verson 1.04 for vB4.0.4P1

Updated images
Fixed/Updated templates with security token authentication.
Adjusted image icon legend for spacing. Should be okay now.
[/LIST]

Verson 1.05 for vB4.0.5P1

Updated images
Reverted all templates and started with new template edits.
Now only has 3 templates that are modified.

Webmist
22 Jan 2010, 01:50
IPB V 1.0.3
Updated css files.
Added some more custom icons.
Corrected some previous colors.
Modified new style variables for 4.0.3.
Included CMS and Blog xml file seperately.



This theme was created with a base install of vbulletin 4.0.5.
This theme is not intended to be a child theme. The CSS will not play well.

Over the next month I've got a couple of major jobs to complete and another theme I'm working on. I'll try my best to get back here and fix any bugs I see.

forexjoker
22 Jan 2010, 02:06
Awesome!! Thanks a lot.

eTiKeT™
22 Jan 2010, 05:45
Hımmm Nice Style Thanks
İnstalled ...

brattanek
22 Jan 2010, 05:50
In Chrome I have a little bug on Icon Legend:

https://www.vbulletin.org/forum/ (http://img132.imageshack.us/i/90568406.jpg/)

LbR
22 Jan 2010, 06:14
Awesome man, Installed it up ;)

LbR
22 Jan 2010, 06:15
In Chrome I have a little bug on Icon Legend:

https://www.vbulletin.org/forum/ (http://img132.imageshack.us/i/90568406.jpg/)


Expanding button you mean?

brattanek
22 Jan 2010, 10:26
Expanding button you mean?

Yes, in IE is ok

Delifed
22 Jan 2010, 12:28
Hmm i like it. But the logo kinda is all by its self. Like it is a bit to far spaced. Also search kinda is all alone and people wouldn't know about it.

Webmist
23 Jan 2010, 00:03
In Chrome I have a little bug on Icon Legend:

http://img132.imageshack.us/img132/2434/90568406.jpg (http://img132.imageshack.us/i/90568406.jpg/)

It's actually the style variables at work.

To correct if you don't like there are 2 css templates you'll have to edit.
In forumdisplay.css
FIND:

dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar right};
margin-{vb:stylevar right}: {vb:math {vb:stylevar padding}/2};
}


REPLACE WITH:

dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar left};
margin-{vb:stylevar left}: {vb:math {vb:stylevar padding}/2};
}


Then in forumhome.css
FIND:

.wgo_subblock dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar right};
margin-{vb:stylevar right}: {vb:math {vb:stylevar padding}/2};
}


REPLACE:

.wgo_subblock dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar left};
margin-{vb:stylevar left}: {vb:math {vb:stylevar padding}/2};
}


It's just changing the variables to the left instead of the right.

Webmist
23 Jan 2010, 00:08
Hmm i like it. But the logo kinda is all by its self. Like it is a bit to far spaced. Also search kinda is all alone and people wouldn't know about it.

I didn't want it to look to much like ipb. As to the search I'll work that in with the upgrade of vb that's not too far off. Thank you for the input.

Frank Sinatra
23 Jan 2010, 08:56
Ey well done i like it!
Regards

vbrissee
25 Jan 2010, 13:02
This one is really Great Thanks

SillyAlien
27 Jan 2010, 03:39
Nice port job.

Small bug: you have your collapse/expand images reversed. [collapse_40b.png] should be the minus, but instead displays the plus and [collapse_40b_collapsed.png] should display the plus and instead displays the minus. In other words, you want to be clicking on a plus sign to expand and on a minus sign to collapse. They're also a bit too low / out of line in the Posting Permissions block at the bottom of the forumdisplay and showthread pages.

Ah, just noticed too... a couple of your thread marker icons (envelopes) are wrong. The "no unread posts" is actually "unread posts" and the "unread posts" is actually unread_dot (thread you posted in).

Webmist
30 Jan 2010, 14:15
Thanks SA. I'll switch those and fix the others noted here. There is a few other fixes as well. But I want to wait for 4.0.2 release early next week as I'm hoping it's a more stable one as to the style variables go.

leeshawks
13 Feb 2010, 15:24
Installed and so far so good. Colors are a little more vivid that the defult style Thanks

elwachiman
14 Feb 2010, 02:54
tnks nice skin

compact123
16 Feb 2010, 11:32
wow awesome a style thanks =)

compact123
16 Feb 2010, 11:49
ummm well sir when i fixed style like 900px, navbar menu is disrupt like the screen shot picture;
so how i can fix it?

http://img718.imageshack.us/img718/4311/32478747.png

http://img294.imageshack.us/img294/2770/36725241.png

cloferba
17 Feb 2010, 17:58
does this work with 4.0.2?

slackin-jer
17 Feb 2010, 23:03
I really like the floating bar on your website. Where can I get such a mod?

basilrath
18 Feb 2010, 13:48
ye the floating tool bar is nice where the hell is that from may i ask?

slackin-jer
19 Feb 2010, 06:05
I found it! Go here to get one: http://www.wibiya.com/

basilrath
19 Feb 2010, 11:21
you is da man lol

Webmist
20 Feb 2010, 23:26
Nice port job.

Small bug: you have your collapse/expand images reversed. [collapse_40b.png] should be the minus, but instead displays the plus and [collapse_40b_collapsed.png] should display the plus and instead displays the minus. In other words, you want to be clicking on a plus sign to expand and on a minus sign to collapse. They're also a bit too low / out of line in the Posting Permissions block at the bottom of the forumdisplay and showthread pages.

Updated the images to show correctly and the thread markers. Except the custom ones.

ummm well sir when i fixed style like 900px, navbar menu is disrupt like the screen shot picture;
so how i can fix it?
I've adjusted this in the update. Your navbar tabs have too many for use with the search bar. That is what is breaking the layout.


does this work with 4.0.2?
Just updated.

miket1234
22 Feb 2010, 17:46
some bugs
When I push the What's New button. Some results come with this

http://img715.imageshack.us/img715/86/wnew.gif

and the icon legend look like this:

http://img709.imageshack.us/img709/8337/foota.gif

miket1234
22 Feb 2010, 17:47
i'm using Fifefox 3 and vBulletin 4.0.2

Webmist
23 Feb 2010, 00:59
i'm using Fifefox 3 and vBulletin 4.0.2

If you don't mind send me a pm with a link. So I can see where it's breaking.

xTa`
23 Feb 2010, 04:58
Can do better, don't like it, very poor quality, but thanks anyways.
Get a look to an IPB3 adaptation on vB 3.8.4 : http://www.xtaze.net..

robbiefritz
01 Mar 2010, 17:42
Why are my Forum Category Strips purple? installed the 4.0.2 version.

It seems that the th_bg.png file that should be in the images>ibp>tabs folder is not. The text in the forum categories is also different. Similar issue? Thanks

Juggernaut
03 May 2010, 04:50
This is not compatible with 4.0.3?

asd_ra7la
03 May 2010, 10:35
Nice Style Thanks
تصميم مواقع (http://www.hexll.com/)

spoky29
03 May 2010, 17:44
Very nice style, but waiting for update 4.0.3 thanks for your work!

Fungsten
05 May 2010, 20:34
Very good sir!

But a couple of questions:

1) When clicking on "Mark Forums Read" I get a security token error.
2) In IE though the forum itself fits on to the screen there is a large blue sector that takes up another half of the screen. BTW, it's fine in Chrome.

Any ideas? Thank you sir!

Astyanax
07 May 2010, 22:18
When will this be updated to 4.0.3?

Webmist
09 May 2010, 19:04
Very good sir!

But a couple of questions:

1) When clicking on "Mark Forums Read" I get a security token error.
2) In IE though the forum itself fits on to the screen there is a large blue sector that takes up another half of the screen. BTW, it's fine in Chrome.

Any ideas? Thank you sir!

Securtiy token error sounds like a template edit. The only templates edits is css and

When will this be updated to 4.0.3?

Yes I'm in the process of doing it now.

Fungsten
09 May 2010, 19:53
Securtiy token error sounds like a template edit. The only templates edits is css and

And? lol.

ZEHH
10 May 2010, 02:00
Waiting for update of version 4.0.3

tofrine
10 May 2010, 23:32
thx
nice work !

spoky29
10 May 2010, 23:41
Yes I'm in the process of doing it now.

Great! thanks

ellinofatsa
24 May 2010, 07:51
i have this problem

https://www.vbulletin.org/forum/external/2010/05/17.png


its ok i fix that with upload again all the files!

Rhodesyo
24 May 2010, 08:10
This is a very pretty skin - thank you, Webmist. Looking forward to 4.0.3!

twitch
28 May 2010, 21:48
heck yeah, nice work! looking forward to 4.0.3 !

twitch
29 May 2010, 04:02
Thanks for the update! I'm not sure which xml file to use. There is one for the cms and blog, what are those for?

snerd
29 May 2010, 05:50
Fantastic skin, thanks! Only had to add Facebook and Myspace images to the social bookmarks. :up:

Webmist
29 May 2010, 07:01
Thanks for the update! I'm not sure which xml file to use. There is one for the cms and blog, what are those for?

It's just the widgets and sidebars. Most won't need them as every things in the css templates and style variables.

twitch
29 May 2010, 13:34
It's just the widgets and sidebars. Most won't need them as every things in the css templates and style variables.

Thanks for the info. Do I just upload them in the CMS admin area somehow?

Fungsten
30 May 2010, 04:27
Your submission could not be processed because a security token was invalid.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.

I'm still getting this if I click on "Mark Forums Read". :confused:

On Edit:

It's only if there are are no threads to mark read. But still it's the only style where this is an issue.

snerd
30 May 2010, 07:07
Can do better, don't like it, very poor quality, but thanks anyways.
Get a look to an IPB3 adaptation on vB 3.8.4 : http://www.xtaze.net..
LOL! Ya little prick, go make your own then. :mad:

Still installed and love it.

zonaenlinea
31 May 2010, 15:47
It's actually the style variables at work.

To correct if you don't like there are 2 css templates you'll have to edit.
In forumdisplay.css
FIND:

dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar right};
margin-{vb:stylevar right}: {vb:math {vb:stylevar padding}/2};
}


REPLACE WITH:

dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar left};
margin-{vb:stylevar left}: {vb:math {vb:stylevar padding}/2};
}


Then in forumhome.css
FIND:

.wgo_subblock dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar right};
margin-{vb:stylevar right}: {vb:math {vb:stylevar padding}/2};
}


REPLACE:

.wgo_subblock dl.icon_legends dt {
float: {vb:stylevar left};
clear: {vb:stylevar left};
margin-{vb:stylevar left}: {vb:math {vb:stylevar padding}/2};
}


It's just changing the variables to the left instead of the right.

Ise friend is so like you said and nothing worked and what not just like you explain ise

Fungsten
02 Jun 2010, 02:48
I'm getting a security token error even with unread posts.

balkanboy
02 Jun 2010, 07:21
hey mate see image bellow not sure what to change in FF it displays as shown in IE its fine i rather it be the opposite lol >.< any way to fix that???

tanerokutan
02 Jun 2010, 22:40
same style but red version I'm looking for.

WhiskeyOSS
08 Jun 2010, 00:37
Very Nice Style very professional looking.. thank you
Installed www.ossauctions.com

balkanboy
09 Jun 2010, 04:08
also how can we change the search area ....it looks messy :(

ahmedipa
14 Jun 2010, 09:13
good style my brother thank you

balkanboy
21 Jun 2010, 23:51
4.0.4 update?

balkanboy
14 Jul 2010, 09:54
having display issues with 4.0.4 mate mostly the expand button,.... known issue?

haidm
14 Jul 2010, 15:41
How can I make all user online in the same line (in Who is online)?
https://www.vbulletin.org/forum/external/2010/07/25.png

apokphp
14 Jul 2010, 18:56
It's a beautiful style...thanks for this. I wish vb would do a much better job on their default skin like IPB does.

apokphp
14 Jul 2010, 19:14
1 problem though...whenever I edit the psd file w/ PS CS4, the background color is always off. I've even removed the highlight/spotlight/etc... layers thinking this was throwing it off...but it isn't.

I can't edit the PSD file and convert it into the logo.png w/o the bg color being off. Anyone help?

www.onlinedebate.net/

apokphp
14 Jul 2010, 19:23
Found another problem...when displaying "What's going on?" at the bottom of the forum, it lists the online users vertically instead of horizontally (like it should).

*edit*

Just realized that this problem is the same as a poster's above (Haidm)...didn't see his post earlier.

apokphp
14 Jul 2010, 19:30
Yikes...also had to disable the CMS. It displayed EVERYTHING veritically as well. The entire layout was "fried". It's only in this style that this happens. Great looking style, but seems like there may be more bugs that need to be looked at.

Fungsten
15 Jul 2010, 19:48
Found another problem...when displaying "What's going on?" at the bottom of the forum, it lists the online users vertically instead of horizontally (like it should).

*edit*

Just realized that this problem is the same as a poster's above (Haidm)...didn't see his post earlier.

Does it with mine too!!

Tyran1
17 Jul 2010, 13:39
vB 4.0.5

Bug:

http://www.vbulletin.org/forum/attachment.php?attachmentid=119752&stc=1&d=1279373970

apokphp
17 Jul 2010, 16:59
Another graphic bug.

Posting Permissions is "off". The first "P" does not show.

apokphp
17 Jul 2010, 23:15
I don't think this style is supported any more. The author hasn't been here in a while and the demo site is no longer a vb site.

I've begun to make some changes myself and learn how to correct the bugs in this style. I'll post the corrections once I have them all sorted out.

balkanboy
19 Jul 2010, 01:41
cheers mate if you could its going to be a hassle for me to change to a new main theme, but if worse comes to worse ill have to if this has no more support

apokphp
20 Jul 2010, 17:19
Been trying to get answers at vb.com and here at vb.org. I am just so shocked at the lack of support. It didn't used to be this way. Both communities had always been extremely busy with helpful members. I suspect that vb4 and the change in business practices has driven away many customers (thus helpful members).

Also, it seems as if the community is filled a bit more with less than courteous members (than there used to be). It's a shame, vb used to be top notch.

Blackbeard02
24 Jul 2010, 11:52
Very nice style thanks for your work I am getting 1 issue with it, when clicking on new post or daily post the forum the thread is in won't show

1Turk
24 Jul 2010, 19:36
Please uptade vBulletin version 4.0.5 ?

apokphp
25 Jul 2010, 05:27
To resolve the vertical list (instead of horizontal) of names in various places, you have to make a template edit.

Find vbulletin.css template in your style.

The following code is supposed to be in that template (found near the top), but it's been edited. Remove the edited code and replace it with the original code which is:

.commalist li {display:inline;}

naoba
12 Sep 2010, 06:05
This does not work on 4.06. Could you please update? The nav bar is breaking up. And in showthread, the user information such as profile, notification etc showed up at the top-left. I'd be glad if someone could help me out wit this. I have marked this installed.

Deimos
10 Oct 2010, 16:59
Yea, doesn't work on 4.0.7, either, which is a shame, as it's a great style.

OldSchoolDSL
13 Oct 2010, 23:48
Worked flawlessly on mine :)
4.0.7

Raedahn
28 Feb 2011, 15:54
Having issue with a few things in Firefox 3.6.13.

http://www.indiscretion-guild.com/forums/forumdisplay.php/16-Chat

1) The "post a new thread" button at the bottom of the forum is obscured by the Thread Display Options menu bar.

2) The posting permissions & icon legend minimize buttons in the right hand corners aren't completely centered in the gray bar.

3) Selected messages moderation menu in the private messaging window shows white text on a white background.

OldSchoolDSL
01 Mar 2011, 03:50
Un-installed

Optimized community. Wanted to move away from themes / styles which used a lot of added images.

pablete
15 Mar 2011, 18:25
Thank's. I have a problem with this theme. the button of 'facebook connect' isn't show on header...

how to fix?
THX

I use: vb 4.1.2

Santi86
27 Oct 2011, 08:09
Works with 4.1.7?

MoDz
28 Oct 2011, 22:32
Updatet Version?

NewGameX
26 Jan 2012, 11:49
Is it works in vB 4.1.10 ? You just add 4.0.1 4.0. 4.0.3 4.0.4 and 4.05.

hexeditor
27 Jan 2012, 18:22
work it??

sodasusu
20 Jul 2012, 23:29
work for vbulletin 4.2.0 nice job

GhostHunter2010
25 Jul 2012, 19:40
the best style so far
works on vb 4.2 without a single problem very cool rip thx for sharin

Caillou
17 Feb 2013, 04:30
Very nice theme.

vimarc
22 Feb 2013, 04:35
Installed but find layout is not aligned centered . left side outside padding is more then right side