PDA

View Full Version : [RE-RELEASED vB2.0.1] Upgraded Signature-Editor w/ Preview


VirtueTech
29 Jul 2001, 08:13
Credit goes to AA and Fryzid for their original hack found here: http://www.vbulletin.com/forum/showthread.php?s=&threadid=12282

HACK UPDATE:
I have updated this hack a bit with my fix above and some other additions as you'll see below.

Additions Adds new 'navbar' to header
Adds Control Panel navbar to header
Adds smilies window to signature editor
Centralized Signature Limit Variable at top of script as an option.
Ability to allow "Administrators" to have different siganture length.
Fixes Bad_Madman's vbcode additon
Cleans up HTML a bit
Screenshot
http://images.paintballcity.com/sig_hack.gif

Directions
The attached file contains the following new items:
- '_editsignature' template
- sedit.php

Upgrading: Just replace the old template and php script with the new ones
First Time Install: Read the modified install.txt

07/29/01 6:19AM EST - First attachment had bad files. Please re-download.

malc
29 Jul 2001, 09:15
I think your attachement isn't good ... because the file is equal to the original hack :(

VirtueTech
29 Jul 2001, 10:29
DOH! :eek:

I updated the ZIP file please re-download.

RobAC
29 Jul 2001, 14:51
James,

Nice job!

GB
29 Jul 2001, 16:41
hrmmm...i cant get it to work. where exactly am i supposed to put that sedit.php file? first i had it in my public_html folder, then moved it to my forums folder, then my admin folder......???

Fryzid
29 Jul 2001, 16:46
Put it again in your forum folder.

GB
29 Jul 2001, 16:49
got it to work....but for some reason i had to put sedit.php in my public_html folder to get it to work....not my forums folder

Stasik
30 Jul 2001, 00:23
A small additional hack for all who want replace the signature box through a link to signature editor

NEWS
30.07.01 ATTENTION!!! ALL PEOPLE WHO HAVE INSTALLED THE HACK HAVE TO UPDATE IT FROM THIS THREAD, OR THE SIGNATURE WILL BE BLANK, AFTER EDITING THE PROFILE

DEMO
http://www.realwebhost.net/ed.gif

HACK
edit modifyprofile template
Step 1
delete link - delete <a href="sedit.php?s=$session[sessionhash]&action=show">Signature-Editor</a>

Step 2
if you want to replace the signature box through a text link - read Step2-a
if you want to replace the signature box through a image link - read Step2-b (image called editor.gif should be located in your /images/ derictory)

substep a
replace:
<td bgcolor="#DFDFDF"><textarea name="signature" rows="6" cols="40">$bbuserinfo[signature]</textarea>

with:
<td bgcolor="#DFDFDF" align="center"><inout type=hidden name="signature" value="$bbuserinfo[signature]"><a href=sedit.php?s=$session[sessionhash]&action=show>Signature Editor</a>

substep b
<td bgcolor="#DFDFDF"><textarea name="signature" rows="6" cols="40">$bbuserinfo[signature]</textarea>

with
<td bgcolor="#DFDFDF" align="center"><inout type=hidden name="signature" value="$bbuserinfo[signature]"><a href="sedit.php?s=$session[sessionhash]&action=show"><img border=0 src="./images/editor.gif"></a>


ENYOJ

VirtueTech
30 Jul 2001, 05:11
Thanks RobAC :)

GB - I'm not sure why you would have to do that.

the_sisko
30 Jul 2001, 08:22
@Stasik:
Don't forget to edit the update query to the database, otherwise your signatur will get blank, when you just edit the profile!!!

EXCHANGE
30 Jul 2001, 08:44
Really nice update :D

Stasik
30 Jul 2001, 10:57
Originally posted by The_Sisko
@Stasik:
Don't forget to edit the update query to the database, otherwise your signatur will get blank, when you just edit the profile!!!

ups... ;) i`ll modify it

VirtueTech
02 Aug 2001, 11:55
New Addition - 08/01/01

After seeing what Stasik did with the button I wanted to it to my site, but I added
a little change to show the signature on the "modify profile" template along
with the button. This borrows code from the original sedit.php hack.

Check it out:
http://images.paintballcity.com/sig_pic.gif

Here's how to do it:
In member.php find:

$signature=htmlspecialchars($bbuserinfo[signature]);


And AFTER it add:

$signaturepreview=bbcodeparse($signature,0,$allowsmilies); // preview


Next open your modifyprofile template

Replace::

<tr>
<td bgcolor="#DFDFDF" valign="top"><b><normalfont>Signature:</normalfont></b><br>
<smallfont>Optional signature you may use to appear at bottom of your posts.</smallfont>
<p><smallfont>HTML code is $htmlonoff<br>
<a href="misc.php?s=$session[sessionhash]&action=bbcode">vB Code</A> is $bbcodeonoff<br>
[img] code is $imgcodeonoff<br>
<a href="misc.php?s=$session[sessionhash]&action=showsmilies">Smilies</a> are $smiliesonoff
</smallfont></p></td>
<td bgcolor="#DFDFDF"><textarea name="signature" rows="6" cols="40">$bbuserinfo[signature]</textarea></td>
</tr>


With:

<tr>
<td bgcolor="#8080A6" colspan="2"><normalfont color="#EEEEFF" class="thtcolor"><b>Signature Preview</b> - </normalfont><smallfont color="white">Optional signature you may use to appear at bottom of your posts.</smallfont> </td>
</tr>
<tr>
<td bgcolor="#DFDFDF" valign="top"><blockquote>$signaturepreview</blockquote></td>
<td bgcolor="#DFDFDF" align="center"><a href="sedit.php?s=$session[sessionhash]&action=show"><img src="images/edit_sig.gif" width="122" height="23" border="0"></a></td>
</tr>


and copy the attached image for your "edit signature" button. If you want to change
the color all you need to do is "colorize" the image and change the HUE.
http://images.paintballcity.com/edit_sig.gif

I hope you like it. :)

Phil
06 Aug 2001, 09:35
That is a nice hack VirtueTech...just adding the latest addition with the button, but I get a parse error in the member.php after I add your change. This may be because I am using vB2.0.3??


Also, your specified colours in the template would be better off replaced with the vB colour variables ({ tableheadbgcolor}, etc) to integrate with any style set.



Edit...I just noticed that the vB will swap those variables for the current colour values when called from a post.....how about adding this infor to your original .zip??

VirtueTech
06 Aug 2001, 19:21
I have not tried this hack with vb2.0.3 yet sorry. When I upgrade I will post here.

As for your idea...I will add that. :)

DarkReaper
07 Aug 2001, 02:09
I just installed it on 2.0.3. It doesn't work right. The vBCode and Smilies boxes aren't there and some of the text is the wrong color.

VirtueTech
07 Aug 2001, 02:16
Yes I know check my last post. This hack is not ready for vb2.0.3 yet

Phil
07 Aug 2001, 07:17
Originally posted by VirtueTech
I have not tried this hack with vb2.0.3 yet sorry. When I upgrade I will post here.

As for your idea...I will add that. :)


Thanks...the original hack works great in 2.0.3, it is just when I add the info to the member.php for the sig to be previewed on the usercp page that I get the parse error....I am sure it won't be a hard fix, but what do I know :rolleyes:

GB
07 Aug 2001, 11:50
I first installed this hack when I was running vB2.0.0 beta4, and just recently upgraded to vB2.0.3 and it works just fine for me.

DarkReaper
08 Aug 2001, 02:32
When will this be avaliable for vB 2.0.3?

Dakota
09 Aug 2001, 18:56
I think I've found a slight bug. After a user edits their sig in the sig editor it takes them back to the profile. And it shows the preview of the sig and everything there, but if they submit modifications on the preview page it deletes their sig.

I am using vB 2.0.1

webhost
11 Aug 2001, 17:35
I am using with version 2.0.3 no problems works fine. I add smilies, img;s text color all works fine. Using the button also
upgrade mind to use VirtueTech changes
Joey

VirtueTech
11 Aug 2001, 18:01
I will posting posting a fix to that bug later Dakota - I have to run out with my family for a bit...I also have another small upgrade to somone elses Idea with the edit button.

Will post again later tonight :)

snyx
11 Aug 2001, 19:02
2.03 works fine www.form-kaos.com

valid
11 Aug 2001, 19:55
do this

http://vbulletin.com/forum/showthread.php?s=&threadid=25056

Phil
12 Aug 2001, 13:42
Working great with 2.0.3 now....apart from the slight bug that Dakota found.

davibou
13 Aug 2001, 16:56
i have install the hack well but just a small problem when i want to preview , save or return back i have a blanck page what can i do now ????

bitbender
14 Aug 2001, 00:23
Great work! :cool: :cool: :cool:

Installed in my 2.0.3 board like a snap!

Eaisest Hack to apply Yet

Triple THUMBS UP!!

webhost
20 Aug 2001, 20:31
VirtueTech

Any ideas yet on the 2.0.3 bug, to keep my signature from disappearing after a edit profile function?

webhost
20 Aug 2001, 21:49
fix for version 2.0.3 with problem with signature leaving after you hit submit button. Doesn't look as pretty but it works and corrects the problem. Make this change only if you have installed and are using the button on the right and the signature preview on the left in usercp profile

Find this in modifyprofile template

<td bgcolor="#DFDFDF" valign="top"><blockquote>$signaturepreview</blockquote></td>


Replace with this
<td bgcolor="{secondaltcolor}"><textarea name="signature" rows="6" cols="40">$bbuserinfo[signature]</textarea></td>

Sarge
21 Aug 2001, 04:38
Originally posted by webhost
fix for version 2.0.3 with problem with signature leaving after [/PHP]


Works great broheim
Sarge

bitbender
21 Aug 2001, 04:48
Yep, Completely Kewl!

Hoffi
21 Aug 2001, 12:36
I turned HTML in Sig on, and installed the Editor.
It works fine, but: If I uses HTML-Tags in the Sig, in the preview the Tags are shown. In the Part: Current Saved Signature in Profile it is shown right.

Where's the Problem?

webhost
21 Aug 2001, 13:36
Hoffi

Read my post above this is correct, to have it like before you
can do it but you lost it everytime you hit the submit button.
To do what you are talking about would take an additional field in the database which is nothing big, but it would also take a major hack in the member php file. Unless someone else knows a easier way.

Phil
22 Aug 2001, 06:23
Originally posted by webhost
fix for version 2.0.3 with problem with signature leaving after you hit submit button. Doesn't look as pretty but it works and corrects the problem. Make this change only if you have installed and are using the button on the right and the signature preview on the left in usercp profile


Works great...thanks a lot :cool:

Hoffi
26 Aug 2001, 07:47
A solution for the Problem i have posted in this Thread:

http://www.vbulletin.com/forum/showthread.php?s=&postid=161037&t=9224#post161037

The SQL-Statement must be changed.

webhost
26 Aug 2001, 07:55
Hoffi

I received this same information last week from The_Sisko, just got around to trying it and it does seem to work,

Joey

Thanks

Afterburner
26 Aug 2001, 14:05
If you go to the usercp click on edit profile than on Signatur editor it shows the bug in the attachment, if you click on prewiew (also without changes) it seems OK

webhost
26 Aug 2001, 14:25
Aferburner what are you talking about explain yourself man, don't see anything about a attachment bug.

Afterburner
26 Aug 2001, 14:30
you dont see the green color ? and the not "converted" smilies ?

I think if I open the sig editor the first time (not the prewiew page) all signatures shall be the same ! Am I right ? My screenshot shows in the prewiew-table not the orginal signature (I dont mean the prewiew page) Do you understand me ? Sorry for the english but I am from Germany

tubedogg
27 Aug 2001, 07:38
OK I've got a zip here with everything fixed up.

Things to know:
--The problem reported by afterburner is fixed.
--The problem with the signature being cleared upon submitting modifyprofile is fixed.
--The default is now to show the user's current signature on the modifyprofile page, with a link to the signature editor. You can change this link to the button provided by VirtueTech if you want to.
--To upgrade, copy and paste the contents of the _editsignature.txt file into your _editsignature template, and make the required changes to member.php and the modifyprofile template. If you have already edited the modifyprofile template I highly suggest you replace those changes with the ones in the install.txt file in the zip.
--It has been fully tested with v2.0.3.

This is my modification to VT's hack, which is a mod to a hack by Fryzid, which is a rewrite of AA's v1.x hack. Got that? ;)

I fixed the bug afterburner reported...only this time I *actually* fixed it. See the new zip file here (http://www.vbulletin.com/forum/showthread.php?postid=162067#post162067).

eva2000
27 Aug 2001, 07:42
Originally posted by tubedogg
This is my modification to VT's hack, which is a mod to a hack by Fryzid, which is a rewrite of AA's v1.x hack. Got that? ;) geez... does that mean this hack is a vB mod's modification of a modified hack which was a rewritten modification of a hack? :)

FWC
27 Aug 2001, 07:55
geez... does that mean this hack is a vB mod's modification of a modified hack which was a rewritten modification of a hack?

LOL!! I don't know. I have the VT version installed. I just downloaded this one. I'll upgrade tomorrow when I am awake again. :D

tubedogg
27 Aug 2001, 08:13
Here's a PSD of the button I'm using on my board for the link to the Sig Editor...enjoy :)

webhost
27 Aug 2001, 10:21
tubedogg

Do we need to change this back in member.php?

A solution for the Problem i have posted in this Thread:

http://www.vbulletin.com/forum/show...9224#post161037

The SQL-Statement must be changed.

tubedogg
27 Aug 2001, 18:42
Yes you should change that back to the original.

webhost
27 Aug 2001, 18:44
thank you

Afterburner
27 Aug 2001, 19:56
@ tubedogg

still the same problem

I uploaded the new sedit.php and replaced the _editsignature Template with the new template

I made no further modifications because I dont need the hack in the "edit profile" - page

webhost
27 Aug 2001, 20:06
Afterburner

Just got through installing hack all over again with changes, now go to my board and see if it works on my board for you.

Let Me know
Just tried your signature, the blues and greens are correct just the reds turn lite green so it is better but still a problem

Joey

tubedogg
27 Aug 2001, 20:11
Originally posted by Afterburner
@ tubedogg

still the same problem

I uploaded the new sedit.php and replaced the _editsignature Template with the new template

I made no further modifications because I dont need the hack in the "edit profile" - page Regardless of whether you want to use it, the changes to member.php need to be made to not erase the signature when you submit your profile. Also you need to find
<input type="hidden" name="action" value="updateprofile">
and add right below it
<input type="hidden" name="signature" value="$sendsig">
in the modifyprofile template - otherwise, again, it will submit a blank signature.

Are you still having the same problem with the &gt; instead of the > etc.?

webhost
27 Aug 2001, 20:16
tubedogg
I have all of those changes that you mention and have the same problem
afterburner has. You did fix the profile signature submit save feature it now works, but aferburner's problem still does exist. I tried his signature on my board as we did yesterday and we have the same problem.

look in his signature above the reds he has in it turn to lite green after a save, they look red when you preview but when you save they turn lite green

tubedogg
27 Aug 2001, 20:20
Can you post, in [php] tags, the code used to make his signature please? (the [php] tags will keep it from parsing as vB Code)

webhost
27 Aug 2001, 20:25
removed

tubedogg
27 Aug 2001, 20:37
The problem is the quotes surrounding the color values - that is not valid vB Code and is confusing the editor.

webhost
27 Aug 2001, 20:42
how does it work in his signature above?

tubedogg
27 Aug 2001, 20:47
I should've elaborated - the quotes are getting turned into &quot; which is in turn not valid vB Code.

I might be able to fix this...lemme see...

webhost
27 Aug 2001, 20:48
ok thanks

tubedogg
27 Aug 2001, 21:33
See this post (http://www.vbulletin.com/forum/showthread.php?postid=162297#post162297)for the latest zip file.

webhost
27 Aug 2001, 22:34
Thanks Tubedogg.

I have tried it. It is better but 1 small bug.

The way I have installed is in the profile section. I have the edit signature button on the right and my current signature on the left looks just like my signature in the bottom of this post. I went in and uploaded your new sedit.php file. I then went to the edit profile section and I put in afterburners signature for a test. Once I put it in I previewed it it looked correct with all colors correctly showing. I then saved and it took me back to the profile section . The signature showing there still has the wrong colors no red but instead lite green. I then submitted and went and looked at one of my post and the signature showed in the post correctly with the correct colors. So it shows correctly in the edit signature section and in the post section but not in the field in the edit profile options page . Hope this makes sense.

Joey

tubedogg
27 Aug 2001, 22:37
I know this sounds like a copout, but I don't see how that's possible, for it to be displaying correctly in three places but not the fourth.

webhost
27 Aug 2001, 22:39
if you want I can email you an guest signon for you to see for yourself.

Joey

tubedogg
27 Aug 2001, 22:45
Please do - cause I just tried it again on my board and it all works, even with afterburner's sig.

webhost
27 Aug 2001, 22:58
Kevin do you still need it?

DarkReaper
27 Aug 2001, 22:59
Works great for me, but in the Edit Profile screen it doesn't parse the vBCodes in the sig. Is this a problem or is it not supposed to? :)

webhost
28 Aug 2001, 01:55
not needed

webhost
28 Aug 2001, 02:39
AfterBurner


Check out your signature on the board, it works all locations.

I took out the hard coded color numbers you had and just used the names red,seagreen and it works fine. Check it out

Joey

Now to change my signature back here and get rid of those colors.

tubedogg
28 Aug 2001, 02:59
webhost, make sure you have all of the following in member.php:

4. Open member.php and find

eval("\$customfields .= \"".gettemplate("register_customfields")."\";");
}

Right below that, add
$signature1=$bbuserinfo[signature];
$signature2=$bbuserinfo[signature];
$signature=bbcodeparse($signature1,0,$allowsmilies);
$sendsig=htmlspecialchars($signature2);

Then find

if ($email!=$emailconfirm) {

and right *ABOVE* it, add

$signature=ereg_replace('&gt;', '>', $signature);
$signature=ereg_replace('&lt;', '<', $signature);
$signature=ereg_replace('&quot;', "\"", $signature);
$signature=ereg_replace('&amp;', '&', $signature);

That's the only reason I can see it would work for me and not for you.

DarkReaper: It parses fine for me on the profile screen. Have you made *all* of the changes noted in the install.txt file?

DarkReaper
28 Aug 2001, 03:04
Yea I did it all. Here's the section of code that seems would be the problem...looks fine to me.

eval("\$customfields .= \"".gettemplate("register_customfields")."\";");
}

$signature=bbcodeparse($bbuserinfo[signature],0,$allowsmilies);
$sendsig=htmlspecialchars($bbuserinfo[signature]);

webhost
28 Aug 2001, 03:16
Tubedogg

That was it man

I didn't have eveything in there. I had the following like the DarkReaper

$signature=bbcodeparse($bbuserinfo[signature],0,$allowsmilies);
$sendsig=htmlspecialchars($bbuserinfo[signature]);

I changed it to what you had; this and it worked. The hard coded numbers like Afterburner has also works,

$signature1=$bbuserinfo[signature];
$signature2=$bbuserinfo[signature];
$signature=bbcodeparse($signature1,0,$allowsmilies);
$sendsig=htmlspecialchars($signature2);

Thanks for your efforts today it is highly appreciated.

Joey

tubedogg
28 Aug 2001, 03:21
For some reason I didn't have that in the install.txt file...OK here is an updated zip file with the correct instructions. :)

Bald Bouncer
28 Aug 2001, 03:59
Very cool hack, thanks a lot.
Is it just me or does adding hacks become addictive :D

Afterburner
28 Aug 2001, 04:16
works fine, thx for fixing this problem

MApI
28 Aug 2001, 12:05
Tubedogg re-installed your up-hack, but I've still the same prob. When I click on Signature Editor, return only a blank page with this msg:
vBulletin Message
...:... Ku||3us.NET ...:...

Working with VB 2.0.3. What I do wrong ??? :confused:

Thx in adv.

Bye

DarkReaper
29 Aug 2001, 01:29
Argh! I just did the update you suggested and it still doesn't parse the vB code on the Edit Profile screen. Here's the code snippet from member.php:


...
eval("\$customfields .= \"".gettemplate("register_customfields")."\";");
}

$signature1=$bbuserinfo[signature];
$signature2=$bbuserinfo[signature];
$signature=bbcodeparse($signature1,0,$allowsmilies);
$sendsig=htmlspecialchars($signature2);

if ($allowhtml) {
...

cyrus
29 Aug 2001, 13:29
aaarrghhhh

I did exactly as in the zip file right at the beginning but I get an empty white page when I click on the sigeditor on my EDIT PROFILE page.

What should i dooooo ???

I run vb 2.0.3

pls help

THAN K YOUUUUUUu

webhost
29 Aug 2001, 13:38
first read back a couple of pages and install tubedogg's rewrite of the hack then look I believe torwards the end of the first page and look for VirtueTech add on for the hack then install that over tubedogg's that is it

SirSteve
29 Aug 2001, 13:59
Ok, the new version fixed a few things but people are still e-mailing me thinking the Signature section in the edit profile page (that shows the signature in raw format) isn't exactly correct because it doesn't line break them correctly. Any way to fix this? Having this "Preview" the signature would be much better (on the edit profile page).

webhost
29 Aug 2001, 14:03
Steve look I believe torwards the end of the first page and look for VirtueTech add on for the hack then install that over tubedogg's that is it

SirSteve
16 Sep 2001, 22:15
This entire thread is a mess.

I had to remove this hack because of all the bugs.

I want the signature editor and preview signature on the modify profile page with the Edit Signature button.

This hack should work if you edit your signature and when you go back to the modify profile page and hit Submit (assuming you made a change in another field like Location), it will save.

VirtueTech
17 Sep 2001, 02:05
I am upgrading to v2.0.3 tonight or tomorrow. I will update this hack soon. Within the week.

webhost
17 Sep 2001, 02:08
using vb 2.0.3 and it works just fine for me no problems

shadowbreed
17 Sep 2001, 02:47
2.0.3 working great!!!

[VbbFr]Elie
17 Sep 2001, 03:55
Yes It's working great in v2.0.3 bu i've got the same trouble like After...

If i dont click on Preview, HTML is not working in the 2 previews area ...
I've to push 'Preview' and it's working after ...
Why not before when i just go to sedit.php ?

Thanks :)
I've to finish French Version ... :)

snyx
17 Sep 2001, 05:14
okay on 2.03 and everything worked great, but I had the problem where after you "SAVED" it worked, but then when you hit "SUBMIT" on the profile page it erased it. I changed it with webhost fix, now it works, but it looses that "preview" I really like, any way of getting it to work with the preview on and the "SUBMIT" on profile page not deleting the sig?

snyx
18 Sep 2001, 22:42
thanks to webhost for fixing up my prob.
just curious, why does the SAVE button take so long to prosess?

DarkReaper
20 Sep 2001, 03:22
There's only one problem with this on 2.0.3:

To make it compatible with online.php, open online.php.

Find:

default:
$userinfo[activity] = 'unknown';
}


BEFORE that, add this:

case 'sedit.php':
$userinfo[activity] = 'editsig';
break;


Then find this:

default:
// Let's show the admin the location but put something false up for everyone else..
if ($bbuserinfo[usergroupid] == 6) {
$userinfo[location] = htmlspecialchars(stripslashes(replacesession($userinfo[location])));
$userinfo[where] = "<b>Unknown Location:</b> <a href=\"$userinfo[location]\">$userinfo[location]</a>";
} else {
// We were unable to parse the location
$userinfo[where] = "$bbtitle <a href='index.php?s=$session[sessionhash]'>Main Index</a>";;
}


BEFORE that, add this:

case 'editsig':
$userinfo[where] = "Changing Forum Signature";
break;

SirSteve
20 Sep 2001, 04:12
Originally posted by DarkReaper
There's only one problem with this on 2.0.3:

To make it compatible with online.php, open online.php.

Find:

default:
$userinfo[activity] = 'unknown';
}


BEFORE that, add this:

case 'sedit.php':
$userinfo[activity] = 'editsig';
break;


Then find this:

default:
// Let's show the admin the location but put something false up for everyone else..
if ($bbuserinfo[usergroupid] == 6) {
$userinfo[location] = htmlspecialchars(stripslashes(replacesession($userinfo[location])));
$userinfo[where] = "<b>Unknown Location:</b> <a href=\"$userinfo[location]\">$userinfo[location]</a>";
} else {
// We were unable to parse the location
$userinfo[where] = "$bbtitle <a href='index.php?s=$session[sessionhash]'>Main Index</a>";;
}


BEFORE that, add this:

case 'editsig':
$userinfo[where] = "Changing Forum Signature";
break;


Excellent catch! Thanks!

bbensen
21 Sep 2001, 03:34
Warning: Undefined variable: REQUEST_URI in C:\Inetpub\diydaw\cgi-bin\vbbs\global.php on line 39

Warning: Undefined index: HTTP_POST_VARS in C:\Inetpub\diydaw\cgi-bin\vbbs\global.php on line 64

Warning: Undefined index: action in C:\Inetpub\diydaw\cgi-bin\vbbs\global.php on line 64

Warning: Undefined index: action in C:\Inetpub\diydaw\cgi-bin\vbbs\global.php on line 67

ummm found the problem and fix in another post.

Great Hack!!!

Neo
25 Sep 2001, 13:58
ummm could someone give me the newest version.. there are alot on this thread... i am confused @_@

MarkB
05 Oct 2001, 12:43
Originally posted by MApI
Tubedogg re-installed your up-hack, but I've still the same prob. When I click on Signature Editor, return only a blank page with this msg:


Working with VB 2.0.3. What I do wrong ??? :confused:

Thx in adv.

Bye

I'm getting this problem too, but only for SOME users (I can see it fine, for instance)...

:confused:

Prince
07 Nov 2001, 16:30
Originally posted by tubedogg
For some reason I didn't have that in the install.txt file...OK here is an updated zip file with the correct instructions. :)

Does anyone know if this works with VB 2.2.0 ???

Prince
07 Nov 2001, 17:43
hmmm....I just installed and eveything worked, except even though it said I could not add more than the limit of lines I set in sedit.php, it still saved it as my sig when I posted....?

MApI
25 Nov 2001, 09:51
Hi, someone tested as new install on vB 2.21 ?

cya

|DarkManX|
25 Nov 2001, 19:45
works on 2.2


is there anyway to correct this in the online.php

Unknown Location: /tof/sedit.php?&action=show

for it to say like editing sig or something....

great hack

FWC
25 Nov 2001, 20:10
In online.php I put // SigEdit
case 'sigedit':
$userinfo[where] = "<a href='sedit.php?s=&action=show&s=$session[sessionhash]'>Editing Signature</a>";
break;
// SigEdit Endright before case 'spider':
$userinfo[where] = "Search Engine Spider";
break;and// SigEdit
case 'sedit.php':
$userinfo[activity] = 'sigedit';
break;
// SigEdit Endright before case '/robots.txt':
$userinfo[activity] = 'spider';
break;

It says Editing Signature now in Who's Online.

Horizon
26 Nov 2001, 21:11
I get this on my page.....

Warning: Undefined variable: REQUEST_URI in d:\inetpub\wwwroot\forum\global.php on line 60

Warning: Undefined index: HTTP_POST_VARS in d:\inetpub\wwwroot\forum\global.php on line 85

Warning: Undefined index: action in d:\inetpub\wwwroot\forum\global.php on line 85

Warning: Undefined index: action in d:\inetpub\wwwroot\forum\global.php on line 88

AnY ideas?

I am using ver. 2.2.1 vbulletin

Dalius
18 Dec 2001, 01:17
Can we get an updated version of this for 2.2.1 please?

VirtueTech
18 Dec 2001, 01:55
As soon as I get upgrade to 2.2.1 I will. :)

Dalius
18 Dec 2001, 01:58
https://www.vbulletin.org/forum/external/2011/01/19.gif Cool

DarkReaper
20 Dec 2001, 23:57
I installed this on 2.2.1 with only one problem - user's signatures randomly disappear. It is truly random as far as I can tell - mine disappeared and I haven't touched my profile/options/signature since I installed it....

VirtueTech
21 Dec 2001, 02:15
This usually happens because when you go to the signature page you come back to the profile and hit submit. The signature is blank in the profile page...so you need to remove the signature from the UPDATE query in member.php

You need to modify your member.php

In 2.0.3 find and remove:

,signature='".addslashes($signature)."'


From this line:

$DB_site->query("UPDATE user SET birthday='".addslashes($birthday)."',signature='".addslashes($signature)."',customtitle='".intval($customtitle)."',usertitle='".addslashes($customtext)."',email='".addslashes(htmlspecialchars($email))."',parentemail='".addslashes(htmlspecialchars($parentemail))."',coppauser='$coppauser',homepage='".addslashes(htmlspecialchars($homepage))."',icq='".addslashes(htmlspecialchars($icq))."',aim='".addslashes(htmlspecialchars($aim))."',yahoo='".addslashes(htmlspecialchars($yahoo))."',usergroupid='$bbuserinfo[usergroupid]' $awaysql WHERE userid='$bbuserinfo[userid]'");


I hope this helps. :) I'm not sure what the line is in 2.2.*

DarkReaper
21 Dec 2001, 03:32
Old line:
$DB_site->query("UPDATE user SET birthday='".addslashes($birthday)."',signature='".addslashes($signature)."',customtitle='".intval($customtitle)."',usertitle='".addslashes($customtext)."',email='".addslashes(htmlspecialchars($email))."',parentemail='".addslashes(htmlspecialchars($parentemail))."',coppauser='$coppauser',homepage='".addslashes(htmlspecialchars($homepage))."',icq='".addslashes(htmlspecialchars($icq))."',aim='".addslashes(htmlspecialchars($aim))."',yahoo='".addslashes(htmlspecialchars($yahoo))."',usergroupid='$bbuserinfo[usergroupid]' WHERE userid='$bbuserinfo[userid]'");



New line:
$DB_site->query("UPDATE user SET birthday='".addslashes($birthday)."',customtitle='".intval($customtitle)."',usertitle='".addslashes($customtext)."',email='".addslashes(htmlspecialchars($email))."',parentemail='".addslashes(htmlspecialchars($parentemail))."',coppauser='$coppauser',homepage='".addslashes(htmlspecialchars($homepage))."',icq='".addslashes(htmlspecialchars($icq))."',aim='".addslashes(htmlspecialchars($aim))."',yahoo='".addslashes(htmlspecialchars($yahoo))."',usergroupid='$bbuserinfo[usergroupid]' WHERE userid='$bbuserinfo[userid]'");

VirtueTech
21 Dec 2001, 03:33
:)

thats right. Sorry did you not like the way I posted it :(

DarkReaper
21 Dec 2001, 03:37
No...that's for vB 2.2.1 :)

VirtueTech
21 Dec 2001, 03:42
ic

XiXora
21 Dec 2001, 17:00
hehe. i think we need this rereleasing. its a mess :P

Horizon
08 Jan 2002, 18:01
I get this at the top of the page for this hack

that is in EDIT SIGNATURE AREA

Warning: Undefined variable: REQUEST_URI in d:\inetpub\wwwroot\forum\global.php on line 60

Warning: Undefined index: HTTP_POST_VARS in d:\inetpub\wwwroot\forum\global.php on line 85

Warning: Undefined index: action in d:\inetpub\wwwroot\forum\global.php on line 85

Warning: Undefined index: action in d:\inetpub\wwwroot\forum\global.php on line 88

Sadie Frost
10 Jan 2002, 20:19
I just installed this using the attachment in the first post (sig_editor.zip).

It appears to be working fine for me, so I'm leery of re-doing it with sig_editorupdate.zip.

Can anyone tell me if I need to install the update or if the original zip works fine?

I'm running 2.2.1 :)

FWC
10 Jan 2002, 20:50
Originally posted by Sadie Frost
Can anyone tell me if I need to install the update or if the original zip works fine?

I'm running 2.2.1 :) I think you can use the original zip. But, you do need to make the code change to keep saving options from overwriting what the editor saves. I switched over to Tubedogg's last zip. I think there are instructions elsewhere in the thread for how to solve the overwriting problem. But, this is one very confusing thread. :)

Lucky
11 Jan 2002, 00:02
Great hack.

For 2.2.1 I had to fix the error/warning message, by adding the following line right under the first line ( <$php ) in sedit.php:

error_reporting(7);

Shenlong
11 Jan 2002, 00:22
Awesome hack, all my members are pleased, espically my ones not familiar with vBBs now because they can easily add stuff, 20 lines is perfect for them, no more long quotes are sigs, thanks so much VirtualTech, hack works great! cant wait for more ;)

MApI
13 Jan 2002, 10:40
Works very well, without any king of problem & with easy intallation.

Thx. :D

cya

Dalius
13 Jan 2002, 15:34
Can someone post a WORKING 2.1.1 version!

i dont want to read the whole post! :(

Massiel
18 Mar 2002, 03:55
Is this available for 2.2.2? I saw a board that has this hack installed and is 2.2.2, can someone put all the code together? It is really hard knowing what to add and not to add after reading all the suggestions in all the thread pages! I really want to add this hack but it looks too scary this way. Please help!

Massiel
18 Mar 2002, 23:51
Anyone?

Massiel
22 Mar 2002, 02:46
oh boy

Sadie Frost
27 Mar 2002, 15:53
I just used the original zip in the first post and it has worked fine for me since 2.2.1 (now on 2.2.4) :)

Dark Odin
30 Apr 2002, 00:59
Okay I'm having some problems. I want to have the signature editor and keep the textarea for the signature on the edit profile page, buttttttt, the textarea in the edit profile page doesn't save when you edit it. I've used all the updates with the original hack from the first page. Any ideas?

Dark Odin
01 May 2002, 20:26
*BUMP*

Dark Odin
03 May 2002, 20:23
*BUMP*

Keyser Söze
05 May 2002, 06:15
this hack would be wonderful if it also had a way to upload a sig image to use :)

Dark Odin
06 May 2002, 01:32
*BUMP* Can you people please help me out here?

Dark Odin
08 May 2002, 00:44
*BUMP*

xeon
15 May 2002, 20:59
I like this hack, but it just doesn't seem to have all bugs worked out for 2.2.5. I have messed with it, but being a rookie I am a bit lost. At first attempt the preview showed the unformatted vbcode, I got that fixed. Now my sig link results in a vbullentin message box page, not the sedit page i used to have when i used this back in previous versions of vb. Any tips why clicking the link would not give me the sig editor?
Here's my modifyprofile add-in
<tr>
<td bgcolor="#1D6AA0" colspan="2"><normalfont color="#EEEEFF" class="thtcolor"><b>Signature Editor and Preview</b></normalfont> <smallfont color="#EEEEFF" class=thtcolor>Optional signature you may use to appear at the bottom fo your posts.</smallfont></td>
</tr>
<tr>
<td bgcolor="#13486D" valign="top"><blockquote>$signaturepreview</blockquote></td>

<td bgcolor="#13486D" align="center"><a href="sedit.php?s=$session[sessionhash]&action=show"><img src="images/editsig.gif" width="122" height="23" border="0">
</a></td>
</tr>
If this isn't where I need to be looking, where should I be?
It seems to work with Netscape fine, go figure IE is giving me trouble.

*It would be really cool if this was updated and compiled.

Velocd
16 May 2002, 01:31
Ok, can somebody help me get this code working:

I want to display a signature link in the usercp navbar, and also an avatar link, like Vbulletin.org has.

See this attachment for the signature link (like FFRepublic has) and see the next post attachment for the avatar link. This way I can just remove the whole section of editing your avatar in the options page or profile page, and also it provides quicker access to the frequently used areas.

(the reason I ask for this and not do it myself is that I've tried and for some reason I can't get it to work correctly)

Velocd
16 May 2002, 01:32
Avatar Link:

Velocd
16 May 2002, 04:37
bump ^

Erwin
16 May 2002, 07:03
Velocd,

In the usercpnav template, find this:


<td bgcolor="$cpnav[3]"><smallfont><b><a href="member.php?s=$session[sessionhash]&action=editoptions">Options</a></b></smallfont></td>


Add these lines directly after it:


<td bgcolor="$cpnav[2]"><smallfont><b><a href="sedit.php?s=$session[sessionhash]&action=show">Signature</a></b></smallfont></td>
<td bgcolor="$cpnav[2]"><smallfont><b><a href="member.php?s=$session[sessionhash]&action=editavatar">Avatar</a></b></smallfont></td>


That should add the signature and avatar links to the usercp nav bar. :)

Erwin
16 May 2002, 07:18
A screenshot of what it should look like once you install it:

Velocd
16 May 2002, 19:18
Yes, but does it work correctly when you click on other links, like say click on options or the signature link, will the correct link above be highlighted? There should be some type of php file modification...

For example, to see the issues I'm having refer to the below attachment:

Dalius
18 May 2002, 19:01
I have a prob.

It doesn't parse the Signature exactly

Look at the preview in edit.

Dalius
18 May 2002, 19:03
Actual Sig:

xeon
20 May 2002, 13:39
I think you need to do this, it worked for me:
http://www.vbulletin.org/forum/showthread.php?postid=148587#post148587

dotagious
21 May 2002, 20:32
Anyone know if this works with 2.2.5 ?

Erwin
22 May 2002, 04:19
Yes, it works well with 2.2.5 - you just need to install the right bits.

dotagious
23 May 2002, 21:50
Are the right "bits" explained in the original instructions?

Jeremy W.
04 Jun 2002, 21:46
Awesome :)

Hoffi
09 Sep 2002, 21:49
Argh. Now I Install this Hack on a new 2.2.7 Board and I have trouble.
Opening the sigeditor works, but if i click on Preview or Save the only Thing I see is a fully white page. :(

garoboldy
17 Sep 2002, 05:17
yeah, I have 2.2.7 and I am getting a blank page after I click on preview or save....whats the deal

anyone know whats going on???

thanks for any info. later

Mathieu
17 Sep 2002, 07:20
Thanks for this hack i'll try it when i've time

Hoffi
17 Sep 2002, 16:06
anybody has an idea for my Prob?

garoboldy
17 Sep 2002, 21:30
got my paged fixed...works pretty well
great hack

Kurisu
09 Oct 2002, 19:06
How did you get it fixed, garoboldy?

wolfe
11 Oct 2002, 12:47
did you reupload the new sedit.php file from the new zip ?

Kurisu
12 Oct 2002, 23:09
Now it works. My problem was that I had differnet versions of "Preview", "Save" and "Back" in sedit.php and _editsiganture template cause I had to translate everything into german.

isman
13 Oct 2002, 14:54
I'm using 2.2.7 and am having a problem when I save my profile options. Instead of saving and returning I get this.
If you have forgotten your username or password, you can request to have your username emailed to you and to reset your password. When you fill in your registered email address, you will be sent instructions on how to reset your password.I've followed the instructions and applied some of the other fixes throughout this thread but can't figure this one out.

Can someone offer some suggestions on this one?

isman
13 Oct 2002, 15:10
Never mind. I didn't read the instructions correctly and did a replace instead of an add below.

Kurisu
23 Oct 2002, 10:45
Hm I'm using 2.2.6 and every time a user updates his profile, the signature is lost. Anyone can help?

feldmaresciallo
24 Feb 2003, 10:25
Someone could tell me how put into thi s hack a img dimensions control?

i need to allow only 400x200 images.

Someone could help me?

PurpleCow
05 Aug 2003, 12:49
Anyone knows, if this is working on 2.3.0 ??

I want this hack !

Thanks

daFish
06 Nov 2003, 17:14
This is really a great hack.
Good work.

But some of my users have a problem using the editor.

I installed it correctly and it works for me and some others fine, bot IE6 and Firebird 0.7, but some of the users didn't get the editor to work.
All they got is what you can see in the image attached.

Anyone can help?

-Fish