PDA

View Full Version : sql_connect: Access denied for user


ThorstenA
01 May 2010, 00:01
After installing today, I can not run the scripts, I always get these errors:

... lots of same errors before
using config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'...
indexing index 'VisitorMessageMain'...
ERROR: index 'VisitorMessageMain': sql_connect: Access denied for user 'correct_db_user'@'localhost' (using password: YES) (DSN=mysql://admin_mysql:***@localhost:3306/correct_db_name).
total 0 docs, 0 bytes
total 0.010 sec, 0.00 bytes/sec, 0.00 docs/sec
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff
... and after :)

The database name and all other database information seem to be fetched right, but why is then the access denied for this user?

borbole
01 May 2010, 00:05
Does that db user has full permissions and access to the db that he is assigned to?

ThorstenA
01 May 2010, 00:12
This is the admin db user. It is the same user that I have in my config.php

--------------- Added 1272701807 at 1272701807 ---------------

I am using CentOS with DirectAdmin, MySQL 5.0.51 and PHP 5.2.10.

I removed all actions I took before, did all the steps again and still this problem occurs.

coffee
01 May 2010, 09:07
I had same problem but found it solved here (http://www.sphinxsearch.com/forum/view.html?id=4635).

So, just remove any pound signs (#) from your db user password.

ThorstenA
01 May 2010, 09:30
Thanks!!!! It works now! It was the pound sign in my password - hehe :D

Unbelievable good service here, and that on saturday :)

coffee
01 May 2010, 09:31
You're most welcome :)