PDA

View Full Version : Troubles using sphinx search


RedFoxy
09 Jun 2010, 03:04
Hi all!
I followed ALL instructions, I generated the indexes, I imported the plugin and changed the search engine in my vbulletin, but when I try to do a search i give:

Oops! An error occurred: index BlogCommentDelta,BlogCommentMain,BlogEntryDelta,BlogEntryMain,CMSArticlesDelta,C MSArticlesMain,DiscussionMessageDelta,DiscussionMessageMain,ForumDelta,ForumMain ,SocialGroupDelta,SocialGroupMain,ThreadPostDelta,ThreadPostMain,VisitorMessageD elta,VisitorMessageMain: SPH_GROUPBY_ATTRPAIR is not supported any more (just group on 'bigint' attribute)

I'm using Sphinx 0.9.9-id64-release on freebsd 7

Ryan Ashbrook
09 Jun 2010, 05:23
See the announcement: http://www.vbulletin.com/forum/showthread.php?350427-Sphinx-search-BETA-for-vBulletin-4.0

The Sphinx product was created on Sphinx 0.9.8, and it is noted that it may not work on versions newer than that.

I don't know if that's the direct cause of your issue (not familiar with Sphinx), just wanted to point that out. :)

RedFoxy
09 Jun 2010, 11:56
I'll try with 0.9.8 then... Thank you!

Boofo
23 Dec 2010, 10:50
I tried with 0.9.8.1 and got the same error.

RedFoxy
23 Dec 2010, 16:05
I'm using the suggested archive in that article (i followed whole article) and it goes http://www.vbulletin.com/forum/showthread.php/350427-Sphinx-search-BETA-for-vBulletin-4.0?p=2075036&viewfull=1