PDA

View Full Version : [3.8.5] Invalid Security Token on Mark Forums Read


Speysider
27 Jun 2010, 13:04
Problem: After upgrading to vBulletin 3.8.5, my users now get Invalid Security Token errors on the Mark Forums Read script.

Reason: Upgrading a forum isn't easy and usually some edits in a new version don't get added as planned. When you've upgraded to vBulletin Version 3.8.5 and you get Invalid Security Token errors regarding the Mark Forums Read script, then please read this thread first! It contains a permanent fix to this issue.

The issue is relating to modified templates. The vBulletin upgrade script does NOT modify templates it wants to modify if the administrator has already modified a template. In this case, modifying the navbar or forumhome templates will result in an invalid security token error when trying to use the Mark Forums Read script.

Solution:

In your forumhome template, find the following code:
<a href="forumdisplay.php?$session[sessionurl]do=markread rel="nofollow">$vbphrase[mark_forums_read]</a>
Replace it with this:
<a href="forumdisplay.php?$session[sessionurl]do=markread&amp;markreadhash=$bbuserinfo[securitytoken]" rel="nofollow">$vbphrase[mark_forums_read]</a>
In your navbar template (twice), find this code:
<td class="vbmenu_control"><a href="forumdisplay.php?$session[sessionurl]do=markread" rel="nofollow">$vbphrase[mark_forums_read]</a></td>
And replace with this:
<a href="forumdisplay.php?$session[sessionurl]do=markread&amp;markreadhash=$bbuserinfo[securitytoken]" rel="nofollow">$vbphrase[mark_forums_read]</a>Hope this fixes your error.

Diablo-Sat
02 Jan 2011, 21:54
thanks mate worked for me