PDA

View Full Version : Installation Assistance


Banana
13 Feb 2011, 13:38
I've been installing Sphinx as per the installation instructions here: http://www.vbulletin.com/forum/showthread.php/350690-Sphinx-search-BETA-for-vBulletin-4.0-Multi-site-configuration

All goes well until step 13:
13. Run the main.sh cron using:

/usr/local/sphinx/cron-multisite/main.sh --config /usr/local/sphinx/sites/mysite1.com/etc/vbulletin-sphinx-mysite1.php

Where I get the following error

[root@www cur]# which php
/usr/bin/php
[root@www cur]# php -v
PHP Warning: Module 'gd' already loaded in Unknown on line 0
PHP 5.2.10 (cli) (built: Jun 21 2009 10:41:24)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
with the ionCube PHP Loader v3.3.1, Copyright (c) 2002-2009, by ionCube Ltd., and
with XCache v1.2.2, Copyright (c) 2005-2007, by mOo

[root@www cur]# /usr/local/sphinx/cron-multisite/main.sh --config /usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php
using config file '/usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php'...
Sphinx 0.9.9-id64-release (r2117)
Copyright (c) 2001-2009, Andrew Aksyonoff

using config file '/usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php'...
PHP Warning: Module 'gd' already loaded in Unknown on line 0
ERROR: error executing '/usr/bin/php' in /usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php line 1 col 1.
FATAL: failed to parse config file '/usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php'
Sphinx 0.9.9-id64-release (r2117)
Copyright (c) 2001-2009, Andrew Aksyonoff

This error repeats itself many times.

Here's my edit to the config file


[root@www cur]# head -20 /usr/local/sphinx/sites/xxxxxx.org/etc/vbulletin-sphinx.php
#!/usr/bin/php
<?php

/*
Set $myforumroot to the absolute path to your forum directory.
Example:

*/

$myforumroot = '/var/www/vhosts/xxxxxx.org/httpdocs/forums';

/*########## DO NOT TOUCH ANYTHING BELOW THIS LINE ##########*/

error_reporting(0);
ob_start();
chdir($myforumroot);
require_once('./global.php');

//print_r($vbulletin->config[MasterServer]);


(domain name substituted by xxxxxx)

Help appreciated. Thanks

PitchouneN64ngc
13 Feb 2011, 16:17
I think this is related to the version of Sphinx you are running. It was developed with Sphinx 0.9.8 and you have Sphinx 0.9.9.

Banana
13 Feb 2011, 16:28
Really? Sphinx 0.9.9 wouldn't be backward compatible???!

PitchouneN64ngc
13 Feb 2011, 21:41
Some users have tested with Sphinx 0.9.9 and it failed.

kerplunknet
10 Aug 2011, 05:13
Is this really true? Unbelievable.

Boofo
10 Aug 2011, 05:14
I couldn't get it to run on Sphinx 0.9.9 so I gave up on it.