View Full Version : No contenttypes found on line 427. HOW TO restore this table?

03 Mar 2012, 09:51
Hi @ all!
I explain to you the dynamic of problem.
When I upgraded from 4.0.3 patch liv 7 to 4.0.8 patch liv 8 I found many megabytes in excess in the contenttype table (I realized when I'm go to see in AdminCP -> Maintaince -> Repair/Optimize Tables ).
Then I'm went to see too into phpMyAdmin that table, but, with great stupor, the megabytes in excess aren't appear. I've saw only a bar --- .
I don't have realized.
My Next step was to empty that table!!!!contenttype was empty in 1 second.
I tried to import the table from the old forum, I tried to do other upgrades, but the result is always the same:

No contenttypes found on line 427 in /home/mysite/public_html/forums/vb/types.php
#0 /home/mysite/public_html/forums/vb/types.php(268): vB_Types->loadContentTypes(Array)
#1 /home/mysite/public_html/forums/vb/types.php(158): vB_Types->loadTypeInfo(Array)
#2 /home/mysite/public_html/forums/vb/types.php(120): vB_Types->loadTypes()
#3 /home/mysite/public_html/forums/vb/types.php(136): vB_Types->__construct()
#4 /home/mysite/public_html/forums/vb/search/core.php(110): vB_Types::instance()
#5 /home/mysite/public_html/forums/packages/vbforum/search/indexcontroller/post.php(42): vB_Search_Core->get_contenttypeid('vBForum', 'Post')
#6 /home/mysite/public_html/forums/packages/vbdbsearch/core.php(39): vBForum_Search_IndexController_Post->__construct()
#7 [internal function]: vBDBSearch_Core::init()
#8 /home/mysite/public_html/forums/vb/search/core.php(86): call_user_func(Array)
#9 /home/mysite/public_html/forums/search.php(103): vB_Search_Core::get_instance()
#10 {main}

Fatal error: No contenttypes found on line 427 in [path]/vb/types.php in [path]/vb/vb.php on line 287

03 Mar 2012, 17:08
You just emptied the table? Completely? I mean, did you drop it or just truncate it? And what version are you running and forums or suite?