PDA

View Full Version : Miscellaneous Hacks - Easy Google Analytics


Shadow
14 Oct 2012, 15:15
Description:
This small and simple modification will allow you to easily add your Google Analytics tracking code to your site without editing templates. Editing templates may seem daunting to some people however this modification allows you to paste your code in a box and it'll handle the rest.

Your Analytics tracking code will be added to the end of the footer template so it doesn't slow the loading of your site down.

Installation:
Download the product XML and import it through the 'Manage Products' page in the AdminCP.
Add your tracking code to: Admin CP -> Settings -> Options -> Google Analytics Settings.
Done.
Changelog:
14/10/2012 - Version 1.00:
- Initial release.

Notes:
I'm always looking to improve my work for the people that enjoy using it. If you have any suggestions on how I can improve this hack then please leave a comment and I'll see what I'm able to do. Don't forget to 'Mark As Installed' if you've got it installed!

TheSupportForum
14 Oct 2012, 15:52
its great to see you took my advice on adding a template hook :)
from my previous message on about your other product for this product

Shadow
14 Oct 2012, 16:00
its great to see you took my advice on adding a template hook :)
from my previous message on about your other product for this product

Indeed I did, it was a fair suggestion. The other one was just a code snippet and a suggestion for users as to where to place it. But nonetheless, thank you for your suggestion :)

MARCO1
14 Oct 2012, 17:22
Finally Aakif, Good work mate :)

Shadow
14 Oct 2012, 17:26
Finally Aakif, Good work mate :)

Thank you :p Got some more coming :)

Dutch_Boy
04 Dec 2012, 22:53
Hey thanks!

Does it take time for Google to process or is it because I installed it on VB4.2.0?

Brandon Sheley
06 Dec 2012, 18:32
Hey thanks!

Does it take time for Google to process or is it because I installed it on VB4.2.0?

this is a vb 5 mod so...
Also google analytics are generally a day behind, unless you check the "real time" tracking tab.

Shadow
08 Dec 2012, 21:20
Hey thanks!

Does it take time for Google to process or is it because I installed it on VB4.2.0?

You should install this version if you're running vBulletin 4 - http://www.vbulletin.org/forum/showthread.php?t=290306

photo
15 Dec 2012, 14:26
It's not working for vBulletin 4.2.0 Patch Level 3.

Shadow
15 Dec 2012, 16:20
It's not working for vBulletin 4.2.0 Patch Level 3.

Because this is the vBulletin 5 version. You'll need to download and install this instead: http://www.vbulletin.org/forum/showthread.php?t=290306

JamalFree
16 Jan 2013, 13:42
Thank for sharing

Dorgham
04 Apr 2013, 00:21
work Great
Wait for new

Raima
15 Jul 2013, 15:06
Just installed this, and it's not working with 5.03 for me.

Google Analytics says the tracking is not installed.

I imported the file downloaded, went into options, pasted the code in, clicked on save and nothing.

I have a look at the page source, and I can see the google analytics code inserted. Not sure why Google Analytics is saying it's not being tracked.

Any ideas?

Is anyone else having difficulties?

fords8
15 Jul 2013, 22:09
Just installed this, and it's not working with 5.03 for me.

Google Analytics says the tracking is not installed.

I imported the file downloaded, went into options, pasted the code in, clicked on save and nothing.

I have a look at the page source, and I can see the google analytics code inserted. Not sure why Google Analytics is saying it's not being tracked.

Any ideas?

Is anyone else having difficulties?
How long did you wait? I just did mine 2 days ago and it is working. And I am on 5.0.3.

Raima
16 Jul 2013, 02:46
How long did you wait? I just did mine 2 days ago and it is working. And I am on 5.0.3.

It's been over 12 hours now. How long did it take Google analytical to acknowledge tracking was installed?

Each time I refresh the Google Analytical page, it says under tracking info:

Status: Tracking Not Installed

Last checked: Jul 15, 2013 6:22:29 PM PDT

The Google Analytics tracking code has not been detected on your website's home page. For Analytics to function, you or your web administrator must add the code to each page of your website.

Each time I refresh or check, the last checked details change.

Any ideas?

EDIT: Just noticed Google Analytics offer 2 types of tracking.

Universal Analytics (beta) which is the default option and Classic Analytics. I've just switched over to Classic Analytics. There's no dynamic updates, so I'll just wait if that does the trick.

EDIT 2: Changing to Classic Analytics worked.

fords8
16 Jul 2013, 04:21
It's been over 12 hours now. How long did it take Google analytical to acknowledge tracking was installed?

Each time I refresh the Google Analytical page, it says under tracking info:

Status: Tracking Not Installed

Last checked: Jul 15, 2013 6:22:29 PM PDT

The Google Analytics tracking code has not been detected on your website's home page. For Analytics to function, you or your web administrator must add the code to each page of your website.

Each time I refresh or check, the last checked details change.

Any ideas?
I read that it could take 24 to 48 hours for it to start tracking. You did paste all the code into it?

belfast2012
16 Sep 2013, 19:40
I don't see manage products page, I do see Enable/Disable Hook System, when I enable that I don't see anyway to upload the xml? do I need to upload the xml file somewhere on the server first?

belfast2012
17 Sep 2013, 00:54
I don't see manage products page, I do see Enable/Disable Hook System, when I enable that I don't see anyway to upload the xml? do I need to upload the xml file somewhere on the server first?

Anyone help a newb! :erm:

fords8
10 Oct 2013, 19:26
NM Fixed!

dgincr
20 Nov 2014, 17:32
Hey everyone,

I am trying to install google analytics for my forum. Unfortunately it's not working. I tried putting in the footer, header and headerinclude.... nothing.

I then installed the plugin called "Easy google analytics"
http://awesomescreenshot.com/0473vyqbb6

Nothing is working for me.... what am i doing wrong ??

TheLastSuperman
21 Nov 2014, 21:19
Hey everyone,

I am trying to install google analytics for my forum. Unfortunately it's not working. I tried putting in the footer, header and headerinclude.... nothing.

I then installed the plugin called "Easy google analytics"
http://awesomescreenshot.com/0473vyqbb6

Nothing is working for me.... what am i doing wrong ??

If you've never used Google Analytics before on your site, give it some time, in the least 24hrs for data to start showing.

If you have installed tracking and don't see data in your reports after 24 hours, you may have one or more of the following issues.

https://support.google.com/analytics/answer/1009683?hl=en&rd=1

mykkal
27 Feb 2015, 20:09
Be so awesome if there was a version of this for vb 4.2.X. Is there???

markoroots
01 Mar 2015, 20:45
You should install this version if you're running vBulletin 4 - http://www.vbulletin.org/forum/showthread.php?t=290306

Read here. ;)

delds
26 Sep 2015, 21:00
now will this work also if I put a 2nd script in after the google Analytics script. I have a special independent stats program that requires a script entered also, that way I have stats generated from 2 sources

Thangvip9x
02 Oct 2015, 02:26
It's not working for vBulletin 4.2.0 Patch Level 3.

Please upgrade your site to vBulletin version 5.0.0 or greater