PDA

View Full Version : Stuck with Impex


errorware
24 Jun 2015, 22:24
Hi all,

I just read about Impex not being supported any longer, been away of vBulletin for a while so...

Well, in any case, I offer myself to port an SMF 2.2 into vBulletin 4.2 so I downloaded from GitHub and edited the config file, install on my vBulletin and pretty much all went as expected... Pretty much untill I check the forum, after no error messages at the import screen, there was no Forums, I just created a test forum and all of the sudden all the forums appear with the correct post count...

...Then I realized the posts werent there, so and I havent manage to sort this out... The posts are in the database but they just dont show in the forum... Also users dont show in the userlist and aparently ther passwords dont match...

I think the posts are mainly the biggest deal...

Any clues? :confused:

Regards

TheLastSuperman
25 Jun 2015, 04:22
You need to update the counters, these are under:

> AdminCP > Maintenance > General Maintenance Tools

Once you do this, the forums should show - do not run the import script twice simply update counters (for forums/threads/posts) then check the forum to see if populated with a list of categories, forums, and sub-forums.

errorware
25 Jun 2015, 12:29
Yeah, that helped.

I started a fresh install. Deleted the default forum created by the installer and then import... I reset the counters, rebuild the search index and went to the Forum Manager, save the forum order and that worked fine, I can see the threads and they seem to be populated with posts, I emptied the cache and yeah... Seemed to worked...

Problem now is, I can only see some posts, for example I have a board with 90 threads and 150 replies, showing the latest post in the index... But when I go in I see nothing but this message "There have been no posts in the last 30 days in this forum. Try using the controls below to search for any older posts that may exist."... on other forums I get one or two posts tops... (?)

Another clue is that, for example, one of the forums is 'Java Programming' I see the correct post count but when I go in theres nothing, just the message. But if I do a search for "java" I get all the results and posts there supposed to show on the Java forum I can actually go into the posts and see then no probs...

Any idea?

regards.

=============== EDIT =================

Cool, I got it, I had to go into every forum (at the Forum Manager) and set Show All Posts, it was only showing a few latest ones, the rest was sort of archived...

Thanks for your help!