PDA

View Full Version : Help My Site Please ..


dumpster
11 Sep 2002, 03:15
i8 this iz my site www.liquidflo.com , But i cant edit users nor bann people for some reason , This iz whut comes up when i try

Database error in vBulletin Control Panel 2.2.5:

Invalid SQL: SELECT userid
FROM user
WHERE username='Da yung 1 '
AND userid <>
mysql error: You have an error in your SQL syntax near '' at line 4

mysql error number: 1064

Date: Tuesday 10th of September 2002 11:13:58 PM
Script: http://www.liquidflo.com/rap/rap/admin/user.php
Referer: http://www.liquidflo.com/rap/admin/user.php?s=&action=edit&userid=13

--------

and i dont understand , me and the other admins r tryin to fix it but it's not working .. Plz help , if this iz the wrong forum , i'm sorry i just didnt kno where to put it ... plz help PLEEAAASEE :cross-eyed:

Peace

TECK
11 Sep 2002, 03:23
how come you have VB225 installed? is a new board right? from teh number of posts...

filburt1
11 Sep 2002, 03:24
Maybe upgrading to the most recent, most secure, least hackable version (2.2.7) will fix your woes.

'Course you'd download it from the member's area...:devious:

Steve Machol
11 Sep 2002, 17:52
dumpster, please go to this (http://www.vbulletin.com/members/vbulletin.org.php) page and enter your username, to show you are licensed. (you will need to use your customer number and password to access that page)
Thank you.

supersimon
12 Sep 2002, 01:50
sorry hes from my site and i cant upgrade to 2.2.7 because we have so many hacks installed / and all my templates are gone because when i back uped teh board they were left out so when ui upgrade will it restore the templates ?

Steve Machol
12 Sep 2002, 03:01
You need to upgrade to fix the problem.

supersimon
13 Sep 2002, 02:19
will i lose my hacks

Steve Machol
13 Sep 2002, 02:21
Whenever you upgrade all hacks involving changes to the vB php files will be overwritten. You will need to reapply those hacks to the new files. Customized templates are not overwritten though.

supersimon
14 Sep 2002, 15:09
umm ok is there a way if i tottally re install my board i can restore only the post and members ?
and i'll be installing teh 2.2.7 from teh 2.2.5

DeadMan384AD
14 Sep 2002, 19:37
Originally posted by dumpster
i8 this iz my site www.liquidflo.com , But i cant edit users nor bann people for some reason , This iz whut comes up when i try

Database error in vBulletin Control Panel 2.2.5:

Invalid SQL: SELECT userid
FROM user
WHERE username='Da yung 1 '
AND userid <>

It looks the user has a space at the end of his username, unless you copied and pasted wrong, tell him to remove the space after the "1"

That might help if you havent upgraded yet :)

Xenon
14 Sep 2002, 19:46
nope the problem is the userid <>
nothing folows to it.
it's a known bug with vb < 226 and php 4.2.x

at simon: you should enter dumpsters name in the form at vb.com so he can also get access here..
your question: if you have a backup of your DB then it would be possible ;)

Chris M
14 Sep 2002, 20:28
My friend had the same problem;)

He upgraded to 2.2.6 a while ago, and it sorted it:)

Satan

supersimon
14 Sep 2002, 22:52
so if i unistalled my board and installed 2.2.7 and than restored my backup from 2.2.5 will everyting be back including my templates and hacks,members and posts

Steve Machol
14 Sep 2002, 23:21
There's no need to uninstall the board and restore the database. Just upload the 2.2.7 files and run the upgrade scripts:

upgrade19.php
upgrade20.php

http://www.vbulletin.com/members/upgrade.html

supersimon
14 Sep 2002, 23:23
ok i know that but u said it wouldnt restore my templates because mine were forgotten when i moved my board so now it only shows teh edited and customized templates ?

Steve Machol
14 Sep 2002, 23:24
*sigh*

As has been mentioned this is a bug with 2.2.6 and PHP 4.2.x. There is nothing wrong with the database.

supersimon
14 Sep 2002, 23:27
i8 i'll update tonight

DarkDraco07
15 Sep 2002, 01:19
i just uploaded a fresh 2.2.7 forum and rehacked it with new hacks and such.

all the errors and bugs that compiled onto the forums since 2.2.3 are long gone now

supersimon
15 Sep 2002, 05:27
same