PDA

View Full Version : Custom ON/OFF Icons per forum...


Chris M
31 Dec 2002, 17:25
Please do the following before attempting to install:

1.) Backup your Files before doing anything
2.) Be aware that although I have tested this myself, there may still be problems...If you do not backup your files, I cannot condone your install of this hack...
3.) If you want to Backup your Database, You can - There shouldn't be any need to...

The file you should have is:

install_forumicons_c_txt.php

Install Info:
Hack Version: 1.0
Files to edit: 2
Templates to add: 0
Templates to edit: 2
Queries to Run: 1
Time to install: Approx 3-5 Minutes

Credits
Requested by - sasjamal here (http://www.vbulletin.org/forum/showthread.php?s=&threadid=47179)

Support - I unfortunately cannot be here during the coming weeks (Mon-Fri), so therefore you will have to rely on others for assitance, should it be urgent...If you do require assitance, please - Only reply in this thread!!

Hack info

What does it do? - Basically, you can Select Custom On/Off.gif image for a forum:)

Additional Info/Updates

Image Info : Forum must be open for posts. All Custom Images will be in the format "on-forum-[id].gif"/"off-forum-[id].gif" where [id] is the forumid of the for the ON.gif/OFF.gif File is for (must be present in the images folder)

Screenshots/Live Demo

At this time, there are no screenshots, or a Live Demo...If someone can provide them, thank you:)

Enjoy!:)

Satan

curley
31 Dec 2002, 20:38
can you have different ones for different forums??

Mystis
31 Dec 2002, 22:02
Yes, that's what the whole point is curley.

Nice one hellsatan :D

Dean C
31 Dec 2002, 22:02
I think that's what this hack does curley :p

Silenced Soul
31 Dec 2002, 22:07
nice one hellsatan. Was looking for something like this :D.

Chris M
31 Dec 2002, 23:47
Thanks:)

I thought it would be pretty simple to do, so I did it:)

Satan

Chris M
31 Dec 2002, 23:48
@Curley - Yes that is what this hack allows:)

You must have the "Custom Images?" option set to yes for it to show the Custom Image;)

Satan

Silenced Soul
01 Jan 2003, 03:57
just installed, and works like a charm ;D

Chris M
01 Jan 2003, 10:54
Great:) Glad you like it!:)

Satan

sasjamal
05 Jan 2003, 16:49
Any Screen Shots / Demos?

Chris M
05 Jan 2003, 20:10
Unfortunately I know of none:(

I am not a graphical person, so Custom images are not my forte:(

If anyone can provide some though;):)

Satan

Kars10
06 Jan 2003, 21:44
Installed and works great!!
Thanks Chris!!

Btw: I will post some screenshots tomorrow ... ;)

Chris M
08 Jan 2003, 18:29
Thanks Karsten:)

Satan

sweetmercifulcr
04 Apr 2003, 18:57
do the queries have to be run or can it be done without the queries?

Xelation
18 Apr 2003, 07:53
I've done everything right but its not working.. this is what im naming the files

off-forum-10.gif
off-forum-[10].gif

Ive tried both and it doesnt work, can you help me?

Chris M
19 Apr 2003, 17:57
@sweetmercifulcr - Yes the query must be ran:)

@Xelation - I have noticed an error in the instructions:(

In the instructions (the last file change), it says:

=============
Replace with:
=============

if ((!$forumperms['canpostnew'] and $showlocks) or $forum['allowposting']==0) {
$forum['onoff'].='lock';
}
if ($forum['onimage']=="1") {
$onoffid="$forum[forumid]";
}else{
$onoffid="";
}
That is wrong...

It should be:

=============
Replace with:
=============

if ((!$forumperms['canpostnew'] and $showlocks) or $forum['allowposting']==0) {
$forum['onoff'].='lock';
}
if ($forum['onoffimage']=="1") {
$onoffid="$forum[forumid]";
}else{
$onoffid="";
}

That should correct your problem:)

Satan

Chris M
19 Apr 2003, 18:09
Ok...

I noticed another error:

In the instructions file, in the admin/forum.php changes, change:

makeyesnocode("Use Custom Forum Image?<br>(on.gif & off.gif)","onimage",$forum['onoffimage']);

to

makeyesnocode("Use Custom Forum Image?<br>(on.gif & off.gif)","onoffimage",$forum['onoffimage']);

:)

Satan

D7MeEe
23 May 2003, 08:24
Thanks
Thanks


D7MeEe

gmarik
23 Oct 2003, 16:18
Goog, good, gracious!

Blaine0002
16 Nov 2003, 19:05
its just what i wanted but... it dosent work! if i activate a forum i go to the main page and theres a red X there.

so i right click on the X and go to properties and the image is looking for off-forum-.gif

with no ID number!? any fixes?

http://www.crossingcentral.com

Sting3r
24 Nov 2003, 08:22
^ am having the same problem. The ids dont work. IT asks for off-forum-.gif.

Blaine0002
25 Nov 2003, 19:20
yeah, can somone get back to us!?

gmarik
25 Nov 2003, 21:08
I'll be working on my own version of this hack with alpha transparency and no off.gif's

MaDCaT75
10 Dec 2003, 23:16
yeah, can somone get back to us!?
same here!!!!!

Blaine0002
21 Dec 2003, 17:26
come on!

MaDCaT75
24 Dec 2003, 03:31
I think this hack is officially dead :\

Blaine0002
24 Dec 2003, 14:06
yeah, i guess so. Damnit.

Doubledoom
24 Dec 2003, 14:09
it works on 2.3.0

MaDCaT75
26 Dec 2003, 03:49
it works on 2.3.0
I have 2.3.0 - it doesnt work for me..... can you gimme a hand plz?

Blaine0002
26 Dec 2003, 13:18
same herr

gmarik
28 Dec 2003, 16:58
Could somebody integrate this with vBulletin on/off icons?
It would look something like roboUK site, it would be great. I tried and failed ...